aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-10-09 22:05:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-10-09 22:05:57 +0000
commitab710acde2c2fa1d40543614f64050a8b97b59c9 (patch)
tree04a71857d93428b8fe459bf0ec9ddeb363d5f0fb
parent2ebe0e0a90868450e81e1a01a05c9b993719a6f1 (diff)
downloadports-ab710acde2c2fa1d40543614f64050a8b97b59c9.tar.gz
ports-ab710acde2c2fa1d40543614f64050a8b97b59c9.zip
- Move vdpau-video to libva-vdpau-driver to follow upstream project
name change - Update to 0.7.4 - Take maintainership - Update master site - Undeprecate - Remove ABI version number from LIB_DEPENDS - Convert to new options framework - Add note in UPDATING about the move
Notes
Notes: svn path=/head/; revision=305607
-rw-r--r--MOVED1
-rw-r--r--UPDATING15
-rw-r--r--multimedia/Makefile2
-rw-r--r--multimedia/libva-vdpau-driver/Makefile (renamed from multimedia/vdpau-video/Makefile)29
-rw-r--r--multimedia/libva-vdpau-driver/distinfo2
-rw-r--r--multimedia/libva-vdpau-driver/pkg-descr (renamed from multimedia/vdpau-video/pkg-descr)0
-rw-r--r--multimedia/libva-vdpau-driver/pkg-plist (renamed from multimedia/vdpau-video/pkg-plist)0
-rw-r--r--multimedia/vdpau-video/distinfo2
8 files changed, 31 insertions, 20 deletions
diff --git a/MOVED b/MOVED
index 2db8b0cb4a50..e38011ece544 100644
--- a/MOVED
+++ b/MOVED
@@ -3716,3 +3716,4 @@ textproc/aspell-without-dicten|textproc/aspell|2012-09-24|The dictionary is no l
www/jakarta-jmeter|www/jmeter|2012-09-25|Former Jakarta projects now live on their own
www/smarty|www/smarty2|2012-09-26|Renamed to prepare for addition of Smarty 3.x to the tree
devel/p5-Devel-Mallinfo||2012-10-08|Has expired: Does not work on FreeBSD, mallinfo() is a GNU libc function and is not available on FreeBSD
+multimedia/vdpau-video|multimedia/libva-vdpau-driver|2012-10-09|Project renamed
diff --git a/UPDATING b/UPDATING
index 95f9dd6e80ef..6756b74eb6a0 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,21 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20121009:
+ AFFECTS: users of multimedia/vdpau-video
+ AUTHOR: madpilot@FreeBSD.org
+
+ vdpau-video has been renamed upstream to libva-vdpau-driver. The
+ port has been changed accordingly.
+
+ Please update the port origins as follows:
+
+ # portmaster -o multimedia/vdpau-video multimedia/libva-vdpau-driver
+ or
+ # portupgrade -fo multimedia/vdpau-video multimedia/libva-vdpau-driver
+ or
+ # pkg set -o multimedia/vdpau-video:multimedia/libva-vdpau-driver
+
20121008:
AFFECTS: users of mail/squirrelmail
AUTHOR: adamw@FreeBSD.org
diff --git a/multimedia/Makefile b/multimedia/Makefile
index b225e2cc8bbf..cf6422999196 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -168,6 +168,7 @@
SUBDIR += libtuner
SUBDIR += libv4l
SUBDIR += libva
+ SUBDIR += libva-vdpau-driver
SUBDIR += libvdpau
SUBDIR += libvpx
SUBDIR += libxine
@@ -330,7 +331,6 @@
SUBDIR += vcdimager
SUBDIR += vcdpad
SUBDIR += vcdtools
- SUBDIR += vdpau-video
SUBDIR += vdpauinfo
SUBDIR += vdr
SUBDIR += vdr-plugin-control
diff --git a/multimedia/vdpau-video/Makefile b/multimedia/libva-vdpau-driver/Makefile
index 70ea2cc323db..78eca4a2b370 100644
--- a/multimedia/vdpau-video/Makefile
+++ b/multimedia/libva-vdpau-driver/Makefile
@@ -1,29 +1,22 @@
-# New ports collection makefile for: vdpau-video
-# Date created: 5 Jan 2011
-# Whom: Anonymous
-#
# $FreeBSD$
-#
-PORTNAME= vdpau-video
-DISTVERSION= 0.7.3
+PORTNAME= libva-vdpau-driver
+PORTVERSION= 0.7.4
CATEGORIES= multimedia
-MASTER_SITES= http://www.splitted-desktop.com/~gbeauchesne/${PORTNAME}/
+MASTER_SITES= http://www.freedesktop.org/software/vaapi/releases/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= madpilot@FreeBSD.org
COMMENT= A VDPAU-based backend for VAAPI
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-10-20
-
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-LIB_DEPENDS= vdpau.1:${PORTSDIR}/multimedia/libvdpau
+LIB_DEPENDS= vdpau:${PORTSDIR}/multimedia/libvdpau
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libva.pc:${PORTSDIR}/multimedia/libva \
${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= gl
@@ -31,13 +24,15 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DEBUG STRIP
+
+.include <bsd.port.options.mk>
-.if !defined(WITH_DEBUG)
+.if empty(PORT_OPTIONS:MDEBUG)
CONFIGURE_ARGS+= --disable-debug
.endif
-.if defined(STRIP) && ${STRIP} != ""
+.if ${PORT_OPTIONS:MSTRIP}
INSTALL_TARGET= install-strip
.endif
@@ -48,4 +43,4 @@ post-patch: .SILENT
-e '/\^vdpau_version/s|$$CC -E|& ${CPPFLAGS}|' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/libva-vdpau-driver/distinfo b/multimedia/libva-vdpau-driver/distinfo
new file mode 100644
index 000000000000..0b4a91c41969
--- /dev/null
+++ b/multimedia/libva-vdpau-driver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libva-vdpau-driver-0.7.4.tar.bz2) = 155c1982f0ac3f5435ba20b221bcaa11be212c37db548cd1f2a030ffa17e9bb9
+SIZE (libva-vdpau-driver-0.7.4.tar.bz2) = 316729
diff --git a/multimedia/vdpau-video/pkg-descr b/multimedia/libva-vdpau-driver/pkg-descr
index 1d9e9ff29e0d..1d9e9ff29e0d 100644
--- a/multimedia/vdpau-video/pkg-descr
+++ b/multimedia/libva-vdpau-driver/pkg-descr
diff --git a/multimedia/vdpau-video/pkg-plist b/multimedia/libva-vdpau-driver/pkg-plist
index 657c8fc4acaf..657c8fc4acaf 100644
--- a/multimedia/vdpau-video/pkg-plist
+++ b/multimedia/libva-vdpau-driver/pkg-plist
diff --git a/multimedia/vdpau-video/distinfo b/multimedia/vdpau-video/distinfo
deleted file mode 100644
index 2921c21589f5..000000000000
--- a/multimedia/vdpau-video/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (vdpau-video-0.7.3.tar.gz) = 28f66adc7d87a513a765dd79fda469e895b76692173d2aa79a26f4a618f91266
-SIZE (vdpau-video-0.7.3.tar.gz) = 400121