aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-08-03 02:28:37 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-08-03 02:28:37 +0000
commit336cf4f81e31ae43ff7b5ec434e2305615de4392 (patch)
tree4576a7747a6b31da2bea36008036d704f50906b2
parentd20e22b19f0493c822434dde64443d9c0fe50277 (diff)
downloadports-336cf4f81e31ae43ff7b5ec434e2305615de4392.tar.gz
ports-336cf4f81e31ae43ff7b5ec434e2305615de4392.zip
Use the stable, slow moving lang/gcc instead of lang/gcc46 for
USE_GCC=4.6 and USE_GCC=4.6+ and generally whenever the default version of GCC is employed. This will significantly benefit tinderboxes and the larger, reasonably conservative user base by reducing the amount of rebuilds. Rename _GCC_BUILD_DEPENDS to _GCC_PORT, but still set _GCC_BUILD_DEPENDS in the end for the sake of some ports relying on that. PR: 169449 Discussed with: bf
Notes
Notes: svn path=/head/; revision=301878
-rw-r--r--Mk/bsd.gcc.mk21
1 files changed, 14 insertions, 7 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 9cb9bec5441c..9650128166bb 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -178,29 +178,36 @@ _USE_GCC:= ${GCC_DEFAULT_VERSION}
. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
. if ${OSVERSION} < ${_GCCVERSION_${v}_L} || ${OSVERSION} > ${_GCCVERSION_${v}_R}
V:= ${_GCCVERSION_${v}_V:S/.//}
-_GCC_BUILD_DEPENDS:= gcc${V}
_GCC_PORT_DEPENDS:= gcc${V}
+. if ${_USE_GCC} == ${GCC_DEFAULT_VERSION}
+_GCC_PORT:= gcc
+. else
+_GCC_PORT:= gcc${V}
+. endif
CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}
. if ${_USE_GCC} != 3.4
-CFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
-LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
+CFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
. if defined (USE_FORTRAN)
. if ${USE_FORTRAN} == yes
-FFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
+FFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
. endif
. endif
+# The following is for the sakes of some ports which use this without
+# ever telling us; to be fixed.
+_GCC_BUILD_DEPENDS:= ${_GCC_PORT_DEPENDS}
. endif
. endif
. endif
.endfor
.undef V
-.if defined(_GCC_BUILD_DEPENDS)
-BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
+.if defined(_GCC_PORT_DEPENDS)
+BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_PORT}
. if ${_USE_GCC} != 3.4
-RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
+RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_PORT}
. if ${_USE_GCC} != 4.2
# Later GCC ports already depend on binutils; make sure whatever we
# build leverages this as well.