aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-08-10 18:36:27 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-08-10 18:36:27 +0000
commit600af559c2f75c62beae1201d7f558ac4af20774 (patch)
treee456de53cd25acc64c5c2881d2b439c9989df5cb
parent7e870f4606b3fa4102602cbaed848ae699181da5 (diff)
downloadports-600af559c2f75c62beae1201d7f558ac4af20774.tar.gz
ports-600af559c2f75c62beae1201d7f558ac4af20774.zip
- Add USE_OPENSSL, since all lang/python ports build the _ssl module, which
requires a working OpenSSL implementation Phabric: D569 Reviewed by: wg@ With hat: python@
Notes
Notes: svn path=/head/; revision=364557
-rw-r--r--lang/python27/Makefile3
-rw-r--r--lang/python32/Makefile3
-rw-r--r--lang/python33/Makefile3
-rw-r--r--lang/python34/Makefile3
4 files changed, 8 insertions, 4 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 1de0f20d2109..341fce59b510 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= 2.7.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -16,6 +16,7 @@ LICENSE= PSFL
USES= cpe ncurses pkgconfig readline tar:xz
USE_LDCONFIG= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
CPE_VENDOR= python
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 95d8ca3336a0..f97ce815b92d 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python32
PORTVERSION= 3.2.5
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -15,6 +15,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
USES= cpe ncurses pkgconfig readline tar:xz
+USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 85e48a442311..0df4b515a7ba 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= 3.3.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -15,6 +15,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
USES= cpe ncurses pkgconfig readline tar:xz
+USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index f5530a851b3c..cd333e3319a9 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= 3.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -16,6 +16,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
USES= cpe ncurses pkgconfig readline tar:xz
+USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes