aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 07:34:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 07:34:39 +0000
commit835d028dc90b109961e7685857a4c230d3b76112 (patch)
tree035b16e53b7a7083a9c292ff769a7fb7ce7e4a33
parent9062a865ce6f98baa86e297ee5dda906bbbb1c01 (diff)
downloadports-835d028dc90b109961e7685857a4c230d3b76112.tar.gz
ports-835d028dc90b109961e7685857a4c230d3b76112.zip
Add gToDo, a todo list application for the GNOME desktop. The goal of the
program is to be simple and easy to use. The program is made to fill up the gap of amissing gtk+-2.0 standalone todo list. PR: 57341 Submitted by: Jeremy Messenger <mezz7@cox.net>
Notes
Notes: svn path=/head/; revision=89750
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gtodo/Makefile25
-rw-r--r--deskutils/gtodo/distinfo1
-rw-r--r--deskutils/gtodo/files/patch-src::callback.c32
-rw-r--r--deskutils/gtodo/files/patch-src::interface.c13
-rw-r--r--deskutils/gtodo/files/patch-src::mcategory.c12
-rw-r--r--deskutils/gtodo/files/patch-src::todo_db.c12
-rw-r--r--deskutils/gtodo/pkg-descr5
-rw-r--r--deskutils/gtodo/pkg-plist8
9 files changed, 109 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index a123ab2b8fa2..b6ee664291e7 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -26,6 +26,7 @@
SUBDIR += gnotime
SUBDIR += goats
SUBDIR += gtimer
+ SUBDIR += gtodo
SUBDIR += gucharmap
SUBDIR += gworkspace
SUBDIR += ical
diff --git a/deskutils/gtodo/Makefile b/deskutils/gtodo/Makefile
new file mode 100644
index 000000000000..831b07fd8605
--- /dev/null
+++ b/deskutils/gtodo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gtodo
+# Date created: 29 September 2003
+# Whom: Mezz <mezz7@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtodo
+PORTVERSION= 0.13
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://qball.no-ip.com/
+
+MAINTAINER= mezz7@cox.net
+COMMENT= An Gtk2 Todo list manager
+
+BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget gtk20 libxml2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/deskutils/gtodo/distinfo b/deskutils/gtodo/distinfo
new file mode 100644
index 000000000000..742389c8fdbd
--- /dev/null
+++ b/deskutils/gtodo/distinfo
@@ -0,0 +1 @@
+MD5 (gtodo-0.13.tar.gz) = 8522ab159fc30a2b4500eb54d6ef694b
diff --git a/deskutils/gtodo/files/patch-src::callback.c b/deskutils/gtodo/files/patch-src::callback.c
new file mode 100644
index 000000000000..87b98f82dca1
--- /dev/null
+++ b/deskutils/gtodo/files/patch-src::callback.c
@@ -0,0 +1,32 @@
+--- src/callback.c.orig Mon Sep 29 01:45:56 2003
++++ src/callback.c Mon Sep 29 01:48:27 2003
+@@ -26,8 +26,8 @@
+
+ if(cur != root)
+ {
+- xmlFreeNode(cur);
+ xmlUnlinkNode(cur);
++ xmlFreeNode(cur);
+ gtk_list_store_remove(mw.list, &iter);
+ }
+ else{
+@@ -167,8 +167,8 @@
+ if(xmlStrEqual(temp, (const xmlChar *)tm))
+ {
+ g_signal_handler_block(mw.option, shand);
+- xmlFreeNode(cur);
+ xmlUnlinkNode(cur);
++ xmlFreeNode(cur);
+ read_categorys();
+ g_signal_handler_unblock(mw.option, shand);
+ cur = NULL;
+@@ -302,8 +302,8 @@
+ cur = get_id_node(category, value);
+ if(cur != root)
+ {
+- xmlFreeNode(cur);
+ xmlUnlinkNode(cur);
++ xmlFreeNode(cur);
+ //gtk_list_store_remove(mw.list, &nextiter);
+ }
+ else{
diff --git a/deskutils/gtodo/files/patch-src::interface.c b/deskutils/gtodo/files/patch-src::interface.c
new file mode 100644
index 000000000000..52b1f3f8bb5d
--- /dev/null
+++ b/deskutils/gtodo/files/patch-src::interface.c
@@ -0,0 +1,13 @@
+--- src/interface.c.orig Mon Sep 29 01:33:44 2003
++++ src/interface.c Mon Sep 29 01:33:52 2003
+@@ -179,8 +179,8 @@
+
+
+ g_signal_connect(G_OBJECT (mw.treeview), "row-activated", G_CALLBACK (gui_add_todo_item), GINT_TO_POINTER(1));
+- g_signal_connect(mw.window, "delete-event", G_CALLBACK(window_close), NULL);
+- g_signal_connect(mw.window, "destroy-event", G_CALLBACK(quit_program), NULL);
++ g_signal_connect(mw.window, "delete-event", G_CALLBACK(gtk_main_quit), NULL);
++ g_signal_connect(mw.window, "destroy-event", G_CALLBACK(gtk_main_quit), NULL);
+ gtk_window_add_accel_group(GTK_WINDOW(mw.window), mw.accel_group);
+
+ if(settings.do_tray) tray_init();
diff --git a/deskutils/gtodo/files/patch-src::mcategory.c b/deskutils/gtodo/files/patch-src::mcategory.c
new file mode 100644
index 000000000000..4f7ea4c3aa3b
--- /dev/null
+++ b/deskutils/gtodo/files/patch-src::mcategory.c
@@ -0,0 +1,12 @@
+--- src/mcategory.c.orig Mon Sep 29 01:41:35 2003
++++ src/mcategory.c Mon Sep 29 01:41:41 2003
+@@ -99,8 +99,8 @@
+ if(xmlStrEqual(temp, (const xmlChar *)category))
+ {
+ g_signal_handler_block(mw.option, shand);
+- xmlFreeNode(cur);
+ xmlUnlinkNode(cur);
++ xmlFreeNode(cur);
+ read_categorys();
+ g_signal_handler_unblock(mw.option, shand);
+ cur = NULL;
diff --git a/deskutils/gtodo/files/patch-src::todo_db.c b/deskutils/gtodo/files/patch-src::todo_db.c
new file mode 100644
index 000000000000..9b5c14baa442
--- /dev/null
+++ b/deskutils/gtodo/files/patch-src::todo_db.c
@@ -0,0 +1,12 @@
+--- src/todo_db.c.orig Mon Sep 29 01:51:18 2003
++++ src/todo_db.c Mon Sep 29 01:51:55 2003
+@@ -399,8 +399,8 @@
+ item = g_ascii_strtoull(due, NULL,0);
+ if(atoi(done) && item < (now-settings.purge_days))
+ {
+- xmlFreeNode(cur1);
+ xmlUnlinkNode(cur1);
++ xmlFreeNode(cur1);
+ cur1= root->xmlChildrenNode;
+ if(cur1 != NULL) cur2= cur1->xmlChildrenNode;
+ else cur2 = NULL;
diff --git a/deskutils/gtodo/pkg-descr b/deskutils/gtodo/pkg-descr
new file mode 100644
index 000000000000..1d3ad9b60370
--- /dev/null
+++ b/deskutils/gtodo/pkg-descr
@@ -0,0 +1,5 @@
+gToDo is as the name suggests a todo list application. The goal of the program
+is to be simple and easy to use. The program is made to fill up the gap of a
+missing gtk+-2.0 standalone todo list.
+
+WWW: http://qball.no-ip.com/test/index.php?s=44
diff --git a/deskutils/gtodo/pkg-plist b/deskutils/gtodo/pkg-plist
new file mode 100644
index 000000000000..d28b680fabc3
--- /dev/null
+++ b/deskutils/gtodo/pkg-plist
@@ -0,0 +1,8 @@
+bin/gtodo
+share/gnome/applications/gtodo.desktop
+share/gnome/pixmaps/gtodo-about.png
+share/gnome/pixmaps/gtodo-edit.png
+share/gnome/pixmaps/gtodo.png
+share/gnome/pixmaps/gtodo_tray.svg
+share/locale/sr/LC_MESSAGES/gtodo.mo
+share/locale/sr@Latn/LC_MESSAGES/gtodo.mo