aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-27 01:16:41 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-27 01:16:41 +0000
commit86e10e595b1c52850d29d70198a3fc4bbd49c3f3 (patch)
tree452419bf1c91329c585668bf479816231f62ee7a
parenteb99a7e192fe397dfc80e54540fece196247404f (diff)
downloadports-86e10e595b1c52850d29d70198a3fc4bbd49c3f3.tar.gz
ports-86e10e595b1c52850d29d70198a3fc4bbd49c3f3.zip
- Update to 0.9.11
- library version update of related ports Changelog libprelude: - Hook class comparison function. Accept NULL, equal, not equal operator. - Introduce better error checking in the idmef-class API, which is now considered public and might be used by external application. Rename error code to reflect the API. - Change to the way IDMEF listed element are handled. Specifying negative number as the position of the element from the low level API now allow to position the element at the specified (reversed) index. Using the high level API a negative index permit to address a list of element backward (replace an element). - Build fixes for SWIG > 1.3.27. - Modify idmef_value_match() so that it always unroll listed value (do it for both val1 and val2. Remove assertion, and let idmef_value_type_compare() return an error code in case there is an issue. - Handle path using IDMEF_LIST_APPEND or IDMEF_LIST_PREPEND as path using an undefined list index on idmef_path_get() call. - Make criteria parser accept (*) list index. - Implement comparison function for all IDMEF object. PR: ports/104328 Submitted by: maintainer (Robin Gruyters) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=178081
-rw-r--r--security/libprelude/Makefile7
-rw-r--r--security/libprelude/distinfo6
-rw-r--r--security/libprelude/pkg-plist2
-rw-r--r--security/libpreludedb/Makefile2
-rw-r--r--security/prelude-lml/Makefile2
-rw-r--r--security/prelude-manager/Makefile2
-rw-r--r--security/samhain/Makefile2
-rw-r--r--security/snort/Makefile2
8 files changed, 13 insertions, 12 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 7dae1c7be714..5275804cf0a9 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
PORTNAME= libprelude
-PORTVERSION= 0.9.10.2
+PORTVERSION= 0.9.11
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -21,7 +21,7 @@ USE_GPG= yes
SIG_SUFFIX= .sig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var
@@ -37,7 +37,8 @@ PLIST_SUB+= WITH_PERL="@comment "
.endif
.if defined(WITH_PYTHON)
-USE_PYTHON= yes
+USE_PYTHON= 2.3+
+.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+= --with-python
PLIST_SUB+= WITH_PYTHON=""
.else
diff --git a/security/libprelude/distinfo b/security/libprelude/distinfo
index abb0a36fda36..25dbe92f7f91 100644
--- a/security/libprelude/distinfo
+++ b/security/libprelude/distinfo
@@ -1,3 +1,3 @@
-MD5 (libprelude-0.9.10.2.tar.gz) = 999e9f86a23abfb05985d027610cbe8f
-SHA256 (libprelude-0.9.10.2.tar.gz) = b7c82b6d6193100f39a39738227f3317abfc78bd0593ad306ea1b97a9352db90
-SIZE (libprelude-0.9.10.2.tar.gz) = 1790030
+MD5 (libprelude-0.9.11.tar.gz) = e0ec03daf8230829f238a1e58f10846b
+SHA256 (libprelude-0.9.11.tar.gz) = 1f1ae289bd6d4fac277e43287c5024d38a3e9eb47bc64e404b610d17de5100f6
+SIZE (libprelude-0.9.11.tar.gz) = 1809482
diff --git a/security/libprelude/pkg-plist b/security/libprelude/pkg-plist
index 25a3556ebc43..a6230f94193c 100644
--- a/security/libprelude/pkg-plist
+++ b/security/libprelude/pkg-plist
@@ -52,7 +52,7 @@ include/libprelude/prelude.h
include/libprelude/variable.h
lib/libprelude.la
lib/libprelude.so
-lib/libprelude.so.9
+lib/libprelude.so.10
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Prelude.pm
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/.packlist
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/Prelude.bs
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 51b4f5984e83..cca365efb0d3 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Framework library for access to Prelude NIDS database
-LIB_DEPENDS= prelude.9:${PORTSDIR}/security/libprelude
+LIB_DEPENDS= prelude.10:${PORTSDIR}/security/libprelude
USE_GPG= yes
SIG_SUFFIX= .sig
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index ae8ce937afb4..766b61c739b4 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Prelude Network Intrusion Detection System Log Monitoring Lackey
-LIB_DEPENDS+= prelude.[8-?]:${PORTSDIR}/security/libprelude \
+LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude \
pcre.0:${PORTSDIR}/devel/pcre
USE_GPG= yes
diff --git a/security/prelude-manager/Makefile b/security/prelude-manager/Makefile
index bc388ddacf24..60a09b90adb6 100644
--- a/security/prelude-manager/Makefile
+++ b/security/prelude-manager/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Prelude Network Intrusion Detection System central logging point
-LIB_DEPENDS+= prelude.[6-?]:${PORTSDIR}/security/libprelude \
+LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude \
gnutls.13:${PORTSDIR}/security/gnutls
USE_GPG= yes
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index 2626e860a000..5aaabcd14134 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -93,7 +93,7 @@ CONFIGURE_ARGS+= --with-logserver=${WITH_LOG_SERVER}
CONFIGURE_ARGS+= --with-altlogserver=${WITH_ALT_LOG_SERVER}
.endif
.if defined(WITH_PRELUDE)
-LIB_DEPENDS+= prelude.[7-?]:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --with-prelude
.endif
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 351822a8464f..7d1f93173eab 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -106,7 +106,7 @@ CONFIGURE_ARGS+= --with-postgresql=no
.endif
.if defined(WITH_PRELUDE)
-LIB_DEPENDS+= prelude.[7-?]:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --enable-prelude
PLIST_SUB+= PRELUDE=""
.else