aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2016-10-12 21:19:55 +0000
committerDon Lewis <truckman@FreeBSD.org>2016-10-12 21:19:55 +0000
commit9443a4f6e98a17cc1b618cc7f9d04e3c2f0af075 (patch)
tree997d1124d2936a7902bed0002ed6f2fdd5e49421
parent022c0f9056fe53bff1274232f3329a118bb3b0f5 (diff)
downloadports-9443a4f6e98a17cc1b618cc7f9d04e3c2f0af075.tar.gz
ports-9443a4f6e98a17cc1b618cc7f9d04e3c2f0af075.zip
Upgrade ApacheOpenOffice to version 4.1.3.
This version contains the fix for CVE-2016-1513 that was fixed locally in 4.1.2_8 with a patch from upstream. Configure now requires p5-LWP-Protocol-https, though we don't actually use it we don't use bootstrap to download anything.
Notes
Notes: svn path=/head/; revision=423894
-rw-r--r--editors/openoffice-4/Makefile9
-rw-r--r--editors/openoffice-4/distinfo6
-rw-r--r--editors/openoffice-4/files/patch-CVE-2016-151326
3 files changed, 8 insertions, 33 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index b4331fe1ffda..81c8abb99a05 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 10
+#PORTREVISION= 1
CATEGORIES= editors java
MASTER_SITES= APACHE/openoffice/${PORTVERSION}/source \
http://tools.openoffice.org/unowinreg_prebuild/680/:unoreg \
@@ -49,6 +49,7 @@ LICENSE_PERMS_W3C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= \
p5-Archive-Zip>=0:archivers/p5-Archive-Zip \
p5-libwww>=0:www/p5-libwww \
+ p5-LWP-Protocol-https>0:www/p5-LWP-Protocol-https \
p5-XML-Parser>=0:textproc/p5-XML-Parser \
${LOCALBASE}/bin/unzip:archivers/unzip \
zip:archivers/zip \
@@ -97,10 +98,10 @@ RUN_DEPENDS= \
AOOVERSION1= 4
AOOVERSION2= 1
-AOOVERSION3= 2
+AOOVERSION3= 3
# From solenv/inc/minor.mk SOURCEREVISION LAST_MINOR BUILD
-AOOTAG= AOO412m3\(Build:9782\)
-SVNREVISION= 1709696
+AOOTAG= AOO413m1\(Build:9783\)
+SVNREVISION= 1761381
EXTSRC= ApacheOpenOffice.ext_sources.${AOOVERSION1}.x.x.20150707.tar.gz
AOOVERSION= ${AOOVERSION1}.${AOOVERSION2}.${AOOVERSION3}
diff --git a/editors/openoffice-4/distinfo b/editors/openoffice-4/distinfo
index dd2b668d62e7..30fe4fac9c86 100644
--- a/editors/openoffice-4/distinfo
+++ b/editors/openoffice-4/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1469002349
-SHA256 (openoffice/apache-openoffice-4.1.2-r1709696-src.tar.bz2) = 2e06774424eb564559f9e6d63ff79aa00522b210067717c5a8cfb54b3b7f1812
-SIZE (openoffice/apache-openoffice-4.1.2-r1709696-src.tar.bz2) = 219041975
+TIMESTAMP = 1476083119
+SHA256 (openoffice/apache-openoffice-4.1.3-r1761381-src.tar.bz2) = 225ee39d3426389e3add68aec0921af1d22d18cada8c905c02811e873c08ebc0
+SIZE (openoffice/apache-openoffice-4.1.3-r1761381-src.tar.bz2) = 219143777
SHA256 (openoffice/unowinreg.dll) = f563e522922133db9340b0306711c2d8767cc3481dd9e7d9b0d059906d12653c
SIZE (openoffice/unowinreg.dll) = 6144
SHA256 (openoffice/ApacheOpenOffice.ext_sources.4.x.x.20150707.tar.gz) = 966a8333c83a18ddd84401389006d6e0b52b8175924b808b54b88211669985fa
diff --git a/editors/openoffice-4/files/patch-CVE-2016-1513 b/editors/openoffice-4/files/patch-CVE-2016-1513
deleted file mode 100644
index 5d5370810c1f..000000000000
--- a/editors/openoffice-4/files/patch-CVE-2016-1513
+++ /dev/null
@@ -1,26 +0,0 @@
---- tools/source/generic/poly2.cxx.orig 2014-02-25 08:20:50 UTC
-+++ tools/source/generic/poly2.cxx
-@@ -196,8 +196,9 @@ void PolyPolygon::Insert( const Polygon&
-
- void PolyPolygon::Remove( sal_uInt16 nPos )
- {
-- DBG_CHKTHIS( PolyPolygon, NULL );
-- DBG_ASSERT( nPos < Count(), "PolyPolygon::Remove(): nPos >= nSize" );
-+ DBG_CHKTHIS( PolyPolygon, NULL );
-+ DBG_ASSERT( nPos < Count(), "PolyPolygon::Remove(): nPos >= nSize" );
-+ if ( nPos >= Count() ) return; // not removable
-
- if ( mpImplPolyPolygon->mnRefCount > 1 )
- {
-@@ -216,8 +217,9 @@ void PolyPolygon::Remove( sal_uInt16 nPo
-
- void PolyPolygon::Replace( const Polygon& rPoly, sal_uInt16 nPos )
- {
-- DBG_CHKTHIS( PolyPolygon, NULL );
-- DBG_ASSERT( nPos < Count(), "PolyPolygon::Replace(): nPos >= nSize" );
-+ DBG_CHKTHIS( PolyPolygon, NULL );
-+ DBG_ASSERT( nPos < Count(), "PolyPolygon::Replace(): nPos >= nSize" );
-+ if ( nPos >= Count() ) return; // not replaceable
-
- if ( mpImplPolyPolygon->mnRefCount > 1 )
- {