aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-08-30 09:56:05 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-08-30 09:56:05 +0000
commita4f7d9d69c27f625b428736efafd44de4d614857 (patch)
tree4a437ef11ee03dc818007c2b4bb992d16f4f67af
parentd2c2c5b0e4853f64840a5f980b386ffe53454936 (diff)
downloadports-a4f7d9d69c27f625b428736efafd44de4d614857.tar.gz
ports-a4f7d9d69c27f625b428736efafd44de4d614857.zip
Chase mpfr library and bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=198517
-rw-r--r--deskutils/genius/Makefile4
-rw-r--r--devel/cross-gcc/Makefile4
-rw-r--r--devel/djgpp-gcc/Makefile4
-rw-r--r--lang/gcc/Makefile2
-rw-r--r--lang/gcc42/Makefile2
-rw-r--r--lang/gcc43/Makefile2
-rw-r--r--lang/gcc44/Makefile2
-rw-r--r--lang/gcc45/Makefile2
-rw-r--r--lang/gcc46/Makefile2
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gnat-gcc43/Makefile3
-rw-r--r--math/gretl/Makefile3
-rw-r--r--math/wcalc/Makefile3
14 files changed, 20 insertions, 17 deletions
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index fd3828d1e8cf..5d30fb984030 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -7,7 +7,7 @@
PORTNAME= genius
PORTVERSION= 0.7.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://ftp.5z.com/pub/genius/
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9].[0-9]).*/\1/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Arbitrary precision calculator for Gnome Desktop Environment
-LIB_DEPENDS= mpfr.1:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= mpfr.2:${PORTSDIR}/math/mpfr
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget gtksourceview intlhack \
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index 87f37d2a91a5..c84320388b17 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= gcc
PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC:S,$,:gcc,} \
${MASTER_SITE_SOURCEWARE:S,$,:newlib,}
@@ -151,7 +151,7 @@ TGTLANGS:= "${TGTLANGS},objc"
.if defined(WITH_FORTRAN)
TGTLANGS:= "${TGTLANGS},fortran"
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
PLIST_FILES+= bin/${OURTARGET}-gfortran \
${OURTARGET}/bin/gfortran
diff --git a/devel/djgpp-gcc/Makefile b/devel/djgpp-gcc/Makefile
index 29fb2817d84e..8ac75e7c430e 100644
--- a/devel/djgpp-gcc/Makefile
+++ b/devel/djgpp-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= ${GCCVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.delorie.com/pub/djgpp/current/v2gnu/:djsource \
ftp://ftp.mirror.ac.uk/sites/www.delorie.com/current/v2gnu/:djsource \
@@ -33,7 +33,7 @@ BUILD_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
aclocal-1.9:${PORTSDIR}/devel/automake19
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
.endif
RUN_DEPENDS= ${TARGET}-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${LOCALBASE}/${TARGET}/bin/stubify:${PORTSDIR}/devel/${PKGNAMEPREFIX}crx
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 56a3a10ca165..9c4206afb9d4 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.2
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 42
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 8a7238b502ac..051e69f809b3 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -23,7 +23,7 @@ MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.3
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
SUFFIX= 43
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index d9d6492f5e88..2cd0c101fdfa 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -9,6 +9,7 @@
PORTNAME= gnat-gcc
PORTVERSION= 4.3.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GCC} \
http://lovetemple.net/data/:boot
@@ -22,7 +23,7 @@ MAINTAINER= karel@lovetemple.net
COMMENT= The GNU Ada Compiler system
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
ONLY_FOR_ARCHS= i386
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 020c8a81e8d7..af7768b2164e 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gretl
PORTVERSION= 1.6.5
+PORTREVISION= 1
CATEGORIES= math finance
MASTER_SITES= SF
@@ -16,7 +17,7 @@ COMMENT= Gnu Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
diff --git a/math/wcalc/Makefile b/math/wcalc/Makefile
index eb5de164743d..2fd8013ef2f1 100644
--- a/math/wcalc/Makefile
+++ b/math/wcalc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wcalc
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= w-calc
@@ -16,7 +17,7 @@ MAINTAINER= amarendra.godbole@gmail.com
COMMENT= A natural-expression command-line calculator
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
- mpfr.1:${PORTSDIR}/math/mpfr
+ mpfr.2:${PORTSDIR}/math/mpfr
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib