aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:26:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-16 08:26:25 +0000
commitd22728a7e856c5c9ae691125736d656a2c1163ad (patch)
tree631e17a2b7895241106d33db493284675e581402
parentf329319eb51eb2930a53eb96f5f2932c737a71b8 (diff)
downloadports-d22728a7e856c5c9ae691125736d656a2c1163ad.tar.gz
ports-d22728a7e856c5c9ae691125736d656a2c1163ad.zip
Fix some non default LIB_DEPENDS
With hat: portmgr
Notes
Notes: svn path=/head/; revision=362050
-rw-r--r--math/atlas/Makefile2
-rw-r--r--math/calctool/Makefile2
-rw-r--r--math/petsc/Makefile8
-rw-r--r--math/xspread/Makefile2
-rw-r--r--misc/amanda-server/Makefile2
-rw-r--r--misc/amanda26-server/Makefile2
-rw-r--r--misc/amanda32-server/Makefile2
-rw-r--r--multimedia/emotion/Makefile2
-rw-r--r--multimedia/gmtk/Makefile2
-rw-r--r--multimedia/mlt/Makefile14
-rw-r--r--net-im/centericq/Makefile6
-rw-r--r--net-mgmt/pmacct/Makefile2
-rw-r--r--net-mgmt/snmp4nagios/Makefile2
-rw-r--r--net-p2p/gnunet/Makefile2
-rw-r--r--net-p2p/transmission-remote-gui/Makefile2
-rw-r--r--net/click/Makefile2
-rw-r--r--net/httping/Makefile2
-rw-r--r--net/mediatomb/Makefile18
-rw-r--r--net/openldap24-server/Makefile2
-rw-r--r--net/openser/Makefile2
-rw-r--r--net/quagga-re/Makefile4
-rw-r--r--net/rabbitmq-c-devel/Makefile2
-rw-r--r--net/shmux/Makefile2
-rw-r--r--net/spserver/Makefile2
-rw-r--r--net/tcpdump/Makefile2
-rw-r--r--net/trafshow3/Makefile2
-rw-r--r--net/wire/Makefile2
-rw-r--r--news/inn/Makefile4
28 files changed, 49 insertions, 49 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index f60b501d8590..7d9a019b42f3 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -55,7 +55,7 @@ POINTER?= 32
.endif
.if defined(MAINTAINER_MODE)
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
.endif
.for i in DATA DOCS
diff --git a/math/calctool/Makefile b/math/calctool/Makefile
index 9a32f3b05380..9d03ff6b66cb 100644
--- a/math/calctool/Makefile
+++ b/math/calctool/Makefile
@@ -38,7 +38,7 @@ PLIST_SUB+= TTY="@comment "
.if ${PORT_OPTIONS:MXVIEW}
BINARIES+= xv_calctool
-LIB_DEPENDS+= xview.3:${PORTSDIR}/x11-toolkits/xview
+LIB_DEPENDS+= libxview.so:${PORTSDIR}/x11-toolkits/xview
PLIST_SUB+= XVIEW=""
.else
PLIST_SUB+= XVIEW="@comment "
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index bdabfe20dc68..ebb3d0d0f598 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -123,11 +123,11 @@ PLIST_SUB+= MPIUNI=""
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
LIBBLASLAPACK= -L${LOCALBASE}/lib -lalapack -lcblas -lf77blas
CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.else
-LIB_DEPENDS+= lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
LIBBLASLAPACK= -L${LOCALBASE}/lib -llapack -lblas
CONFIGURE_ARGS+= --with-blas-lapack-lib="${LIBBLASLAPACK}"
.endif
@@ -161,7 +161,7 @@ CONFLICTS+= metis-4*
WITH_BLACS= yes
.endif
.if defined(WITH_BLACS) && defined(WITH_MPI)
-LIB_DEPENDS+= blacs:${PORTSDIR}/math/blacs
+LIB_DEPENDS+= libblacs.so:${PORTSDIR}/math/blacs
CONFIGURE_ARGS+= --with_blacs=1 \
--with-blacs-include=${LOCALBASE}/include \
--with-blacs-lib=[${LOCALBASE}/lib/libblacsc.a,${LOCALBASE}/lib/libblacsf77.a,${LOCALBASE}/lib/libblacs.a]
@@ -169,7 +169,7 @@ CONFIGURE_ARGS+= --with_blacs=1 \
WITH_SCALAPACK= yes
. endif
. if defined(WITH_SCALAPACK)
-LIB_DEPENDS+= scalapack:${PORTSDIR}/math/scalapack
+LIB_DEPENDS+= libscalapack.so:${PORTSDIR}/math/scalapack
CONFIGURE_ARGS+= --with-scalapack=1 \
--with-scalapack-dir=${LOCALBASE}
. endif
diff --git a/math/xspread/Makefile b/math/xspread/Makefile
index 6ee80103ef2e..6d7997500c95 100644
--- a/math/xspread/Makefile
+++ b/math/xspread/Makefile
@@ -31,7 +31,7 @@ PLIST_FILES= bin/pxspread bin/xspread man/man1/pxspread.1.gz \
.if ${PORT_OPTIONS:MX11}
USE_XORG= x11 xau xcb xdmcp xt
-LIB_DEPENDS+= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs
+LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.else
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 5540b879ca09..a486b902c5ca 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -144,7 +144,7 @@ CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
# If configure founds libcurl, automatically enabled it (with plist change).
.if ${PORT_OPTIONS:MS3}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
.else
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index b22e1936078e..27e46e698186 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -145,7 +145,7 @@ RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
# If configure founds libcurl, automatically enabled it (with plist change).
.if ${PORT_OPTIONS:MS3}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
.else
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 51415533e17c..137867b06f28 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -141,7 +141,7 @@ CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
# If configure founds libcurl, automatically enabled it (with plist change).
.if ${PORT_OPTIONS:MS3}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
.else
diff --git a/multimedia/emotion/Makefile b/multimedia/emotion/Makefile
index 5232504b8f65..15b6bb209d97 100644
--- a/multimedia/emotion/Makefile
+++ b/multimedia/emotion/Makefile
@@ -47,7 +47,7 @@ PLIST_SUB+= GST="@comment "
.endif
.if ${PORT_OPTIONS:MLIBXINE}
-LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= libxine.so:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+=--enable-xine
PLIST_SUB+= XINE=""
.else
diff --git a/multimedia/gmtk/Makefile b/multimedia/gmtk/Makefile
index 0c46cb763a7f..0c114af900a1 100644
--- a/multimedia/gmtk/Makefile
+++ b/multimedia/gmtk/Makefile
@@ -27,7 +27,7 @@ GIO_DESC= Use GIO for file I/O
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
CONFIGURE_ARGS+= --with-alsa
.else
CONFIGURE_ARGS+= --without-alsa
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index fa4f407cd74c..aed73691fde3 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -95,7 +95,7 @@ PLIST_SUB+= GTK2="@comment "
.endif
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= libjack.so:${PORTSDIR}/audio/jack
BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
CONFIGURE_ARGS+=--enable-jackrack
PLIST_SUB+= JACK=""
@@ -105,7 +105,7 @@ PLIST_SUB+= JACK="@comment "
.endif
.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
USE_QT4+= corelib gui opengl svg xml
CONFIGURE_ARGS+=--enable-qimage \
--qimage-includedir="${QT_INCDIR}" \
@@ -123,7 +123,7 @@ PLIST_SUB+= QT4="@comment "
.endif
.if ${PORT_OPTIONS:MQUICKTIME}
-LIB_DEPENDS+= dv:${PORTSDIR}/multimedia/libdv \
+LIB_DEPENDS+= libdv.so:${PORTSDIR}/multimedia/libdv \
quicktime:${PORTSDIR}/multimedia/libquicktime
CONFIGURE_ARGS+=--enable-kino
PLIST_SUB+= QUICKTIME=""
@@ -133,7 +133,7 @@ PLIST_SUB+= QUICKTIME="@comment "
.endif
.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-resample
PLIST_SUB+= SAMPLERATE=""
.else
@@ -142,7 +142,7 @@ PLIST_SUB+= SAMPLERATE="@comment "
.endif
.if ${PORT_OPTIONS:MSOX}
-LIB_DEPENDS+= sox:${PORTSDIR}/audio/sox
+LIB_DEPENDS+= libsox.so:${PORTSDIR}/audio/sox
CONFIGURE_ARGS+=--enable-sox
PLIST_SUB+= SOX=""
.else
@@ -151,7 +151,7 @@ PLIST_SUB+= SOX="@comment "
.endif
.if ${PORT_OPTIONS:MSWFDEC}
-LIB_DEPENDS+= swfdec-0.8:${PORTSDIR}/graphics/swfdec
+LIB_DEPENDS+= libswfdec-0.8.so:${PORTSDIR}/graphics/swfdec
CONFIGURE_ARGS+=--enable-swfdec
PLIST_SUB+= SWFDEC=""
.else
@@ -167,7 +167,7 @@ CONFIGURE_ARGS+=--avformat-no-vdpau
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--enable-vorbis
PLIST_SUB+= VORBIS=""
.else
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 23400aea5af6..c12069e781e8 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -59,12 +59,12 @@ CONFIGURE_ARGS+= --enable-locales-fix
.endif
.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --with-fribidi
.endif
.if ${PORT_OPTIONS:MMSN}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --disable-msn
.endif
@@ -101,7 +101,7 @@ CONFIGURE_ARGS+= --disable-lj
.endif
.if ${PORT_OPTIONS:MGG}
-LIB_DEPENDS+= gadu.3:${PORTSDIR}/polish/ekg
+LIB_DEPENDS+= libgadu.so:${PORTSDIR}/polish/ekg
LIBGADU= -lgadu
.else
CONFIGURE_ARGS+= --disable-gg
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index e36c2a60addf..3d9fbb5f9d7b 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -101,7 +101,7 @@ CONFIGURE_ARGS+=--enable-mongodb \
.endif
.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+=--enable-geoip \
--with-geoip-libs=${LOCALBASE}/lib \
--with-geoip-includes=${LOCALBASE}/include
diff --git a/net-mgmt/snmp4nagios/Makefile b/net-mgmt/snmp4nagios/Makefile
index 23b0bb6a548d..6c337b84ed4a 100644
--- a/net-mgmt/snmp4nagios/Makefile
+++ b/net-mgmt/snmp4nagios/Makefile
@@ -39,7 +39,7 @@ LIBS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MRRDTOOL}
-LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
+LIB_DEPENDS+= librrd.so:${PORTSDIR}/databases/rrdtool
CONFIGURE_ARGS+=--with-rrd
PLIST_SUB+= RRD=""
.else
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
index af4788f76a27..fc39a6206bb8 100644
--- a/net-p2p/gnunet/Makefile
+++ b/net-p2p/gnunet/Makefile
@@ -74,7 +74,7 @@ report.sh
.if ${PORT_OPTIONS:MHTTP}
BROKEN = WITH_HTTP requires libmicrohttpd 0.9.18 or higher
-LIB_DEPENDS+= microhttpd:${PORTSDIR}/www/libmicrohttpd
+LIB_DEPENDS+= libmicrohttpd.so:${PORTSDIR}/www/libmicrohttpd
CONFIGURE_ARGS+= --with-microhttpd=${LOCALBASE}
PLIST_SUB+= HTTP=""
.else
diff --git a/net-p2p/transmission-remote-gui/Makefile b/net-p2p/transmission-remote-gui/Makefile
index d1c106fa2b4b..63cb611f0f85 100644
--- a/net-p2p/transmission-remote-gui/Makefile
+++ b/net-p2p/transmission-remote-gui/Makefile
@@ -57,7 +57,7 @@ BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/edit
.endif
.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= Qt4Pas.5:${PORTSDIR}/x11-toolkits/qt4pas
+LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
.endif
diff --git a/net/click/Makefile b/net/click/Makefile
index 45f3a6d827d7..dce3ce94a951 100644
--- a/net/click/Makefile
+++ b/net/click/Makefile
@@ -97,7 +97,7 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MXML_EXPAT}
CONFIGURE_ARGS+= --with-expat=${LOCALBASE}
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
PLIST_SUB+= XMLCLICK=""
.else
PLIST_SUB+= XMLCLICK="@comment "
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 58c415cb3cb0..a71ea5744863 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -33,7 +33,7 @@ MAKE_ENV+= NC=no
.if ${PORT_OPTIONS:MFFTW}
MAKE_ENV+= FW=yes
-LIB_DEPENDS+= fftw3:${PORTSDIR}/math/fftw3
+LIB_DEPENDS+= libfftw3.so:${PORTSDIR}/math/fftw3
.else
MAKE_ENV+= FW=no
.endif
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index cb49b89aaff6..a0d63f5736b5 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -69,7 +69,7 @@ LIBEXTRACTOR_DESC= libextractor support
CONFIGURE_ARGS+= --enable-sqlite3 \
--with-sqlite3-h="${LOCALBASE}/include" \
--with-sqlite3-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
.else
CONFIGURE_ARGS+= --disable-sqlite3
.endif
@@ -86,7 +86,7 @@ CONFIGURE_ARGS+= --disable-mysql
CONFIGURE_ARGS+= --enable-libjs \
--with-js-h="${LOCALBASE}/include" \
--with-js-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= js:${PORTSDIR}/lang/spidermonkey17
+LIB_DEPENDS+= libjs.so:${PORTSDIR}/lang/spidermonkey17
.else
CONFIGURE_ARGS+= --disable-libjs
.endif
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+= --disable-libjs
CONFIGURE_ARGS+= --enable-libexif \
--with-libexif-h="${LOCALBASE}/include" \
--with-libexif-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
.else
CONFIGURE_ARGS+= --disable-libexif
.endif
@@ -110,7 +110,7 @@ CONFIGURE_ARGS+= --disable-external-transcoding
CONFIGURE_ARGS+= --enable-ffmpegthumbnailer \
--with-ffmpegthumbnailer-h="${LOCALBASE}/include" \
--with-ffmpegthumbnailer-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= ffmpegthumbnailer:${PORTSDIR}/multimedia/ffmpegthumbnailer
+LIB_DEPENDS+= libffmpegthumbnailer.so:${PORTSDIR}/multimedia/ffmpegthumbnailer
.else
CONFIGURE_ARGS+= --disable-ffmpegthumbnailer
.endif
@@ -119,14 +119,14 @@ CONFIGURE_ARGS+= --disable-ffmpegthumbnailer
.if ${PORT_OPTIONS:MCURL} && ${PORT_OPTIONS:MEXTERNAL_TRANSCODING}
CONFIGURE_ARGS+= --enable-curl \
--with-curl-cfg="${LOCALBASE}/bin/curl-config"
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
.else
CONFIGURE_ARGS+= --disable-curl
.endif
.if ${PORT_OPTIONS:MFFMPEG}
CONFIGURE_ARGS+= --enable-ffmpeg
-LIB_DEPENDS+= avformat:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
.else
CONFIGURE_ARGS+= --disable-ffmpeg
.endif
@@ -135,7 +135,7 @@ CONFIGURE_ARGS+= --disable-ffmpeg
CONFIGURE_ARGS+= --enable-libextractor \
--with-extractor-h="${LOCALBASE}/include" \
--with-extractor-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= extractor:${PORTSDIR}/textproc/libextractor
+LIB_DEPENDS+= libextractor.so:${PORTSDIR}/textproc/libextractor
.else
CONFIGURE_ARGS+= --disable-libextractor
.endif
@@ -144,7 +144,7 @@ CONFIGURE_ARGS+= --disable-libextractor
CONFIGURE_ARGS+= --enable-id3lib \
--with-id3lib-h="${LOCALBASE}/include" \
--with-id3lib-libs="${LOCALBASE}/lib"
-LIB_DEPENDS+= id3:${PORTSDIR}/audio/id3lib
+LIB_DEPENDS+= libid3.so:${PORTSDIR}/audio/id3lib
.else
CONFIGURE_ARGS+= --disable-id3lib
.endif
@@ -152,7 +152,7 @@ CONFIGURE_ARGS+= --disable-id3lib
.if ${PORT_OPTIONS:MTAGLIB}
CONFIGURE_ARGS+= --enable-taglib \
--with-taglib-cfg="${LOCALBASE}/bin/taglib-config"
-LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
+LIB_DEPENDS+= libtag.so:${PORTSDIR}/audio/taglib
.else
CONFIGURE_ARGS+= --disable-taglib
.endif
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 42eca8e84dde..9db60f057c6c 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -471,7 +471,7 @@ PLIST_SUB+= SLAPI="@comment "
.if ${PORT_OPTIONS:MSLP}
CONFIGURE_ARGS+= --enable-slp
-LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
+LIB_DEPENDS+= libslp.so:${PORTSDIR}/net/openslp
.endif
# Include tcp-wrapper support
diff --git a/net/openser/Makefile b/net/openser/Makefile
index fa3212bd6798..4a4cf210a598 100644
--- a/net/openser/Makefile
+++ b/net/openser/Makefile
@@ -80,7 +80,7 @@ MAKE_ENV+= POSTGRESQL=postgres
.endif
.if ${PORT_OPTIONS:MUNIXODBC}
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
MODULES+= unixodbc
.else
MAKE_ENV+= UNIXODBC=unixodbc
diff --git a/net/quagga-re/Makefile b/net/quagga-re/Makefile
index 0ef0bacb7bde..33d102c701e7 100644
--- a/net/quagga-re/Makefile
+++ b/net/quagga-re/Makefile
@@ -114,7 +114,7 @@ CONFIGURE_ARGS+=--enable-rtadv
.if ${PORT_OPTIONS:MSNMP}
CONFIGURE_ARGS+=--enable-snmp
-LIB_DEPENDS+=netsnmp:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+=libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
.endif
.if ${PORT_OPTIONS:MTCPSOCKETS}
@@ -122,7 +122,7 @@ CONFIGURE_ARGS+=--enable-tcp-zebra
.endif
.if ${PORT_OPTIONS:MDLMALLOC}
-LIB_DEPENDS+=dlmalloc:${PORTSDIR}/devel/libdlmalloc
+LIB_DEPENDS+=libdlmalloc.so:${PORTSDIR}/devel/libdlmalloc
LDFLAGS+=-ldlmalloc
SUB_LIST= RCLDCONFIG=ldconfig
.else
diff --git a/net/rabbitmq-c-devel/Makefile b/net/rabbitmq-c-devel/Makefile
index fd501cbc6753..54abe0830160 100644
--- a/net/rabbitmq-c-devel/Makefile
+++ b/net/rabbitmq-c-devel/Makefile
@@ -46,7 +46,7 @@ CONFIGURE_ARGS+= --enable-64-bit
.endif
.if ${PORT_OPTIONS:MPOPT}
-LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS+= libpopt.so:${PORTSDIR}/devel/popt
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/shmux/Makefile b/net/shmux/Makefile
index d8181f106955..3054947bb3de 100644
--- a/net/shmux/Makefile
+++ b/net/shmux/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --with-pcre=no
diff --git a/net/spserver/Makefile b/net/spserver/Makefile
index ab94c2541ba6..1b7bfc61f57e 100644
--- a/net/spserver/Makefile
+++ b/net/spserver/Makefile
@@ -33,7 +33,7 @@ PLIST_SUB+= WITH_MATRIXSSL="@comment "
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
ALL_TARGET+= build_gnutls
PLIST_SUB+= WITH_GNUTLS=""
.else
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 54b14816f236..d57c7c4c4d8c 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -52,7 +52,7 @@ CONFIGURE_ARGS+= --disable-smb
.endif
.if ${PORT_OPTIONS:MSMI}
-LIB_DEPENDS+= smi:${PORTSDIR}/net-mgmt/libsmi
+LIB_DEPENDS+= libsmi.so:${PORTSDIR}/net-mgmt/libsmi
.else
CONFIGURE_ARGS+= --disable-smi
.endif
diff --git a/net/trafshow3/Makefile b/net/trafshow3/Makefile
index ec81a4012b10..7b4dd3465ed6 100644
--- a/net/trafshow3/Makefile
+++ b/net/trafshow3/Makefile
@@ -18,7 +18,7 @@ CONFLICTS= trafshow-[45].*
.if defined(WITH_TRAFSHOW_SLANG) || \
(exists(${LOCALBASE}/lib/libslang.a) && !defined(WITHOUT_TRAFSHOW_SLANG))
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2
.endif
GNU_CONFIGURE= yes
diff --git a/net/wire/Makefile b/net/wire/Makefile
index 64f2b6e3f356..40433893b154 100644
--- a/net/wire/Makefile
+++ b/net/wire/Makefile
@@ -27,7 +27,7 @@ MAN1= wire.1
#.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+LIB_DEPENDS+= libreadline.so.6:${PORTSDIR}/devel/readline
.endif
#.include <bsd.port.post.mk>
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 1bf06adbc3c6..3b2bc85e6c74 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -72,7 +72,7 @@ CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
.if ${PORT_OPTIONS:MKERBEROS}
. if exists(${LOCALBASE}/bin/krb5-config)
-LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-kerberos=${LOCALBASE}
. else
CONFIGURE_ARGS+= --with-kerberos=/usr
@@ -104,7 +104,7 @@ CONFIGURE_ARGS+= --enable-keywords
.if ${PORT_OPTIONS:MSASL}
CONFIGURE_ARGS+= --with-sasl=${LOCALBASE}
-LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
.endif
.if ${PORT_OPTIONS:MTAGGED_HASH}