aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-15 17:44:36 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-15 17:44:36 +0000
commitf351e3fcedf3fe4aba5665c61269073a6a67bfd6 (patch)
tree33c7c5dfc5a6304b951b22b9cc048728a4db9f15
parent3d232da302638266548ffa90582ee9475ab40f44 (diff)
downloadports-f351e3fcedf3fe4aba5665c61269073a6a67bfd6.tar.gz
ports-f351e3fcedf3fe4aba5665c61269073a6a67bfd6.zip
Fix build with gcc 3.4
Notes
Notes: svn path=/head/; revision=116294
-rw-r--r--editors/wily/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/editors/wily/Makefile b/editors/wily/Makefile
index e224c0808c44..c8a61c6f0c01 100644
--- a/editors/wily/Makefile
+++ b/editors/wily/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rc:${PORTSDIR}/shells/rc
USE_XLIB= YES
GNU_CONFIGURE= YES
USE_GMAKE= YES
+USE_REINPLACE= YES
MAN1= wgoto.1 win.1 wreplace.1 Tag.1 mktags.1 Man.1
PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
@@ -33,6 +34,10 @@ PORTDOCS= index.html intro.html download.html credits.html FAQ.html \
TUTEDOCS= hello.c start typescript
TUTESHS= findword script send_to_gary
+post-patch:
+ cd ${WRKSRC}/tools/win; ${REINPLACE_CMD} -e 's," in " __FUNCTION__ "()",,' \
+ win.c wgoto.c wreplace.c
+
# Run the configure script in the tools directory.
post-configure:
@${RM} ${WRKSRC}/tools/win/config.cache