aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2007-04-10 18:29:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2007-04-10 18:29:39 +0000
commit20b11fde63db5f4117229df40d33c6e147f3b1c9 (patch)
tree55a816c53e62d0441cc30bedc156b26ca7b433ba
parent0227c3b871f58b7622088360b1b9b78c72a98a9c (diff)
downloadports-20b11fde63db5f4117229df40d33c6e147f3b1c9.tar.gz
ports-20b11fde63db5f4117229df40d33c6e147f3b1c9.zip
Get rid of annoying message when do a "make index" at the system without
linuxolator started: ----- sysctl: unknown oid 'compat.linux.osrelease' ----- Reported by: netchild, rafan, chinsan Suggested by: rafan
Notes
Notes: svn path=/head/; revision=189702
-rw-r--r--emulators/linux_base-c6/Makefile2
-rw-r--r--emulators/linux_base-f10/Makefile2
-rw-r--r--emulators/linux_base-f7/Makefile2
-rw-r--r--emulators/linux_base-f8/Makefile2
-rw-r--r--emulators/linux_base-f9/Makefile2
-rw-r--r--emulators/linux_base-f9/linux_base-f8/Makefile2
-rw-r--r--emulators/linux_base-fc6/Makefile2
-rw-r--r--emulators/linux_base-fc7/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f7/Makefile b/emulators/linux_base-f7/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f7/Makefile
+++ b/emulators/linux_base-f7/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f8/Makefile b/emulators/linux_base-f8/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f8/Makefile
+++ b/emulators/linux_base-f8/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f9/Makefile b/emulators/linux_base-f9/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f9/Makefile
+++ b/emulators/linux_base-f9/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-f9/linux_base-f8/Makefile b/emulators/linux_base-f9/linux_base-f8/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-f9/linux_base-f8/Makefile
+++ b/emulators/linux_base-f9/linux_base-f8/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-fc6/Makefile b/emulators/linux_base-fc6/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-fc6/Makefile
+++ b/emulators/linux_base-fc6/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported
diff --git a/emulators/linux_base-fc7/Makefile b/emulators/linux_base-fc7/Makefile
index c16024b93308..9fb92628100f 100644
--- a/emulators/linux_base-fc7/Makefile
+++ b/emulators/linux_base-fc7/Makefile
@@ -121,7 +121,7 @@ PLIST= pkg-plist
.include <bsd.port.pre.mk>
-LINUX_OSRELEASE!= ${SYSCTL} -n compat.linux.osrelease
+LINUX_OSRELEASE!= ${ECHO} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
.if ${LINUX_OSRELEASE} == "2.4.2"
IGNORE= compat.linux.osrelease: 2.4.2 is not supported