aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:59:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:59:51 +0000
commit2e268f2b02aa4a22028c5e9f1f6a806ec5087d55 (patch)
tree1426357d0a4a081554d0b1ba10254dc61d297b9e
parentd63a260f2e296e52edf9dbfb29ad56b7500b6964 (diff)
downloadports-2e268f2b02aa4a22028c5e9f1f6a806ec5087d55.tar.gz
ports-2e268f2b02aa4a22028c5e9f1f6a806ec5087d55.zip
- Update to 1.02
PR: 144590 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=250802
-rw-r--r--math/py-gato/Makefile34
-rw-r--r--math/py-gato/distinfo6
-rw-r--r--math/py-gato/files/patch-Gato.py25
-rw-r--r--math/py-gato/files/patch-GatoFile.py8
-rw-r--r--math/py-gato/files/patch-Gred.py53
-rw-r--r--math/py-gato/files/patch-TextTreeWidget.py8
-rw-r--r--math/py-gato/pkg-descr2
-rw-r--r--math/py-gato/pkg-plist14
8 files changed, 26 insertions, 124 deletions
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index e9a50a33ac81..e75e8fce4551 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gato
-PORTVERSION= 0.99D
+PORTVERSION= 1.02
CATEGORIES= math python
MASTER_SITES= http://gato.sourceforge.net/Download/
MASTER_SITE_SUBDIR= gato
@@ -18,35 +18,37 @@ COMMENT= A Python-based toolbox to visualise algorithms on graphs
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-USE_PYTHON= yes
WRKSRC= ${WRKDIR}/Gato
-GATO_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Gato
+
+USE_PYTHON= yes
+
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
- @ ${REINPLACE_CMD} -e 's,^.*__future__.*$$,,' ${WRKSRC}/DataStructures.py
+ @${REINPLACE_CMD} -e 's,^.*__future__.*$$,,' ${WRKSRC}/DataStructures.py
+ @${GREP} -lR "^#!" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ '/^#!/s|python.*$$|python|g'
pre-build:
- @ ${TOUCH} ${WRKSRC}/__init__.py
+ @${TOUCH} ${WRKSRC}/__init__.py
do-build:
- @ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
- @ ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
do-install:
- @ ${MKDIR} ${GATO_DIR}
- @ cd ${WRKSRC} && ${FIND} *.py *.pyc *.pyo \
- -name Gato.py\* -o -print \
- | ${CPIO} --verbose -pdum -R ${BINOWN}:${BINGRP} ${GATO_DIR}
+ @${MKDIR} ${PYTHON_SITELIBDIR}/Gato
+.for pyfile in *.py *.pyc *.pyo
+ ${INSTALL_DATA} ${WRKSRC}/${pyfile} ${PYTHON_SITELIBDIR}/Gato
+.endfor
.for script in Gato Gred
- @ ${INSTALL_SCRIPT} ${WRKSRC}/${script}.py ${PREFIX}/bin/${script}
+ @${CHMOD} ${BINMODE} ${PYTHON_SITELIBDIR}/Gato/${script}.py
+ @${LN} -sf ${PYTHON_SITELIBDIR}/Gato/${script}.py ${PREFIX}/bin/${script}
.endfor
-
-post-install:
.if !defined(NOPORTEXAMPLES)
- @ ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
.for egfile in *.alg *.pro *.cat
- @ ${INSTALL_DATA} ${WRKSRC}/${egfile} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${egfile} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/math/py-gato/distinfo b/math/py-gato/distinfo
index 8cb76be817de..e7a7cec7785a 100644
--- a/math/py-gato/distinfo
+++ b/math/py-gato/distinfo
@@ -1,3 +1,3 @@
-MD5 (Gato-0.99D.tar.gz) = 451ef1fd17e6f8b6355377ad325d78eb
-SHA256 (Gato-0.99D.tar.gz) = fc4d87073fe06a2dd9ce504b7481a7963ea4e641c531061bf31ae81cfdd3b06b
-SIZE (Gato-0.99D.tar.gz) = 194444
+MD5 (Gato-1.02.tar.gz) = be60c2effd8d4359eab25e698791d622
+SHA256 (Gato-1.02.tar.gz) = 28632f326429534ccc4919b49aedb4b4b210ac9318024a0aa677a37239231035
+SIZE (Gato-1.02.tar.gz) = 182323
diff --git a/math/py-gato/files/patch-Gato.py b/math/py-gato/files/patch-Gato.py
deleted file mode 100644
index 3b16a3055c15..000000000000
--- a/math/py-gato/files/patch-Gato.py
+++ /dev/null
@@ -1,25 +0,0 @@
---- Gato.py Wed Jul 08 22:14:29 2009 +0900
-+++ Gato.py Wed Jul 08 22:16:07 2009 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
-@@ -1590,11 +1590,11 @@
- self.algoGlobals['A'] = self.GUI.graphDisplay
- # XXX
- # explictely loading packages we want to make available to the algorithm
-- modules = ['DataStructures',
-- 'AnimatedDataStructures',
-- 'AnimatedAlgorithms',
-- 'GraphUtil',
-- 'GatoUtil']
-+ modules = ['Gato.DataStructures',
-+ 'Gato.AnimatedDataStructures',
-+ 'Gato.AnimatedAlgorithms',
-+ 'Gato.GraphUtil',
-+ 'Gato.GatoUtil']
-
- for m in modules:
- exec("from %s import *" % m, self.algoGlobals, self.algoGlobals)
diff --git a/math/py-gato/files/patch-GatoFile.py b/math/py-gato/files/patch-GatoFile.py
deleted file mode 100644
index f75bc3793f78..000000000000
--- a/math/py-gato/files/patch-GatoFile.py
+++ /dev/null
@@ -1,8 +0,0 @@
---- GatoFile.py Wed Mar 8 10:47:35 2006
-+++ GatoFile.py Wed Mar 8 10:47:47 2006
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
diff --git a/math/py-gato/files/patch-Gred.py b/math/py-gato/files/patch-Gred.py
deleted file mode 100644
index 997bf65bec27..000000000000
--- a/math/py-gato/files/patch-Gred.py
+++ /dev/null
@@ -1,53 +0,0 @@
---- Gred.py Wed Jul 08 22:14:29 2009 +0900
-+++ Gred.py Wed Jul 08 22:16:07 2009 +0900
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
-@@ -34,17 +34,17 @@
- # last change by $Author: schliep $.
- #
- ################################################################################
--from GatoGlobals import *
--import GatoGlobals # Needed for help viewer.XXX
--from Graph import Graph
--from DataStructures import EdgeWeight, VertexWeight
--from GraphUtil import OpenCATBoxGraph, OpenGMLGraph, OpenDotGraph, SaveCATBoxGraph, WeightedGraphInformer
--from GraphEditor import GraphEditor
-+from Gato.GatoGlobals import *
-+import Gato.GatoGlobals # Needed for help viewer.XXX
-+from Gato.Graph import Graph
-+from Gato.DataStructures import EdgeWeight, VertexWeight
-+from Gato.GraphUtil import OpenCATBoxGraph, OpenGMLGraph, OpenDotGraph, SaveCATBoxGraph, WeightedGraphInformer
-+from Gato.GraphEditor import GraphEditor
- from Tkinter import *
- import tkFont
--from GatoUtil import stripPath, extension, gatoPath
--import GatoDialogs
--import GatoIcons
-+from Gato.GatoUtil import stripPath, extension, gatoPath
-+from Gato import GatoDialogs
-+from Gato import GatoIcons
- from ScrolledText import *
-
- from tkFileDialog import askopenfilename, asksaveasfilename
-@@ -56,7 +56,7 @@
- import os
- import webbrowser
-
--import GraphCreator, Embedder
-+from Gato import GraphCreator, Embedder
-
- class GredSplashScreen(GatoDialogs.SplashScreen):
-
-@@ -926,7 +926,7 @@
- ## globals()['gVertexRadius'] = 12
- ## globals()['gVertexFrameWidth'] = 0
- ## globals()['gEdgeWidth'] = 2
-- GatoGlobals.cVertexDefault = '#000099'
-+ Gato.GatoGlobals.cVertexDefault = '#000099'
- ## globals()['cEdgeDefault'] = '#999999'
- ## globals()['cLabelDefault'] = 'white'
-
diff --git a/math/py-gato/files/patch-TextTreeWidget.py b/math/py-gato/files/patch-TextTreeWidget.py
deleted file mode 100644
index 4354615a763b..000000000000
--- a/math/py-gato/files/patch-TextTreeWidget.py
+++ /dev/null
@@ -1,8 +0,0 @@
---- TextTreeWidget.py Wed Mar 8 10:47:35 2006
-+++ TextTreeWidget.py Wed Mar 8 10:47:47 2006
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.3
-+#!/usr/bin/env python
- ################################################################################
- #
- # This file is part of Gato (Graph Animation Toolbox)
diff --git a/math/py-gato/pkg-descr b/math/py-gato/pkg-descr
index 012817f6a3a6..7ed369817101 100644
--- a/math/py-gato/pkg-descr
+++ b/math/py-gato/pkg-descr
@@ -10,4 +10,4 @@ Paraphrasing the website:
immediately to an effect - changes to the graph the algorithm has as its
input - by terms of blinking, changing colors and other visual effects.
-WWW: http://gato.sourceforge.net/index.html
+WWW: http://gato.sourceforge.net/
diff --git a/math/py-gato/pkg-plist b/math/py-gato/pkg-plist
index d0f02741b4fb..a5429e9b6093 100644
--- a/math/py-gato/pkg-plist
+++ b/math/py-gato/pkg-plist
@@ -18,6 +18,9 @@ bin/Gred
%%PYTHON_SITELIBDIR%%/Gato/Embedder.py
%%PYTHON_SITELIBDIR%%/Gato/Embedder.pyc
%%PYTHON_SITELIBDIR%%/Gato/Embedder.pyo
+%%PYTHON_SITELIBDIR%%/Gato/Gato.py
+%%PYTHON_SITELIBDIR%%/Gato/Gato.pyc
+%%PYTHON_SITELIBDIR%%/Gato/Gato.pyo
%%PYTHON_SITELIBDIR%%/Gato/GatoConfiguration.py
%%PYTHON_SITELIBDIR%%/Gato/GatoConfiguration.pyc
%%PYTHON_SITELIBDIR%%/Gato/GatoConfiguration.pyo
@@ -33,9 +36,6 @@ bin/Gred
%%PYTHON_SITELIBDIR%%/Gato/GatoIcons.py
%%PYTHON_SITELIBDIR%%/Gato/GatoIcons.pyc
%%PYTHON_SITELIBDIR%%/Gato/GatoIcons.pyo
-%%PYTHON_SITELIBDIR%%/Gato/GatoSystemConfiguration.py
-%%PYTHON_SITELIBDIR%%/Gato/GatoSystemConfiguration.pyc
-%%PYTHON_SITELIBDIR%%/Gato/GatoSystemConfiguration.pyo
%%PYTHON_SITELIBDIR%%/Gato/GatoTest.py
%%PYTHON_SITELIBDIR%%/Gato/GatoTest.pyc
%%PYTHON_SITELIBDIR%%/Gato/GatoTest.pyo
@@ -66,19 +66,13 @@ bin/Gred
%%PYTHON_SITELIBDIR%%/Gato/PlanarityTest.py
%%PYTHON_SITELIBDIR%%/Gato/PlanarityTest.pyc
%%PYTHON_SITELIBDIR%%/Gato/PlanarityTest.pyo
-%%PYTHON_SITELIBDIR%%/Gato/TextTreeWidget.py
-%%PYTHON_SITELIBDIR%%/Gato/TextTreeWidget.pyc
-%%PYTHON_SITELIBDIR%%/Gato/TextTreeWidget.pyo
-%%PYTHON_SITELIBDIR%%/Gato/TreeWidget.py
-%%PYTHON_SITELIBDIR%%/Gato/TreeWidget.pyc
-%%PYTHON_SITELIBDIR%%/Gato/TreeWidget.pyo
%%PYTHON_SITELIBDIR%%/Gato/__init__.py
%%PYTHON_SITELIBDIR%%/Gato/__init__.pyc
%%PYTHON_SITELIBDIR%%/Gato/__init__.pyo
-@dirrm %%PYTHON_SITELIBDIR%%/Gato
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BFS.alg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BFS.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/DFS.alg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/DFS.pro
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.cat
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/Gato