aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2009-01-06 17:55:54 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2009-01-06 17:55:54 +0000
commit87b685f5d4325ba771e96b0ef49c71f903fb3ae0 (patch)
treee8f527e6b4efd08113ec9310adb752508d7a01be
parent7b4ee14e1fc34f0768f24115ada4f2d23bd35e75 (diff)
downloadports-87b685f5d4325ba771e96b0ef49c71f903fb3ae0.tar.gz
ports-87b685f5d4325ba771e96b0ef49c71f903fb3ae0.zip
- Update to 2.6.3
- Remove WITH_OPENCDK knob since it's not relevant anymore - Add WITH_LZO knob PR: 127330 (partially) Submitted by: Yarema <yds@CoolRat.org>
Notes
Notes: svn path=/head/; revision=225334
-rw-r--r--security/gnutls/Makefile17
-rw-r--r--security/gnutls/Makefile.man47
-rw-r--r--security/gnutls/distinfo6
-rw-r--r--security/gnutls/files/patch-CVE-2008-498920
-rw-r--r--security/gnutls/files/patch-includes__gnutls__gnutls.h.in11
-rw-r--r--security/gnutls/pkg-plist1
6 files changed, 46 insertions, 56 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 037e69656717..677773fe6f7c 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 2.4.2
-PORTREVISION= 2
+PORTVERSION= 2.6.3
CATEGORIES= security net
MASTER_SITES= http://josefsson.org/gnutls/releases/ \
ftp://ftp.gnutls.org/pub/gnutls/ \
@@ -33,15 +32,10 @@ USE_AUTOTOOLS= libtool:15
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+= --with-included-lzo --disable-guile
+CONFIGURE_ARGS+= --disable-guile
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if (defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.10)) && !defined(WITHOUT_OPENCDK)
-LIB_DEPENDS+= opencdk.10:${PORTSDIR}/security/opencdk
-.else
-CONFIGURE_ARGS+= --with-included-opencdk
-.endif
.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)) && !defined(WITHOUT_LIBTASN1)
LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
@@ -49,6 +43,13 @@ LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
CONFIGURE_ARGS+= --with-included-libtasn1
.endif
+.if (defined(WITH_LZO) || exists(${LOCALBASE}/lib/liblzo2.so)) && !defined(WITHOUT_LZO)
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+CONFIGURE_ARGS+= --with-lzo
+.else
+CONFIGURE_ARGS+= --with-lzo=no
+.endif
+
.if ${OSVERSION} < 600000
BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
CONFIGURE_ENV+= MAKEINFO="${LOCALBASE}/bin/makeinfo"
diff --git a/security/gnutls/Makefile.man b/security/gnutls/Makefile.man
index 87f6912175a1..d7c92aeeb389 100644
--- a/security/gnutls/Makefile.man
+++ b/security/gnutls/Makefile.man
@@ -88,10 +88,15 @@ MAN3= \
gnutls_compression_set_priority.3 \
gnutls_credentials_clear.3 \
gnutls_credentials_set.3 \
- gnutls_crypto_cipher_register.3 \
- gnutls_crypto_digest_register.3 \
- gnutls_crypto_mac_register.3 \
- gnutls_crypto_rnd_register.3 \
+ gnutls_crypto_bigint_register2.3 \
+ gnutls_crypto_cipher_register2.3 \
+ gnutls_crypto_digest_register2.3 \
+ gnutls_crypto_mac_register2.3 \
+ gnutls_crypto_pk_register2.3 \
+ gnutls_crypto_rnd_register2.3 \
+ gnutls_crypto_single_cipher_register2.3 \
+ gnutls_crypto_single_digest_register2.3 \
+ gnutls_crypto_single_mac_register2.3 \
gnutls_db_check_entry.3 \
gnutls_db_get_ptr.3 \
gnutls_db_remove_session.3 \
@@ -117,6 +122,7 @@ MAN3= \
gnutls_dh_set_prime_bits.3 \
gnutls_error_is_fatal.3 \
gnutls_error_to_alert.3 \
+ gnutls_ext_register.3 \
gnutls_extra_check_version.3 \
gnutls_fingerprint.3 \
gnutls_free.3 \
@@ -240,6 +246,9 @@ MAN3= \
gnutls_pem_base64_encode_alloc.3 \
gnutls_perror.3 \
gnutls_pk_algorithm_get_name.3 \
+ gnutls_pk_get_id.3 \
+ gnutls_pk_get_name.3 \
+ gnutls_pk_list.3 \
gnutls_pkcs12_bag_decrypt.3 \
gnutls_pkcs12_bag_deinit.3 \
gnutls_pkcs12_bag_encrypt.3 \
@@ -309,6 +318,7 @@ MAN3= \
gnutls_record_recv.3 \
gnutls_record_send.3 \
gnutls_record_set_max_size.3 \
+ gnutls_register_md5_handler.3 \
gnutls_rehandshake.3 \
gnutls_rsa_export_get_modulus_bits.3 \
gnutls_rsa_export_get_pubkey.3 \
@@ -332,12 +342,16 @@ MAN3= \
gnutls_session_get_server_random.3 \
gnutls_session_is_resumed.3 \
gnutls_session_set_data.3 \
+ gnutls_session_set_finished_function.3 \
gnutls_session_set_ptr.3 \
gnutls_set_default_export_priority.3 \
gnutls_set_default_priority.3 \
gnutls_sign_algorithm_get_name.3 \
gnutls_sign_callback_set.3 \
gnutls_sign_callback_get.3 \
+ gnutls_sign_get_id.3 \
+ gnutls_sign_get_name.3 \
+ gnutls_sign_list.3 \
gnutls_srp_allocate_client_credentials.3 \
gnutls_srp_allocate_server_credentials.3 \
gnutls_srp_base64_decode.3 \
@@ -349,10 +363,12 @@ MAN3= \
gnutls_srp_server_get_username.3 \
gnutls_srp_set_client_credentials.3 \
gnutls_srp_set_client_credentials_function.3 \
+ gnutls_srp_set_prime_bits.3 \
gnutls_srp_set_server_credentials_file.3 \
gnutls_srp_set_server_credentials_function.3 \
gnutls_srp_verifier.3 \
gnutls_strerror.3 \
+ gnutls_strerror_name.3 \
gnutls_transport_get_ptr.3 \
gnutls_transport_get_ptr2.3 \
gnutls_transport_set_errno.3 \
@@ -411,6 +427,7 @@ MAN3= \
gnutls_x509_crq_set_challenge_password.3 \
gnutls_x509_crq_set_dn_by_oid.3 \
gnutls_x509_crq_set_key.3 \
+ gnutls_x509_crq_set_key_rsa_raw.3 \
gnutls_x509_crq_set_version.3 \
gnutls_x509_crq_sign.3 \
gnutls_x509_crq_sign2.3 \
@@ -454,6 +471,7 @@ MAN3= \
gnutls_x509_crt_set_basic_constraints.3 \
gnutls_x509_crt_set_ca_status.3 \
gnutls_x509_crt_set_crl_dist_points.3 \
+ gnutls_x509_crt_set_crl_dist_points2.3 \
gnutls_x509_crt_set_dn_by_oid.3 \
gnutls_x509_crt_set_expiration_time.3 \
gnutls_x509_crt_set_extension_by_oid.3 \
@@ -464,6 +482,7 @@ MAN3= \
gnutls_x509_crt_set_proxy.3 \
gnutls_x509_crt_set_proxy_dn.3 \
gnutls_x509_crt_set_serial.3 \
+ gnutls_x509_crt_set_subject_alt_name.3 \
gnutls_x509_crt_set_subject_alternative_name.3 \
gnutls_x509_crt_set_subject_key_id.3 \
gnutls_x509_crt_sign2.3 \
@@ -490,16 +509,16 @@ MAN3= \
gnutls_x509_rdn_get.3 \
gnutls_x509_rdn_get_by_oid.3 \
gnutls_x509_rdn_get_oid.3 \
- gnutls_alert_get.3 \
- gnutls_certificate_get_peers.3 \
- gnutls_x509_crt_check_revocation.3 \
- gnutls_x509_crt_get_ca_status.3 \
- gnutls_x509_crt_get_extension_by_oid.3 \
- gnutls_x509_crt_get_subject.3 \
+ gnutls_alert_get.3 \
+ gnutls_certificate_get_peers.3 \
+ gnutls_x509_crt_check_revocation.3 \
+ gnutls_x509_crt_get_ca_status.3 \
+ gnutls_x509_crt_get_extension_by_oid.3 \
+ gnutls_x509_crt_get_subject.3 \
gnutls_x509_crt_get_issuer.3 \
gnutls_x509_crt_init.3 \
- gnutls_x509_crt_set_crq.3 \
- gnutls_x509_crt_set_version.3 \
- gnutls_x509_crt_sign.3 \
- gnutls_x509_crt_verify_data.3 \
+ gnutls_x509_crt_set_crq.3 \
+ gnutls_x509_crt_set_version.3 \
+ gnutls_x509_crt_sign.3 \
+ gnutls_x509_crt_verify_data.3 \
gnutls_x509_dn_get_rdn_ava.3
diff --git a/security/gnutls/distinfo b/security/gnutls/distinfo
index 742388c78939..d1768c0748a4 100644
--- a/security/gnutls/distinfo
+++ b/security/gnutls/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnutls-2.4.2.tar.bz2) = 148bde1f43cae2ea4265439df0da6399
-SHA256 (gnutls-2.4.2.tar.bz2) = 1c70e916c691c7c31ea3c8f2abeedae6c7dfda754e02b373287ceb5b46bfbb0e
-SIZE (gnutls-2.4.2.tar.bz2) = 4958098
+MD5 (gnutls-2.6.3.tar.bz2) = c6d2d1996b87b238ad6f73f92225d9a2
+SHA256 (gnutls-2.6.3.tar.bz2) = eddd7ee659dcf995362cf2ce5e9b43cb9ada34e55e10d28ee6273c555a5240e7
+SIZE (gnutls-2.6.3.tar.bz2) = 5114214
diff --git a/security/gnutls/files/patch-CVE-2008-4989 b/security/gnutls/files/patch-CVE-2008-4989
deleted file mode 100644
index 0fcbc839f437..000000000000
--- a/security/gnutls/files/patch-CVE-2008-4989
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/x509/verify.c.orig 2008-09-16 00:04:19.000000000 +0400
-+++ lib/x509/verify.c 2008-11-14 16:06:59.000000000 +0300
-@@ -414,17 +425,6 @@
- }
- #endif
-
-- /* Check if the last certificate in the path is self signed.
-- * In that case ignore it (a certificate is trusted only if it
-- * leads to a trusted party by us, not the server's).
-- */
-- if (gnutls_x509_crt_check_issuer (certificate_list[clist_size - 1],
-- certificate_list[clist_size - 1]) > 0
-- && clist_size > 0)
-- {
-- clist_size--;
-- }
--
- /* Verify the certificate path (chain)
- */
- for (i = clist_size - 1; i > 0; i--)
diff --git a/security/gnutls/files/patch-includes__gnutls__gnutls.h.in b/security/gnutls/files/patch-includes__gnutls__gnutls.h.in
deleted file mode 100644
index 7af3fcf9e17d..000000000000
--- a/security/gnutls/files/patch-includes__gnutls__gnutls.h.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./includes/gnutls/gnutls.h.in.orig 2008-06-30 13:45:51.000000000 -0700
-+++ ./includes/gnutls/gnutls.h.in 2008-07-30 01:39:55.348483886 -0700
-@@ -287,7 +287,7 @@
- {
- GNUTLS_CRT_PRINT_FULL,
- GNUTLS_CRT_PRINT_ONELINE,
-- GNUTLS_CRT_PRINT_UNSIGNED_FULL,
-+ GNUTLS_CRT_PRINT_UNSIGNED_FULL
- } gnutls_certificate_print_formats_t;
-
- typedef enum
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index e97ba6137e00..5c5af79e9b8b 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -72,6 +72,7 @@ share/aclocal/libgnutls.m4
%%NLS%%share/locale/de/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/en@quot/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/ms/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/nl/LC_MESSAGES/gnutls.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gnutls.mo