aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-13 07:21:04 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-13 07:21:04 +0000
commit9063f9304ce8598f71c59d404dda7fabd8cdc077 (patch)
treeac57f5ed25dbd047668d7b3028d2914c5ee6ec4c
parent3b027b7d05d5546056f679102f4d328e3e5f0b33 (diff)
downloadports-9063f9304ce8598f71c59d404dda7fabd8cdc077.tar.gz
ports-9063f9304ce8598f71c59d404dda7fabd8cdc077.zip
Update to 3.0.4
- Add LICENSE - Use USES=localbase - Use PORTDATA - Sort PLIST Changes: http://git.savannah.gnu.org/cgit/bison.git/tree/NEWS Differential Revision: https://reviews.FreeBSD.org/D9073 PR: 215840 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=431345
-rw-r--r--databases/monetdb/files/patch-monetdb5-extras-jaql-parser-jaql.y25
-rw-r--r--devel/bison/Makefile28
-rw-r--r--devel/bison/distinfo5
-rw-r--r--devel/bison/pkg-plist29
-rw-r--r--editors/xcoral/files/patch-BR_Parser.c35
-rw-r--r--editors/xcoral/files/patch-BR_Parser.y11
-rw-r--r--graphics/pixie/files/patch-src__ri__rib.l25
-rw-r--r--graphics/tumble/files/patch-parser.y20
-rw-r--r--japanese/ming/files/patch-actioncompiler-compile.h11
-rw-r--r--japanese/ming/files/patch-src_actioncompiler_swf4compiler.flex10
-rw-r--r--japanese/ming/files/patch-src_actioncompiler_swf4compiler.y19
-rw-r--r--japanese/ming/files/patch-src_actioncompiler_swf5compiler.flex10
-rw-r--r--japanese/ming/files/patch-src_actioncompiler_swf5compiler.y19
-rw-r--r--lang/hla/Makefile2
-rw-r--r--lang/hla/files/patch-hlaparse.bsn107
-rw-r--r--multimedia/avinfo/Makefile3
-rw-r--r--multimedia/avinfo/files/patch-src-ass.y33
-rw-r--r--net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l11
-rw-r--r--net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y31
-rw-r--r--www/kannel/Makefile5
20 files changed, 363 insertions, 76 deletions
diff --git a/databases/monetdb/files/patch-monetdb5-extras-jaql-parser-jaql.y b/databases/monetdb/files/patch-monetdb5-extras-jaql-parser-jaql.y
new file mode 100644
index 000000000000..380c0d874c34
--- /dev/null
+++ b/databases/monetdb/files/patch-monetdb5-extras-jaql-parser-jaql.y
@@ -0,0 +1,25 @@
+--- monetdb5/extras/jaql/parser/jaql.y.orig 2013-01-14 21:06:06.000000000 +0800
++++ monetdb5/extras/jaql/parser/jaql.y 2017-01-09 04:57:50.801797000 +0800
+@@ -81,12 +81,10 @@
+
+
+ %{
+-#define YYLEX_PARAM j->scanner
+-
+ int jaqllex(YYSTYPE* lvalp, void *scanner);
+
+ void
+-jaqlerror(struct _jc* j, char const *msg)
++jaqlerror(struct _jc* j, char const *msg, char const *yy_)
+ {
+ if (j->err[0] == '\0') {
+ char around[32];
+@@ -114,6 +112,8 @@
+
+ %}
+
++%parse-param {void *scanner}
++
+ %%
+
+ stmt: jaql ';'
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index a914f8d58dd4..cbd3567528a2 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bison
-PORTVERSION= 2.7.1
-PORTREVISION= 1
+PORTVERSION= 3.0.4
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= GNU
@@ -11,32 +10,31 @@ MASTER_SITES= GNU
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Parser generator from FSF, (mostly) compatible with Yacc
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= m4>=1.4.16,1:devel/m4
-RUN_DEPENDS= m4>=1.4.16,1:devel/m4
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS_DEFINE= EXAMPLES NLS
+OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
-CONFIGURE_ARGS+=--disable-yacc
-CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --disable-yacc
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib
TEST_TARGET= check
USE_PERL5= build
-USES= charsetfix makeinfo perl5 tar:xz
+USES= charsetfix localbase makeinfo perl5 tar:xz
INFO= bison
-PORTEXAMPLES= calc++
+PORTDATA= *
+PORTDOCS= *
+PORTEXAMPLES= *
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
post-patch:
- @${RM} ${WRKSRC}/doc/bison.info*
- @${REINPLACE_CMD} 's/MANS = yacc.1/MANS =/' ${WRKSRC}/doc/Makefile.in
-
-post-install:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/calc++
- ${INSTALL_DATA} ${WRKSRC}/examples/calc++/*.[chly]* ${STAGEDIR}${EXAMPLESDIR}/calc++
+ @${REINPLACE_CMD} -e 's|$$(docdir)\(/examples\)|$$(datarootdir)\1/bison|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/\(.*\) _Noreturn void/_Noreturn \1 void/' ${WRKSRC}/data/*.c ${WRKSRC}/lib/*.[ch]
.include <bsd.port.mk>
diff --git a/devel/bison/distinfo b/devel/bison/distinfo
index bf3adf940cbe..c39a8a6d7a33 100644
--- a/devel/bison/distinfo
+++ b/devel/bison/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bison-2.7.1.tar.xz) = b409adcbf245baadb68d2f66accf6fdca5e282cafec1b865f4b5e963ba8ea7fb
-SIZE (bison-2.7.1.tar.xz) = 1781068
+TIMESTAMP = 1482778226
+SHA256 (bison-3.0.4.tar.xz) = a72428c7917bdf9fa93cb8181c971b6e22834125848cf1d03ce10b1bb0716fe1
+SIZE (bison-3.0.4.tar.xz) = 1973796
diff --git a/devel/bison/pkg-plist b/devel/bison/pkg-plist
index 37fe4a3b742b..ff1195a2e100 100644
--- a/devel/bison/pkg-plist
+++ b/devel/bison/pkg-plist
@@ -1,28 +1,6 @@
bin/bison
man/man1/bison.1.gz
share/aclocal/bison-i18n.m4
-%%DATADIR%%/README
-%%DATADIR%%/bison.m4
-%%DATADIR%%/c++-skel.m4
-%%DATADIR%%/c++.m4
-%%DATADIR%%/c-like.m4
-%%DATADIR%%/c-skel.m4
-%%DATADIR%%/c.m4
-%%DATADIR%%/glr.c
-%%DATADIR%%/glr.cc
-%%DATADIR%%/java-skel.m4
-%%DATADIR%%/java.m4
-%%DATADIR%%/lalr1.cc
-%%DATADIR%%/lalr1.java
-%%DATADIR%%/location.cc
-%%DATADIR%%/m4sugar/foreach.m4
-%%DATADIR%%/m4sugar/m4sugar.m4
-%%DATADIR%%/stack.hh
-%%DATADIR%%/xslt/bison.xsl
-%%DATADIR%%/xslt/xml2dot.xsl
-%%DATADIR%%/xslt/xml2text.xsl
-%%DATADIR%%/xslt/xml2xhtml.xsl
-%%DATADIR%%/yacc.c
%%NLS%%share/locale/ast/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/da/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/da/LC_MESSAGES/bison.mo
@@ -46,6 +24,7 @@ share/aclocal/bison-i18n.m4
%%NLS%%share/locale/hr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
%%NLS%%share/locale/hu/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ia/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/id/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
%%NLS%%share/locale/it/LC_MESSAGES/bison-runtime.mo
@@ -63,18 +42,18 @@ share/aclocal/bison-i18n.m4
%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
%%NLS%%share/locale/pl/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/pl/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
%%NLS%%share/locale/pt/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/pt/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
%%NLS%%share/locale/ro/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ro/LC_MESSAGES/bison.mo
%%NLS%%share/locale/ru/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
%%NLS%%share/locale/sl/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sr/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/sq/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sv/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
%%NLS%%share/locale/th/LC_MESSAGES/bison-runtime.mo
diff --git a/editors/xcoral/files/patch-BR_Parser.c b/editors/xcoral/files/patch-BR_Parser.c
new file mode 100644
index 000000000000..5ebeb6122a78
--- /dev/null
+++ b/editors/xcoral/files/patch-BR_Parser.c
@@ -0,0 +1,35 @@
+--- BR_Parser.c.orig 2002-12-18 07:22:09 UTC
++++ BR_Parser.c
+@@ -116,7 +116,7 @@
+
+ #define YYDEBUG 1
+
+-#define BR_YYERROR YYFAIL
++#define BR_YYERROR YYERROR
+
+
+ /*-----------------------------------------------------------------------*/
+@@ -960,12 +960,7 @@ static const short yycheck[] = { 1,
+ #define YYEOF 0
+ #define YYACCEPT goto yyacceptlab
+ #define YYABORT goto yyabortlab
+-#define YYERROR goto yyerrlab1
+-/* Like YYERROR except do call yyerror.
+- This remains here temporarily to ease the
+- transition to the new meaning of YYERROR, for GCC.
+- Once GCC version 2 has supplanted version 1, this can go. */
+-#define YYFAIL goto yyerrlab
++#define YYERROR goto yyerrlab
+ #define YYRECOVERING() (!!yyerrstatus)
+ #define YYBACKUP(token, value) \
+ do \
+@@ -2465,9 +2460,6 @@ yyerrlab: /* here on detecting error *
+ yyerror("parse error");
+ }
+
+- goto yyerrlab1;
+-yyerrlab1: /* here on error raised explicitly by an action */
+-
+ if (yyerrstatus == 3)
+ {
+ /* if just tried and failed to reuse lookahead token after an error, discard it. */
diff --git a/editors/xcoral/files/patch-BR_Parser.y b/editors/xcoral/files/patch-BR_Parser.y
new file mode 100644
index 000000000000..7dc0d5642935
--- /dev/null
+++ b/editors/xcoral/files/patch-BR_Parser.y
@@ -0,0 +1,11 @@
+--- BR_Parser.y.orig 2002-12-18 07:21:52 UTC
++++ BR_Parser.y
+@@ -79,7 +79,7 @@
+
+ #define YYDEBUG 1
+
+-#define BR_YYERROR YYFAIL
++#define BR_YYERROR YYERROR
+
+
+ /*-----------------------------------------------------------------------*/
diff --git a/graphics/pixie/files/patch-src__ri__rib.l b/graphics/pixie/files/patch-src__ri__rib.l
index 9ed7ff5b6e95..42a05961b2a7 100644
--- a/graphics/pixie/files/patch-src__ri__rib.l
+++ b/graphics/pixie/files/patch-src__ri__rib.l
@@ -1,6 +1,6 @@
---- src/ri/rib.l.orig
+--- src/ri/rib.l.orig 2008-11-12 07:00:24 UTC
+++ src/ri/rib.l
-@@ -17,7 +17,7 @@
+@@ -17,7 +17,7 @@ static TRibFile *ribStack = NULL;
// Overwrite the YYinput so that it uses libz
#undef YY_INPUT
@@ -9,7 +9,24 @@
YY_FATAL_ERROR( "input in flex scanner failed" );
#endif
-@@ -223,7 +223,7 @@
+@@ -208,12 +208,12 @@ version return RIB_VERSION;
+ \[ return RIB_ARRAY_BEGIN;
+ \] return RIB_ARRAY_END;
+
+-\"[^\"]*\" { riblval->string = rstrdup(ribtext+1,CRenderer::globalMemory); riblval->string[strlen(riblval->string)-1] = '\0'; return RIB_TEXT;}
+-[+-]?([0-9]+|([0-9]*(\.[0-9]+)?)([eE][+-]?[0-9]+)?) { /*sscanf(ribtext,"%f",&riblval->real);*/ riblval->real = (float) atof(ribtext); return RIB_FLOAT; }
+-[+-]?([0-9]+|([0-9]+(\.[0-9]*)?)([eE][+-]?[0-9]+)?) { /*sscanf(ribtext,"%f",&riblval->real);*/ riblval->real = (float) atof(ribtext); return RIB_FLOAT; }
++\"[^\"]*\" { yylval->string = rstrdup(ribtext+1,CRenderer::globalMemory); yylval->string[strlen(yylval->string)-1] = '\0'; return RIB_TEXT;}
++[+-]?([0-9]+|([0-9]*(\.[0-9]+)?)([eE][+-]?[0-9]+)?) { /*sscanf(ribtext,"%f",&yylval->real);*/ yylval->real = (float) atof(ribtext); return RIB_FLOAT; }
++[+-]?([0-9]+|([0-9]+(\.[0-9]*)?)([eE][+-]?[0-9]+)?) { /*sscanf(ribtext,"%f",&yylval->real);*/ yylval->real = (float) atof(ribtext); return RIB_FLOAT; }
+
+ [\t ] ;
+-#\!.* { riblval->string = rstrdup(ribtext+2,CRenderer::globalMemory); return RIB_STRUCTURE_COMMENT; }
++#\!.* { yylval->string = rstrdup(ribtext+2,CRenderer::globalMemory); return RIB_STRUCTURE_COMMENT; }
+ #.* ;
+ \n { ribLineno++; }
+ <<EOF>> {
+@@ -223,7 +223,7 @@ version return RIB_VERSION;
TRibFile *nextFile = ribStack->next;
rib_delete_buffer( YY_CURRENT_BUFFER );
#ifdef HAVE_ZLIB
@@ -18,7 +35,7 @@
#else
fclose(ribin);
#endif
-@@ -243,7 +243,7 @@
+@@ -243,7 +243,7 @@ version return RIB_VERSION;
rib_delete_buffer( YY_CURRENT_BUFFER );
#ifdef HAVE_ZLIB
diff --git a/graphics/tumble/files/patch-parser.y b/graphics/tumble/files/patch-parser.y
new file mode 100644
index 000000000000..499b51c0e3a6
--- /dev/null
+++ b/graphics/tumble/files/patch-parser.y
@@ -0,0 +1,20 @@
+--- parser.y.orig 2003-12-09 16:45:41 UTC
++++ parser.y
+@@ -110,7 +110,7 @@ image_ranges:
+
+
+ input_file_clause:
+- FILE_KEYWORD STRING ';' { input_set_file ($2) } ;
++ FILE_KEYWORD STRING ';' { input_set_file ($2); } ;
+
+ image_clause:
+ IMAGE INTEGER ';' { range_t range = { $2, $2 }; input_images (range); } ;
+@@ -119,7 +119,7 @@ images_clause:
+ IMAGES image_ranges ';' ;
+
+ rotate_clause:
+- ROTATE INTEGER ';' { input_set_rotation ($2) } ;
++ ROTATE INTEGER ';' { input_set_rotation ($2); } ;
+
+ unit:
+ /* empty */ /* default to INCH */ { $$ = 1.0; }
diff --git a/japanese/ming/files/patch-actioncompiler-compile.h b/japanese/ming/files/patch-actioncompiler-compile.h
new file mode 100644
index 000000000000..c9910c38984b
--- /dev/null
+++ b/japanese/ming/files/patch-actioncompiler-compile.h
@@ -0,0 +1,11 @@
+--- actioncompiler/compile.h.orig 2002-06-24 12:21:54 UTC
++++ actioncompiler/compile.h
+@@ -10,7 +10,7 @@ typedef struct _buffer *Buffer;
+ #include "action.h"
+
+ /* shut up bison.simple */
+-void yyerror(char *msg);
++void yyerror(char *msg, char *yy_);
+ int yylex();
+
+ #ifndef max
diff --git a/japanese/ming/files/patch-src_actioncompiler_swf4compiler.flex b/japanese/ming/files/patch-src_actioncompiler_swf4compiler.flex
deleted file mode 100644
index 4fc84a49fd9e..000000000000
--- a/japanese/ming/files/patch-src_actioncompiler_swf4compiler.flex
+++ /dev/null
@@ -1,10 +0,0 @@
---- actioncompiler/swf4compiler.flex~ 2002-06-24 21:21:54.000000000 +0900
-+++ actioncompiler/swf4compiler.flex 2013-03-14 04:49:15.000000000 +0900
-@@ -5,6 +5,7 @@
-
- #include "compile.h"
- #include "action.h"
-+#define YYPARSE_PARAM buffer
- #include "swf4compiler.tab.h" /* defines token types */
-
- int swf4debug;
diff --git a/japanese/ming/files/patch-src_actioncompiler_swf4compiler.y b/japanese/ming/files/patch-src_actioncompiler_swf4compiler.y
index ea4a943ab75e..9b0ae34fc0be 100644
--- a/japanese/ming/files/patch-src_actioncompiler_swf4compiler.y
+++ b/japanese/ming/files/patch-src_actioncompiler_swf4compiler.y
@@ -1,5 +1,18 @@
---- actioncompiler/swf4compiler.y.orig Mon Dec 2 11:10:00 2002
-+++ actioncompiler/swf4compiler.y Mon Dec 2 11:12:15 2002
+--- actioncompiler/swf4compiler.y.orig 2002-06-24 12:21:54 UTC
++++ actioncompiler/swf4compiler.y
+@@ -6,10 +6,10 @@
+ #include <string.h>
+ #include "compile.h"
+
+-#define YYPARSE_PARAM buffer
+-
+ %}
+
++%parse-param {void *buffer}
++
+ %union {
+ Buffer action;
+ char *str;
@@ -119,7 +119,6 @@
%type <action> expr_opt
%type <action> void_function_call
@@ -16,7 +29,7 @@
elems
: elem
-@@ -277,6 +277,7 @@
+@@ -277,6 +277,7 @@ if_stmt
bufferWriteS16($3, bufferLength($5));
bufferConcat($3, $5);
$$ = $3; }
diff --git a/japanese/ming/files/patch-src_actioncompiler_swf5compiler.flex b/japanese/ming/files/patch-src_actioncompiler_swf5compiler.flex
deleted file mode 100644
index 4a633d31b440..000000000000
--- a/japanese/ming/files/patch-src_actioncompiler_swf5compiler.flex
+++ /dev/null
@@ -1,10 +0,0 @@
---- actioncompiler/swf5compiler.flex~ 2013-03-14 04:53:36.000000000 +0900
-+++ actioncompiler/swf5compiler.flex 2013-03-14 04:52:36.000000000 +0900
-@@ -5,6 +5,7 @@
-
- #include "compile.h"
- #include "action.h"
-+#define YYPARSE_PARAM buffer
- #include "swf5compiler.tab.h" /* defines token types */
-
- int swf5debug;
diff --git a/japanese/ming/files/patch-src_actioncompiler_swf5compiler.y b/japanese/ming/files/patch-src_actioncompiler_swf5compiler.y
index 256f310123ed..273b5cbd412e 100644
--- a/japanese/ming/files/patch-src_actioncompiler_swf5compiler.y
+++ b/japanese/ming/files/patch-src_actioncompiler_swf5compiler.y
@@ -1,5 +1,20 @@
---- actioncompiler/swf5compiler.y.orig 2009-03-06 11:34:48.000000000 +0100
-+++ actioncompiler/swf5compiler.y 2009-03-06 11:37:13.000000000 +0100
+--- actioncompiler/swf5compiler.y.orig 2002-06-24 12:21:54 UTC
++++ actioncompiler/swf5compiler.y
+@@ -8,12 +8,12 @@
+ #include "compile.h"
+ #include "assembler.h"
+
+-#define YYPARSE_PARAM buffer
+-
+ Buffer bf, bc;
+
+ %}
+
++%parse-param {void *buffer}
++
+ %union
+ {
+ Buffer action;
@@ -239,7 +239,7 @@ expr_opt
switch_stmt
diff --git a/lang/hla/Makefile b/lang/hla/Makefile
index 4d1d39580ad9..b524c4ca399d 100644
--- a/lang/hla/Makefile
+++ b/lang/hla/Makefile
@@ -12,7 +12,7 @@ EXTRACT_ONLY= ${PORTNAME}src${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= High Level Assembly
-USES= bison zip:infozip
+USES= bison dos2unix zip:infozip
WRKSRC= ${WRKDIR}/hlasrc/trunk/trunk
MAKEFILE= makefile.bsd
diff --git a/lang/hla/files/patch-hlaparse.bsn b/lang/hla/files/patch-hlaparse.bsn
new file mode 100644
index 000000000000..da50d7d26cf0
--- /dev/null
+++ b/lang/hla/files/patch-hlaparse.bsn
@@ -0,0 +1,107 @@
+--- hlaparse.bsn.orig 2017-01-09 13:30:03 UTC
++++ hlaparse.bsn
+@@ -1,4 +1,4 @@
+-%pure_parser
++%define api.pure
+
+
+ /*****************************/
+@@ -2749,7 +2749,7 @@ doTextBlock:
+
+ _here;
+ doTextBlock7( $<idStr>3, YYS &$<v>6 );
+- YYACCEPT
++ YYACCEPT;
+ }
+
+
+@@ -2763,7 +2763,7 @@ doTextBlock:
+
+ _here;
+ doTextBlock7a( $<s>3, YYS &$<v>6 );
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -2811,7 +2811,7 @@ doStringBlock:
+
+ _here;
+ doStringBlock( $<idStr>3, YYS &$<v>6 );
+- YYACCEPT
++ YYACCEPT;
+ }
+
+
+@@ -2825,7 +2825,7 @@ doStringBlock:
+
+ _here;
+ doStringBlocka( $<s>3, YYS &$<v>6 );
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -2865,7 +2865,7 @@ doMatchBlock:
+
+ _here;
+ doMatchBlock( $<s>3, YYS &$<v>6 );
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -2900,7 +2900,7 @@ doPrint:
+ fputs( "\n", PrintOut );
+
+ _endif
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -2961,7 +2961,7 @@ doParseObjID:
+ _here;
+ memcpy( &d1dnReturnVal, &$<dotName>2, sizeof( union YYSTYPE ));
+ _here;
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -2972,7 +2972,7 @@ doParseClassID:
+ _here;
+ memcpy( &d1dnReturnVal, &$<dotName>2, sizeof( union YYSTYPE ));
+ _here;
+- YYACCEPT
++ YYACCEPT;
+ }
+ ;
+
+@@ -10577,7 +10577,7 @@ OptionalInherit:
+
+ Empty
+ {
+- $<s>$ = NULL
++ $<s>$ = NULL;
+ }
+
+
+@@ -10657,7 +10657,7 @@ OptInherits:
+
+ Empty
+ {
+- $<ru.base>-1 = NULL
++ $<ru.base>-1 = NULL;
+ }
+
+ /*
+@@ -28209,7 +28209,7 @@ OneOrMoreParms:
+ varTkn /* $4 */
+ {
+ ProcGlobal = $<s>3;
+- fastLookup = 1
++ fastLookup = 1;
+ }
+ ';' /* $6 */
+ { /* $7 */
diff --git a/multimedia/avinfo/Makefile b/multimedia/avinfo/Makefile
index fe1ecf1d297a..3343ac78dc87 100644
--- a/multimedia/avinfo/Makefile
+++ b/multimedia/avinfo/Makefile
@@ -20,9 +20,6 @@ PLIST_FILES= bin/${PORTNAME} \
PORTDOCS= *
-
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e '/^CC=/ d; /^CFLAGS=/ d; /^PREFIX=/ d' \
${WRKSRC}/config.mk
diff --git a/multimedia/avinfo/files/patch-src-ass.y b/multimedia/avinfo/files/patch-src-ass.y
new file mode 100644
index 000000000000..1397c1b79dca
--- /dev/null
+++ b/multimedia/avinfo/files/patch-src-ass.y
@@ -0,0 +1,33 @@
+--- src/ass.y.orig 2005-04-22 05:31:53 UTC
++++ src/ass.y
+@@ -25,17 +25,17 @@
+ #include "ass.h"
+ #include "ass.tab.h"
+
+-#define YYLEX_PARAM lexer_ctl
+-#define YYPARSE_PARAM lexer_ctl
+ #define line (((lexerctl_t*)lexer_ctl)->line)
+ #define pos (((lexerctl_t*)lexer_ctl)->c)
+
+-int yyerror( const char *s );
++int yyerror(void *lexer_ctl, const char *s);
+ int yylex (YYSTYPE *lval, void* lexer_ctl);
+
+ %}
+
+-%pure_parser
++%define api.pure
++%lex-param {void *lexer_ctl}
++%parse-param {void *lexer_ctl}
+
+ %union{
+ int letter;
+@@ -258,7 +258,7 @@ var_t Op(var_t var1, var_t var2, int op_
+ return res;
+ }
+
+-int yyerror (const char *s) /* вызывается yyparse в случае ошибки */
++int yyerror (void *lexer_ctl, const char *s) /* вызывается yyparse в случае ошибки */
+ {
+ printf ("\n(error in template)\n");
+ return 1;
diff --git a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l
new file mode 100644
index 000000000000..e3409a5e00c2
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l
@@ -0,0 +1,11 @@
+--- src/rpsl/rpsl.l.orig 2012-07-31 12:10:39 UTC
++++ src/rpsl/rpsl.l
+@@ -713,7 +713,7 @@ void handle_object_error(const char *s,
+ current_object->errors += buffer;
+ }
+
+-void rpslerror(const char *, ...) {
++void rpslerror(void *, const char *, ...) {
+ if (current_attribute) {
+ current_attribute->errorLine = errorLine;
+ current_attribute->errorColon = errorColon - yyleng;
diff --git a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y
new file mode 100644
index 000000000000..7fece1407165
--- /dev/null
+++ b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y
@@ -0,0 +1,31 @@
+--- src/rpsl/rpsl.y.orig 2012-07-31 12:10:39 UTC
++++ src/rpsl/rpsl.y
+@@ -75,7 +75,7 @@ extern void handle_object_error(const ch
+ extern void handle_warning(const char *, ...);
+ extern int yylex();
+ char *token_name(int token_id);
+-void rpslerror(const char *s, ...);
++void rpslerror(void *, const char *s, ...);
+ Attr *changeCurrentAttr(Attr *b);
+ void handleArgumentTypeError(char *attr, const char *method, int position,
+ const RPType *correctType,
+@@ -83,7 +83,6 @@ void handleArgumentTypeError(char *attr,
+ const AttrMethod *searchMethod(const AttrRPAttr *rp_attr, const char *method, ItemList *args);
+
+ /* argument to yyparse result of parsing should be stored here */
+-#define YYPARSE_PARAM object
+ #define yyschema schema
+ #define enable_yy_parser_debugging enable_rpsl_parser_debugging
+
+@@ -91,8 +90,9 @@ extern Object *current_object;
+
+ %}
+
+-%name-prefix="rpsl"
+-%output="rpsl.y.cc"
++%name-prefix "rpsl"
++%output "rpsl.y.cc"
++%parse-param {void *object}
+
+ %expect 1
+
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index a19c9998dcf5..7df56117a16f 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -24,7 +24,7 @@ PORTSCOUT= skipv:1.5.0
USERS= kannel
GROUPS= kannel
-USES= bison gmake iconv ssl tar:bzip2
+USES= gmake iconv ssl tar:bzip2
USE_GCC= yes
USE_GNOME= libxml2
USE_RC_SUBR= ${PORTNAME}_bearerbox ${PORTNAME}_smsbox ${PORTNAME}_wapbox
@@ -44,6 +44,9 @@ MYSQL_CONFIGURE_WITH= mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
+post-patch:
+ @${RM} ${WRKSRC}/wmlscript/wsgram.y
+
post-install:
.for filename in wapkannel.conf smskannel.conf
${INSTALL_DATA} ${WRKSRC}/gw/${filename} \