aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-15 07:35:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-15 07:35:19 +0000
commitcb1aaf68c6aa30e5b178d8bcd3755fc894fbd7e4 (patch)
treed00e57a8160283ea866820b23b70d958adee2ced
parentb582b585cd818f9dcb2061470824f1b60e8b4a73 (diff)
downloadports-cb1aaf68c6aa30e5b178d8bcd3755fc894fbd7e4.tar.gz
ports-cb1aaf68c6aa30e5b178d8bcd3755fc894fbd7e4.zip
- Unbreak parallel builds (-jX) on recent -CURRENT, where our make(1) is
bmake(1), which does not play nice with libtool way of building things - While here, convert LIB_DEPENDS to new form, sort the knobs a bit, and hook test target to our standard "regression-test" one Reported by: marino Tested by: marino (poudriere testport) Approved by: miwi, bapt (portmgr, implicit)
Notes
Notes: svn path=/head/; revision=324754
-rw-r--r--graphics/plotutils/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index 7e8b68d3c314..f8416c295a79 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -1,4 +1,4 @@
-# Created by: Chuck Robey (chuckr)
+# Created by: Chuck Robey <chuckr@FreeBSD.org>
# $FreeBSD$
PORTNAME= plotutils
@@ -11,21 +11,23 @@ MASTER_SITES= GNU
MAINTAINER= stephen@FreeBSD.org
COMMENT= Plotting library and toolkit
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
-USES= motif
+USES= gmake motif # parallel builds are broken with bmake(1)
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-libplotter --enable-libxmi --with-motif
USE_LDCONFIG= yes
-MAN1= ode.1 plot.1 plotfont.1 spline.1 tek2plot.1
-INFO= libxmi plotutils
-
-#CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+MAN1= ode.1 plot.1 plotfont.1 spline.1 tek2plot.1
+INFO= libxmi plotutils
+
test: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} ${_MAKE_JOBS} \
+ ${MAKE_ARGS} check
+
+regression-test: test
.include <bsd.port.mk>