aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:10:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:10:15 +0000
commitcc82ac7af1a4b4743ab599432b8c7f24a774e0c8 (patch)
tree6443da11a92be566759454b76c94714222a13560
parent13441eac4bb7e0e8a50bd437681b05022e55146b (diff)
downloadports-cc82ac7af1a4b4743ab599432b8c7f24a774e0c8.tar.gz
ports-cc82ac7af1a4b4743ab599432b8c7f24a774e0c8.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200792
-rw-r--r--sysutils/asr-utils/Makefile10
-rw-r--r--sysutils/cmospwd/Makefile8
-rw-r--r--sysutils/conky-awesome/Makefile8
-rw-r--r--sysutils/conky/Makefile8
-rw-r--r--sysutils/cromwell/Makefile8
-rw-r--r--sysutils/dcfldd/Makefile9
-rw-r--r--sysutils/dd_rescue/Makefile8
-rw-r--r--sysutils/diskcheckd/Makefile13
-rw-r--r--sysutils/diskscrub/Makefile8
-rw-r--r--sysutils/freebsd-snapshot/Makefile8
-rw-r--r--sysutils/geomgui/Makefile6
-rw-r--r--sysutils/graphicboot/Makefile8
-rw-r--r--sysutils/gstopd/Makefile8
-rw-r--r--sysutils/heartbeat/Makefile13
-rw-r--r--sysutils/heartbeat2/Makefile13
-rw-r--r--sysutils/komparator/Makefile8
-rw-r--r--sysutils/lineak-defaultplugin/Makefile10
-rw-r--r--sysutils/lineak-kdeplugins/Makefile8
-rw-r--r--sysutils/lineak-xosdplugin/Makefile9
-rw-r--r--sysutils/lineakd/Makefile9
-rw-r--r--sysutils/munin-node/Makefile4
-rw-r--r--sysutils/ntfsprogs/Makefile4
-rw-r--r--sysutils/p5-Filesys-Df/Makefile8
-rw-r--r--sysutils/p5-Filesys-Statvfs/Makefile8
-rw-r--r--sysutils/policykit/Makefile8
-rw-r--r--sysutils/scanbuttond/Makefile8
-rw-r--r--sysutils/searchmonkey/Makefile8
-rw-r--r--sysutils/symon/Makefile9
-rw-r--r--sysutils/tmpwatch/Makefile8
-rw-r--r--sysutils/ufs_copy/Makefile8
-rw-r--r--sysutils/xacpim/Makefile6
31 files changed, 34 insertions, 225 deletions
diff --git a/sysutils/asr-utils/Makefile b/sysutils/asr-utils/Makefile
index dbf377cdc66b..57dab9435f1a 100644
--- a/sysutils/asr-utils/Makefile
+++ b/sysutils/asr-utils/Makefile
@@ -18,6 +18,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
COMMENT= Adaptec ASR RAID Management Software
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+
ONLY_FOR_ARCHS= i386
NO_WRKSUBDIR= yes
@@ -35,12 +37,6 @@ PLIST_SUB+= LIBXM=""
PLIST_SUB+= LIBXM="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
.ifndef (WITHOUT_X11)
PLIST_SUB+= X11=""
do-build:
@@ -75,4 +71,4 @@ do-install:
post-install:
@${INSTALL_MAN} ${WRKSRC}/raidutil.8 ${PREFIX}/man/man8/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/cmospwd/Makefile b/sysutils/cmospwd/Makefile
index cfc1fba67006..172b03808654 100644
--- a/sysutils/cmospwd/Makefile
+++ b/sysutils/cmospwd/Makefile
@@ -22,13 +22,7 @@ PORTDOCS= cmospwd.txt
ONLY_FOR_ARCHS= i386 amd64
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|<stdint\.h>|<unistd.h>|' \
- ${WRKSRC}/src/cmospwd.c
-.endif
.if !defined(NOPORTDOCS)
@${REINPLACE_CMD} -e "s/`${ECHO_CMD} -e '\r'`*$$//" \
${WRKSRC}/cmospwd.txt
@@ -45,4 +39,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/conky-awesome/Makefile b/sysutils/conky-awesome/Makefile
index 2edf717cea5d..b9a58997372a 100644
--- a/sysutils/conky-awesome/Makefile
+++ b/sysutils/conky-awesome/Makefile
@@ -104,10 +104,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= not supported on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 2edf717cea5d..b9a58997372a 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -104,10 +104,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= not supported on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/cromwell/Makefile b/sysutils/cromwell/Makefile
index 43a05a491730..860031c0f8f2 100644
--- a/sysutils/cromwell/Makefile
+++ b/sysutils/cromwell/Makefile
@@ -40,12 +40,6 @@ WRKSRC= ${WRKDIR}/cromwell
USE_BZIP2= yes
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Not supported below 5.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,perl,${PERL},g' \
-e 's,^CC.=,CC ?=,' \
@@ -62,4 +56,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dcfldd/Makefile b/sysutils/dcfldd/Makefile
index 705d0958396b..9d17daa6fde5 100644
--- a/sysutils/dcfldd/Makefile
+++ b/sysutils/dcfldd/Makefile
@@ -18,11 +18,4 @@ USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
MAN1= dcfldd.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-dcfldd.h ${PATCHDIR}/extra-patch-human.c \
- ${PATCHDIR}/extra-patch-xstrtol.h
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index e46115c99bd3..370e329fd773 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -17,12 +17,6 @@ USE_GETOPT_LONG=yes
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= default
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -lgnugetopt"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dd_rescue ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@@ -30,4 +24,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.dd_rescue ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/diskcheckd/Makefile b/sysutils/diskcheckd/Makefile
index c59c92bf7a3b..efcfb474aebd 100644
--- a/sysutils/diskcheckd/Makefile
+++ b/sysutils/diskcheckd/Makefile
@@ -25,17 +25,10 @@ CFLAGS+= -D_PATH_CONF='\"${PREFIX}/etc/diskcheckd.conf\"'
MAKEFILE= /usr/share/mk/bsd.prog.mk
MAKE_ARGS= PROG=diskcheckd MAN8=${MAN8}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= is not tested on anything less than 5.0, use at discretion
-.endif
-
do-extract:
@${MKDIR} ${WRKSRC}
-
-.for file in diskcheckd.c diskcheckd.8
- @(cd ${WRKSRC} ; ${CP} ${FILESDIR}/${file} .)
+.for f in diskcheckd.c diskcheckd.8
+ @(cd ${WRKSRC} ; ${CP} ${FILESDIR}/${f} .)
.endfor
do-patch:
@@ -46,4 +39,4 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/diskcheckd.conf ${PREFIX}/etc/diskcheckd.conf.sample
${INSTALL_MAN} ${WRKSRC}/diskcheckd.8 ${PREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/diskscrub/Makefile b/sysutils/diskscrub/Makefile
index 54914c547599..526d24f26cd4 100644
--- a/sysutils/diskscrub/Makefile
+++ b/sysutils/diskscrub/Makefile
@@ -31,10 +31,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/scrub ${PREFIX}/bin/scrub
${INSTALL_MAN} ${WRKSRC}/scrub.1 ${MAN1PREFIX}/man/man1/scrub.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-freebsd4
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/freebsd-snapshot/Makefile b/sysutils/freebsd-snapshot/Makefile
index 6fa01a6e8ef6..fde8ceb2a183 100644
--- a/sysutils/freebsd-snapshot/Makefile
+++ b/sysutils/freebsd-snapshot/Makefile
@@ -26,12 +26,6 @@ SUB_FILES= pkg-message pkg-deinstall
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALLL= ${WRKDIR}/pkg-deinstall
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= FreeBSD lower then 5.x doesn't support snapshot
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/amd.map.snap ${WRKSRC}/snapshot \
@@ -47,4 +41,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/geomgui/Makefile b/sysutils/geomgui/Makefile
index 282dd29dd06b..0f0b766a32ab 100644
--- a/sysutils/geomgui/Makefile
+++ b/sysutils/geomgui/Makefile
@@ -31,8 +31,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
${WRKSRC}/Makefile.in
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= requires GEOM which is only present on FreeBSD 5.x and above
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/graphicboot/Makefile b/sysutils/graphicboot/Makefile
index 535e63f2cbda..1f769232c70d 100644
--- a/sysutils/graphicboot/Makefile
+++ b/sysutils/graphicboot/Makefile
@@ -27,13 +27,7 @@ GNU_CONFIGURE= yes
MAN8= graphicboot.8 sendgbmsg.8
MANCOMPRESSED= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= requires rcorder which is only on FreeBSD 5 or greater
-.endif
-
post-install:
@${CAT} pkg-message
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/gstopd/Makefile b/sysutils/gstopd/Makefile
index 58ac8736a4de..b791da8008aa 100644
--- a/sysutils/gstopd/Makefile
+++ b/sysutils/gstopd/Makefile
@@ -14,12 +14,6 @@ MASTER_SITE_SUBDIR= mr
MAINTAINER= mr@freebsd.org
COMMENT= GEOM stop daemon
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= Needs GEOM(4)
-.endif
-
MAN8= gstopd.8
PLIST_FILES= sbin/gstopd
@@ -27,4 +21,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gstopd ${LOCALBASE}/sbin
${INSTALL_MAN} ${WRKSRC}/gstopd.8 ${LOCALBASE}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 1a798046abf2..007035a76217 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -40,12 +40,6 @@ MAN8= apphbd.8 heartbeat.8 ldirectord.8 meatclient.8 \
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lib-clplumbing-resource.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|logrotate\.d||" \
${WRKSRC}/heartbeat/Makefile.in \
@@ -56,11 +50,6 @@ post-patch:
s|-lnet|`${LIBNET_CONFIG} --libs`|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|<sys/\(resource.h\)>|"\1"|' \
- ${WRKSRC}/lib/clplumbing/coredumps.c
-.endif
-
.if !defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|^\(docdir.*doc/\).*|\1${PORTNAME}|' \
${WRKSRC}/configure.in \
@@ -97,4 +86,4 @@ pre-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/heartbeat2/Makefile b/sysutils/heartbeat2/Makefile
index 1a798046abf2..007035a76217 100644
--- a/sysutils/heartbeat2/Makefile
+++ b/sysutils/heartbeat2/Makefile
@@ -40,12 +40,6 @@ MAN8= apphbd.8 heartbeat.8 ldirectord.8 meatclient.8 \
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lib-clplumbing-resource.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|logrotate\.d||" \
${WRKSRC}/heartbeat/Makefile.in \
@@ -56,11 +50,6 @@ post-patch:
s|-lnet|`${LIBNET_CONFIG} --libs`|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|<sys/\(resource.h\)>|"\1"|' \
- ${WRKSRC}/lib/clplumbing/coredumps.c
-.endif
-
.if !defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|^\(docdir.*doc/\).*|\1${PORTNAME}|' \
${WRKSRC}/configure.in \
@@ -97,4 +86,4 @@ pre-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/komparator/Makefile b/sysutils/komparator/Makefile
index e3c5d298bda8..51f24309cc60 100644
--- a/sysutils/komparator/Makefile
+++ b/sysutils/komparator/Makefile
@@ -22,12 +22,6 @@ USE_GETTEXT= yes
DOCSDIR= ${PREFIX}/share/doc/HTML/en/komparator
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on 4.x
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's,-O2,,g ; \
s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -37,4 +31,4 @@ post-configure:
${REINPLACE_CMD} -e 's|doc po src|po src|g' ${WRKSRC}/Makefile
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lineak-defaultplugin/Makefile b/sysutils/lineak-defaultplugin/Makefile
index 6d8d1c5e21a9..ba1aabc97f41 100644
--- a/sysutils/lineak-defaultplugin/Makefile
+++ b/sysutils/lineak-defaultplugin/Makefile
@@ -36,16 +36,8 @@ PLIST_FILES= lib/lineakd/plugins/defaultplugin.a \
lib/lineakd/plugins/mediadetectplugin.so \
etc/media-detect.conf
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Configure fails to find lineakd
-# lineakd is compiled with 3.4 on FreeBSD 4.x, so plugins must be too
-# USE_GCC= 3.4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lineak-kdeplugins/Makefile b/sysutils/lineak-kdeplugins/Makefile
index 873389fa2df4..b4585efb81f3 100644
--- a/sysutils/lineak-kdeplugins/Makefile
+++ b/sysutils/lineak-kdeplugins/Makefile
@@ -28,14 +28,8 @@ CONFIGURE_ARGS+= --program-prefix=''
MAN1= lineak_kdeplugins.1
#MANCOMPRESSED= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= needs KDE to be compiled with gcc 3.4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
index 0ab8404786af..d02f392257a3 100644
--- a/sysutils/lineak-xosdplugin/Makefile
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -32,16 +32,9 @@ MAN_COMPRESSED= yes
PLIST_FILES= lib/lineakd/plugins/xosdplugin.la \
lib/lineakd/plugins/xosdplugin.so
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Configure fails to find lineakd
-#USE_GCC= 3.4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index 4c006501de28..0424e4792e97 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -30,13 +30,6 @@ PORTDOCS= README TODO AUTHORS
MAN1= lineakd.1
#MANCOMPRESSED= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-# ANSI C++ forbids data member `macro_info' with same name as enclosing class
-USE_GCC= 3.4
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread||' \
${WRKSRC}/lineak/Makefile.in ${WRKSRC}/lineakd/Makefile.in
@@ -54,4 +47,4 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/lineakd.conf.example ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 43159151e528..5ef9f680eaec 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -23,10 +23,6 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-RUN_DEPENDS+= ${LOCALBASE}/etc/rc.subr:${PORTSDIR}/sysutils/rc_subr
-.endif
-
.if ${PERL_LEVEL} < 500800
RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
.endif
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 5b2523da417d..0b9373baff0c 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -47,10 +47,6 @@ MLINKS= mkntfs.8 mkfs.ntfs.8
.include <bsd.port.pre.mk>
-.if (${OSVERSION} < 500000)
-BROKEN= Does not build on FreeBSD < 5.x. Doesn't have fstatvfs(3).
-.endif
-
.if defined(WITH_GNOMEVFS2)
CONFIGURE_ARGS+=--enable-gnome-vfs
USE_GNOME= gnomevfs2
diff --git a/sysutils/p5-Filesys-Df/Makefile b/sysutils/p5-Filesys-Df/Makefile
index 4880b03a2347..1d827021c5a4 100644
--- a/sysutils/p5-Filesys-Df/Makefile
+++ b/sysutils/p5-Filesys-Df/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Filesys::Df.3
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= requires statvfs() which is not available before FreeBSD-5*
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Filesys-Statvfs/Makefile b/sysutils/p5-Filesys-Statvfs/Makefile
index 0e268e77edee..24e953821bb5 100644
--- a/sysutils/p5-Filesys-Statvfs/Makefile
+++ b/sysutils/p5-Filesys-Statvfs/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Filesys::Statvfs.3
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= requires statvfs() which is not available before FreeBSD-5*
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/policykit/Makefile b/sysutils/policykit/Makefile
index 32cf6b06d1bf..794b57676a41 100644
--- a/sysutils/policykit/Makefile
+++ b/sysutils/policykit/Makefile
@@ -33,15 +33,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
USE_RC_SUBR= polkitd
USE_GNOME_SUBR= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build on 4.X
-.endif
-
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/scanbuttond/Makefile b/sysutils/scanbuttond/Makefile
index 0bc25367b41f..8b9be58d418a 100644
--- a/sysutils/scanbuttond/Makefile
+++ b/sysutils/scanbuttond/Makefile
@@ -26,16 +26,10 @@ INSTALLS_SHLIB= yes
SUB_FILES+= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-#BROKEN= does not build
-.endif
-
pre-configure:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|-ldl||g'
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/searchmonkey/Makefile b/sysutils/searchmonkey/Makefile
index f4b9c1d332a8..3f168570599f 100644
--- a/sysutils/searchmonkey/Makefile
+++ b/sysutils/searchmonkey/Makefile
@@ -24,10 +24,4 @@ PLIST_FILES= bin/${PORTNAME} share/pixmaps/${PORTNAME}-32x32.png
CFLAGS= -I${LOCALBASE}/include
LDFLAGS=-L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/symon/Makefile b/sysutils/symon/Makefile
index 9eb61b0eff7c..d7c6f6252aa9 100644
--- a/sysutils/symon/Makefile
+++ b/sysutils/symon/Makefile
@@ -50,14 +50,9 @@ SUBDIR+= client
MAKE_ARGS+= SUBDIR="${SUBDIR}" RRDDIR="${LOCALBASE}"
-.include <bsd.port.pre.mk>
-
-# Symux doesn't need additional LIBS. Symon doesn't need libkvm on FreeBSD 4.x
+# Symux doesn't need additional LIBS.
post-patch:
@${REINPLACE_CMD} 's/^LIBS+=/LIBS=/' ${WRKSRC}/symux/Makefile
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} 's/-lkvm//' ${WRKSRC}/platform/FreeBSD/Makefile.inc
-.endif
pre-install:
@${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
@@ -65,4 +60,4 @@ pre-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/tmpwatch/Makefile b/sysutils/tmpwatch/Makefile
index 1501e89e0c2d..15d160d6368a 100644
--- a/sysutils/tmpwatch/Makefile
+++ b/sysutils/tmpwatch/Makefile
@@ -23,8 +23,6 @@ CFLAGS+= ${CPPFLAGS} -DVERSION=\"${PORTVERSION}\"
MAN8= tmpwatch.8
PLIST_FILES= sbin/tmpwatch
-.include <bsd.port.pre.mk>
-
do-extract:
${MKDIR} ${WRKDIR}
cd ${WRKDIR} && \
@@ -35,10 +33,6 @@ do-extract:
post-patch:
${REINPLACE_CMD} -E "s/^#include.+mntent.h.+//g" ${WRKSRC}/tmpwatch.c
-.if ${OSVERSION} < 500000
- ${REINPLACE_CMD} -E "s/intmax_t/long long/;s/strtoimax/strtoll/" \
- ${WRKSRC}/tmpwatch.c
-.endif
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -o tmpwatch tmpwatch.c
@@ -47,4 +41,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tmpwatch ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/tmpwatch.8 ${MAN8PREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/ufs_copy/Makefile b/sysutils/ufs_copy/Makefile
index 6c0a492b9534..ba2429885d27 100644
--- a/sysutils/ufs_copy/Makefile
+++ b/sysutils/ufs_copy/Makefile
@@ -17,16 +17,10 @@ COMMENT= Fast copy utility for UFS filesystem
WRKSRC= ${WRKDIR}/ufs
MAKE_ARGS= BINDIR=${PREFIX}/sbin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= FreeBSD 4.x does not have libufs
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/xacpim/Makefile b/sysutils/xacpim/Makefile
index 127936eb8f39..aaa75a7601e7 100644
--- a/sysutils/xacpim/Makefile
+++ b/sysutils/xacpim/Makefile
@@ -19,8 +19,4 @@ PLIST_FILES= bin/xacpim
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/xacpim ${PREFIX}/bin/xacpim
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not work on 4.x (does not support ACPI)
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>