aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-03-06 18:52:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-03-06 18:52:19 +0000
commit224bc88c950fd5330852963378653d7c755390d1 (patch)
treed6ec0659879cb11f080226fe3a031a493e2c2908
parent0329ed58d51d7b0e3b41ffd08c7e28cad25373d2 (diff)
downloadports-224bc88c950fd5330852963378653d7c755390d1.tar.gz
ports-224bc88c950fd5330852963378653d7c755390d1.zip
MFH: r567273 r567286 r567291 r567293 r567426 r567510
x11-wm/labwc: add new port Labwc is a wlroots-based stacking compositor for Wayland. It has the following aims: - Be light-weight, small and fast - Have the look and feel of openbox albeit with a smaller feature set - Where practicable, use clients to show wall-paper, take screenshots, and so on - Stay in keeping with wlroots and sway in terms of approach and coding style https://github.com/johanmalm/labwc
Notes
Notes: svn path=/branches/2021Q1/; revision=567511
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/labwc/Makefile52
-rw-r--r--x11-wm/labwc/distinfo3
-rw-r--r--x11-wm/labwc/pkg-descr12
4 files changed, 68 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 986fefce71ed..b3e1ea8445a0 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -52,6 +52,7 @@
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kickshaw
+ SUBDIR += labwc
SUBDIR += larswm
SUBDIR += libcompizconfig
SUBDIR += libdockapp
diff --git a/x11-wm/labwc/Makefile b/x11-wm/labwc/Makefile
new file mode 100644
index 000000000000..8ab8b2466719
--- /dev/null
+++ b/x11-wm/labwc/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= labwc
+DISTVERSION= 0.1.0
+CATEGORIES= x11-wm
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Openbox alternative for Wayland
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols \
+ wlroots>=0.11.0:x11-toolkits/wlroots
+LIB_DEPENDS= libwayland-server.so:graphics/wayland \
+ libwlroots.so:x11-toolkits/wlroots \
+ libinput.so:x11/libinput \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig xorg
+USE_GITHUB= yes
+USE_GNOME= cairo libxml2 pango
+USE_XORG= pixman
+GH_ACCOUNT= johanmalm
+PLIST_FILES= "${MAYBE_SUID}bin/${PORTNAME}"
+
+OPTIONS_DEFINE= MANPAGES SUID X11
+OPTIONS_DEFAULT=MANPAGES SUID X11
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}-actions.5.gz \
+ man/man5/${PORTNAME}-config.5.gz \
+ man/man5/${PORTNAME}-theme.5.gz
+
+SUID_DESC= setuid bit on "${PORTNAME}" binary (to claim DRM without seatd/console-kit-daemon)
+SUID_VARS= MAYBE_SUID="@(,,4755) "
+
+X11_MESON_ENABLED= xwayland
+
+post-patch:
+# Extract (snapshot) version from the port instead of meson.build
+ @${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
+ -e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
+ ${WRKSRC}/meson.build
+# Respect PREFIX for system-wide config and Openbox themes
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
+ -e 's,/usr/local,${PREFIX},' \
+ ${WRKSRC}/docs/${PORTNAME}-config.5.scd \
+ ${WRKSRC}/src/common/dir.c
+
+.include <bsd.port.mk>
diff --git a/x11-wm/labwc/distinfo b/x11-wm/labwc/distinfo
new file mode 100644
index 000000000000..1a39fad6b455
--- /dev/null
+++ b/x11-wm/labwc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615031145
+SHA256 (johanmalm-labwc-0.1.0_GH0.tar.gz) = c3087c0dc846c18499a335fe04c9bc46f014f7421739573636f6f8f746fd3c84
+SIZE (johanmalm-labwc-0.1.0_GH0.tar.gz) = 59533
diff --git a/x11-wm/labwc/pkg-descr b/x11-wm/labwc/pkg-descr
new file mode 100644
index 000000000000..5f2ccfd786e3
--- /dev/null
+++ b/x11-wm/labwc/pkg-descr
@@ -0,0 +1,12 @@
+Labwc is a wlroots-based stacking compositor for Wayland.
+
+It has the following aims:
+
+- Be light-weight, small and fast
+- Have the look and feel of openbox albeit with a smaller feature set
+- Where practicable, use clients to show wall-paper, take screenshots,
+ and so on
+- Stay in keeping with wlroots and sway in terms of approach and
+ coding style
+
+WWW: https://github.com/johanmalm/labwc