aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Wagin <dmitry.wagin@ya.ru>2023-09-26 23:59:35 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2023-09-27 00:01:53 +0000
commite6a0b4910ea6adba80ac4b484e359de6bdb9f39b (patch)
treee5e62bd9b5fb58a4e0359d9cbeaf335b4fb4941a
parent00e44e52fc5fab03f6bb61b24907365f2238429f (diff)
downloadports-e6a0b4910ea6adba80ac4b484e359de6bdb9f39b.tar.gz
ports-e6a0b4910ea6adba80ac4b484e359de6bdb9f39b.zip
databases/foundationdb: Update to 7.1.29, fix build
PR: 269236 Approved by: maintainer timeout (cherry picked from commit 9f94a37075e65ea0bb6e70659326455d43f77b7b)
-rw-r--r--databases/foundationdb/Makefile6
-rw-r--r--databases/foundationdb/distinfo6
-rw-r--r--databases/foundationdb/files/patch-cmake_FDBComponents.cmake8
-rw-r--r--databases/foundationdb/files/patch-cmake_GetMsgpack.cmake2
4 files changed, 10 insertions, 12 deletions
diff --git a/databases/foundationdb/Makefile b/databases/foundationdb/Makefile
index 04453c48deee..9fbf62b8f766 100644
--- a/databases/foundationdb/Makefile
+++ b/databases/foundationdb/Makefile
@@ -1,6 +1,5 @@
PORTNAME= foundationdb
-DISTVERSION= 7.1.25
-PORTREVISION= 1
+DISTVERSION= 7.1.29
CATEGORIES= databases
# PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/pull/
@@ -12,7 +11,6 @@ WWW= https://www.foundationdb.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to configure
BROKEN_aarch64= invalid asm rdtsc
ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= not yet ported to anything else
@@ -24,7 +22,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/msgpack.hpp:devel/msgpack-cxx \
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libeio.so:devel/libeio
-USES= cmake compiler:c++17-lang mono:build python:build shebangfix \
+USES= cmake compiler:c++20-lang mono:build python:build shebangfix \
ssl
USE_GITHUB= yes
GH_ACCOUNT= apple
diff --git a/databases/foundationdb/distinfo b/databases/foundationdb/distinfo
index 902fdaf207b6..8315c830cce1 100644
--- a/databases/foundationdb/distinfo
+++ b/databases/foundationdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1668350492
-SHA256 (apple-foundationdb-7.1.25_GH0.tar.gz) = 0c4679afb982932dfa37cbb7544eee4c8efc2409864af55743345c153407cb2c
-SIZE (apple-foundationdb-7.1.25_GH0.tar.gz) = 11657831
+TIMESTAMP = 1679567621
+SHA256 (apple-foundationdb-7.1.29_GH0.tar.gz) = ad608ddb781eea3ef4607ab9abb41282ca93383814d8149346bf3440cc9f46d5
+SIZE (apple-foundationdb-7.1.29_GH0.tar.gz) = 11676677
diff --git a/databases/foundationdb/files/patch-cmake_FDBComponents.cmake b/databases/foundationdb/files/patch-cmake_FDBComponents.cmake
index 556fe68a9257..815778f2df3a 100644
--- a/databases/foundationdb/files/patch-cmake_FDBComponents.cmake
+++ b/databases/foundationdb/files/patch-cmake_FDBComponents.cmake
@@ -1,6 +1,6 @@
---- cmake/FDBComponents.cmake.orig 2022-09-19 11:42:41 UTC
+--- cmake/FDBComponents.cmake.orig 2023-03-14 19:59:33 UTC
+++ cmake/FDBComponents.cmake
-@@ -24,7 +24,7 @@ else()
+@@ -24,7 +24,7 @@ set(DISABLE_TLS OFF CACHE BOOL "Don't try to find Open
if(DISABLE_TLS)
set(WITH_TLS OFF)
else()
@@ -9,7 +9,7 @@
if(WIN32)
set(OPENSSL_MSVC_STATIC_RT ON)
endif()
-@@ -198,6 +198,13 @@ endif()
+@@ -201,6 +201,13 @@ else()
endif()
################################################################################
@@ -23,7 +23,7 @@
# Coroutine implementation
################################################################################
-@@ -242,6 +249,8 @@ function(print_components)
+@@ -245,6 +252,8 @@ function(print_components)
message(STATUS "Build Documentation (make html): ${WITH_DOCUMENTATION}")
message(STATUS "Build Python sdist (make package): ${WITH_PYTHON_BINDING}")
message(STATUS "Configure CTest (depends on Python): ${WITH_PYTHON}")
diff --git a/databases/foundationdb/files/patch-cmake_GetMsgpack.cmake b/databases/foundationdb/files/patch-cmake_GetMsgpack.cmake
index dee8066686d4..a0bff5b82bf3 100644
--- a/databases/foundationdb/files/patch-cmake_GetMsgpack.cmake
+++ b/databases/foundationdb/files/patch-cmake_GetMsgpack.cmake
@@ -2,7 +2,7 @@
+++ cmake/GetMsgpack.cmake
@@ -1,20 +1,7 @@
-find_package(msgpack 3.3.0 EXACT QUIET CONFIG)
-+find_package(msgpack REQUIRED QUIET CONFIG)
++find_package(msgpack-cxx REQUIRED QUIET CONFIG)
add_library(msgpack INTERFACE)