aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2002-01-29 16:43:55 +0000
committerBill Fenner <fenner@FreeBSD.org>2002-01-29 16:43:55 +0000
commitfa5a13d8ec4f3cfb9309f9b7a77dfadc9c5c8200 (patch)
tree34955d3d287f3a78719c5ba562b086cf0e078ebb
parenta2d149a0c51d8b77a781f08c37213375d94f8189 (diff)
downloadports-fa5a13d8ec4f3cfb9309f9b7a77dfadc9c5c8200.tar.gz
ports-fa5a13d8ec4f3cfb9309f9b7a77dfadc9c5c8200.zip
Don't try to use ${ECHO_CMD} in a != before including bsd.port.pre.mk
Submitted by: distfile survey
Notes
Notes: svn path=/head/; revision=53974
-rw-r--r--editors/mule/Makefile5
-rw-r--r--russian/koi8r-ps/Makefile4
2 files changed, 7 insertions, 2 deletions
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index 81ad7ab1da03..b9bd9e39cbeb 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -92,6 +92,9 @@ WITH_INPUT_METHOD+= --with-wnn6=-lwnn6_for_wnn7 --with-wnn-libraries=${LOCALBASE
.endif
COMP_ELC= egg.elc wnn-egg.elc sj3-client.elc sj3-egg.elc canna.elc
ELC_DIR= ../lisp
+
+.include <bsd.port.pre.mk>
+
# Make a value of INPUT_METHOD
.if defined(INPUT_METHOD)
INPUT_METHOD!= ${ECHO_CMD} ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
@@ -184,4 +187,4 @@ post-install:
post-package:
@${TOUCH} ${TOUCH_FLAGS} ${PACKAGE_COOKIE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/russian/koi8r-ps/Makefile b/russian/koi8r-ps/Makefile
index a8f357a0b289..d7bb7e9e9145 100644
--- a/russian/koi8r-ps/Makefile
+++ b/russian/koi8r-ps/Makefile
@@ -19,6 +19,8 @@ EXTRACT_ONLY=
DIST_SUBDIR= koi8r-ps
+.include <bsd.port.pre.mk>
+
.if !defined(FONTMAP)
FONTMAP!= if which gs > /dev/null 2>&1 ; then \
d=`gs -h | awk '/^Search path:$$/ { nl=1; next } \
@@ -88,4 +90,4 @@ do-install:
${LN} -s fonts.dir ${CPS_DIR}/fonts.scale
${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>