aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-01-07 16:40:17 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-01-07 16:40:17 +0000
commit2ca1fe047a67d4fef5712d06b0f338cbcf3c81e1 (patch)
tree873dee74f2cb2abd7be25338d5a0d7e0a9f7c698
parent3b1084476ae12a7dc8a377f9b0d260e86b8d10ca (diff)
downloadports-2ca1fe047a67d4fef5712d06b0f338cbcf3c81e1.tar.gz
ports-2ca1fe047a67d4fef5712d06b0f338cbcf3c81e1.zip
Don't include bsd.port.pre.mk twice. This usually is caused by first
including bsd.port.pre.mk and then later including bsd.port.mk (the latter of which of course should be bsd.port.post.mk).
Notes
Notes: svn path=/head/; revision=24507
-rw-r--r--devel/codecrusader/Makefile2
-rw-r--r--editors/vim-lite/Makefile5
-rw-r--r--graphics/gfont/Makefile2
-rw-r--r--graphics/killustrator/Makefile2
-rw-r--r--graphics/kplot3d/Makefile2
-rw-r--r--japanese/perl5/Makefile2
-rw-r--r--lang/p5-ExtUtils-F77/Makefile2
-rw-r--r--lang/p5-F77/Makefile2
-rw-r--r--mail/wmpop3/Makefile2
-rw-r--r--misc/dnetc/Makefile2
-rw-r--r--misc/proxyper/Makefile2
-rw-r--r--misc/videotext/Makefile2
-rw-r--r--net/netatalk-asun/Makefile2
-rw-r--r--news/pan/Makefile2
-rw-r--r--news/pan2/Makefile2
-rw-r--r--security/nessus-devel/Makefile2
-rw-r--r--security/nessus-libnasl-devel/Makefile2
-rw-r--r--security/nessus-libnasl/Makefile2
-rw-r--r--security/nessus-libraries-devel/Makefile2
-rw-r--r--security/nessus-libraries/Makefile2
-rw-r--r--security/nessus-plugins-devel/Makefile2
-rw-r--r--security/nessus-plugins/Makefile2
-rw-r--r--security/nessus/Makefile2
-rw-r--r--security/openssh/Makefile2
-rw-r--r--www/kdreamsite/Makefile2
25 files changed, 24 insertions, 29 deletions
diff --git a/devel/codecrusader/Makefile b/devel/codecrusader/Makefile
index cd7d03c8fa20..deed7c412534 100644
--- a/devel/codecrusader/Makefile
+++ b/devel/codecrusader/Makefile
@@ -94,4 +94,4 @@ do-install:
post-install:
@ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/vim-lite/Makefile b/editors/vim-lite/Makefile
index da7edbc66486..bc751b16bce9 100644
--- a/editors/vim-lite/Makefile
+++ b/editors/vim-lite/Makefile
@@ -11,11 +11,6 @@ PKGNAME= vim-lite-5.3
LITE= yes
-.include <bsd.port.pre.mk>
-.if exists(${.CURDIR}/../vim5)
MASTERDIR= ${.CURDIR}/../vim5
-.else
-MASTERDIR= ${PORTSDIR}/editors/vim5
-.endif
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gfont/Makefile b/graphics/gfont/Makefile
index 82421893448a..bca7019bfecd 100644
--- a/graphics/gfont/Makefile
+++ b/graphics/gfont/Makefile
@@ -25,4 +25,4 @@ GNU_CONFIGURE= yes
MAN1= gfont.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/killustrator/Makefile b/graphics/killustrator/Makefile
index 79e3f32ab8fc..c4774d86dced 100644
--- a/graphics/killustrator/Makefile
+++ b/graphics/killustrator/Makefile
@@ -27,4 +27,4 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
BROKEN= "Requires NEWGCC-compiled KDE libs"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/kplot3d/Makefile b/graphics/kplot3d/Makefile
index 0072d8e44e3d..bb2dd823f678 100644
--- a/graphics/kplot3d/Makefile
+++ b/graphics/kplot3d/Makefile
@@ -25,4 +25,4 @@ USE_GMAKE= yes
BROKEN= "Obsolete compiler"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/perl5/Makefile b/japanese/perl5/Makefile
index 15c725976c27..1c47304d30f7 100644
--- a/japanese/perl5/Makefile
+++ b/japanese/perl5/Makefile
@@ -126,4 +126,4 @@ post-install:
@${LN} -fs ${PREFIX}/lib/perl5/${JPERL_VERSION}/i386-freebsd/CORE/libperl.so.${PERL_SHLIBVER} ${PREFIX}/lib/perl5/${JPERL_VERSION}/i386-freebsd/CORE/libperl.so
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/p5-ExtUtils-F77/Makefile b/lang/p5-ExtUtils-F77/Makefile
index 2cdd62f51934..395035d78c73 100644
--- a/lang/p5-ExtUtils-F77/Makefile
+++ b/lang/p5-ExtUtils-F77/Makefile
@@ -33,4 +33,4 @@ post-patch:
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/p5-F77/Makefile b/lang/p5-F77/Makefile
index 2cdd62f51934..395035d78c73 100644
--- a/lang/p5-F77/Makefile
+++ b/lang/p5-F77/Makefile
@@ -33,4 +33,4 @@ post-patch:
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/wmpop3/Makefile b/mail/wmpop3/Makefile
index 1c8b3852697d..d1fb5baf8658 100644
--- a/mail/wmpop3/Makefile
+++ b/mail/wmpop3/Makefile
@@ -34,4 +34,4 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/wmpop3 && ${CHMOD} a+rx ${PREFIX}/share/doc/wmpop3
@${INSTALL_DATA} ${WRKDIR}/${PKGNAME}/README ${PREFIX}/share/doc/wmpop3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index e52b07b61872..6ec87cc6c945 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -88,4 +88,4 @@ do-install:
${INSTALL} -c -m 644 -o ${CLIENTUID} -g ${CLIENTGID} ${WRKDIR}/dnetc.ini ${BINDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/proxyper/Makefile b/misc/proxyper/Makefile
index 227f50d11383..354971d349d3 100644
--- a/misc/proxyper/Makefile
+++ b/misc/proxyper/Makefile
@@ -48,4 +48,4 @@ do-install:
${CHMOD} 755 ${BINDIR}
${LN} -s ${BINDIR}proxyper.sh ${LIBDIR}proxyper.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/videotext/Makefile b/misc/videotext/Makefile
index 3e906526f76e..fe2b8873e250 100644
--- a/misc/videotext/Makefile
+++ b/misc/videotext/Makefile
@@ -31,4 +31,4 @@ pre-install:
@${ECHO} "*********************************************************"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/netatalk-asun/Makefile b/net/netatalk-asun/Makefile
index 14d739b70c4f..ccdfa2ad29de 100644
--- a/net/netatalk-asun/Makefile
+++ b/net/netatalk-asun/Makefile
@@ -57,4 +57,4 @@ MAN8= afpd.8 atalkd.8 papd.8 psf.8
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/pan/Makefile b/news/pan/Makefile
index d0f47b85918f..b0c81ea2deed 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -37,4 +37,4 @@ pre-fetch:
@${ECHO}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
index d0f47b85918f..b0c81ea2deed 100644
--- a/news/pan2/Makefile
+++ b/news/pan2/Makefile
@@ -37,4 +37,4 @@ pre-fetch:
@${ECHO}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-devel/Makefile b/security/nessus-devel/Makefile
index 4f31666e5cfa..a81cfb07f1f4 100644
--- a/security/nessus-devel/Makefile
+++ b/security/nessus-devel/Makefile
@@ -47,4 +47,4 @@ post-install:
@${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
@${ECHO} "=========================================================="
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-libnasl-devel/Makefile b/security/nessus-libnasl-devel/Makefile
index 9f482ba74a37..351cb912f9af 100644
--- a/security/nessus-libnasl-devel/Makefile
+++ b/security/nessus-libnasl-devel/Makefile
@@ -36,4 +36,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-libnasl/Makefile b/security/nessus-libnasl/Makefile
index 9f482ba74a37..351cb912f9af 100644
--- a/security/nessus-libnasl/Makefile
+++ b/security/nessus-libnasl/Makefile
@@ -36,4 +36,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-libraries-devel/Makefile b/security/nessus-libraries-devel/Makefile
index e1db755bd601..4132fb3f24f5 100644
--- a/security/nessus-libraries-devel/Makefile
+++ b/security/nessus-libraries-devel/Makefile
@@ -33,4 +33,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-libraries/Makefile b/security/nessus-libraries/Makefile
index e1db755bd601..4132fb3f24f5 100644
--- a/security/nessus-libraries/Makefile
+++ b/security/nessus-libraries/Makefile
@@ -33,4 +33,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-plugins-devel/Makefile b/security/nessus-plugins-devel/Makefile
index 227598479669..e11c90bf2883 100644
--- a/security/nessus-plugins-devel/Makefile
+++ b/security/nessus-plugins-devel/Makefile
@@ -37,4 +37,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus-plugins/Makefile b/security/nessus-plugins/Makefile
index 227598479669..e11c90bf2883 100644
--- a/security/nessus-plugins/Makefile
+++ b/security/nessus-plugins/Makefile
@@ -37,4 +37,4 @@ GNU_CONFIGURE= yes
BROKEN= "Can't be built successfully in -CURRENT"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/nessus/Makefile b/security/nessus/Makefile
index 4f31666e5cfa..a81cfb07f1f4 100644
--- a/security/nessus/Makefile
+++ b/security/nessus/Makefile
@@ -47,4 +47,4 @@ post-install:
@${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
@${ECHO} "=========================================================="
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 2551a1d65add..5c6e61ac8445 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -152,4 +152,4 @@ post-install:
@${ECHO_MSG} ">> need to update it to work with OpenSSH."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/kdreamsite/Makefile b/www/kdreamsite/Makefile
index 116e403d7968..140c83efbff0 100644
--- a/www/kdreamsite/Makefile
+++ b/www/kdreamsite/Makefile
@@ -23,4 +23,4 @@ USE_GMAKE= yes
BROKEN= "obsolete compiler"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>