aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-15 01:55:41 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-15 01:55:41 +0000
commit43d8007aa3358479e3d90d5e4641290e79eaac09 (patch)
treed1fad5247710b7294d46c534e18823ee76118330
parente980980a39976eb2ccff2aa86feb45f1c3cb03b1 (diff)
downloadports-43d8007aa3358479e3d90d5e4641290e79eaac09.tar.gz
ports-43d8007aa3358479e3d90d5e4641290e79eaac09.zip
o Permission safeness fix: files can become unaccessible depending
on umask(1) settings o Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=148306
-rw-r--r--dns/py-dnspython/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index bd528d88cb90..f6765f0a1538 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dnspython
PORTVERSION= 1.3.5
+PORTREVISION= 1
CATEGORIES= dns python
MASTER_SITES= http://www.dnspython.org/kits/stable/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -41,5 +42,8 @@ post-install:
.for file in ${EXAMPLE_FILES}
@${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
.endfor
+# permission safeness
+ @${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/dns/*
+ @${CHMOD} -R a+X ${PYTHONPREFIX_SITELIBDIR}/dns/*
.include <bsd.port.mk>