aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShigeyuki Fukushima <shige@FreeBSD.org>2000-07-13 05:19:02 +0000
committerShigeyuki Fukushima <shige@FreeBSD.org>2000-07-13 05:19:02 +0000
commit92653af642d02a22ae4f3c0d17e75fc52c641999 (patch)
tree1bc6744b5bd1edd50a3b5aa0dff518943466ec70
parent56097548ad6b25352528275e91f5861bb4be05b0 (diff)
downloadports-92653af642d02a22ae4f3c0d17e75fc52c641999.tar.gz
ports-92653af642d02a22ae4f3c0d17e75fc52c641999.zip
Convert into EMACS_PORT_NAME style port.
Notes
Notes: svn path=/head/; revision=30548
-rw-r--r--editors/flim-xemacs21-mule-current/Makefile20
-rw-r--r--editors/flim-xemacs21-mule-current/pkg-descr2
-rw-r--r--editors/flim-xemacs21-mule/Makefile20
-rw-r--r--editors/flim-xemacs21-mule/pkg-descr2
-rw-r--r--editors/flim113-xemacs21-mule/Makefile20
-rw-r--r--editors/flim113-xemacs21-mule/pkg-descr2
-rw-r--r--editors/flim113/pkg-descr.xemacs21-mule2
-rw-r--r--editors/semi-xemacs21-mule-current/Makefile20
-rw-r--r--editors/semi-xemacs21-mule-current/pkg-descr2
-rw-r--r--editors/semi-xemacs21-mule/Makefile14
-rw-r--r--editors/semi-xemacs21-mule/pkg-descr2
-rw-r--r--editors/semi113-xemacs21-mule/Makefile20
-rw-r--r--editors/semi113-xemacs21-mule/pkg-descr2
-rw-r--r--editors/semi113/pkg-descr.xemacs21-mule2
-rw-r--r--editors/wemi-xemacs21-mule-current/Makefile20
-rw-r--r--editors/wemi-xemacs21-mule-current/pkg-descr2
-rw-r--r--editors/wemi-xemacs21-mule/Makefile14
-rw-r--r--editors/wemi-xemacs21-mule/pkg-descr2
18 files changed, 66 insertions, 102 deletions
diff --git a/editors/flim-xemacs21-mule-current/Makefile b/editors/flim-xemacs21-mule-current/Makefile
index dd982bd71ece..3849d431b448 100644
--- a/editors/flim-xemacs21-mule-current/Makefile
+++ b/editors/flim-xemacs21-mule-current/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ FLIMDOCDIR= ${EMACS_PACKAGESDIR}/lisp/flim
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/flim-xemacs21-mule-current/pkg-descr b/editors/flim-xemacs21-mule-current/pkg-descr
index f5b3afbb48d9..725bff5240b3 100644
--- a/editors/flim-xemacs21-mule-current/pkg-descr
+++ b/editors/flim-xemacs21-mule-current/pkg-descr
@@ -8,6 +8,6 @@ FLIM, message representation or encoding emacs lisp library for xemacs21-mule.
- mailcap parser and utility
FLIM is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/flim-xemacs21-mule/Makefile b/editors/flim-xemacs21-mule/Makefile
index e8dd70244577..38faed3d58d2 100644
--- a/editors/flim-xemacs21-mule/Makefile
+++ b/editors/flim-xemacs21-mule/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim-emacs
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ FLIMDOCDIR= ${EMACS_PACKAGESDIR}/lisp/flim
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/flim-xemacs21-mule/pkg-descr b/editors/flim-xemacs21-mule/pkg-descr
index f5b3afbb48d9..725bff5240b3 100644
--- a/editors/flim-xemacs21-mule/pkg-descr
+++ b/editors/flim-xemacs21-mule/pkg-descr
@@ -8,6 +8,6 @@ FLIM, message representation or encoding emacs lisp library for xemacs21-mule.
- mailcap parser and utility
FLIM is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/flim113-xemacs21-mule/Makefile b/editors/flim113-xemacs21-mule/Makefile
index dd982bd71ece..3849d431b448 100644
--- a/editors/flim113-xemacs21-mule/Makefile
+++ b/editors/flim113-xemacs21-mule/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/flim-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ FLIMDOCDIR= ${EMACS_PACKAGESDIR}/lisp/flim
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/flim113-xemacs21-mule/pkg-descr b/editors/flim113-xemacs21-mule/pkg-descr
index f5b3afbb48d9..725bff5240b3 100644
--- a/editors/flim113-xemacs21-mule/pkg-descr
+++ b/editors/flim113-xemacs21-mule/pkg-descr
@@ -8,6 +8,6 @@ FLIM, message representation or encoding emacs lisp library for xemacs21-mule.
- mailcap parser and utility
FLIM is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/flim113/pkg-descr.xemacs21-mule b/editors/flim113/pkg-descr.xemacs21-mule
index f5b3afbb48d9..725bff5240b3 100644
--- a/editors/flim113/pkg-descr.xemacs21-mule
+++ b/editors/flim113/pkg-descr.xemacs21-mule
@@ -8,6 +8,6 @@ FLIM, message representation or encoding emacs lisp library for xemacs21-mule.
- mailcap parser and utility
FLIM is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/flim/ --- FLIM
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi-xemacs21-mule-current/Makefile b/editors/semi-xemacs21-mule-current/Makefile
index 02da033742b5..9d6e934c19a6 100644
--- a/editors/semi-xemacs21-mule-current/Makefile
+++ b/editors/semi-xemacs21-mule-current/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ SEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/semi-xemacs21-mule-current/pkg-descr b/editors/semi-xemacs21-mule-current/pkg-descr
index e2ac016e0a3d..a02894c10f25 100644
--- a/editors/semi-xemacs21-mule-current/pkg-descr
+++ b/editors/semi-xemacs21-mule-current/pkg-descr
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi-xemacs21-mule/Makefile b/editors/semi-xemacs21-mule/Makefile
index 2defa6402fd1..51a615357104 100644
--- a/editors/semi-xemacs21-mule/Makefile
+++ b/editors/semi-xemacs21-mule/Makefile
@@ -13,14 +13,14 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi-emacs
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
@@ -34,7 +34,7 @@ HAS_MULE= YES
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +57,7 @@ SEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/semi-xemacs21-mule/pkg-descr b/editors/semi-xemacs21-mule/pkg-descr
index e2ac016e0a3d..a02894c10f25 100644
--- a/editors/semi-xemacs21-mule/pkg-descr
+++ b/editors/semi-xemacs21-mule/pkg-descr
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi113-xemacs21-mule/Makefile b/editors/semi113-xemacs21-mule/Makefile
index 02da033742b5..9d6e934c19a6 100644
--- a/editors/semi113-xemacs21-mule/Makefile
+++ b/editors/semi113-xemacs21-mule/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/semi-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.10
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -57,7 +51,7 @@ SEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/semi113-xemacs21-mule/pkg-descr b/editors/semi113-xemacs21-mule/pkg-descr
index e2ac016e0a3d..a02894c10f25 100644
--- a/editors/semi113-xemacs21-mule/pkg-descr
+++ b/editors/semi113-xemacs21-mule/pkg-descr
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/semi113/pkg-descr.xemacs21-mule b/editors/semi113/pkg-descr.xemacs21-mule
index e2ac016e0a3d..a02894c10f25 100644
--- a/editors/semi113/pkg-descr.xemacs21-mule
+++ b/editors/semi113/pkg-descr.xemacs21-mule
@@ -20,6 +20,6 @@ SEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
SEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- SEMI
--- Porting by shige <shige@FreeBSD.ORG>
diff --git a/editors/wemi-xemacs21-mule-current/Makefile b/editors/wemi-xemacs21-mule-current/Makefile
index 7a2faaf5eec3..65156dba1e3e 100644
--- a/editors/wemi-xemacs21-mule-current/Makefile
+++ b/editors/wemi-xemacs21-mule-current/Makefile
@@ -13,28 +13,22 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/wemi-emacs-current
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.8
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
-# RUN_DEPENDS port name's suffix is '-common'.
-HAS_COMMON_PORT= YES
-
-# whether emacs has mule feature
-HAS_MULE= YES
-
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -58,7 +52,7 @@ WEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/wemi-xemacs21-mule-current/pkg-descr b/editors/wemi-xemacs21-mule-current/pkg-descr
index 6f27caa9dc01..0dbda5b8a7b5 100644
--- a/editors/wemi-xemacs21-mule-current/pkg-descr
+++ b/editors/wemi-xemacs21-mule-current/pkg-descr
@@ -30,7 +30,7 @@ WEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
WEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- WEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- WEMI
*** Caution!! ***
diff --git a/editors/wemi-xemacs21-mule/Makefile b/editors/wemi-xemacs21-mule/Makefile
index 12655f1bc114..1a7bfd5808c2 100644
--- a/editors/wemi-xemacs21-mule/Makefile
+++ b/editors/wemi-xemacs21-mule/Makefile
@@ -13,14 +13,14 @@ PORTCLASS= slave
MASTERDIR= ${.CURDIR}/../../editors/wemi-emacs
# emacs port setup
-EMACS_NAME= xemacs
-EMACS_PORT= xemacs21-mule
-EMACS_VER= 21.1.8
-EMACS_CMD= ${PREFIX}/bin/${EMACS_PORT}
-EMACS_PACKAGESDIR= lib/${EMACS_NAME}/site-packages
+EMACS_PORT_NAME= xemacs21-mule
+EMACS_PACKAGESDIR= ${EMACS_LIBDIR}/site-packages
# packages-subdirectories which this port requires
EMACS_PACKAGES_SUBDIRS= info lisp man pkginfo
+SCRIPTS_ENV= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+PLIST_SUB= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR}
+
# how to make and install
ALL_TARGET= package
INSTALL_TARGET= install-package
@@ -34,7 +34,7 @@ HAS_MULE= YES
# whether building info files by emacs or makeinfo
BUILD_INFO_BY_EMACS= YES
# texinfo packages
-BUILD_DEPENDS+= ${PREFIX}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
+BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_PACKAGESDIR}/../xemacs-packages/lisp/texinfo/texinfo.el:${PORTSDIR}/editors/xemacs-sumo-packages
# use pkg/* files in ${.CURDIR}
PKGDIR= ${.CURDIR}/pkg
@@ -58,7 +58,7 @@ WEMIDOCDIR= ${EMACS_PACKAGESDIR}/lisp/semi
xemacs-package: install
@${RM} -f ${.CURDIR}/${XEMACS_PKG_TARBALL}
- @(cd ${PREFIX}/${EMACS_PACKAGESDIR} ;\
+ @(cd ${LOCALBASE}/${EMACS_PACKAGESDIR} ;\
${TAR} -zcf ${.CURDIR}/${XEMACS_PKG_TARBALL} ${XEMACS_PKG_CONTENTS} ;\
)
diff --git a/editors/wemi-xemacs21-mule/pkg-descr b/editors/wemi-xemacs21-mule/pkg-descr
index 6f27caa9dc01..0dbda5b8a7b5 100644
--- a/editors/wemi-xemacs21-mule/pkg-descr
+++ b/editors/wemi-xemacs21-mule/pkg-descr
@@ -30,7 +30,7 @@ WEMI, Library of MIME feature for GNU Emacs for xemacs21-mule.
MUAs. They are released as separated packages.
WEMI is installed the following directory tree:
- ${PREFIX}/lib/xemacs/site-packages/lisp/semi/ --- WEMI
+ ${LOCALBASE}/lib/xemacs/site-packages/lisp/semi/ --- WEMI
*** Caution!! ***