aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-05-16 16:23:57 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-05-16 16:23:57 +0000
commit40810ecc3644a8e9ee61c30ee36613b927f46171 (patch)
treeb68f3b3590005020a09c949ea6b9e4c1921005eb
parentbe982491d9e6f9823e2db980d28b7aab16366621 (diff)
downloadports-40810ecc3644a8e9ee61c30ee36613b927f46171.tar.gz
ports-40810ecc3644a8e9ee61c30ee36613b927f46171.zip
Unbreak build on perl 5.00503
Pointed by: kris
Notes
Notes: svn path=/head/; revision=109264
-rw-r--r--textproc/p5-XML-LibXSLT/Makefile8
-rw-r--r--textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs26
2 files changed, 33 insertions, 1 deletions
diff --git a/textproc/p5-XML-LibXSLT/Makefile b/textproc/p5-XML-LibXSLT/Makefile
index 6af3c94a103e..f7651059c985 100644
--- a/textproc/p5-XML-LibXSLT/Makefile
+++ b/textproc/p5-XML-LibXSLT/Makefile
@@ -26,4 +26,10 @@ PERL_ABASE= ${SITE_PERL}/${PERL_ARCH}
MAN3= XML::LibXSLT.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES= ${FILESDIR}/500503-*
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs b/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
new file mode 100644
index 000000000000..6ed285503380
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/files/500503-patch-LibXSLT.xs
@@ -0,0 +1,26 @@
+--- LibXSLT.xs.orig Mon Mar 1 21:42:43 2004
++++ LibXSLT.xs Sun May 16 20:21:57 2004
+@@ -29,6 +29,23 @@
+ }
+ #endif
+
++#ifndef dTHX
++#define dTHX extern int errno
++#endif
++
++#ifndef SvPV_nolen
++#define SvPV_nolen(sv) \
++ ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK \
++ ? SvPVX(sv) : sv_2pv_nolen(sv))
++
++static char *
++sv_2pv_nolen(register SV *sv)
++{
++ STRLEN n_a;
++ return sv_2pv(sv, &n_a);
++}
++#endif
++
+ #define SET_CB(cb, fld) \
+ RETVAL = cb ? newSVsv(cb) : &PL_sv_undef;\
+ if (SvOK(fld)) {\