aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:23:02 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-12 11:23:02 +0000
commit9dc99562f1bca81370603044acd5ab2081814c5a (patch)
tree7f29a1df1d246ee477815166fa854f5fc3b6e8e1
parent36ca9ac45cad6bc22a09c45e0b68b6d4d7e5f616 (diff)
downloadports-9dc99562f1bca81370603044acd5ab2081814c5a.tar.gz
ports-9dc99562f1bca81370603044acd5ab2081814c5a.zip
Add p5-Term-ReadLine-Zoid 0.06, provides an interactive input buffer
written in plain PERL. PR: ports/72048 Submitted by: ijliao
Notes
Notes: svn path=/head/; revision=118954
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-ReadLine-Zoid/Makefile38
-rw-r--r--devel/p5-Term-ReadLine-Zoid/distinfo2
-rw-r--r--devel/p5-Term-ReadLine-Zoid/pkg-descr7
-rw-r--r--devel/p5-Term-ReadLine-Zoid/pkg-plist56
5 files changed, 104 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ac99c45a8250..d88f4ff30996 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -978,6 +978,7 @@
SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
SUBDIR += p5-Term-ReadKey
+ SUBDIR += p5-Term-ReadLine-Zoid
SUBDIR += p5-Term-Screen
SUBDIR += p5-Term-Shell
SUBDIR += p5-Term-Size
diff --git a/devel/p5-Term-ReadLine-Zoid/Makefile b/devel/p5-Term-ReadLine-Zoid/Makefile
new file mode 100644
index 000000000000..9fe0651ad41c
--- /dev/null
+++ b/devel/p5-Term-ReadLine-Zoid/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: Term::ReadLine::Zoid
+# Date created: Sep 24, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-ReadLine-Zoid
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://zoidberg.student.utwente.nl/downloads/Term-ReadLine-Zoid/
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Provides an interactive input buffer written in plain PERL
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Term::ReadLine::Zoid.3 \
+ Term::ReadLine::Zoid::Base.3 \
+ Term::ReadLine::Zoid::Emacs.3 \
+ Term::ReadLine::Zoid::FileBrowse.3 \
+ Term::ReadLine::Zoid::ISearch.3 \
+ Term::ReadLine::Zoid::ViCommand.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Requiers perl 5.6+, install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Term-ReadLine-Zoid/distinfo b/devel/p5-Term-ReadLine-Zoid/distinfo
new file mode 100644
index 000000000000..74ffd56dae86
--- /dev/null
+++ b/devel/p5-Term-ReadLine-Zoid/distinfo
@@ -0,0 +1,2 @@
+MD5 (Term-ReadLine-Zoid-0.06.tar.gz) = d8f9414b462d5ad5576c40c50175760b
+SIZE (Term-ReadLine-Zoid-0.06.tar.gz) = 33293
diff --git a/devel/p5-Term-ReadLine-Zoid/pkg-descr b/devel/p5-Term-ReadLine-Zoid/pkg-descr
new file mode 100644
index 000000000000..84c0dfd4c692
--- /dev/null
+++ b/devel/p5-Term-ReadLine-Zoid/pkg-descr
@@ -0,0 +1,7 @@
+This package provides a set of modules that form an interactive input buffer
+written in plain perl with minimal dependencies. It features almost all
+key-bindings described in the posix spec for the sh(1) utility with some
+extensions like multiline editing; this includes a vi-command mode with a
+save-buffer (for copy-pasting) and an undo-stack.
+
+WWW: http://search.cpan.org/dist/Term-ReadLine-Zoid/
diff --git a/devel/p5-Term-ReadLine-Zoid/pkg-plist b/devel/p5-Term-ReadLine-Zoid/pkg-plist
new file mode 100644
index 000000000000..bba3f08c5d50
--- /dev/null
+++ b/devel/p5-Term-ReadLine-Zoid/pkg-plist
@@ -0,0 +1,56 @@
+%%SITE_PERL%%/Term/ReadLine/Zoid.pm
+%%SITE_PERL%%/Term/ReadLine/Zoid/Base.pm
+%%SITE_PERL%%/Term/ReadLine/Zoid/Emacs.pm
+%%SITE_PERL%%/Term/ReadLine/Zoid/FileBrowse.pm
+%%SITE_PERL%%/Term/ReadLine/Zoid/ISearch.pm
+%%SITE_PERL%%/Term/ReadLine/Zoid/ViCommand.pm
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/_do_motion.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/_get_chr.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/_parse_chrs.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/alias.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/ascii.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/autosplit.ix
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/bindchr.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/bindkey.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/bsearch.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/eval.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/fsearch.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/quit.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/set.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/shell.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/testchr.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_B.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_C.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_D.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_E.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_F.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_G.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_J.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_K.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_N.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_P.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_S.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_U.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_V.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_W.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_X.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_Y.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_c_repeat.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_case.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_comment.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_complete.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_cursor.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_home.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_increment.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_macro.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_mini_buffer.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_r.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_repeat.al
+%%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand/vi_topic.al
+@dirrm %%SITE_PERL%%/Term/ReadLine/Zoid
+@dirrm %%SITE_PERL%%/auto/Term/ReadLine/Zoid/ViCommand
+@dirrm %%SITE_PERL%%/auto/Term/ReadLine/Zoid
+@unexec rmdir %D/%%SITE_PERL%%/Term/ReadLine 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Term 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Term/ReadLine 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Term 2>/dev/null || true