aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:47:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:47:48 +0000
commiteb22aa0d9c59142a4264f5cb822f05e830649ce7 (patch)
tree69397c751649ac4cf29b2bf3d45bb764d29f4b36
parentb93b137c4c230b40c450882a21d3d74a563637c7 (diff)
downloadports-eb22aa0d9c59142a4264f5cb822f05e830649ce7.tar.gz
ports-eb22aa0d9c59142a4264f5cb822f05e830649ce7.zip
- Update graphics/osg to 3.0.1
- Bump revisions on dependent ports due to shlib version bump - Remove option to use graphics/osg-devel instead of graphics/osg from simgear and flightgear (1) - Remove option to use graphics/osg-devel instead of graphics/osg from fgrun for consistency Submitted by: martymac (1)
Notes
Notes: svn path=/head/; revision=295536
-rw-r--r--devel/simgear/Makefile10
-rw-r--r--games/fgrun/Makefile10
-rw-r--r--games/flightgear/Makefile10
-rw-r--r--games/palomino/Makefile3
-rw-r--r--graphics/osg/Makefile69
-rw-r--r--graphics/osg/distinfo4
-rw-r--r--graphics/osg/files/patch-CMakeLists.txt20
-rw-r--r--graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp (renamed from graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++)16
-rw-r--r--graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp20
-rw-r--r--graphics/osg/pkg-plist142
10 files changed, 198 insertions, 106 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index e675cf438563..8f6ed742b784 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simgear
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= devel games
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/ \
@@ -21,13 +22,8 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- boost_thread.4:${PORTSDIR}/devel/boost-libs
-
-.if defined(WITH_OSG_DEVEL)
-LIB_DEPENDS+= osg.59:${PORTSDIR}/graphics/osg-devel
-.else
-LIB_DEPENDS+= osg.55:${PORTSDIR}/graphics/osg
-.endif
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ osg.80:${PORTSDIR}/graphics/osg
USE_BZIP2= yes
USE_XORG= ice sm x11 xext xi xt xmu
diff --git a/games/fgrun/Makefile b/games/fgrun/Makefile
index c300490d290a..118a2307ebd0 100644
--- a/games/fgrun/Makefile
+++ b/games/fgrun/Makefile
@@ -7,24 +7,20 @@
PORTNAME= fgrun
PORTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= buganini@gmail.com
COMMENT= A graphical frontend to run FlightGear Flight Simulator
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ osg.80:${PORTSDIR}/graphics/osg
BUILD_DEPENDS= simgear>=2.4.0:${PORTSDIR}/devel/simgear \
${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= simgear>=2.4.0:${PORTSDIR}/devel/simgear \
fgfs:${PORTSDIR}/games/flightgear
-.if defined(WITH_OSG_DEVEL)
-LIB_DEPENDS+= osg.59:${PORTSDIR}/graphics/osg-devel
-.else
-LIB_DEPENDS+= osg.55:${PORTSDIR}/graphics/osg
-.endif
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boost="${LOCALBASE}"
USE_GMAKE= yes
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index f40db8e3352e..ac4646be6462 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flightgear
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
@@ -20,19 +21,14 @@ COMMENT= The FlightGear flight simulator
LICENSE= GPLv2
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ osg.80:${PORTSDIR}/graphics/osg
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/flightgear/version:${PORTSDIR}/games/flightgear-data
-.if defined(WITH_OSG_DEVEL)
-LIB_DEPENDS+= osg.59:${PORTSDIR}/graphics/osg-devel
-.else
-LIB_DEPENDS+= osg.55:${PORTSDIR}/graphics/osg
-.endif
-
USE_BZIP2= yes
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
diff --git a/games/palomino/Makefile b/games/palomino/Makefile
index 9f0cf36cba4e..232b0f6b4287 100644
--- a/games/palomino/Makefile
+++ b/games/palomino/Makefile
@@ -7,6 +7,7 @@
PORTNAME= palomino
PORTVERSION= 20120310
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.palomino3d.org/sim/
DISTFILES= ${PORTNAME}_src_${PORTVERSION}.txz \
@@ -18,7 +19,7 @@ DISTFILES= ${PORTNAME}_src_${PORTVERSION}.txz \
MAINTAINER= ports@FreeBSD.org
COMMENT= Action flight simulator with its own 3D engine
-LIB_DEPENDS= osg.55:${PORTSDIR}/graphics/osg
+LIB_DEPENDS= osg.80:${PORTSDIR}/graphics/osg
USE_BZIP2= yes
USE_XZ= yes
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 61cb89f4bc46..ffa26b4e6201 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= osg
-PORTVERSION= 2.8.2
-PORTREVISION= 8
+PORTVERSION= 3.0.1
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-${PORTVERSION}/source/ \
http://mirror.amdmi3.ru/distfiles/
@@ -32,9 +31,9 @@ MAKE_JOBS_SAFE= yes
USE_GCC= 4.2+
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=55 \
- OPENTHREADS_VERSION=2.4.0 \
- OPENTHREADS_SHLIBVER=11
+ OSG_SHLIBVER=80 \
+ OPENTHREADS_VERSION=2.6.0 \
+ OPENTHREADS_SHLIBVER=12
PORTSCOUT= limitw:1,even
@@ -48,21 +47,21 @@ OPTIONS= CURL "Support for cURL" off \
ITK "Support for InsightToolkit" off \
VNC "Support for LibVNCServer" off \
OPENEXR "Support for OpenEXR" off \
+ FFMPEG "Support for FFmpeg" off \
SVG "Support for SVG through librsvg2" off \
PDF "Support for PDF through poppler" off \
- XRANDR "Use Xrandr" on
+ XRANDR "Use Xrandr" on \
+ SDL "Use SDL (joystick support in present3d)" off
# broken (openvrml from ports is too old)
# OPENVRML "Support for OpenVRML" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# GUI toolkits are only needed for building examples, which are not even installed
-FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets # only for examples
-FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL # not in ports
-FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
-FORCE_PC_IGNORE= GTK GTKGL # only for examples
-FORCE_PC_REQUIRE=
+FORCE_IGNORE= FLTK GLUT FOX Qt3 Qt4 wxWidgets OpenAL GtkGl # only for examples
+FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL FBX # not in ports
+FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
# options that affect FIND_PACKAGE
.if defined(WITH_CURL)
@@ -167,30 +166,43 @@ FORCE_IGNORE+= OpenEXR
PLIST_SUB+= OPENEXR="@comment "
.endif
+.if defined(WITH_FFMPEG)
+FORCE_REQUIRE+= FFmpeg
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+PLIST_SUB+= FFMPEG=""
+.else
+FORCE_IGNORE+= FFmpeg
+PLIST_SUB+= FFMPEG="@comment "
+.endif
+
+.if defined(WITH_SDL)
+FORCE_REQUIRE+= SDL
+USE_SDL= sdl
+.else
+FORCE_IGNORE+= SDL
+.endif
+
# options that affect PKG_CHECK_MODULES
.if defined(WITH_SVG)
-FORCE_PC_REQUIRE+=RSVG
+FORCE_REQUIRE+= RSVG
LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2
PLIST_SUB+= SVG=""
.else
-FORCE_PC_IGNORE+=RSVG
+FORCE_IGNORE+= RSVG
PLIST_SUB+= SVG="@comment "
.endif
.if defined(WITH_PDF)
-FORCE_PC_REQUIRE+=POPPLER
+FORCE_REQUIRE+= Poppler-glib
LIB_DEPENDS+= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
PLIST_SUB+= PDF=""
.else
-FORCE_PC_IGNORE+=POPPLER
+FORCE_IGNORE+= Poppler-glib
PLIST_SUB+= PDF="@comment "
.endif
.if defined(WITH_SVG) || defined(WITH_PDF)
-FORCE_PC_REQUIRE+=CAIRO
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-.else
-FORCE_PC_IGNORE+=CAIRO
.endif
# other options
@@ -201,9 +213,18 @@ CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
USE_XORG+= xrandr
.endif
+.if defined(WITHOUT_XRANDR)
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
+.else
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
+USE_XORG+= xrandr
+.endif
+
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
+ @${REINPLACE_CMD} -e '/FIND_LIBRARY.*DL_LIBRARY/ d' \
+ ${WRKSRC}/CMakeLists.txt
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt
@@ -212,13 +233,5 @@ post-patch:
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|^|#|' \
${WRKSRC}/CMakeLists.txt
.endfor
-.for p in ${FORCE_PC_REQUIRE}
- @${REINPLACE_CMD} -e 's|PKG_CHECK_MODULES.*${p}|& REQUIRED| ' \
- ${WRKSRC}/CMakeLists.txt
-.endfor
-.for p in ${FORCE_PC_IGNORE}
- @${REINPLACE_CMD} -e '/PKG_CHECK_MODULES.*${p}/ s|^|#|' \
- ${WRKSRC}/CMakeLists.txt
-.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/osg/distinfo b/graphics/osg/distinfo
index d1163e420ad9..0e9a0637714e 100644
--- a/graphics/osg/distinfo
+++ b/graphics/osg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenSceneGraph-2.8.2.zip) = 0903e3a29eba07856c563d1b313f6b803bee702e9145a27677d8dcab57db98ab
-SIZE (OpenSceneGraph-2.8.2.zip) = 6472487
+SHA256 (OpenSceneGraph-3.0.1.zip) = 0c1103574b0a5a27c7d68d43454f1bf9c0cea114a583c42637bc8eb47b1d8296
+SIZE (OpenSceneGraph-3.0.1.zip) = 6780282
diff --git a/graphics/osg/files/patch-CMakeLists.txt b/graphics/osg/files/patch-CMakeLists.txt
index e7dc6a6dce0d..f1df43923067 100644
--- a/graphics/osg/files/patch-CMakeLists.txt
+++ b/graphics/osg/files/patch-CMakeLists.txt
@@ -1,20 +1,20 @@
---- CMakeLists.txt.orig 2009-01-29 16:29:08.000000000 +0300
-+++ CMakeLists.txt 2009-02-05 17:45:24.000000000 +0300
-@@ -459,7 +459,7 @@
+--- CMakeLists.txt.orig 2011-07-31 11:50:34.000000000 +0400
++++ CMakeLists.txt 2012-03-05 05:54:52.485029323 +0400
+@@ -588,7 +588,7 @@
IF(UNIX AND NOT WIN32 AND NOT APPLE)
IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
+ SET(LIB_POSTFIX "" CACHE STRING "suffix for 32/64 dir placement")
MARK_AS_ADVANCED(LIB_POSTFIX)
- ENDIF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- ENDIF(UNIX AND NOT WIN32 AND NOT APPLE)
-@@ -766,7 +766,7 @@
+ ENDIF()
+ ENDIF()
+@@ -972,7 +972,7 @@
+ ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
@ONLY
)
+- INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
++ INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
+ ENDFOREACH(PKGCONFIG_FILE)
--INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
-+INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
- # Run this as late as possible so users can easier spot the message
- IF (${CMAKE_INSTALL_PREFIX} STREQUAL "/usr/local")
diff --git a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp
index d1997c322f3f..eeaba23f077d 100644
--- a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++
+++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp
@@ -1,14 +1,14 @@
---- src/OpenThreads/pthreads/PThread.c++.orig 2008-11-05 13:27:49.000000000 +0300
-+++ src/OpenThreads/pthreads/PThread.c++ 2009-02-04 18:06:28.000000000 +0300
+--- src/OpenThreads/pthreads/PThread.cpp.orig 2011-06-24 00:09:26.000000000 +0400
++++ src/OpenThreads/pthreads/PThread.cpp 2012-03-05 05:57:02.886704932 +0400
@@ -21,6 +21,7 @@
#include <sys/types.h>
#include <unistd.h>
#include <pthread.h>
+#include <pthread_np.h>
+ #include <limits.h>
- #if defined __linux || defined __sun || defined __APPLE__
- #include <string.h>
-@@ -125,7 +126,7 @@
+ #if defined __linux || defined __sun || defined __APPLE__ || ANDROID
+@@ -136,7 +137,7 @@
#if defined(__sgi)
pthread_setrunon_np( pd->cpunum );
#elif defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
@@ -17,7 +17,7 @@
CPU_ZERO( &cpumask );
CPU_SET( pd->cpunum, &cpumask );
-@@ -541,7 +542,7 @@
+@@ -569,7 +570,7 @@
if (pd->isRunning && Thread::CurrentThread()==this)
{
@@ -26,7 +26,7 @@
CPU_ZERO( &cpumask );
CPU_SET( pd->cpunum, &cpumask );
#if defined(HAVE_PTHREAD_SETAFFINITY_NP)
-@@ -975,7 +976,7 @@
+@@ -1031,7 +1032,7 @@
else
{
#if defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
@@ -34,4 +34,4 @@
+ cpuset_t cpumask;
CPU_ZERO( &cpumask );
CPU_SET( cpunum, &cpumask );
-
+ #if defined(HAVE_PTHREAD_SETAFFINITY_NP)
diff --git a/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp b/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
deleted file mode 100644
index 0891be87a53d..000000000000
--- a/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/osgPlugins/png/ReaderWriterPNG.cpp.orig 2010-03-28 16:40:42.000000000 -0600
-+++ src/osgPlugins/png/ReaderWriterPNG.cpp 2010-03-28 16:41:42.000000000 -0600
-@@ -173,7 +173,7 @@
- endinfo = png_create_info_struct(png);
-
- fin.read((char*)header,8);
-- if (fin.gcount() == 8 && png_check_sig(header, 8))
-+ if (fin.gcount() == 8 && (png_sig_cmp(header, 0, 8) == 0))
- png_set_read_fn(png,&fin,png_read_istream); //Use custom read function that will get data from istream
- else
- {
-@@ -224,7 +224,7 @@
- if (color == PNG_COLOR_TYPE_PALETTE)
- png_set_palette_to_rgb(png);
- if (color == PNG_COLOR_TYPE_GRAY && depth < 8)
-- png_set_gray_1_2_4_to_8(png);
-+ png_set_expand_gray_1_2_4_to_8(png);
- if (png_get_valid(png, info, PNG_INFO_tRNS))
- png_set_tRNS_to_alpha(png);
-
diff --git a/graphics/osg/pkg-plist b/graphics/osg/pkg-plist
index 072228684a24..ec6257070ace 100644
--- a/graphics/osg/pkg-plist
+++ b/graphics/osg/pkg-plist
@@ -3,6 +3,7 @@ bin/osgconv
bin/osgfilecache
bin/osgversion
bin/osgviewer
+bin/present3D
include/OpenThreads/Atomic
include/OpenThreads/Barrier
include/OpenThreads/Block
@@ -20,6 +21,8 @@ include/osg/AnimationPath
include/osg/ApplicationUsage
include/osg/ArgumentParser
include/osg/Array
+include/osg/ArrayDispatchers
+include/osg/AudioStream
include/osg/AutoTransform
include/osg/Billboard
include/osg/BlendColor
@@ -28,6 +31,7 @@ include/osg/BlendFunc
include/osg/BoundingBox
include/osg/BoundingSphere
include/osg/BoundsChecking
+include/osg/BufferIndexBinding
include/osg/BufferObject
include/osg/Camera
include/osg/CameraNode
@@ -64,12 +68,14 @@ include/osg/FrameStamp
include/osg/FrontFace
include/osg/GL
include/osg/GL2Extensions
+include/osg/GLBeginEndAdapter
include/osg/GLExtensions
include/osg/GLObjects
include/osg/GLU
include/osg/Geode
include/osg/Geometry
include/osg/GraphicsContext
+include/osg/GraphicsCostEstimator
include/osg/GraphicsThread
include/osg/Group
include/osg/Hint
@@ -100,6 +106,8 @@ include/osg/NodeTrackerCallback
include/osg/NodeVisitor
include/osg/Notify
include/osg/Object
+include/osg/Observer
+include/osg/ObserverNodePath
include/osg/OccluderNode
include/osg/OcclusionQueryNode
include/osg/OperationThread
@@ -123,11 +131,14 @@ include/osg/Scissor
include/osg/Sequence
include/osg/ShadeModel
include/osg/Shader
+include/osg/ShaderAttribute
+include/osg/ShaderComposer
include/osg/ShadowVolumeOccluder
include/osg/Shape
include/osg/ShapeDrawable
include/osg/State
include/osg/StateAttribute
+include/osg/StateAttributeCallback
include/osg/StateSet
include/osg/Stats
include/osg/Stencil
@@ -144,6 +155,7 @@ include/osg/Texture
include/osg/Texture1D
include/osg/Texture2D
include/osg/Texture2DArray
+include/osg/Texture2DMultisample
include/osg/Texture3D
include/osg/TextureCubeMap
include/osg/TextureRectangle
@@ -153,6 +165,8 @@ include/osg/Transform
include/osg/TriangleFunctor
include/osg/TriangleIndexFunctor
include/osg/Uniform
+include/osg/UserDataContainer
+include/osg/ValueObject
include/osg/Vec2
include/osg/Vec2b
include/osg/Vec2d
@@ -178,45 +192,74 @@ include/osg/fast_back_stack
include/osg/io_utils
include/osg/observer_ptr
include/osg/ref_ptr
+include/osgAnimation/Action
+include/osgAnimation/ActionAnimation
+include/osgAnimation/ActionBlendIn
+include/osgAnimation/ActionBlendOut
+include/osgAnimation/ActionCallback
+include/osgAnimation/ActionStripAnimation
+include/osgAnimation/ActionVisitor
include/osgAnimation/Animation
include/osgAnimation/AnimationManagerBase
-include/osgAnimation/Assert
+include/osgAnimation/AnimationUpdateCallback
include/osgAnimation/BasicAnimationManager
include/osgAnimation/Bone
+include/osgAnimation/BoneMapVisitor
include/osgAnimation/Channel
include/osgAnimation/CubicBezier
include/osgAnimation/EaseMotion
include/osgAnimation/Export
+include/osgAnimation/FrameAction
include/osgAnimation/Interpolator
include/osgAnimation/Keyframe
include/osgAnimation/LinkVisitor
+include/osgAnimation/MorphGeometry
include/osgAnimation/RigGeometry
+include/osgAnimation/RigTransform
+include/osgAnimation/RigTransformHardware
+include/osgAnimation/RigTransformSoftware
include/osgAnimation/Sampler
include/osgAnimation/Skeleton
-include/osgAnimation/Skinning
+include/osgAnimation/StackedMatrixElement
+include/osgAnimation/StackedQuaternionElement
+include/osgAnimation/StackedRotateAxisElement
+include/osgAnimation/StackedScaleElement
+include/osgAnimation/StackedTransform
+include/osgAnimation/StackedTransformElement
+include/osgAnimation/StackedTranslateElement
+include/osgAnimation/StatsHandler
+include/osgAnimation/StatsVisitor
include/osgAnimation/Target
include/osgAnimation/Timeline
include/osgAnimation/TimelineAnimationManager
-include/osgAnimation/UpdateCallback
+include/osgAnimation/UpdateBone
+include/osgAnimation/UpdateMaterial
+include/osgAnimation/UpdateMatrixTransform
include/osgAnimation/Vec3Packed
include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
+include/osgDB/Callbacks
include/osgDB/ConvertUTF
+include/osgDB/DataTypes
include/osgDB/DatabasePager
+include/osgDB/DatabaseRevisions
include/osgDB/DotOsgWrapper
include/osgDB/DynamicLibrary
include/osgDB/Export
-include/osgDB/Field
-include/osgDB/FieldReader
-include/osgDB/FieldReaderIterator
+include/osgDB/ExternalFileWriter
include/osgDB/FileCache
include/osgDB/FileNameUtils
include/osgDB/FileUtils
include/osgDB/ImageOptions
include/osgDB/ImagePager
+include/osgDB/ImageProcessor
include/osgDB/Input
+include/osgDB/InputStream
+include/osgDB/ObjectWrapper
+include/osgDB/Options
include/osgDB/Output
+include/osgDB/OutputStream
include/osgDB/ParameterOutput
include/osgDB/PluginQuery
include/osgDB/ReadFile
@@ -224,8 +267,10 @@ include/osgDB/ReaderWriter
include/osgDB/Registry
include/osgDB/Serializer
include/osgDB/SharedStateManager
+include/osgDB/StreamOperator
include/osgDB/Version
include/osgDB/WriteFile
+include/osgDB/XmlParser
include/osgDB/fstream
include/osgFX/AnisotropicLighting
include/osgFX/BumpMapping
@@ -233,6 +278,7 @@ include/osgFX/Cartoon
include/osgFX/Effect
include/osgFX/Export
include/osgFX/MultiTextureControl
+include/osgFX/Outline
include/osgFX/Registry
include/osgFX/Scribe
include/osgFX/SpecularHighlights
@@ -240,18 +286,23 @@ include/osgFX/Technique
include/osgFX/Validator
include/osgFX/Version
include/osgGA/AnimationPathManipulator
+include/osgGA/CameraManipulator
include/osgGA/CameraViewSwitchManipulator
include/osgGA/DriveManipulator
include/osgGA/EventQueue
include/osgGA/EventVisitor
include/osgGA/Export
+include/osgGA/FirstPersonManipulator
include/osgGA/FlightManipulator
include/osgGA/GUIActionAdapter
include/osgGA/GUIEventAdapter
include/osgGA/GUIEventHandler
include/osgGA/KeySwitchMatrixManipulator
-include/osgGA/MatrixManipulator
+include/osgGA/MultiTouchTrackballManipulator
include/osgGA/NodeTrackerManipulator
+include/osgGA/OrbitManipulator
+include/osgGA/SphericalManipulator
+include/osgGA/StandardManipulator
include/osgGA/StateSetManipulator
include/osgGA/TerrainManipulator
include/osgGA/TrackballManipulator
@@ -271,6 +322,7 @@ include/osgManipulator/Scale2DDragger
include/osgManipulator/ScaleAxisDragger
include/osgManipulator/Selection
include/osgManipulator/TabBoxDragger
+include/osgManipulator/TabBoxTrackballDragger
include/osgManipulator/TabPlaneDragger
include/osgManipulator/TabPlaneTrackballDragger
include/osgManipulator/TrackballDragger
@@ -281,14 +333,20 @@ include/osgManipulator/TranslatePlaneDragger
include/osgManipulator/Version
include/osgParticle/AccelOperator
include/osgParticle/AngularAccelOperator
+include/osgParticle/AngularDampingOperator
+include/osgParticle/BounceOperator
include/osgParticle/BoxPlacer
include/osgParticle/CenteredPlacer
+include/osgParticle/CompositePlacer
include/osgParticle/ConnectedParticleSystem
include/osgParticle/ConstantRateCounter
include/osgParticle/Counter
+include/osgParticle/DampingOperator
+include/osgParticle/DomainOperator
include/osgParticle/Emitter
include/osgParticle/ExplosionDebrisEffect
include/osgParticle/ExplosionEffect
+include/osgParticle/ExplosionOperator
include/osgParticle/Export
include/osgParticle/FireEffect
include/osgParticle/FluidFrictionOperator
@@ -300,6 +358,7 @@ include/osgParticle/ModularEmitter
include/osgParticle/ModularProgram
include/osgParticle/MultiSegmentPlacer
include/osgParticle/Operator
+include/osgParticle/OrbitOperator
include/osgParticle/Particle
include/osgParticle/ParticleEffect
include/osgParticle/ParticleProcessor
@@ -314,11 +373,18 @@ include/osgParticle/RandomRateCounter
include/osgParticle/SectorPlacer
include/osgParticle/SegmentPlacer
include/osgParticle/Shooter
+include/osgParticle/SinkOperator
include/osgParticle/SmokeEffect
include/osgParticle/SmokeTrailEffect
include/osgParticle/VariableRateCounter
include/osgParticle/Version
include/osgParticle/range
+include/osgPresentation/AnimationMaterial
+include/osgPresentation/CompileSlideCallback
+include/osgPresentation/Export
+include/osgPresentation/PickEventHandler
+include/osgPresentation/SlideEventHandler
+include/osgPresentation/SlideShowConstructor
include/osgShadow/ConvexPolyhedron
include/osgShadow/DebugShadowMap
include/osgShadow/Export
@@ -375,8 +441,10 @@ include/osgText/Export
include/osgText/FadeText
include/osgText/Font
include/osgText/Font3D
+include/osgText/Glyph
include/osgText/KerningType
include/osgText/String
+include/osgText/Style
include/osgText/Text
include/osgText/Text3D
include/osgText/TextBase
@@ -392,14 +460,17 @@ include/osgUtil/Export
include/osgUtil/GLObjectsVisitor
include/osgUtil/HalfWayMapGenerator
include/osgUtil/HighlightMapGenerator
+include/osgUtil/IncrementalCompileOperation
include/osgUtil/IntersectVisitor
include/osgUtil/IntersectionVisitor
include/osgUtil/LineSegmentIntersector
+include/osgUtil/MeshOptimizers
include/osgUtil/OperationArrayFunctor
include/osgUtil/Optimizer
include/osgUtil/PlaneIntersector
include/osgUtil/PolytopeIntersector
include/osgUtil/PositionalStateContainer
+include/osgUtil/PrintVisitor
include/osgUtil/ReflectionMapGenerator
include/osgUtil/RenderBin
include/osgUtil/RenderLeaf
@@ -407,6 +478,7 @@ include/osgUtil/RenderStage
include/osgUtil/ReversePrimitiveFunctor
include/osgUtil/SceneGraphBuilder
include/osgUtil/SceneView
+include/osgUtil/ShaderGen
include/osgUtil/Simplifier
include/osgUtil/SmoothingVisitor
include/osgUtil/StateGraph
@@ -421,8 +493,6 @@ include/osgUtil/Version
include/osgViewer/CompositeViewer
include/osgViewer/Export
include/osgViewer/GraphicsWindow
-include/osgViewer/GraphicsWindowX11
-include/osgViewer/PixelBufferX11
include/osgViewer/Renderer
include/osgViewer/Scene
include/osgViewer/Version
@@ -430,6 +500,7 @@ include/osgViewer/View
include/osgViewer/Viewer
include/osgViewer/ViewerBase
include/osgViewer/ViewerEventHandlers
+include/osgViewer/api/X11/GraphicsHandleX11
include/osgViewer/api/X11/GraphicsWindowX11
include/osgViewer/api/X11/PixelBufferX11
include/osgVolume/Export
@@ -490,6 +561,9 @@ lib/libosgManipulator.so.%%OSG_SHLIBVER%%
lib/libosgParticle.so
lib/libosgParticle.so.%%OSG_VERSION%%
lib/libosgParticle.so.%%OSG_SHLIBVER%%
+lib/libosgPresentation.so
+lib/libosgPresentation.so.%%OSG_VERSION%%
+lib/libosgPresentation.so.%%OSG_SHLIBVER%%
lib/libosgShadow.so
lib/libosgShadow.so.%%OSG_VERSION%%
lib/libosgShadow.so.%%OSG_SHLIBVER%%
@@ -523,11 +597,23 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_bvh.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_cfg.so
%%CURL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_curl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dds.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osganimation.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgfx.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgshadow.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgsim.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgterrain.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgviewer.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgvolume.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgwidget.so
%%ITK%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_dicom.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dw.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
%%OPENEXR%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_exr.so
+%%FFMPEG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_ffmpeg.so
%%FREETYPE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_freetype.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_geo.so
@@ -550,24 +636,32 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_obj.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_openflight.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osg.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osga.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osganimation.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgfx.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgparticle.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgshadow.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgterrain.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgviewer.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgvolume.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgwidget.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_p3d.so
%%PDF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_pdf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pic.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_ply.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_png.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pnm.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_pov.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_pvr.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_revisions.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rgb.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_scale.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osganimation.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgfx.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgmanipulator.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgshadow.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgvolume.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_shp.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_stl.so
%%SVG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_svg.so
@@ -583,6 +677,21 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so
%%XINE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_xine.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
+libdata/pkgconfig/openscenegraph-osg.pc
+libdata/pkgconfig/openscenegraph-osgAnimation.pc
+libdata/pkgconfig/openscenegraph-osgDB.pc
+libdata/pkgconfig/openscenegraph-osgFX.pc
+libdata/pkgconfig/openscenegraph-osgGA.pc
+libdata/pkgconfig/openscenegraph-osgManipulator.pc
+libdata/pkgconfig/openscenegraph-osgParticle.pc
+libdata/pkgconfig/openscenegraph-osgShadow.pc
+libdata/pkgconfig/openscenegraph-osgSim.pc
+libdata/pkgconfig/openscenegraph-osgTerrain.pc
+libdata/pkgconfig/openscenegraph-osgText.pc
+libdata/pkgconfig/openscenegraph-osgUtil.pc
+libdata/pkgconfig/openscenegraph-osgViewer.pc
+libdata/pkgconfig/openscenegraph-osgVolume.pc
+libdata/pkgconfig/openscenegraph-osgWidget.pc
libdata/pkgconfig/openscenegraph.pc
libdata/pkgconfig/openthreads.pc
@dirrm lib/osgPlugins-%%OSG_VERSION%%
@@ -596,6 +705,7 @@ libdata/pkgconfig/openthreads.pc
@dirrm include/osgTerrain
@dirrm include/osgSim
@dirrm include/osgShadow
+@dirrm include/osgPresentation
@dirrm include/osgParticle
@dirrm include/osgManipulator
@dirrm include/osgGA