aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 09:59:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 09:59:01 +0000
commitb3e4e19ddced293c5d1147a3172d522b4a807708 (patch)
tree3c883a39a2d25fb39090c52b9f70a4343ca7cc7a
parenteaa56b6fc08ef5b5a1500ce02bed6585015cad94 (diff)
downloadports-b3e4e19ddced293c5d1147a3172d522b4a807708.tar.gz
ports-b3e4e19ddced293c5d1147a3172d522b4a807708.zip
Add an explicit dependency on pkgconf
Notes
Notes: svn path=/head/; revision=326132
-rw-r--r--audio/esperanza/Makefile2
-rw-r--r--audio/gqmpeg-devel/Makefile4
-rw-r--r--deskutils/osmo/Makefile2
-rw-r--r--editors/gedit/Makefile9
-rw-r--r--emulators/x48/Makefile2
-rw-r--r--games/freeciv/Makefile3
-rw-r--r--net-im/ejabberd/Makefile3
-rw-r--r--net-mgmt/virt-viewer/Makefile2
-rw-r--r--net/desktop-data-model/Makefile9
-rw-r--r--palm/synce-gvfs/Makefile3
-rw-r--r--sysutils/swapd/Makefile8
-rw-r--r--textproc/ibus/Makefile8
-rw-r--r--x11-fm/nautilus/Makefile3
-rw-r--r--x11-toolkits/eel/Makefile9
-rw-r--r--x11-toolkits/gtk-sharp-beans/Makefile2
-rw-r--r--x11-toolkits/gtksourceview/Makefile9
-rw-r--r--x11-toolkits/libgnomeprintuimm/Makefile8
-rw-r--r--x11-toolkits/libgnomeui/Makefile3
-rw-r--r--x11-toolkits/libgnomeuimm/Makefile2
-rw-r--r--x11/gnome-screensaver/Makefile3
20 files changed, 27 insertions, 67 deletions
diff --git a/audio/esperanza/Makefile b/audio/esperanza/Makefile
index 096413b546e7..f1140d3cd8b9 100644
--- a/audio/esperanza/Makefile
+++ b/audio/esperanza/Makefile
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_QT4= gui xml network imageformats_run \
qmake_build moc_build rcc_build uic_build
QT_NONSTANDARD= yes
-USES= gmake
+USES= gmake pkgconfig
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --disable-growl
diff --git a/audio/gqmpeg-devel/Makefile b/audio/gqmpeg-devel/Makefile
index 73395ffe8456..c01c20adce59 100644
--- a/audio/gqmpeg-devel/Makefile
+++ b/audio/gqmpeg-devel/Makefile
@@ -12,8 +12,6 @@ COMMENT= Another gtk-based MP3 frontend
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USES= pkgconfig
-
.if defined(WITH_MPG321)
RUN_DEPENDS+= mpg321:${PORTSDIR}/audio/mpg321
.else
@@ -28,7 +26,7 @@ RUN_DEPENDS+= xmp:${PORTSDIR}/audio/xmp
RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
.endif
-USES= gmake
+USES= gmake pkgconfig
LATEST_LINK= gqmpeg-devel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes xproto
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
index 9bdc478db87e..f12f037ffd03 100644
--- a/deskutils/osmo/Makefile
+++ b/deskutils/osmo/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
gtkhtml:${PORTSDIR}/www/libgtkhtml
USE_GNOME= gtk20
-USES= gettext gmake
+USES= gettext gmake pkgconfig
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index ed8747ddb332..a2bdd444e4e9 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gedit2
-# Date created: 14 May 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/editors/gedit/Makefile,v 1.125 2010/09/30 19:58:54 kwm Exp $
-#
PORTNAME= gedit
PORTVERSION= 2.30.4
@@ -23,10 +19,9 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USE_XORG= sm
USE_BZIP2= yes
-USES= gettext
+USES= gettext gmake pkgconfig
INSTALLS_OMF= yes
USE_LDCONFIG= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_GNOME= gnomeprefix gnomehack intlhack gconf2 gtksourceview2 \
desktopfileutils gnomedocutils ltasneededhack
diff --git a/emulators/x48/Makefile b/emulators/x48/Makefile
index 14b863743ec1..58b3e908a5b1 100644
--- a/emulators/x48/Makefile
+++ b/emulators/x48/Makefile
@@ -24,7 +24,7 @@ AUTOMAKE_ARGS= --add-missing --copy -Wno-portability
ACLOCAL_ARGS= # default args (--acdir=...) produce broken configure script
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= LIBS=-lutil
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_XORG= x11 xext xt
NO_WRKSUBDIR= yes
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index ac7d05ce36ac..1fe685e602df 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -11,8 +11,7 @@ COMMENT= Free turn-based multiplayer strategy
RUN_DEPENDS= hicolor-icon-theme>=0:${PORTSDIR}/misc/hicolor-icon-theme
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
USE_BZIP2= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 68fabefad69c..cb76310c4d29 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -21,8 +21,7 @@ USERS= ejabberd
GROUPS= ${USERS}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= iconv
+USES= iconv gmake pkgconfig
USE_RC_SUBR= ${PORTNAME}
NOPRECIOUSMAKEVARS= yes
diff --git a/net-mgmt/virt-viewer/Makefile b/net-mgmt/virt-viewer/Makefile
index 4d206b977885..d65fdd60f32b 100644
--- a/net-mgmt/virt-viewer/Makefile
+++ b/net-mgmt/virt-viewer/Makefile
@@ -21,7 +21,7 @@ FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
CONFIGURE_ENV+= DATADIRNAME=share
-USES= gmake
+USES= gmake pkgconfig
MAN1= remote-viewer.1 virt-viewer.1
diff --git a/net/desktop-data-model/Makefile b/net/desktop-data-model/Makefile
index b129405f8da9..4f621cda73c2 100644
--- a/net/desktop-data-model/Makefile
+++ b/net/desktop-data-model/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: desktop-data-model
-# Date created: 2008-05-28
-# Whom: Ashish Shukla <wahjava@gmail.com>
-#
+# Created by: Ashish Shukla <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= desktop-data-model
PORTVERSION= 1.2.4
@@ -25,9 +21,8 @@ LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
-USE_GMAKE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext gmake pkgconfig
USE_GNOME= gnomehack gtk20 glib20 gnomedesktop gnomevfs2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-maemo=no
diff --git a/palm/synce-gvfs/Makefile b/palm/synce-gvfs/Makefile
index 6e3f92397eef..55202304c52d 100644
--- a/palm/synce-gvfs/Makefile
+++ b/palm/synce-gvfs/Makefile
@@ -15,8 +15,7 @@ LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix gvfs
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/sysutils/swapd/Makefile b/sysutils/swapd/Makefile
index 84d6e909e84d..7dc6a07649e7 100644
--- a/sysutils/swapd/Makefile
+++ b/sysutils/swapd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: swapd
-# Date created: August 16, 2007
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= swapd
PORTVERSION= 1.0.3
@@ -16,7 +12,7 @@ COMMENT= A daemon that watches free memory and manages swap files
LIB_DEPENDS= statgrab:${PORTSDIR}/devel/libstatgrab
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_RC_SUBR= swapd
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index 3b03e4c851bc..1871deea3c45 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ibus
-# Date created: 21 October 2008
-# Whom: Henry Hu <henry.hu.sh@gmail.com>
-#
+# Created by: Henry Hu <henry.hu.sh@gmail.com>
# $FreeBSD$
-#
PORTNAME= ibus
PORTVERSION= 1.4.1
@@ -28,7 +24,7 @@ USE_PYTHON= yes
USE_GNOME= pygtk2 gconf2
USE_LDCONFIG= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
GCONF_SCHEMAS= ibus.schemas
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 47135f4d4ea6..f597632372bd 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -21,8 +21,7 @@ CONFLICTS= nautilus-3.[0-9]*
INSTALLS_ICONS= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= gettext desktop-file-utils shared-mime-info
+USES= gettext desktop-file-utils shared-mime-info gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop \
librsvg2 ltverhack gvfs ltasneededhack
USE_LDCONFIG= yes
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
index 5b09c7345f84..22bec842232e 100644
--- a/x11-toolkits/eel/Makefile
+++ b/x11-toolkits/eel/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: eel2
-# Date created: 8th May 2001
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11-toolkits/eel/Makefile,v 1.90 2010/09/28 09:15:49 kwm Exp $
-#
PORTNAME= eel
PORTVERSION= 2.26.0
@@ -16,9 +12,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Generally useful classes and extensions to GNOME
-USES= gettext
+USES= gettext gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
USE_XORG= xrender
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack gnomedesktop ltverhack intlhack
diff --git a/x11-toolkits/gtk-sharp-beans/Makefile b/x11-toolkits/gtk-sharp-beans/Makefile
index 1707dca220ba..a43b68f1ad46 100644
--- a/x11-toolkits/gtk-sharp-beans/Makefile
+++ b/x11-toolkits/gtk-sharp-beans/Makefile
@@ -12,8 +12,8 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gio-sharp-2.0.pc:${PORTSDIR}/devel
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
+USES= gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
.include <bsd.port.pre.mk>
diff --git a/x11-toolkits/gtksourceview/Makefile b/x11-toolkits/gtksourceview/Makefile
index d252562d86ec..151060fbc43c 100644
--- a/x11-toolkits/gtksourceview/Makefile
+++ b/x11-toolkits/gtksourceview/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gtksourceview
-# Date created: 07 May 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11-toolkits/gtksourceview/Makefile,v 1.46 2007/05/19 21:36:33 marcus Exp $
-#
PORTNAME= gtksourceview
PORTVERSION= 1.8.5
@@ -20,8 +16,7 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-USES= gettext
-USE_GMAKE= yes
+USES= gettext gmake pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gnomehack libgnome libgnomeprintui intlhack \
diff --git a/x11-toolkits/libgnomeprintuimm/Makefile b/x11-toolkits/libgnomeprintuimm/Makefile
index 16971c71c8fc..0b74f0c8fbfe 100644
--- a/x11-toolkits/libgnomeprintuimm/Makefile
+++ b/x11-toolkits/libgnomeprintuimm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libgnomeprintuimm
-# Date created: 17 December 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libgnomeprintuimm
PORTVERSION= 2.5.2
@@ -21,7 +17,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gnomeprefix gnomehack libgnomeprintui
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index b646754115ee..efd464341c9f 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -21,8 +21,7 @@ LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring \
RUN_DEPENDS= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_XORG= sm
-USE_GMAKE= yes
-USES= bison pathfix gettext
+USES= bison pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix gnomehier libbonoboui ltverhack \
referencehack gvfs
USE_LDCONFIG= yes
diff --git a/x11-toolkits/libgnomeuimm/Makefile b/x11-toolkits/libgnomeuimm/Makefile
index a9a1864ec678..a85b6267f891 100644
--- a/x11-toolkits/libgnomeuimm/Makefile
+++ b/x11-toolkits/libgnomeuimm/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= gnomemm-2.0:${PORTSDIR}/x11/libgnomemm \
glademm-2.0:${PORTSDIR}/devel/libglademm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES= gmake pathfix
+USES= gmake pathfix pkgconfig
USE_GNOME= libgnomeui
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 7d24aac610c8..9637629a8cbb 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -18,10 +18,9 @@ RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
CONFLICTS= gnome-screensaver-3.[0-9]*
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_XORG= xtst xxf86vm
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix intlhack gnomemenus libgnomekbd gnomedesktop
CONFIGURE_ARGS= --with-gdm-config=${LOCALBASE}/etc/gdm/custom.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \