aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-06-08 18:11:16 +0000
committerCy Schubert <cy@FreeBSD.org>2011-06-08 18:11:16 +0000
commit0b898f41b89df6c154c51dca13326290bb368c44 (patch)
tree376492745c9ebf1ad53aec164d4b577c07e75af4
parentabe6bd552a6e2575439108ce564206e3cd8a805b (diff)
downloadports-0b898f41b89df6c154c51dca13326290bb368c44.tar.gz
ports-0b898f41b89df6c154c51dca13326290bb368c44.zip
Resurrect this port.
Assume maintainership.
Notes
Notes: svn path=/head/; revision=275244
-rw-r--r--x11-toolkits/slingshot/Makefile34
-rw-r--r--x11-toolkits/slingshot/distinfo3
-rw-r--r--x11-toolkits/slingshot/files/patch-aa81
-rw-r--r--x11-toolkits/slingshot/files/patch-ba40
-rw-r--r--x11-toolkits/slingshot/files/patch-bc15
-rw-r--r--x11-toolkits/slingshot/files/patch-ca192
-rw-r--r--x11-toolkits/slingshot/files/patch-config.svr411
-rw-r--r--x11-toolkits/slingshot/files/patch-da19
-rw-r--r--x11-toolkits/slingshot/files/patch-gcc495
-rw-r--r--x11-toolkits/slingshot/files/patch-lex.yy.c17
-rw-r--r--x11-toolkits/slingshot/pkg-descr15
-rw-r--r--x11-toolkits/slingshot/pkg-plist24
12 files changed, 546 insertions, 0 deletions
diff --git a/x11-toolkits/slingshot/Makefile b/x11-toolkits/slingshot/Makefile
new file mode 100644
index 000000000000..3265b7f30a66
--- /dev/null
+++ b/x11-toolkits/slingshot/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: SlingShot
+# Date created: 5 March 1997
+# Whom: Pedro Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME= slingshot
+PORTVERSION= 2.1
+PORTREVISION= 3
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.x.org/R5contrib/
+DISTNAME= SlingShot${PORTVERSION}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Supplemental Libraries to extend Xview
+
+LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+
+WRKSRC= ${WRKDIR}/sspkg2.1
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+MAKE_ENV= OPENWINHOME=${LOCALBASE}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.ps ${DOCSDIR}
+ ${GZIP_CMD} ${DOCSDIR}/README ${DOCSDIR}/*.ps
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/slingshot/distinfo b/x11-toolkits/slingshot/distinfo
new file mode 100644
index 000000000000..a3e430d630de
--- /dev/null
+++ b/x11-toolkits/slingshot/distinfo
@@ -0,0 +1,3 @@
+MD5 (SlingShot2.1.tar.Z) = 4ac24274f94867268423bc35af658be2
+SHA256 (SlingShot2.1.tar.Z) = b634a775adbbadaf7f3f776409f61686bd1b2ea0335042e8ae83c3d3b4597251
+SIZE (SlingShot2.1.tar.Z) = 680092
diff --git a/x11-toolkits/slingshot/files/patch-aa b/x11-toolkits/slingshot/files/patch-aa
new file mode 100644
index 000000000000..7902fdc3c825
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-aa
@@ -0,0 +1,81 @@
+*** Makefile.orig Wed Nov 3 04:18:39 1993
+--- Makefile Sat Mar 4 04:17:25 2000
+***************
+*** 2,8 ****
+ # @(#) Makefile 1.21 93/10/25
+
+ SSPKGHOME = .
+! INSTALL_DIR = /home2/install
+ TARFILE = /home2/tmp/sspkgs-tar
+
+ SRCDIR = $(SSPKGHOME)/src
+--- 2,8 ----
+ # @(#) Makefile 1.21 93/10/25
+
+ SSPKGHOME = .
+! INSTALL_DIR = $(PREFIX)
+ TARFILE = /home2/tmp/sspkgs-tar
+
+ SRCDIR = $(SSPKGHOME)/src
+***************
+*** 16,29 ****
+ subdirs: $(INCLUDEDIR) $(SRCDIR) examples
+
+ $(INCLUDEDIR): FORCE
+! cd $@; make
+
+ $(SRCDIR): FORCE Make.config
+! cd $@; make
+
+
+ examples: FORCE
+! cd $@; make
+
+ #
+ # Make.config has things that are needed to build on various platforms.
+--- 16,29 ----
+ subdirs: $(INCLUDEDIR) $(SRCDIR) examples
+
+ $(INCLUDEDIR): FORCE
+! cd $@; $(MAKE)
+
+ $(SRCDIR): FORCE Make.config
+! cd $@; $(MAKE)
+
+
+ examples: FORCE
+! cd $@; $(MAKE)
+
+ #
+ # Make.config has things that are needed to build on various platforms.
+***************
+*** 45,58 ****
+
+ clean:
+ -sccs clean
+! (cd $(INCLUDEDIR); make clean)
+! (cd $(SRCDIR); make clean)
+! (cd examples; make clean)
+ rm -f Make.config
+
+! install: $(INSTALL_DIR) FORCE
+! (cd $(INCLUDEDIR); make install INSTALL_DIR=$(INSTALL_DIR))
+! (cp $(LIBDIR)/* $(INSTALL_DIR)/lib)
+ -ranlib $(INSTALL_DIR)/lib/libsspkg.a
+ -ranlib $(INSTALL_DIR)/lib/libsspkg.sa.*
+ (cd $(INSTALL_DIR)/lib; rm -f libsspkg.so; ln -s libsspkg.so.* libsspkg.so)
+--- 48,61 ----
+
+ clean:
+ -sccs clean
+! (cd $(INCLUDEDIR); $(MAKE) clean)
+! (cd $(SRCDIR); $(MAKE) clean)
+! (cd examples; $(MAKE) clean)
+ rm -f Make.config
+
+! install: all $(INSTALL_DIR) FORCE
+! (cd $(INCLUDEDIR); $(MAKE) install INSTALL_DIR=$(INSTALL_DIR))
+! (${BSD_INSTALL_DATA} $(LIBDIR)/* $(INSTALL_DIR)/lib)
+ -ranlib $(INSTALL_DIR)/lib/libsspkg.a
+ -ranlib $(INSTALL_DIR)/lib/libsspkg.sa.*
+ (cd $(INSTALL_DIR)/lib; rm -f libsspkg.so; ln -s libsspkg.so.* libsspkg.so)
diff --git a/x11-toolkits/slingshot/files/patch-ba b/x11-toolkits/slingshot/files/patch-ba
new file mode 100644
index 000000000000..a5aaca885d84
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-ba
@@ -0,0 +1,40 @@
+*** src/Makefile.orig Tue Oct 26 03:37:43 1993
+--- src/Makefile Sat Mar 4 04:17:50 2000
+***************
+*** 15,22 ****
+
+ INCDIR = $(SSPKGHOME)/include/sspkg
+ PRIVATEINCDIR = $(SSPKGHOME)/src
+! #CFLAGS = -O
+! CFLAGS = -g
+ CPPFLAGS = -I$(SSPKGHOME)/include -I$(PRIVATEINCDIR) -I$(OPENWINHOME)/include
+
+
+--- 15,22 ----
+
+ INCDIR = $(SSPKGHOME)/include/sspkg
+ PRIVATEINCDIR = $(SSPKGHOME)/src
+! CFLAGS += -DNO_SINCOS
+! #CFLAGS = -g
+ CPPFLAGS = -I$(SSPKGHOME)/include -I$(PRIVATEINCDIR) -I$(OPENWINHOME)/include
+
+
+***************
+*** 112,119 ****
+
+
+ install: $(STATICLIBRARY) $(SHAREDLIB) FORCE
+! cp $(STATICLIBRARY) $(INSTALL_DIR)/lib
+! cp $(SHAREDLIB) $(INSTALL_DIR)/lib
+ ln -s $(SHAREDLIB) $(INSTALLDIR)/libsspkg.so
+
+
+--- 112,119 ----
+
+
+ install: $(STATICLIBRARY) $(SHAREDLIB) FORCE
+! ${BSD_INSTALL_DATA} $(STATICLIBRARY) $(INSTALL_DIR)/lib
+! ${BSD_INSTALL_DATA} $(SHAREDLIB) $(INSTALL_DIR)/lib
+ ln -s $(SHAREDLIB) $(INSTALLDIR)/libsspkg.so
+
+
diff --git a/x11-toolkits/slingshot/files/patch-bc b/x11-toolkits/slingshot/files/patch-bc
new file mode 100644
index 000000000000..66fe77a6917f
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-bc
@@ -0,0 +1,15 @@
+*** src/tacho.c.orig Thu Apr 24 20:48:57 1997
+--- src/tacho.c Thu Apr 24 20:56:55 1997
+***************
+*** 19,24 ****
+--- 19,28 ----
+ #include "drawobj_impl.h"
+ #include <math.h>
+
++ #ifdef __FreeBSD__
++ #define irint(x) ((int)rint((x)))
++ #endif
++
+ Pkg_private int tacho_init();
+ Pkg_private Xv_opaque tacho_set_avlist();
+ Pkg_private Xv_opaque tacho_get_attr();
diff --git a/x11-toolkits/slingshot/files/patch-ca b/x11-toolkits/slingshot/files/patch-ca
new file mode 100644
index 000000000000..1ca1ae1d2c9b
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-ca
@@ -0,0 +1,192 @@
+*** examples/Makefile.orig Tue Nov 2 14:18:49 1993
+--- examples/Makefile Sat Mar 4 18:44:23 2000
+***************
+*** 1,5 ****
+
+! # @(#) Makefile 1.21 93/11/02
+
+ SSPKGHOME = ..
+
+--- 1,5 ----
+
+! # @(#) $(MAKE)file 1.21 93/11/02
+
+ SSPKGHOME = ..
+
+***************
+*** 8,94 ****
+ SSPKGLIB = $(SSPKGHOME)/lib/libsspkg.a
+
+
+! DBXFLAGS = -g
+! CFLAGS = $(DBXFLAGS) -I$(SSPKGHOME)/include -I$(OPENWINHOME)/include
+ LDFLAGS = -L$(LIBDIR) $(LIBS) $(SSPKGLIB) -lm
+
+ all: icons array_tile clockobj color color2 \
+! dnd dnd2 drawarea drawimage drawline drawtext grip \
+ group icons misc selection tacho thermo tree
+
+ array_tile: FORCE
+! cd $@; make
+
+ clockobj: FORCE
+! cd $@; make
+
+ dnd: FORCE
+! cd $@; make
+
+ dnd2: FORCE
+! cd $@; make
+
+ drawarea: FORCE
+! cd $@; make
+
+ drawline: FORCE
+! cd $@; make
+
+ group: FORCE
+! cd $@; make
+
+ grip: FORCE
+! cd $@; make
+
+ icons: FORCE
+! cd $@; make
+
+ misc: FORCE
+! cd $@; make
+
+ selection: FORCE
+! cd $@; make
+
+ tree: FORCE
+! cd $@; make
+
+ drawtext: FORCE
+! cd $@; make
+
+ drawimage: FORCE
+! cd $@; make
+
+ tacho: FORCE
+! cd $@; make
+
+ color: FORCE
+! cd $@; make
+
+ color2: FORCE
+! cd $@; make
+
+ thermo: FORCE
+! cd $@; make
+
+ clean:
+! -(cd array_tile; make clean; rm -f .make.state)
+! -(cd color; make clean; rm -f .make.state)
+! -(cd color2; make clean; rm -f .make.state)
+! -(cd clockobj; make clean; rm -f .make.state)
+! -(cd dnd; make clean; rm -f .make.state)
+! -(cd dnd2; make clean; rm -f .make.state)
+! -(cd drawarea; make clean; rm -f .make.state)
+! -(cd drawimage; make clean; rm -f .make.state)
+! -(cd drawline; make clean; rm -f .make.state)
+! -(cd drawtext; make clean; rm -f .make.state)
+! -(cd grip; make clean; rm -f .make.state)
+! -(cd group; make clean; rm -f .make.state)
+! -(cd icons; make clean; rm -f .make.state)
+! -(cd misc; make clean; rm -f .make.state)
+! -(cd selection; make clean; rm -f .make.state)
+! -(cd tree; make clean; rm -f .make.state)
+! -(cd tacho; make clean; rm -f .make.state)
+! -(cd thermo; make clean; rm -f .make.state)
+
+ FORCE:
+
+--- 8,94 ----
+ SSPKGLIB = $(SSPKGHOME)/lib/libsspkg.a
+
+
+! #DBXFLAGS = -g
+! CFLAGS += $(DBXFLAGS) -I$(SSPKGHOME)/../include -I$(OPENWINHOME)/include
+ LDFLAGS = -L$(LIBDIR) $(LIBS) $(SSPKGLIB) -lm
+
+ all: icons array_tile clockobj color color2 \
+! dnd drawarea drawimage drawline drawtext grip \
+ group icons misc selection tacho thermo tree
+
+ array_tile: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ clockobj: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ dnd: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ dnd2: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ drawarea: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ drawline: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ group: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ grip: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ icons: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ misc: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ selection: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ tree: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ drawtext: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ drawimage: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ tacho: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ color: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ color2: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ thermo: FORCE
+! cd $@; $(MAKE) all 'CFLAGS=$(CFLAGS)' 'CC=$(CC)' 'MAKE=$(MAKE)'
+
+ clean:
+! -(cd array_tile; $(MAKE) clean; rm -f .make.state)
+! -(cd color; $(MAKE) clean; rm -f .make.state)
+! -(cd color2; $(MAKE) clean; rm -f .make.state)
+! -(cd clockobj; $(MAKE) clean; rm -f .make.state)
+! -(cd dnd; $(MAKE) clean; rm -f .make.state)
+! -(cd dnd2; $(MAKE) clean; rm -f .make.state)
+! -(cd drawarea; $(MAKE) clean; rm -f .make.state)
+! -(cd drawimage; $(MAKE) clean; rm -f .make.state)
+! -(cd drawline; $(MAKE) clean; rm -f .make.state)
+! -(cd drawtext; $(MAKE) clean; rm -f .make.state)
+! -(cd grip; $(MAKE) clean; rm -f .make.state)
+! -(cd group; $(MAKE) clean; rm -f .make.state)
+! -(cd icons; $(MAKE) clean; rm -f .make.state)
+! -(cd misc; $(MAKE) clean; rm -f .make.state)
+! -(cd selection; $(MAKE) clean; rm -f .make.state)
+! -(cd tree; $(MAKE) clean; rm -f .make.state)
+! -(cd tacho; $(MAKE) clean; rm -f .make.state)
+! -(cd thermo; $(MAKE) clean; rm -f .make.state)
+
+ FORCE:
+
diff --git a/x11-toolkits/slingshot/files/patch-config.svr4 b/x11-toolkits/slingshot/files/patch-config.svr4
new file mode 100644
index 000000000000..9b225e4de75f
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-config.svr4
@@ -0,0 +1,11 @@
+--- config.svr4.orig Wed May 17 11:15:53 2006
++++ config.svr4 Wed May 17 11:19:04 2006
+@@ -1,7 +1,7 @@
+
+ # @(#) config.svr4 1.7 92/10/27
+
+-CONFIGPIC = -Kpic
++CONFIGPIC = -fPIC
+ CONFIGSHAREDLIBLD = ld -G -o $@ -h libsspkg.so.1 $? -lm -lc;
+
+ SHAREDLIB = $(LIBDIR)/libsspkg.so.1
diff --git a/x11-toolkits/slingshot/files/patch-da b/x11-toolkits/slingshot/files/patch-da
new file mode 100644
index 000000000000..094a41ceb258
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-da
@@ -0,0 +1,19 @@
+*** include/sspkg/Makefile.orig Sat Oct 23 02:34:35 1993
+--- include/sspkg/Makefile Sat Mar 4 05:05:40 2000
+***************
+*** 13,19 ****
+ -sccs clean
+
+ install: FORCE
+! cp $(INCLUDEFILES) $(INSTALL_DIR)/include/sspkg
+
+ FORCE:
+
+--- 13,19 ----
+ -sccs clean
+
+ install: FORCE
+! ${BSD_INSTALL_DATA} $(INCLUDEFILES) $(INSTALL_DIR)/include/sspkg
+
+ FORCE:
+
diff --git a/x11-toolkits/slingshot/files/patch-gcc4 b/x11-toolkits/slingshot/files/patch-gcc4
new file mode 100644
index 000000000000..41f812cb7849
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-gcc4
@@ -0,0 +1,95 @@
+--- src/canshell.c.orig Tue Oct 26 00:39:15 1993
++++ src/canshell.c Tue Jun 19 00:26:42 2007
+@@ -458,6 +458,8 @@
+ }
+
+
++static void rectobj_show_rects();
++
+ void
+ canvas_shell_event_proc(paint_window, event, arg)
+ Xv_window paint_window;
+@@ -468,7 +470,6 @@
+ Canvas_shell_info *csinfo;
+ Rectobj rectobj;
+ Rectobj_info *rinfo;
+- static void rectobj_show_rects();
+
+ canvas_shell = (Canvas_shell) xv_get(paint_window, CANVAS_PAINT_CANVAS_WINDOW);
+ csinfo = CANVAS_SHELL_PRIVATE(canvas_shell);
+--- src/drawimage.c.orig Tue Oct 26 00:40:12 1993
++++ src/drawimage.c Tue Jun 19 00:33:21 2007
+@@ -216,6 +216,8 @@
+ }
+
+
++static void render_image();
++
+ /*ARGSUSED*/
+ Pkg_private void
+ drawimage_paint_proc(drawimage, dpy, win, xrects)
+@@ -229,7 +231,6 @@
+ Drawimage_image *image;
+ GC gc;
+ int highlighted;
+- static void render_image();
+
+ gc = XCreateGC(dpy, win, 0, 0);
+
+--- src/rectobj.c.orig Fri Nov 5 07:51:06 1993
++++ src/rectobj.c Tue Jun 19 00:28:09 2007
+@@ -757,12 +757,13 @@
+ return XV_OK;
+ }
+
++static void *set_shared_info();
++
+ static void
+ rectobj_add_to_parent_list(rinfo)
+ Rectobj_info *rinfo;
+ {
+ Rectobj_info *parent_rinfo;
+- void *set_shared_info();
+
+ /* add adjustment for stacking order here */
+ if(rinfo->parent) {
+diff -ur work/sspkg2.1/src/tree.c foo/sspkg2.1/src/tree.c
+--- src/tree.c.orig Tue Oct 26 00:41:13 1993
++++ src/tree.c Tue Jun 19 00:47:27 2007
+@@ -392,21 +392,21 @@
+ }
+
+
+-void tree_set_geometries();
+-void tree_set_xy();
+-void tree_set_links();
+-void tree_move_links();
+-void tree_calc_positions();
+-void tree_attach_parent();
+-Polyline *tree_line();
+-void tree_layout();
+-void tree_layout_leaf();
+-int tree_join();
+-int tree_merge();
+-int tree_offset();
+-Polyline *tree_bridge();
+-void tree_calc_breadth_depth();
+-void tree_set_breadth_depth();
++static void tree_set_geometries();
++static void tree_set_xy();
++static void tree_set_links();
++static void tree_move_links();
++static void tree_calc_positions();
++static void tree_attach_parent();
++static Polyline *tree_line();
++static void tree_layout();
++static void tree_layout_leaf();
++static int tree_join();
++static int tree_merge();
++static int tree_offset();
++static Polyline *tree_bridge();
++static void tree_calc_breadth_depth();
++static void tree_set_breadth_depth();
+
+ /* These are copied from tree private to avoid passing them around */
+ static Listnode *line_heap_list;
diff --git a/x11-toolkits/slingshot/files/patch-lex.yy.c b/x11-toolkits/slingshot/files/patch-lex.yy.c
new file mode 100644
index 000000000000..f2d202bca317
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-lex.yy.c
@@ -0,0 +1,17 @@
+--- examples/tree/lex.yy.c.orig Tue Apr 15 11:56:25 2003
++++ examples/tree/lex.yy.c Tue Apr 15 11:57:27 2003
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <unistd.h>
+ # define U(x) x
+ # define NLSTATE yyprevious=YYNEWLINE
+ # define BEGIN yybgin = yysvec + 1 +
+@@ -66,7 +67,7 @@
+ int yymorfg;
+ extern char *yysptr, yysbuf[];
+ int yytchar;
+-FILE *yyin = {stdin}, *yyout = {stdout};
++FILE *yyin = STDIN_FILENO, *yyout = STDOUT_FILENO;
+ extern int yylineno;
+ struct yysvf {
+ struct yywork *yystoff;
diff --git a/x11-toolkits/slingshot/pkg-descr b/x11-toolkits/slingshot/pkg-descr
new file mode 100644
index 000000000000..8eda1a855e7e
--- /dev/null
+++ b/x11-toolkits/slingshot/pkg-descr
@@ -0,0 +1,15 @@
+Slingshot provides rectangles (like the Xt Intrinsics' RectObj gadget),
+drag-and-drop support, images, icons and text, trees, lines, arrows...
+You can look at the documentation for the details, but here's a few
+teasers: there are new objects (clock, bag, box). The grip and the
+drawarea have had a few interesting features added. The documentation
+has been improved dramatically. The drawtext can now be editible.
+
+CAVEATS
+-------
+
+This is NOT an official or supported product of Sun Microsystems, Inc.
+This software has been developed to leverage other efforts, and it is
+being released because it is hoped others can get benefits from it too.
+However, there ARE bugs in this software which may never be fixed, and
+there is no guarantee of compatibility between releases.
diff --git a/x11-toolkits/slingshot/pkg-plist b/x11-toolkits/slingshot/pkg-plist
new file mode 100644
index 000000000000..d65041f3d432
--- /dev/null
+++ b/x11-toolkits/slingshot/pkg-plist
@@ -0,0 +1,24 @@
+include/sspkg/array.h
+include/sspkg/box.h
+include/sspkg/canshell.h
+include/sspkg/disp_list.h
+include/sspkg/drawobj.h
+include/sspkg/grip.h
+include/sspkg/list.h
+include/sspkg/patchlevel.h
+include/sspkg/rectobj.h
+include/sspkg/tree.h
+lib/libsspkg.a
+lib/libsspkg.so
+lib/libsspkg.so.1
+%%PORTDOCS%%%%DOCSDIR%%/README.gz
+%%PORTDOCS%%%%DOCSDIR%%/appA.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/appB.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/appC.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/appD.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/appE.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ch1.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ch2.ps.gz
+%%PORTDOCS%%%%DOCSDIR%%/ch3.ps.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/sspkg