aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-10 04:34:41 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-10-10 04:34:41 +0000
commit10fbe411522452c50bcc17fb471ac7485ce66f0e (patch)
tree20af9bc5b33a4ad120638373878aadc96f51e0ae
parentd822332d5ae8ac0a516f46f18b3f8aa29005a6da (diff)
downloadports-10fbe411522452c50bcc17fb471ac7485ce66f0e.tar.gz
ports-10fbe411522452c50bcc17fb471ac7485ce66f0e.zip
- Fix build w/ lang/perl5.12
- Bump PORTREVISION PR: ports/150149 Submitted by: Bill Brinzer <bill.brinzer@gmail.com> Approved by: maintainer timeout (clsung ; 17 days)
Notes
Notes: svn path=/head/; revision=262730
-rw-r--r--devel/p5-Data-Alias/Makefile1
-rw-r--r--devel/p5-Data-Alias/files/patch-Alias.xs69
2 files changed, 70 insertions, 0 deletions
diff --git a/devel/p5-Data-Alias/Makefile b/devel/p5-Data-Alias/Makefile
index 89d451a2ddc2..1d39a14795c2 100644
--- a/devel/p5-Data-Alias/Makefile
+++ b/devel/p5-Data-Alias/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Data-Alias
PORTVERSION= 1.07
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/devel/p5-Data-Alias/files/patch-Alias.xs b/devel/p5-Data-Alias/files/patch-Alias.xs
new file mode 100644
index 000000000000..7b953c076e02
--- /dev/null
+++ b/devel/p5-Data-Alias/files/patch-Alias.xs
@@ -0,0 +1,69 @@
+--- Alias.xs
++++ Alias.xs
+@@ -75,6 +75,10 @@
+ #define SvPVX_const SvPVX
+ #endif
+
++#if (PERL_COMBI_VERSION >= 5011000)
++#define SVt_RV SVt_IV
++#endif
++
+ #ifndef SvREFCNT_inc_NN
+ #define SvREFCNT_inc_NN SvREFCNT_inc
+ #endif
+@@ -366,7 +370,7 @@ STATIC void da_localize_gvar(pTHX_ GP *gp, SV **sptr) {
+ SSPUSHPTR(gp);
+ SSPUSHINT(SAVEt_DESTRUCTOR_X);
+ ++gp->gp_refcnt;
+- *sptr = Nullsv;
++ *sptr = NULL;
+ }
+
+ STATIC SV *da_refgen(pTHX_ SV *sv) {
+@@ -1248,7 +1252,7 @@ OP *DataAlias_pp_return(pTHX) {
+ cxstack_ix--;
+ POPSUB(cx, sv);
+ } else {
+- sv = Nullsv;
++ sv = NULL;
+ }
+ PL_curpm = newpm;
+ LEAVESUB(sv);
+@@ -1433,7 +1437,7 @@ STATIC int da_transform(pTHX_ OP *op, int sib) {
+ int hits = 0;
+
+ while (op) {
+- OP *kid = Nullop, *tmp;
++ OP *kid = NULL, *tmp;
+ int ksib = TRUE;
+ OPCODE optype;
+
+@@ -1447,7 +1451,9 @@ STATIC int da_transform(pTHX_ OP *op, int sib) {
+ default:
+ --hits;
+ switch (optype) {
++#if PERL_COMBI_VERSION < 5006000
+ case OP_SETSTATE:
++#endif
+ case OP_NEXTSTATE:
+ case OP_DBSTATE:
+ PL_curcop = (COP *) op;
+@@ -1586,7 +1592,9 @@ STATIC int da_peep2(pTHX_ OP *o) {
+ if (da_peep2(aTHX_ k))
+ return 1;
+ } else switch (o->op_type ? o->op_type : o->op_targ) {
++#if PERL_COMBI_VERSION < 5006000
+ case OP_SETSTATE:
++#endif
+ case OP_NEXTSTATE:
+ case OP_DBSTATE:
+ PL_curcop = (COP *) o;
+@@ -1764,7 +1772,7 @@ STATIC OP *da_ck_entersub(pTHX_ OP *o) {
+ kUNOP->op_first = last;
+ while (kid->op_sibling != last)
+ kid = kid->op_sibling;
+- kid->op_sibling = Nullop;
++ kid->op_sibling = NULL;
+ cLISTOPx(cUNOPo->op_first)->op_last = kid;
+ if (kid->op_type == OP_NULL && inside)
+ kid->op_flags &= ~OPf_SPECIAL;