aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-09 22:29:11 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-09 22:29:11 +0000
commit1cc2283a20945120530173834dab6a62738eb53d (patch)
treedf4cc83aa53f8718776e4cb065e35d343ed42e24
parent8fc31d32f074ef22562c3b6e20705a57d97332ba (diff)
downloadports-1cc2283a20945120530173834dab6a62738eb53d.tar.gz
ports-1cc2283a20945120530173834dab6a62738eb53d.zip
Add new port devel/qconf:
QConf allows you to have a nice configure script for your qmake-based project. It is intended for developers who don't need (or want) to use the more complex GNU autotools. With qconf/qmake, it is easy to maintain a cross-platform project that uses a familiar configuration interface on unix. WWW: http://delta.affinix.com/qconf/ PR: based on ports/151028 Submitted by: Andreev Maxim <andreevmaxim at gmail.com>
Notes
Notes: svn path=/head/; revision=262715
-rw-r--r--devel/qconf/Makefile27
-rw-r--r--devel/qconf/distinfo3
-rw-r--r--devel/qconf/pkg-descr7
-rw-r--r--devel/qconf/pkg-plist11
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/qconf/Makefile b/devel/qconf/Makefile
new file mode 100644
index 000000000000..8e057ef4c527
--- /dev/null
+++ b/devel/qconf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: qconf
+# Date created: 2010-10-28
+# Whom: Andreev Maxim <andreevmaxim@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qconf
+PORTVERSION= 1.4
+CATEGORIES= devel
+MASTER_SITES= http://delta.affinix.com/download/
+
+MAINTAINER= andreevmaxim@gmail.com
+COMMENT= Tool to create configure script for qmake-based project
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib xml moc_build qmake_build
+HAS_CONFIGURE= yes
+QT_NONSTANDARD= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --datadir=${DATADIR:S,/qconf,,} \
+ --qtdir=${QT_PREFIX} \
+ --verbose
+
+.include <bsd.port.mk>
diff --git a/devel/qconf/distinfo b/devel/qconf/distinfo
new file mode 100644
index 000000000000..eb2f925ee3c7
--- /dev/null
+++ b/devel/qconf/distinfo
@@ -0,0 +1,3 @@
+MD5 (qconf-1.4.tar.bz2) = e0080044f88c31e032008d5a5682a112
+SHA256 (qconf-1.4.tar.bz2) = 212bce09a585a22cf4b9e1a881e8f79c32a82e5cb8ea7f99a056a50faf809af8
+SIZE (qconf-1.4.tar.bz2) = 27344
diff --git a/devel/qconf/pkg-descr b/devel/qconf/pkg-descr
new file mode 100644
index 000000000000..bb22fccd8308
--- /dev/null
+++ b/devel/qconf/pkg-descr
@@ -0,0 +1,7 @@
+QConf allows you to have a nice configure script for your qmake-based
+project. It is intended for developers who don't need (or want) to
+use the more complex GNU autotools. With qconf/qmake, it is easy
+to maintain a cross-platform project that uses a familiar configuration
+interface on unix.
+
+WWW: http://delta.affinix.com/qconf/
diff --git a/devel/qconf/pkg-plist b/devel/qconf/pkg-plist
new file mode 100644
index 000000000000..98d57e384d2b
--- /dev/null
+++ b/devel/qconf/pkg-plist
@@ -0,0 +1,11 @@
+bin/qconf
+%%DATADIR%%/conf/conf.cpp
+%%DATADIR%%/conf/conf.pro
+%%DATADIR%%/conf/conf4.cpp
+%%DATADIR%%/conf/conf4.h
+%%DATADIR%%/conf/conf4.pro
+%%DATADIR%%/modules/qt31.qcm
+%%DATADIR%%/modules/qt41.qcm
+@dirrm %%DATADIR%%/modules
+@dirrm %%DATADIR%%/conf
+@dirrm %%DATADIR%%