aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-20 23:04:13 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-20 23:04:13 +0000
commit24b3b2d538a965fab545ce56903fa740225d9ec5 (patch)
tree8e9060203a14da778ee65527743ed42ba3fc5ee0
parentd0c7dbe793d81d88a2773156ba8da37cb4ed366f (diff)
downloadports-24b3b2d538a965fab545ce56903fa740225d9ec5.tar.gz
ports-24b3b2d538a965fab545ce56903fa740225d9ec5.zip
Remove the old-and-broken sybase (DB-lib) extension and point users to
the new-and-working sybase (CT-lib) extension.
Notes
Notes: svn path=/head/; revision=114315
-rw-r--r--MOVED2
-rw-r--r--Mk/bsd.php.mk3
-rw-r--r--databases/Makefile2
-rw-r--r--databases/php4-sybase/Makefile14
-rw-r--r--databases/php5-sybase/Makefile14
-rw-r--r--lang/php4-extensions/Makefile5
-rw-r--r--lang/php4/Makefile.ext6
-rw-r--r--lang/php5-extensions/Makefile5
-rw-r--r--lang/php5/Makefile.ext6
-rw-r--r--lang/php53/Makefile.ext6
10 files changed, 7 insertions, 56 deletions
diff --git a/MOVED b/MOVED
index daec49bae0a2..7c657dee2ba3 100644
--- a/MOVED
+++ b/MOVED
@@ -1197,3 +1197,5 @@ lang/php4-dtc|lang/php4|2004-07-19|Useless with the new PHP modular infrastructu
lang/php4-horde|lang/php4|2004-07-19|Useless with the new PHP modular infrastructure
lang/php4-nms|lang/php4|2004-07-19|Useless with the new PHP modular infrastructure
www/mod_php4-twig|www/mod_php4|2004-07-19|Useless with the new PHP modular infrastructure
+databases/php4-sybase|databases/php4-sybase_ct|2004-07-21|Switch to use the new working library
+databases/php5-sybase|databases/php5-sybase_ct|2004-07-21|Switch to use the new working library
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 231067cd1886..cd4d776596ab 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -249,7 +249,7 @@ _USE_PHP_ALL= bcmath bz2 calendar crack ctype curl dba dbase dbx dio \
ming mnogosearch mssql mysql mysqli ncurses odbc \
openssl oracle overload panda pcntl pcre pdf pgsql posix \
pspell readline recode session shmop simplexml snmp soap \
- sockets sqlite sybase sybase_ct sysvmsg sysvsem sysvshm \
+ sockets sqlite sybase_ct sysvmsg sysvsem sysvshm \
tidy tokenizer wddx xml xmlrpc xsl xslt yaz yp zip zlib
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
@@ -307,7 +307,6 @@ snmp_DEPENDS= net-mgmt/php${PHP_VER}-snmp
soap_DEPENDS= net/php${PHP_VER}-soap
sockets_DEPENDS=net/php${PHP_VER}-sockets
sqlite_DEPENDS= databases/php${PHP_VER}-sqlite
-sybase_DEPENDS= databases/php${PHP_VER}-sybase
sybase_ct_DEPENDS= databases/php${PHP_VER}-sybase_ct
sysvmsg_DEPENDS=devel/php${PHP_VER}-sysvmsg
sysvsem_DEPENDS=devel/php${PHP_VER}-sysvsem
diff --git a/databases/Makefile b/databases/Makefile
index b40cd22e082d..20a55e1e4368 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -215,7 +215,6 @@
SUBDIR += php4-odbc
SUBDIR += php4-oracle
SUBDIR += php4-pgsql
- SUBDIR += php4-sybase
SUBDIR += php4-sybase_ct
SUBDIR += php5-dba
SUBDIR += php5-dbase
@@ -229,7 +228,6 @@
SUBDIR += php5-oracle
SUBDIR += php5-pgsql
SUBDIR += php5-sqlite
- SUBDIR += php5-sybase
SUBDIR += php5-sybase_ct
SUBDIR += phpmyadmin
SUBDIR += phppgadmin
diff --git a/databases/php4-sybase/Makefile b/databases/php4-sybase/Makefile
deleted file mode 100644
index 4ed253b5cff3..000000000000
--- a/databases/php4-sybase/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# New ports collection makefile for: php4-sybase
-# Date created: 7 Jul 2004
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php4
-
-PKGNAMESUFFIX= -sybase
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php5-sybase/Makefile b/databases/php5-sybase/Makefile
deleted file mode 100644
index 5392bb67a48f..000000000000
--- a/databases/php5-sybase/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# New ports collection makefile for: php5-sybase
-# Date created: 7 Jul 2004
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php5
-
-PKGNAMESUFFIX= -sybase
-
-.include "${MASTERDIR}/Makefile"
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index 75c9b62f0c43..8d3b1ed040f3 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -72,8 +72,7 @@ OPTIONS= BCMATH "bc style precision math functions" off \
SHMOP "shmop support" off \
SNMP "SNMP support" off \
SOCKETS "sockets support" off \
- SYBASE "Sybase database support (DB-lib)" off \
- SYBASE_CT "Sybase database support (CT-lib)" off \
+ SYBASE_CT "Sybase database support" off \
SYSVMSG "System V message support" off \
SYSVSEM "System V semaphore support" off \
SYSVSHM "System V shared memory support" off \
@@ -101,7 +100,7 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CRACK CTYPE CURL DBA DBASE DBX DIO \
MCVE MHASH MIME_MAGIC MING MNOGOSEARCH MSSQL MYSQL NCURSES \
ODBC OPENSSL ORACLE OVERLOAD PANDA PCNTL PCRE PDF PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SNMP SOCKETS \
- SYBASE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM TOKENIZER \
+ SYBASE_CT SYSVMSG SYSVSEM SYSVSHM TOKENIZER \
WDDX XML XMLRPC XSLT YAZ YP ZIP ZLIB
SEL_OPTIONS= yes
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index f2a44a29a45b..ee4425901830 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -306,12 +306,6 @@ OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
CONFIGURE_ARGS+=--enable-sockets
.endif
-.if ${PHP_MODNAME} == "sybase"
-LIB_DEPENDS+= sybdb.4:${PORTSDIR}/databases/freetds
-
-CONFIGURE_ARGS+=--with-sybase=${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "sybase_ct"
LIB_DEPENDS+= ct.2:${PORTSDIR}/databases/freetds
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 4b8f2b9c104c..a95de04a8a3f 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -73,8 +73,7 @@ OPTIONS= BCMATH "bc style precision math functions" off \
SOAP "SOAP support" off \
SOCKETS "sockets support" off \
SQLITE "sqlite support" on \
- SYBASE "Sybase database support (DB-lib)" off \
- SYBASE_CT "Sybase database support (CT-lib)" off \
+ SYBASE_CT "Sybase database support" off \
SYSVMSG "System V message support" off \
SYSVSEM "System V semaphore support" off \
SYSVSHM "System V shared memory support" off \
@@ -103,7 +102,7 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE DBX DIO \
MCVE MHASH MIME_MAGIC MING MNOGOSEARCH MSSQL MYSQL MYSQLI \
NCURSES ODBC OPENSSL ORACLE PANDA PCNTL PCRE PDF PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
- SOCKETS SQLITE SYBASE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
+ SOCKETS SQLITE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
TIDY TOKENIZER WDDX XML XMLRPC XSL YAZ YP ZIP ZLIB
SEL_OPTIONS= yes
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 313db804cc85..fe3dde6eb774 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -322,12 +322,6 @@ PHP_HEADER_DIRS=libsqlite/src
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
-.if ${PHP_MODNAME} == "sybase"
-LIB_DEPENDS+= sybdb.4:${PORTSDIR}/databases/freetds
-
-CONFIGURE_ARGS+=--with-sybase=${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "sybase_ct"
LIB_DEPENDS+= ct.2:${PORTSDIR}/databases/freetds
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 313db804cc85..fe3dde6eb774 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -322,12 +322,6 @@ PHP_HEADER_DIRS=libsqlite/src
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
-.if ${PHP_MODNAME} == "sybase"
-LIB_DEPENDS+= sybdb.4:${PORTSDIR}/databases/freetds
-
-CONFIGURE_ARGS+=--with-sybase=${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "sybase_ct"
LIB_DEPENDS+= ct.2:${PORTSDIR}/databases/freetds