aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
pcsc-lite:
- Upgrade to 1.2.9.b.7 - Use libtool15 - make hier(7)-compliant by moving the pcsc/drivers to lib/pcsc/drivers - Compile with USB support per default. Use WITHOUT_USB to disable usb support - Chase libusb shared library version (Forgotten by leeym) Based on: PR 76068 Reviewed by: maintainer, sem (earlier patch) ifd-devkit: - Chase pcsclite sharedlibrary version ifd-gempc410: - Unbreak by updating to 0.9.3 - Move library to lib/pcsc/drivers - Chase pcsclite sharedlibrary version NOTE: This was not tested, I don't own the specific hardware ifd-gpr400: - Chase pcsclite sharedlibrary version - Fix build with new pcsc-lite - Chase new pcsclite drivers location ifd-slb_rf60: - Chase pcsclite sharedlibrary version ifd-test: - Chase pcsclite sharedlibrary version - Fix build with new pcsclite libchipcard: - Update to 0.9.1[1] - Chase pcsclite shared library version - Fix build with new pcsclite [1]PR: 78815 [1]Submitted by: lofi opensc: - Chase pcsclite shared library version - Fix build on CURRENT opensc-esteid - Chase pcsclite shared library version - Fix build with new pcsclite p5-PCSC-Card: - Update to 1.4.2 - Chase pcsclite shared library version - Fix build with new pcsclite ruby-pcsc-lite - Mark broken, does not compile with new pcsc-lite Maintainer will work on new version Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=133752
-rw-r--r--devel/ifd-test/Makefile11
-rw-r--r--devel/ifd-test/files/patch-Makefile14
-rw-r--r--devel/libchipcard/Makefile13
-rw-r--r--devel/libchipcard/distinfo4
-rw-r--r--devel/libchipcard/files/patch-hbcicard.cpp13
-rw-r--r--devel/libchipcard/pkg-message17
-rw-r--r--devel/libchipcard/pkg-plist19
-rw-r--r--devel/p5-PCSC-Card/Makefile11
-rw-r--r--devel/p5-PCSC-Card/distinfo4
-rw-r--r--devel/p5-PCSC-Card/files/patch-Makefile.PL11
-rw-r--r--devel/pcsc-lite/Makefile41
-rw-r--r--devel/pcsc-lite/distinfo4
-rw-r--r--devel/pcsc-lite/files/patch-doc::Makefile.in12
-rw-r--r--devel/pcsc-lite/files/patch-etc::Makefile.in12
-rw-r--r--devel/pcsc-lite/files/pkg-message.in4
-rw-r--r--devel/pcsc-lite/pkg-plist51
-rw-r--r--devel/ruby-pcsc-lite/Makefile4
-rw-r--r--security/ifd-devkit/Makefile3
-rw-r--r--security/ifd-gempc410/Makefile12
-rw-r--r--security/ifd-gempc410/distinfo4
-rw-r--r--security/ifd-gempc410/files/patch-GemPC410::gbpserial.c11
-rw-r--r--security/ifd-gempc410/pkg-plist7
-rw-r--r--security/ifd-gpr400/Makefile2
-rw-r--r--security/ifd-gpr400/files/patch-Makefile60
-rw-r--r--security/ifd-gpr400/files/patch-gpr400_ifd.c21
-rw-r--r--security/ifd-slb_rf60/Makefile3
-rw-r--r--security/opensc-esteid/Makefile9
-rw-r--r--security/opensc/Makefile11
28 files changed, 196 insertions, 192 deletions
diff --git a/devel/ifd-test/Makefile b/devel/ifd-test/Makefile
index c22bedd6ea34..a36e7b7c8771 100644
--- a/devel/ifd-test/Makefile
+++ b/devel/ifd-test/Makefile
@@ -7,19 +7,26 @@
PORTNAME= ifd-test
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel security
MASTER_SITES= http://www.linuxnet.com/drivers/readers/files/
MAINTAINER= bms@FreeBSD.org
COMMENT= IFD Test Suite for PC/SC Lite
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
+USE_REINPLACE= yes
NOMAN=
PLIST_FILES= sbin/ifdtest
+MAKE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="-L${PREFIX}/lib -lpcsclite ${PTHREAD_LIBS}"
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,LPSTR,LPTSTR,g; s,LPCSTR,LPCTSTR,g" \
+ ${WRKSRC}/commands.h ${WRKSRC}/ifdtest.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ifdtest ${PREFIX}/sbin
diff --git a/devel/ifd-test/files/patch-Makefile b/devel/ifd-test/files/patch-Makefile
index f41753cdf30b..7ad608fa8869 100644
--- a/devel/ifd-test/files/patch-Makefile
+++ b/devel/ifd-test/files/patch-Makefile
@@ -1,18 +1,14 @@
---- Makefile.orig Wed Aug 28 14:26:32 2002
-+++ Makefile Wed Aug 28 14:27:06 2002
-@@ -1,10 +1,12 @@
+--- Makefile.orig Tue Apr 17 18:49:02 2001
++++ Makefile Mon Apr 11 21:23:34 2005
+@@ -1,10 +1,7 @@
# Makefile for utilities
# David Corcoran <corcoran@linuxnet.com>
-+PREFIX?= /usr/local
-+
- CC = gcc
+-CC = gcc
-CFLAGS = -g -w
-INCLUDE = -I/usr/local/pcsc/include
-LIBS = -L/usr/local/pcsc/lib -lpcsclite
-+CFLAGS = -g -w -pthread
-+INCLUDE = -I${PREFIX}/include
-+LIBS = -L${PREFIX}/lib -lpcsclite
++INCLUDE = -I${PREFIX}/include -I${PREFIX}/include/PCSC
OBJS = testIBM.o testAMMI.o testSCHL.o testSIEMENS.o testBULL.o testGD.o commands.o testA.o testB.o
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index 3cb64698fa4b..9e5dc3d8ccdb 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -1,13 +1,12 @@
# Ports collection makefile for: LibChipCard
# Date created: 19 January 2003
-# Whom: Martin Preuss<martin@libchipcard.de>
+# Whom: Martin Preuss <martin@libchipcard.de>
#
# $FreeBSD$
#
PORTNAME= libchipcard
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= libchipcard
@@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR= libchipcard
MAINTAINER= martin@libchipcard.de
COMMENT= "A library for easy access to chipcards"
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
USE_OPENSSL= yes
@@ -30,6 +29,12 @@ MAN1= ctfstool.1 chipcardd.1 geldkarte.1 hbcicard.1 \
kvkd.1 memcard.1 libchipcard-config.1 readertest.1
MAN5= libchipcard.conf.5 chipcardc.conf.5 chipcardd.conf.5
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,LPCSTR,LPCTSTR," ${WRKSRC}/src/libchipcard/engine/reader/ctdriver_pcsc.h
+ ${REINPLACE_CMD} -e "s,libpcsclite.so.0,libpcsclite.so.1,; \
+ s,/usr/local/pcsc/include,${LOCALBASE}/include/PCSC," ${WRKSRC}/configure
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d
diff --git a/devel/libchipcard/distinfo b/devel/libchipcard/distinfo
index 8417ba70c5af..d8d4b0f87faa 100644
--- a/devel/libchipcard/distinfo
+++ b/devel/libchipcard/distinfo
@@ -1,2 +1,2 @@
-MD5 (libchipcard-0.8.tar.gz) = 9684596e6f760eb19f2906cff74d0a1e
-SIZE (libchipcard-0.8.tar.gz) = 640272
+MD5 (libchipcard-0.9.1.tar.gz) = 9de5833b693a5221a046d4fe7efcc4c6
+SIZE (libchipcard-0.9.1.tar.gz) = 724733
diff --git a/devel/libchipcard/files/patch-hbcicard.cpp b/devel/libchipcard/files/patch-hbcicard.cpp
index 954c79e93fdc..e69de29bb2d1 100644
--- a/devel/libchipcard/files/patch-hbcicard.cpp
+++ b/devel/libchipcard/files/patch-hbcicard.cpp
@@ -1,13 +0,0 @@
---- src/libchipcard/cards/hbcicard.cpp.orig Mon Dec 29 10:58:25 2003
-+++ src/libchipcard/cards/hbcicard.cpp Mon Dec 29 10:59:41 2003
-@@ -401,8 +401,8 @@
- string id;
- string fcp;
- CTError err;
-- unsigned char id1[9]={{0xd2},{0x76},{0x00},{0x00},{0x25},{0x48},{0x42},{0x01},{0x00}};
-- unsigned char id2[9]={{0xd2},{0x76},{0x00},{0x00},{0x25},{0x48},{0x42},{0x02},{0x00}};
-+ unsigned char id1[9]={0xd2,0x76,0x00,0x00,0x25,0x48,0x42,0x01,0x00};
-+ unsigned char id2[9]={0xd2,0x76,0x00,0x00,0x25,0x48,0x42,0x02,0x00};
-
- #if DEBUGMODE>15
- fprintf(stderr,"LIBCHIPCARD: Checking type.\n");
diff --git a/devel/libchipcard/pkg-message b/devel/libchipcard/pkg-message
index a857a0b9da99..008c5fcb6e39 100644
--- a/devel/libchipcard/pkg-message
+++ b/devel/libchipcard/pkg-message
@@ -1,9 +1,8 @@
-***********************************************************************
-* *
-* You need to setup the following configurations files before using *
-* LibChipCard: *
-* - %%PREFIX%%/etc/chipcardc.conf (client configuration) *
-* - %%PREFIX%%/etc/chipcardd.conf (daemon configuration) *
-* I have installed example files (filenames above+".example"). *
-* *
-***********************************************************************
+*******************************************************************************
+* *
+* Example configurations have been installed to: *
+* *
+* %%PREFIX%%/share/libchipcard/examples/chipcardc.conf (client configuration) *
+* %%PREFIX%%/share/libchipcard/examples/chipcardd.conf (daemon configuration) *
+* *
+*******************************************************************************
diff --git a/devel/libchipcard/pkg-plist b/devel/libchipcard/pkg-plist
index 93d0de707fa6..7032f8c5a491 100644
--- a/devel/libchipcard/pkg-plist
+++ b/devel/libchipcard/pkg-plist
@@ -5,8 +5,6 @@ bin/hbcicard
bin/libchipcard-config
bin/memcard
bin/readertest
-etc/chipcardc.conf.example
-etc/chipcardd.conf.example
etc/rc.d/chipcardd.sh
include/chameleon/chameleon.h
include/chameleon/conf.h
@@ -22,21 +20,26 @@ include/chameleon/ipcservicelayer.h
include/chameleon/ipctransportlayer.h
include/chameleon/libloader.h
include/chameleon/logger.h
+include/chipcard.h
include/chipcard/ctcard.h
+include/chipcard/ctcardbase.h
+include/chipcard/ctcardtrader.h
include/chipcard/ctcommand.h
include/chipcard/ctcore_public.h
include/chipcard/ctdatacache.h
include/chipcard/cterror.h
include/chipcard/ctfilesystem2.h
include/chipcard/ctgeldkarte.h
+include/chipcard/ctinitializer.h
include/chipcard/ctkvkcard.h
include/chipcard/ctmemorycard.h
include/chipcard/ctmisc.h
include/chipcard/ctpointer.h
include/chipcard/ctprocessorcard.h
+include/chipcard/ctreadercontext.h
+include/chipcard/ctreadertrader.h
include/chipcard/cttlv.h
include/chipcard/ctversion.h
-include/chipcard.h
include/chipcard/hbcicard.h
include/chipcard/libchipcard.h
include/chipcard/rsacard.h
@@ -44,7 +47,7 @@ include/ctversion.h
lib/libchipcard.a
lib/libchipcard.la
lib/libchipcard.so
-lib/libchipcard.so.17
+lib/libchipcard.so.20
sbin/chipcardd
sbin/kvkd
share/aclocal/libchipcard.m4
@@ -59,9 +62,13 @@ share/libchipcard/drivers/README
share/libchipcard/drivers/ctapi-fake.dsc
share/libchipcard/drivers/cyberjack.dsc
share/libchipcard/drivers/kobil.dsc
+share/libchipcard/drivers/orga.dsc
share/libchipcard/drivers/towitoko.dsc
-@dirrm include/chameleon
-@dirrm include/chipcard
+share/libchipcard/examples/chipcardc.conf
+share/libchipcard/examples/chipcardd.conf
+@dirrm share/libchipcard/examples
@dirrm share/libchipcard/drivers
@dirrm share/libchipcard/commands
@dirrm share/libchipcard
+@dirrm include/chipcard
+@dirrm include/chameleon
diff --git a/devel/p5-PCSC-Card/Makefile b/devel/p5-PCSC-Card/Makefile
index c6faa1d2b48a..796f63eb04d2 100644
--- a/devel/p5-PCSC-Card/Makefile
+++ b/devel/p5-PCSC-Card/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PCSC-Card
-PORTVERSION= 1.2.2
+PORTVERSION= 1.4.2
CATEGORIES= devel perl5
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-perl/
PKGNAMEPREFIX= p5-
@@ -15,7 +15,9 @@ DISTNAME= pcsc-perl-${PORTVERSION}
MAINTAINER= bms@FreeBSD.org
COMMENT= Perl bindings for the PC/SC Lite Framework
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -30,4 +32,9 @@ MAKE_ENV= "LOCALBASE=$(LOCALBASE)"
MAN3= Chipcard::PCSC::Card.3 Chipcard::PCSC.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-patch:
+ ${REINPLACE_CMD} -e "s,-I/usr/local/pcsc/include,${LOCALBASE}/include/PCSC," \
+ ${WRKSRC}/Makefile.PL
+
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-PCSC-Card/distinfo b/devel/p5-PCSC-Card/distinfo
index f1fc7c16f31f..528ddd0e25fc 100644
--- a/devel/p5-PCSC-Card/distinfo
+++ b/devel/p5-PCSC-Card/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcsc-perl-1.2.2.tar.gz) = ec590bd7c14f265eaaac5d209b89c3b5
-SIZE (pcsc-perl-1.2.2.tar.gz) = 38616
+MD5 (pcsc-perl-1.4.2.tar.gz) = 76f55845a4601605be9ee7d57254c32d
+SIZE (pcsc-perl-1.4.2.tar.gz) = 41532
diff --git a/devel/p5-PCSC-Card/files/patch-Makefile.PL b/devel/p5-PCSC-Card/files/patch-Makefile.PL
deleted file mode 100644
index 17738c5fa518..000000000000
--- a/devel/p5-PCSC-Card/files/patch-Makefile.PL
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.PL.orig Tue May 27 20:31:10 2003
-+++ Makefile.PL Mon Sep 29 03:09:07 2003
-@@ -6,7 +6,7 @@
- 'VERSION_FROM' => 'PCSC.pm', # finds $VERSION
- 'LIBS' => [''], # e.g., '-lm'
- 'DEFINE' => '-O2 -Wall', # e.g., '-DHAVE_SOMETHING'
-- 'INC' => '-I/usr/local/pcsc/include', # e.g., '-I/usr/include/other'
-+ 'INC' => '-I$(LOCALBASE)/include', # e.g., '-I/usr/include/other'
- 'PL_FILES' => {},
- );
-
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index 6c7bb612001c..b691a0f84ce6 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= pcsc-lite
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.9.b.7
PORTEPOCH= 2
CATEGORIES= devel security
-MASTER_SITES= http://alioth.debian.org/download.php/419/
+MASTER_SITES= http://alioth.debian.org/download.php/975/
+DISTNAME= pcsc-lite-${PORTVERSION:S/.b./-beta/}
MAINTAINER= toni@soth.at
COMMENT= A smartcard development library
@@ -17,8 +18,9 @@ COMMENT= A smartcard development library
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
-USE_INC_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 15
+WRKSRC= ${WRKDIR}/pcsc-lite-1.2.9-beta7
INSTALLS_SHLIB= yes
CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--prefix=${PREFIX} \
@@ -27,39 +29,50 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
--enable-runpid=/var/run/pcscd.pid \
--enable-ipcdir=/var/tmp/ \
--enable-confdir=${PREFIX}/etc/ \
- --enable-usbdropdir=${PREFIX}/pcsc/drivers/ \
- --enable-muscledropdir=${PREFIX}/pcsc/services/ \
+ --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers/ \
+ --enable-muscledropdir=${PREFIX}/lib/pcsc/services/ \
--enable-threadsafe
+USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
+
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= formaticc.1
-MAN8= bundleTool.8 pcscd.8
+MAN5= reader.conf.5
+MAN8= pcscd.8
-.if defined(WITH_USB)
-LIB_DEPENDS+= usb-0.1.7:${PORTSDIR}/devel/libusb
+.if !defined(WITHOUT_USB)
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
CONFIGURE_ARGS+=--enable-libusb=${PREFIX}
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,^datadir,#datadir,; s,^data_DATA,#data_DATA," ${WRKSRC}/doc/Makefile.in
+ ${REINPLACE_CMD} -e "s,^confdir,#sysconfdir,; s,^conf_DATA,#sysconf_DATA,; s,^EXTRA_DIST,#EXTRA_DIST," ${WRKSRC}/etc/Makefile.in
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "pcsc-lite has the following option(s):"
- @${ECHO_MSG} " WITH_USB=yes Enable USB support"
+ @${ECHO_MSG} " WITHOUT_USB=yes Disable USB support"
@${ECHO_MSG}
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/README.DAEMON ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/pcsc-lite-0.8.7.pdf ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/muscle-api-1.3.0.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/pcsc-lite.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/ifdhandler-3.pdf ${DOCSDIR}
.endif
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.am ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.in ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/example/pcsc_demo.c ${EXAMPLESDIR}
- @${MKDIR} ${PREFIX}/pcsc/drivers
- @${MKDIR} ${PREFIX}/pcsc/services
+ @${MKDIR} ${PREFIX}/lib/pcsc/drivers
+ @${MKDIR} ${PREFIX}/lib/pcsc/services
+ ${TOUCH} ${PREFIX}/lib/pcsc/drivers/.keep_me
+ ${TOUCH} ${PREFIX}/lib/pcsc/services/.keep_me
+ ${MKDIR} ${PREFIX}/etc/reader.conf.d
${INSTALL_DATA} ${WRKSRC}/etc/reader.conf \
- ${PREFIX}/etc/reader.conf.sample
+ ${PREFIX}/etc/reader.conf.d/reader.conf.sample
${INSTALL_SCRIPT} ${FILESDIR}/pcscd.sh \
${PREFIX}/etc/rc.d/pcscd.sh.sample
@${SED} 's,%%PREFIX%%,${PREFIX},g' < ${FILESDIR}/pkg-message.in > \
diff --git a/devel/pcsc-lite/distinfo b/devel/pcsc-lite/distinfo
index 7da46d33c5bf..c97ed7d34576 100644
--- a/devel/pcsc-lite/distinfo
+++ b/devel/pcsc-lite/distinfo
@@ -1,2 +1,2 @@
-MD5 (pcsc-lite-1.2.0.tar.gz) = 98456d274b2f4bfe74c5ab59070f8d50
-SIZE (pcsc-lite-1.2.0.tar.gz) = 790384
+MD5 (pcsc-lite-1.2.9-beta7.tar.gz) = 6457f8070e8950e66952000142b1b3bf
+SIZE (pcsc-lite-1.2.9-beta7.tar.gz) = 771887
diff --git a/devel/pcsc-lite/files/patch-doc::Makefile.in b/devel/pcsc-lite/files/patch-doc::Makefile.in
deleted file mode 100644
index da1c6720c0cd..000000000000
--- a/devel/pcsc-lite/files/patch-doc::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- doc/Makefile.in.bak Mon Mar 17 03:44:22 2003
-+++ doc/Makefile.in Mon Mar 17 03:44:42 2003
-@@ -69,3 +69,3 @@
-
--datadir = $(prefix)/doc
-+#datadir = $(prefix)/doc
- AMTAR = @AMTAR@
-@@ -98,3 +98,3 @@
- install_sh = @install_sh@
--data_DATA = pcsc-lite-0.8.7.pdf muscle-api-1.3.0.pdf README.DAEMON
-+#data_DATA = pcsc-lite-0.8.7.pdf muscle-api-1.3.0.pdf README.DAEMON
- man_MANS = pcscd.8 bundleTool.8 formaticc.1
diff --git a/devel/pcsc-lite/files/patch-etc::Makefile.in b/devel/pcsc-lite/files/patch-etc::Makefile.in
deleted file mode 100644
index 6cd5a8ea39df..000000000000
--- a/devel/pcsc-lite/files/patch-etc::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- etc/Makefile.in.bak Mon Mar 17 03:13:17 2003
-+++ etc/Makefile.in Mon Mar 17 03:14:27 2003
-@@ -27,3 +27,3 @@
- datadir = @datadir@
--sysconfdir = @sysconfdir@
-+#sysconfdir = @sysconfdir@
- sharedstatedir = @sharedstatedir@
-@@ -96,3 +96,3 @@
-
--sysconf_DATA = reader.conf
-+#sysconf_DATA = reader.conf
-
diff --git a/devel/pcsc-lite/files/pkg-message.in b/devel/pcsc-lite/files/pkg-message.in
index a23e29abf5fa..bdef6edf7383 100644
--- a/devel/pcsc-lite/files/pkg-message.in
+++ b/devel/pcsc-lite/files/pkg-message.in
@@ -4,7 +4,7 @@ PC/SC-Lite has been installed.
You can fetch drivers from http://www.linuxnet.com/sourcedrivers.html
After installing the driver, please update the pcscd configuration file
-%%PREFIX%%/etc/reader.conf by using the default
-%%PREFIX%%/etc/reader.conf.sample
+%%PREFIX%%/etc/reader.conf.d/reader.conf by using the default
+%%PREFIX%%/etc/reader.conf.d/reader.conf.sample
------------------------------------------------------------------------
diff --git a/devel/pcsc-lite/pkg-plist b/devel/pcsc-lite/pkg-plist
index 6854e2061754..33c0781a8e3f 100644
--- a/devel/pcsc-lite/pkg-plist
+++ b/devel/pcsc-lite/pkg-plist
@@ -1,33 +1,34 @@
-bin/bundleTool
bin/formaticc
-bin/installifd
-bin/pcsc_demo
-%%PORTDOCS%%%%DOCSDIR%%/README.DAEMON
-%%PORTDOCS%%%%DOCSDIR%%/pcsc-lite-0.8.7.pdf
-%%PORTDOCS%%%%DOCSDIR%%/muscle-api-1.3.0.pdf
-%%EXAMPLESDIR%%/Makefile.am
-%%EXAMPLESDIR%%/Makefile.in
-%%EXAMPLESDIR%%/pcsc_demo.c
etc/rc.d/pcscd.sh.sample
-etc/reader.conf.sample
-include/debuglog.h
-include/mscdefines.h
-include/musclecard.h
-include/pcsclite.h
-include/winscard.h
-include/wintypes.h
+etc/reader.conf.d/reader.conf.sample
+include/PCSC/debuglog.h
+include/PCSC/dyn_generic.h
+include/PCSC/ifdhandler.h
+include/PCSC/parser.h
+include/PCSC/pcsclite.h
+include/PCSC/sys_generic.h
+include/PCSC/thread_generic.h
+include/PCSC/winscard.h
+include/PCSC/wintypes.h
lib/libpcsclite.a
lib/libpcsclite.so
-lib/libpcsclite.so.0
-lib/libmusclecard.a
-lib/libmusclecard.so
-lib/libmusclecard.so.0
+lib/libpcsclite.so.1
+lib/pcsc/drivers/.keep_me
+lib/pcsc/services/.keep_me
libdata/pkgconfig/libpcsclite.pc
-libdata/pkgconfig/libmusclecard.pc
+sbin/installifd
sbin/pcscd
+sbin/update-reader.conf
+%%PORTDOCS%%%%DOCSDIR%%/README.DAEMON
+%%PORTDOCS%%%%DOCSDIR%%/pcsc-lite.pdf
+%%PORTDOCS%%%%DOCSDIR%%/ifdhandler-3.pdf
+%%EXAMPLESDIR%%/Makefile.am
+%%EXAMPLESDIR%%/Makefile.in
+%%EXAMPLESDIR%%/pcsc_demo.c
+@dirrm etc/reader.conf.d
+@dirrm include/PCSC
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
-@dirrm libdata/pkgconfig
-@dirrm pcsc/drivers
-@dirrm pcsc/services
-@dirrm pcsc
+@dirrm lib/pcsc/drivers
+@dirrm lib/pcsc/services
+@dirrm lib/pcsc
diff --git a/devel/ruby-pcsc-lite/Makefile b/devel/ruby-pcsc-lite/Makefile
index e5705fb41f9b..398479b50510 100644
--- a/devel/ruby-pcsc-lite/Makefile
+++ b/devel/ruby-pcsc-lite/Makefile
@@ -17,7 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= toni@soth.at
COMMENT= Ruby extension for the UNIX PC/SC Lite API (MUSCLE)
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+
+BROKEN= "Does not compile with new pcsc-lite. Port will be updated soon."
USE_RUBY= yes
RUBY_VER= 1.8
diff --git a/security/ifd-devkit/Makefile b/security/ifd-devkit/Makefile
index 3dd96c6ef6c3..f3dad41219eb 100644
--- a/security/ifd-devkit/Makefile
+++ b/security/ifd-devkit/Makefile
@@ -7,13 +7,14 @@
PORTNAME= ifd-devkit
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.linuxnet.com/drivers/readers/files/
MAINTAINER= bms@FreeBSD.org
COMMENT= IFD Handler Developer's Kit for MUSCLE PC/SC Lite
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
INSTALLS_SHLIB= yes
diff --git a/security/ifd-gempc410/Makefile b/security/ifd-gempc410/Makefile
index ef59cc040603..964d8326178c 100644
--- a/security/ifd-gempc410/Makefile
+++ b/security/ifd-gempc410/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ifd-gempc410
-PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= security
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/
DISTNAME= ifd-gempc-${PORTVERSION}
@@ -16,9 +15,7 @@ MAINTAINER= des@freebsd.org
COMMENT= PC/SC Lite driver for the GemPC 410 serial smart card reader
BUILD_DEPENDS= ${LOCALBASE}/include/ifdhandler.h:${PORTSDIR}/security/ifd-devkit
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
-
-BROKEN= "Does not fetch"
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -38,6 +35,11 @@ post-configure:
${SED} -e 's|%%PREFIX%%|${PREFIX}|g' <${FILESDIR}/message >${PKGMESSAGE}
${TOUCH} ${WRKSRC}/GemPC410/dep_stamp ${WRKSRC}/common/dep_stamp
+do-install:
+ ${MKDIR} ${PREFIX}/lib/pcsc/drivers/serial
+ ${INSTALL_DATA} ${WRKSRC}/GemPC410/libGemPC410.so* \
+ ${PREFIX}/lib/pcsc/drivers/serial
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/security/ifd-gempc410/distinfo b/security/ifd-gempc410/distinfo
index 4b68e086004a..d377f1c7021c 100644
--- a/security/ifd-gempc410/distinfo
+++ b/security/ifd-gempc410/distinfo
@@ -1,2 +1,2 @@
-MD5 (ifd-gempc-0.8.2.tar.gz) = 4d8789efb4dfab288bd1be5e82c7da42
-SIZE (ifd-gempc-0.8.2.tar.gz) = 301986
+MD5 (ifd-gempc-0.9.3.tar.gz) = 4ec32085972f365b1a115e653b04bcf6
+SIZE (ifd-gempc-0.9.3.tar.gz) = 301817
diff --git a/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c b/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c
deleted file mode 100644
index 7e90bd73b5b2..000000000000
--- a/security/ifd-gempc410/files/patch-GemPC410::gbpserial.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- GemPC410/gbpserial.c.orig Tue May 13 16:49:38 2003
-+++ GemPC410/gbpserial.c Tue May 13 16:53:04 2003
-@@ -410,7 +410,7 @@
- return STATUS_UNSUCCESSFUL;
- }
-
-- sprintf(dev_name, "/dev/pcsc/%d", (int) channel);
-+ sprintf(dev_name, "/dev/cuaa%d", (int) channel);
-
- /* check if the same channel is not already used */
- for (i=0; i<PCSCLITE_MAX_CHANNELS; i++)
diff --git a/security/ifd-gempc410/pkg-plist b/security/ifd-gempc410/pkg-plist
index 6a3448fb96c6..882423e2d78d 100644
--- a/security/ifd-gempc410/pkg-plist
+++ b/security/ifd-gempc410/pkg-plist
@@ -1,3 +1,4 @@
-lib/libGemPC410.so
-lib/libGemPC410.so.0
-lib/libGemPC410.so.0.8.2
+lib/pcsc/drivers/serial/libGemPC410.so
+lib/pcsc/drivers/serial/libGemPC410.so.0
+lib/pcsc/drivers/serial/libGemPC410.so.0.9.3
+@dirrm lib/pcsc/drivers/serial
diff --git a/security/ifd-gpr400/Makefile b/security/ifd-gpr400/Makefile
index c130e86d696f..a3268b384adc 100644
--- a/security/ifd-gpr400/Makefile
+++ b/security/ifd-gpr400/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= bms@FreeBSD.org
COMMENT= PC/SC Lite driver for Gemplus GPR400 PCMCIA Smart Card Readers
BUILD_DEPENDS= ${LOCALBASE}/include/ifdhandler.h:${PORTSDIR}/security/ifd-devkit
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
MAKE_ENV+= DESTDIR="${PREFIX}"
diff --git a/security/ifd-gpr400/files/patch-Makefile b/security/ifd-gpr400/files/patch-Makefile
index 08bead01bc8f..2fe1fd689fe1 100644
--- a/security/ifd-gpr400/files/patch-Makefile
+++ b/security/ifd-gpr400/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Aug 9 06:14:42 2001
-+++ Makefile Sun Sep 8 18:11:11 2002
-@@ -1,36 +1,41 @@
+--- Makefile.orig Thu Aug 9 07:14:42 2001
++++ Makefile Mon Apr 11 21:07:03 2005
+@@ -1,36 +1,39 @@
-# GPR400 IFD Handler Makefile
-#
-# Author: Joe Phillips <joe.phillips@innovationsw.com>
@@ -16,32 +16,43 @@
-LEX = flex
-OBJ := $(filter-out test.o, $(patsubst %.c,%.o,$(wildcard *.c)))
-INCLUDE = -I.
-+#XXX
-+PREFIX?= /usr/local
+DESTDIR?= ${PREFIX}
-+
+
+-MAKEXE = make
+-LIBNAME = libgpr400_ifd.so
+-PREFIX = /usr/local/pcsc
+# XXX
+LIBDIR= /lib
+#LIBDIR= /pcsc
+INCSDIR= /include
-+
+
+-DEFS = -DPCSC_DEBUG=1 #-DATR_DEBUG=1
+SHLIB_NAME= libgpr400_ifd.so
+SHLIB_MAJOR= 0
+SHLIB_MINOR= 3
-+
+
+-all: unix
+NOMAN= 1
+NOPROFILE= 1
-+
+
+-clean:
+- rm -f *.o $(LIBNAME) core
+.if !defined(NO_DEBUG)
+CFLAGS+= -g -Wall
+.endif
-+
+
+-osx: $(OBJ)
+- $(CC) -dynamiclib $(OBJ) -o $(LIBNAME)
+GPRDEVNAME?= /dev/gprsc0
-+
-+CFLAGS+= -I. -I${DESTDIR}${INCSDIR} -DGPRDEVNAME=\"${GPRDEVNAME}\"
+
+-unix: $(OBJ)
+- $(LD) -shared $(OBJ) -o $(LIBNAME)
++CFLAGS+= -I. -I${DESTDIR}${INCSDIR}/PCSC -I${DESTDIR}${INCSDIR} -DGPRDEVNAME=\"${GPRDEVNAME}\"
+LDFLAGS+= -L${DESTDIR}/lib
+LDADD+= -lpcsclite
-+
+
+-$(patsubst %.c,%.o,$(wildcard *.c)) : %.o : %.c
+- $(CC) $(CFLAGS) -c $< $(INCLUDE) $(DEFS)
+.if !defined(NO_PCSC_DEBUG)
+CFLAGS+= -DPCSC_DEBUG=1
+.if defined(PCSC_ATR_DEBUG)
@@ -49,27 +60,8 @@
+.endif
+.endif
--MAKEXE = make
--LIBNAME = libgpr400_ifd.so
--PREFIX = /usr/local/pcsc
+-##
+SRCS= gpr400_ifd.c
+INCS= gpr400.h
-
--DEFS = -DPCSC_DEBUG=1 #-DATR_DEBUG=1
--
--all: unix
--
--clean:
-- rm -f *.o $(LIBNAME) core
--
--osx: $(OBJ)
-- $(CC) -dynamiclib $(OBJ) -o $(LIBNAME)
--
--unix: $(OBJ)
-- $(LD) -shared $(OBJ) -o $(LIBNAME)
--
--$(patsubst %.c,%.o,$(wildcard *.c)) : %.o : %.c
-- $(CC) $(CFLAGS) -c $< $(INCLUDE) $(DEFS)
--
--##
++
+.include <bsd.lib.mk>
diff --git a/security/ifd-gpr400/files/patch-gpr400_ifd.c b/security/ifd-gpr400/files/patch-gpr400_ifd.c
index ff08a8b8f152..eab88a809cfc 100644
--- a/security/ifd-gpr400/files/patch-gpr400_ifd.c
+++ b/security/ifd-gpr400/files/patch-gpr400_ifd.c
@@ -1,5 +1,5 @@
---- gpr400_ifd.c.orig Wed Aug 22 03:21:43 2001
-+++ gpr400_ifd.c Sun Sep 8 18:10:47 2002
+--- gpr400_ifd.c.orig Wed Aug 22 04:21:43 2001
++++ gpr400_ifd.c Mon Apr 11 21:09:23 2005
@@ -77,7 +77,7 @@
printf("IFDHCreateChannel:\n");
#endif
@@ -9,3 +9,20 @@
if(gpr_fd < 0){
return IFD_COMMUNICATION_ERROR;
}
+@@ -597,16 +597,6 @@
+ RxLength should be zero on error.
+ *
+ **/
+-RESPONSECODE IFDHControl ( DWORD Lun, PUCHAR TxBuffer,
+- DWORD TxLength, PUCHAR RxBuffer,
+- PDWORD RxLength )
+-{
+-#ifdef PCSC_DEBUG
+- printf("IFDHControl:\n");
+-#endif
+- return IFD_NOT_SUPPORTED;
+-
+-}/* IFDHControl */
+
+ /**
+ * check if there is a smartcard in the reader
diff --git a/security/ifd-slb_rf60/Makefile b/security/ifd-slb_rf60/Makefile
index 8bc90ff510e8..f6d21fa3b084 100644
--- a/security/ifd-slb_rf60/Makefile
+++ b/security/ifd-slb_rf60/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ifd-slb_rf60
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.linuxnet.com/drivers/readers/files/
DISTNAME= ${PORTNAME:S/^ifd-//}-drv-${PORTVERSION}
@@ -14,7 +15,7 @@ DISTNAME= ${PORTNAME:S/^ifd-//}-drv-${PORTVERSION}
MAINTAINER= toni@soth.at
COMMENT= PC/SC Lite driver for the Reflex 62 serial smart card reader
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
diff --git a/security/opensc-esteid/Makefile b/security/opensc-esteid/Makefile
index a218c86ba699..b3bced8a409b 100644
--- a/security/opensc-esteid/Makefile
+++ b/security/opensc-esteid/Makefile
@@ -7,7 +7,7 @@
PORTNAME= esteid
PORTVERSION= 0.7.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security devel
MASTER_SITES= http://marie.vtl.ee/esteid/
PKGNAMEPREFIX= opensc-
@@ -16,7 +16,7 @@ DISTNAME= opensc-esteid-0.7.0-1
MAINTAINER= hadara@bsd.ee
COMMENT= ISO 7816 Smartcard API Library (OpenSSH Compatible)
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_OPENLDAP= yes
INSTALLS_SHLIB= yes
@@ -28,16 +28,21 @@ CONFIGURE_ARGS= --with-pcsclite=${LOCALBASE} \
--with-ldap-lib=openldap \
--with-ldap-dir=${LOCALBASE} \
--with-plugin-dir=${LOCALBASE}/share/opensc/plugins
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/PCSC"
+USE_REINPLACE= yes
MAN1= pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1 \
cryptoflex-tool.1 \
opensc-config.1 opensc-explorer.1 opensc-tool.1
MAN5= pkcs15-profile.5
MAN7= pkcs15.7 opensc.7
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
BROKEN= "Does not compile on amd64 (missing -fPIC)"
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s,LPCSTR,LPCTSTR," ${WRKSRC}/src/libopensc/reader-pcsc.c
.include <bsd.port.post.mk>
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index 5327e279d234..fd51ad1aa2c9 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opensc
PORTVERSION= 0.9.4
+PORTREVSION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.opensc.org/files/
@@ -19,6 +20,7 @@ USE_OPENSSL= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
MANCOMPRESSED= no
MAN1= pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1 opensc-tool.1 \
@@ -47,7 +49,7 @@ CONFIGURE_ARGS+= --with-pam
.endif
.if !defined(WITHOUT_PCSC_LITE)
-LIB_DEPENDS+= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
CONFIGURE_ARGS+= --with-pcsclite=${LOCALBASE}
.endif
@@ -84,4 +86,9 @@ CONFIGURE_ARGS+= --without-docbook
CONFIGURE_ARGS+= --with-openct=${LOCALBASE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,ulong,u_long," ${WRKSRC}/src/openscd/openscd.c
+
+.include <bsd.port.post.mk>