aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-18 20:21:53 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-18 20:21:53 +0000
commit3b64ffeba3280ff8a220ae36696876ccc297897f (patch)
tree99e266cd9b7aaf695b1ed438bbf7caf5462291da
parentc4ff8f3272e7e12d4eba66ed97680e48dfaf3f5a (diff)
downloadports-3b64ffeba3280ff8a220ae36696876ccc297897f.tar.gz
ports-3b64ffeba3280ff8a220ae36696876ccc297897f.zip
- split out -server part from ioquake3-based ports:
- games/ioquake3-devel-server added - games/ioquake3-server added - games/iourbanterror-server - games/openarena-server added - update games/ioquake3-devel to svn revision 2244 - update games/openarena to 0.8.8 - update games/openarena-data to 0.8.8 Doing this in single commit since all this ports are tightly interconnected. PR: ports/165842 Submitted by: Dominic Fandrey <kamikaze at bsdforen dot de> (maintainer)
Notes
Notes: svn path=/head/; revision=296922
-rw-r--r--games/Makefile4
-rw-r--r--games/ioquake3-devel-server/Makefile17
-rw-r--r--games/ioquake3-devel/Makefile9
-rw-r--r--games/ioquake3-devel/distinfo4
-rw-r--r--games/ioquake3-server/Makefile17
-rw-r--r--games/ioquake3/Makefile63
-rw-r--r--games/ioquake3/files/patch-code-client-cl_curl.h12
-rw-r--r--games/ioquake3/pkg-descr2
-rw-r--r--games/ioquake3/pkg-plist8
-rw-r--r--games/iourbanterror-server/Makefile17
-rw-r--r--games/iourbanterror/Makefile18
-rw-r--r--games/iourbanterror/distinfo2
-rw-r--r--games/iourbanterror/pkg-descr2
-rw-r--r--games/openarena-data/Makefile32
-rw-r--r--games/openarena-data/distinfo6
-rw-r--r--games/openarena-data/pkg-plist1
-rw-r--r--games/openarena-oax/Makefile8
-rw-r--r--games/openarena-server/Makefile17
-rw-r--r--games/openarena/Makefile27
-rw-r--r--games/openarena/Makefile.include6
-rw-r--r--games/openarena/distinfo4
-rw-r--r--games/openarena/files/patch-Makefile8
-rw-r--r--games/openarena/files/patch-feature-DEFAULT_LIBDIR20
-rw-r--r--games/openarena/pkg-descr2
-rw-r--r--games/urbanterror-data/Makefile28
-rw-r--r--games/urbanterror-data/pkg-descr2
26 files changed, 214 insertions, 122 deletions
diff --git a/games/Makefile b/games/Makefile
index fc1b78e551c4..e3f50e864511 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -391,7 +391,10 @@
SUBDIR += interlogic
SUBDIR += ioquake3
SUBDIR += ioquake3-devel
+ SUBDIR += ioquake3-devel-server
+ SUBDIR += ioquake3-server
SUBDIR += iourbanterror
+ SUBDIR += iourbanterror-server
SUBDIR += irrlamb
SUBDIR += ishido
SUBDIR += ivan
@@ -617,6 +620,7 @@
SUBDIR += openarena
SUBDIR += openarena-data
SUBDIR += openarena-oax
+ SUBDIR += openarena-server
SUBDIR += openastromenace
SUBDIR += opencity
SUBDIR += opengfx
diff --git a/games/ioquake3-devel-server/Makefile b/games/ioquake3-devel-server/Makefile
new file mode 100644
index 000000000000..c0d22bef39d2
--- /dev/null
+++ b/games/ioquake3-devel-server/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: ioquake3-devel-server
+# Date created: 19 May 2012
+# Whom: Dominic Fandrey <kamikaze@bsdforen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ioquake3-devel
+PKGNAMESUFFIX= -server
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= Ioquake3 development snapshot dedicated server
+
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+MASTERDIR= ${.CURDIR}/../${PORTNAME}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3-devel/Makefile b/games/ioquake3-devel/Makefile
index a49d50a2212b..cf1b93e8e349 100644
--- a/games/ioquake3-devel/Makefile
+++ b/games/ioquake3-devel/Makefile
@@ -14,12 +14,15 @@ MASTER_SITES?= ftp://deponie.yamagi.org/freebsd/distfiles/ioquake3/ \
MAINTAINER?= kamikaze@bsdforen.de
COMMENT?= Development SVN snapshots of ioquake3
-PLIST?= ${.CURDIR}/../ioquake3/pkg-plist
+MASTERDIR= ${.CURDIR}/../ioquake3
+DESCR?= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DISTINFO_FILE?= ${.CURDIR}/../${PORTNAME}/distinfo
PATCHDIR?= ${WRKDIR}/freebsd-patchset/
+PKGMESSAGE?= ${.CURDIR}/../${PORTNAME}/pkg-message
-SVNREVISION?= 2194
+SVNREVISION?= 2244
BINSUFFIX?= -devel
HAS_DLRENDERER?= yes
-.include "${.CURDIR}/../ioquake3/Makefile"
+.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3-devel/distinfo b/games/ioquake3-devel/distinfo
index 168c2eb6d6e7..a4d2cc8f5945 100644
--- a/games/ioquake3-devel/distinfo
+++ b/games/ioquake3-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ioquake3-devel-1.36_SVN2194.zip) = 91ef10e29ebc49c4d1faa4265b573e98c3b804b71004111142ee7b55543a54ff
-SIZE (ioquake3-devel-1.36_SVN2194.zip) = 5660634
+SHA256 (ioquake3-devel-1.36_SVN2244.zip) = a7ade108c015a1aa572082900a9995371d7853d6953226ef93bdfad9e46583fb
+SIZE (ioquake3-devel-1.36_SVN2244.zip) = 5650901
diff --git a/games/ioquake3-server/Makefile b/games/ioquake3-server/Makefile
new file mode 100644
index 000000000000..06fd2dee3bc5
--- /dev/null
+++ b/games/ioquake3-server/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: ioquake3-server
+# Date created: 19 May 2012
+# Whom: Dominic Fandrey <kamikaze@bsdforen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ioquake3
+PKGNAMESUFFIX= -server
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= Ioquake3 dedicated server
+
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+MASTERDIR= ${.CURDIR}/../${PORTNAME}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 2b3720d7eadc..68fe89d4111d 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ioquake3
DISTVERSION?= 1.36
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES= games
MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
# Using zip this way enables slaves to override it.
@@ -20,25 +20,46 @@ BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
USE_GMAKE= yes
-OPTIONS+= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on \
+.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX:M*-server}
+# Server config
+WITH_DEDICATED= yes
+WITHOUT_CLIENT= yes
+WITHOUT_SERVER= yes
+WITHOUT_CURL= yes
+WITHOUT_OPENAL= yes
+WITHOUT_MUMBLE= yes
+WITHOUT_VORBIS= yes
+WITHOUT_TOOLS= yes
+WITHOUT_DLRENDERER= yes
+.else
+# Client config
+WITH_CLIENT= yes
+WITHOUT_DEDICATED= yes
+OPTIONS+= SERVER "Install dedicated server" on \
CURL "Enable cURL for http/ftp download" on \
OPENAL "Enable OpenAL audio output" on \
MUMBLE "Enable Mumble support (no dependencies)" on \
VORBIS "Enable Ogg Vorbis support" on
-.if !defined(NO_GAMELIBS)
-OPTIONS+= GAMELIBS "Build game libraries" off
-.endif
-.if defined(HAS_DLRENDERER)
+. if defined(NO_TOOLS)
+WITHOUT_TOOLS= yes
+. else
+OPTIONS+= TOOLS "Enable modding tools" on
+. endif
+. if defined(HAS_DLRENDERER)
OPTIONS+= DLRENDERER "Build dynamically loaded renderer" on
-.else
+. else
WITHOUT_DLRENDERER= yes
+. endif
+.endif
+# Common config
+.if !defined(NO_GAMELIBS)
+OPTIONS+= GAMELIBS "Build game libraries" off
.endif
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
DEFAULT_LIBDIR="${LIBDIR}" \
HOMEPATH="${HOMEPATH}" \
- VERSION="${DISTVERSION}" \
+ VERSION="${Q3ENGINEVER}" \
ARCH="${ARCH}" \
USE_LOCAL_HEADERS=0
PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
@@ -47,7 +68,8 @@ PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
ALL_TARGET= release
MAKE_JOBS_SAFE= yes
-LIBDIR= ${PREFIX}/lib/${PORTNAME}
+LIBDIR= ${PREFIX}/lib/${PORTNAME}${PKGNAMESUFFIX}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
BUILDDIR= ${WRKSRC}/build/${ALL_TARGET}-${OPSYS:L}-${ARCH}
BINSUFFIX?=
HOMEPATH?= /.${PORTNAME}
@@ -62,13 +84,10 @@ Q3BASE?= baseq3 \
Q3ICON?= ${PREFIX}/share/pixmaps/quake3.xpm
Q3RENDERER?= renderer_opengl1_${ARCH}
Q3INSTALL?=
+Q3ENGINEVER?= ${DISTVERSION}
ONLY_FOR_ARCHS= amd64 i386
-# Make sure TARGET and CFLAGS fit together for cross-compiling.
-MACHINE_ARCH= ${ARCH}
-.include <bsd.cpu.mk>
-
.include <bsd.port.options.mk>
.if defined(NO_GAMELIBS) && defined(WITH_GAMELIBS)
@@ -82,14 +101,18 @@ IGNORE= does not support WITH_DLRENDERER
ALL_TARGET= debug
.endif
+.if !defined(WITHOUT_SERVER)
+RUN_DEPENDS+= ${Q3SERVER}${BINSUFFIX}:${PORTSDIR}/games/${PORTNAME}-server
+.endif
+
.if !defined(DESKTOP_ENTRIES)
. if !defined(WITHOUT_CLIENT)
-DESKTOP_ENTRIES+= "${Q3CLIENT} ${DISTVERSION}" "${COMMENT}" \
+DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER}" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}${BINSUFFIX}" "Application;Game;" false
. endif
. if defined(WITH_SMP)
-DESKTOP_ENTRIES+= "${Q3CLIENT} ${DISTVERSION} SMP" "${COMMENT}" \
+DESKTOP_ENTRIES+= "${Q3CLIENT} ${Q3ENGINEVER} SMP" "${COMMENT}" \
"${Q3ICON}" \
"${Q3CLIENT}-smp${BINSUFFIX}" "Application;Game;" false
. endif
@@ -179,15 +202,23 @@ MAKE_ARGS+= USE_RENDERER_DLOPEN=0
PLIST_SUB+= DLRENDERER="@comment "
.endif
+.if !defined(WITHOUT_TOOLS)
+PLIST_SUB+= TOOLS=""
+.else
+PLIST_SUB+= TOOLS="@comment "
+.endif
+
do-install: ${Q3INSTALL}
.for bin in ${Q3BIN}
${INSTALL_PROGRAM} ${BUILDDIR}/${bin}.${ARCH} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
+.if !defined(WITHOUT_TOOLS)
.for bin in ${Q3TOOLS}
${INSTALL_PROGRAM} ${BUILDDIR}/tools/${bin} \
${PREFIX}/bin/${bin}${BINSUFFIX}
.endfor
+.endif
.if !defined(WITHOUT_DLRENDERER)
.for renderer in ${Q3RENDERER}
${MKDIR} ${LIBDIR}
diff --git a/games/ioquake3/files/patch-code-client-cl_curl.h b/games/ioquake3/files/patch-code-client-cl_curl.h
deleted file mode 100644
index ca97eb61347d..000000000000
--- a/games/ioquake3/files/patch-code-client-cl_curl.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- code/client/cl_curl.h.orig 2011-11-03 10:16:32.000000000 +0100
-+++ code/client/cl_curl.h 2011-11-03 10:16:56.000000000 +0100
-@@ -34,8 +34,7 @@
- #elif defined(MACOS_X)
- #define DEFAULT_CURL_LIB "libcurl.dylib"
- #else
--#define DEFAULT_CURL_LIB "libcurl.so.4"
--#define ALTERNATE_CURL_LIB "libcurl.so.3"
-+#define DEFAULT_CURL_LIB "libcurl.so"
- #endif
-
- #ifdef USE_LOCAL_HEADERS
diff --git a/games/ioquake3/pkg-descr b/games/ioquake3/pkg-descr
index d49d4c07954b..f6cbe35744e7 100644
--- a/games/ioquake3/pkg-descr
+++ b/games/ioquake3/pkg-descr
@@ -8,4 +8,4 @@ playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
the engine has been ported to many new platforms and has had a slew of new
features added, along with massive bug extermination.
-WWW: http://ioquake3.org/
+WWW: http://ioquake3.org/
diff --git a/games/ioquake3/pkg-plist b/games/ioquake3/pkg-plist
index 28ba1453d551..8be318c64485 100644
--- a/games/ioquake3/pkg-plist
+++ b/games/ioquake3/pkg-plist
@@ -1,10 +1,10 @@
%%DEDICATED%%bin/ioq3ded%%BINSUFFIX%%
%%CLIENT%%bin/ioquake3%%BINSUFFIX%%
%%SMP%%bin/ioquake3-smp%%BINSUFFIX%%
-bin/q3asm%%BINSUFFIX%%
-bin/q3cpp%%BINSUFFIX%%
-bin/q3lcc%%BINSUFFIX%%
-bin/q3rcc%%BINSUFFIX%%
+%%TOOLS%%bin/q3asm%%BINSUFFIX%%
+%%TOOLS%%bin/q3cpp%%BINSUFFIX%%
+%%TOOLS%%bin/q3lcc%%BINSUFFIX%%
+%%TOOLS%%bin/q3rcc%%BINSUFFIX%%
%%DLRENDERER%%%%LIBDIR%%/renderer_opengl1_%%ARCH%%.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/cgame%%ARCH%%.so
%%GAMELIBS%%%%LIBDIR%%/baseq3/qagame%%ARCH%%.so
diff --git a/games/iourbanterror-server/Makefile b/games/iourbanterror-server/Makefile
new file mode 100644
index 000000000000..15866a6a585a
--- /dev/null
+++ b/games/iourbanterror-server/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: iourbanterror-server
+# Date created: 19 May 2012
+# Whom: Dominic Fandrey <kamikaze@bsdforen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iourbanterror
+PKGNAMESUFFIX= -server
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= Urban Terror dedicated server
+
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+MASTERDIR= ${.CURDIR}/../${PORTNAME}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index 908fe1201026..6ef3cad06887 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -7,7 +7,6 @@
PORTNAME= iourbanterror
PORTVERSION= ${GAMEVERSION}.s${SVNREVISION}
-DISTVERSION= 1.36_SVN${SVNREVISION}+${GAMEVERSION}
PORTEPOCH= 1
CATEGORIES= games
DISTNAME= ioquake3-devel-1.36_SVN${SVNREVISION}
@@ -17,18 +16,21 @@ COMMENT= Quake 3 engine modified for Urban Terror (based on ioquake3)
RUN_DEPENDS= ${Q3DIR}/q3ut4:${PORTSDIR}/games/urbanterror-data
-PLIST= ${.CURDIR}/pkg-plist
+MASTERDIR= ${.CURDIR}/../ioquake3-devel
+DISTINFO_FILE= ${.CURDIR}/../ioquake3-devel/distinfo
+PLIST= ${.CURDIR}/../${PORTNAME}/pkg-plist
NO_GAMELIBS= yes
+NO_TOOLS= yes
# The docs belong to ioquake3
NOPORTDOCS= yes
GAMEVERSION= 4.1.1
+Q3ENGINEVER= 1.36_SVN${SVNREVISION}+${GAMEVERSION}
Q3TOTALCONV= yes
Q3DIR= ${PREFIX}/share/quake3
Q3ICON= ${PREFIX}/share/quake3/q3ut4/q3ut.ico
Q3CLIENT= ioUrbanTerror
Q3SERVER= ioUrTded
-Q3TOOLS=
Q3BASE= q3ut4
BINSUFFIX=
HOMEPATH= /.ioUrbanTerror
@@ -36,16 +38,16 @@ HOMEPATH= /.ioUrbanTerror
MAKE_ARGS+= BUILD_MISSIONPACK=0 \
BUILD_STANDALONE=1
-UTPATCHES!= echo ${.CURDIR}/files/*
+UTPATCHES= ${.CURDIR}/../${PORTNAME}/files/*
post-patch:
-.for _file in ${UTPATCHES}
- @${PATCH} -sd "${WRKSRC}" < ${_file}
-.endfor
+ @for utpatch in ${UTPATCHES}; do \
+ ${PATCH} -sd "${WRKSRC}" < $$utpatch; \
+ done
@${REINPLACE_CMD} \
-e 's/ioquake3/${Q3CLIENT}/g' \
-e 's/ioq3ded/${Q3SERVER}/g' \
-e 's/baseq3/${Q3BASE}/g' \
"${WRKSRC}/Makefile"
-.include "../ioquake3-devel/Makefile"
+.include "${MASTERDIR}/Makefile"
diff --git a/games/iourbanterror/distinfo b/games/iourbanterror/distinfo
deleted file mode 100644
index 168c2eb6d6e7..000000000000
--- a/games/iourbanterror/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ioquake3-devel-1.36_SVN2194.zip) = 91ef10e29ebc49c4d1faa4265b573e98c3b804b71004111142ee7b55543a54ff
-SIZE (ioquake3-devel-1.36_SVN2194.zip) = 5660634
diff --git a/games/iourbanterror/pkg-descr b/games/iourbanterror/pkg-descr
index 2998ff22860d..5acc5f06f0ad 100644
--- a/games/iourbanterror/pkg-descr
+++ b/games/iourbanterror/pkg-descr
@@ -9,4 +9,4 @@ and nice jumps. Urban Terror has 7 game modes, 25 maps and 15 weapons.
This port installs a modified ioquake3 engine for Urban Terror called
ioUrbanTerror, and depends on the data, resulting in a playable game.
-WWW: http://www.urbanterror.info/
+WWW: http://www.urbanterror.info/
diff --git a/games/openarena-data/Makefile b/games/openarena-data/Makefile
index a32539909041..3b1b331790a2 100644
--- a/games/openarena-data/Makefile
+++ b/games/openarena-data/Makefile
@@ -6,35 +6,33 @@
#
PORTNAME= data
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.8
CATEGORIES= games
-MASTER_SITES= http://openarena.ws/request.php?2\\\#/:data \
- http://openarena.ws/request.php?3\\\#/:patch
-DISTFILES= ${OA_DATA}:data \
- ${OA_PATCH}:patch
+MASTER_SITES= SF/oarena:data \
+ http://openarena.ws/request.php?4\\\#/:data \
+ SF/oarena:patch \
+ http://openarena.ws/request.php?5\\\#/:patch
+DISTFILES= ${OA_DATA}:data
EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
COMMENT= OpenArena game data files
-USE_ZIP= yes
-
WRKSRC= ${WRKDIR}/baseoa
NO_BUILD= yes
FETCH_ARGS=
-USE_ZIP= yes
-OA_DATA= oa081.zip
-OA_DATA_VER= 0.8.1
-OA_PATCH= oa085p.zip
-OA_PATCH_VER= 0.8.1
+OA_DATA= ${PKGNAMEPREFIX}${OA_DATA_VER}.zip
+OA_DATA_VER= 0.8.8
-post-extract:
- ${UNZIP_CMD} -j ${DISTDIR}/${OA_DATA} ${PKGNAMEPREFIX}${OA_DATA_VER}/${OABASE}/\* -d ${WRKSRC}
- ${UNZIP_CMD} -j ${DISTDIR}/${OA_PATCH} ${PKGNAMEPREFIX}${OA_PATCH_VER}/${OABASE}/\* -d ${WRKSRC}
+.include "../openarena/Makefile.include"
do-install:
${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR})
+.for _file in ${DISTFILES:C/:[^:]*//}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${_file} \
+ ${EXTRACT_AFTER_ARGS} -C ${DATADIR} --strip-components 2 \
+ ${PKGNAMEPREFIX}\?.\?.\?/baseoa/
+.endfor
-.include "../openarena/Makefile.include"
+.include <bsd.port.post.mk>
diff --git a/games/openarena-data/distinfo b/games/openarena-data/distinfo
index a5b0590d33a4..72ffd7475fb0 100644
--- a/games/openarena-data/distinfo
+++ b/games/openarena-data/distinfo
@@ -1,4 +1,2 @@
-SHA256 (oa081.zip) = c96282de8bc2ac5781df58c6adbce4265376e36190af50d7528f51dc739b6d7d
-SIZE (oa081.zip) = 318927645
-SHA256 (oa085p.zip) = d360c4b095bc3b34d03d9a366b21c12052c3f9e9c57e86b17c8b2c038baa4719
-SIZE (oa085p.zip) = 42528474
+SHA256 (openarena-0.8.8.zip) = 5a8faf7f5b51f351b0a1618c06b6b98a5f1a6758f1d39818de2c87df2a0bac4a
+SIZE (openarena-0.8.8.zip) = 425189255
diff --git a/games/openarena-data/pkg-plist b/games/openarena-data/pkg-plist
index 046a011fa386..e976ec45740a 100644
--- a/games/openarena-data/pkg-plist
+++ b/games/openarena-data/pkg-plist
@@ -6,5 +6,6 @@
%%DATADIR%%/pak5-TA.pk3
%%DATADIR%%/pak6-misc.pk3
%%DATADIR%%/pak6-patch085.pk3
+%%DATADIR%%/pak6-patch088.pk3
@dirrm %%DATADIR%%
@dirrmtry %%OADIR%%
diff --git a/games/openarena-oax/Makefile b/games/openarena-oax/Makefile
index 28940cad691d..24e02f412281 100644
--- a/games/openarena-oax/Makefile
+++ b/games/openarena-oax/Makefile
@@ -11,13 +11,10 @@ CATEGORIES= games
MASTER_SITES= http://files.poulsander.com/~poul19/public_files/eliminationSource/
DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= .zip
-EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
COMMENT= OpenArena Mod: OpenArena Xpanded
-USE_ZIP= yes
-
PLIST_SUB+= DISTNAME="${DISTNAME}" \
PORTNAME="${PORTNAME}"
@@ -25,11 +22,10 @@ NO_BUILD= yes
OABASE= ${DISTNAME}
-post-extract:
- ${UNZIP_CMD} -j ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
-
do-install:
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR})
.include "../openarena/Makefile.include"
+
+.include <bsd.port.post.mk>
diff --git a/games/openarena-server/Makefile b/games/openarena-server/Makefile
new file mode 100644
index 000000000000..236cd06e618d
--- /dev/null
+++ b/games/openarena-server/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: openarena-server
+# Date created: 19 May 2012
+# Whom: Dominic Fandrey <kamikaze@bsdforen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openarena
+PKGNAMESUFFIX= -server
+
+MAINTAINER= kamikaze@bsdforen.de
+COMMENT= OpenArena dedicated server
+
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+MASTERDIR= ${.CURDIR}/../${PORTNAME}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index 2ddae0fdf18e..f09a058806da 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -7,11 +7,11 @@
PORTNAME= openarena
PORTVERSION= ${GAMEVERSION}.s${SVNREVISION}
-DISTVERSION= 1.36_SVN${SVNREVISION}+${GAMEVERSION}
-PORTREVISION= 9
+PORTREVISION= 0
PORTEPOCH= 1
-MASTER_SITES= http://files.poulsander.com/~poul19/public_files/oa/dev081/
-DISTNAME= ${PORTNAME}-engine-source-0.8.x-22
+MASTER_SITES= SF/oarena/src \
+ http://files.poulsander.com/~poul19/public_files/oa/dev088/
+DISTNAME= ${PORTNAME}-engine-source-0.8.8
# Master port defines EXTRACT_SUFX unless already defined
EXTRACT_SUFX= .tar.bz2
@@ -20,22 +20,29 @@ COMMENT= Quake3 total conversion based on the ioquake3 engine
RUN_DEPENDS= ${DATADIR}/${Q3BASE}/pak0.pk3:${PORTSDIR}/games/openarena-data
+MASTERDIR= ${.CURDIR}/../ioquake3
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DISTINFO_FILE= ${.CURDIR}/../${PORTNAME}/distinfo
+PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
+PLIST= ${.CURDIR}/../${PORTNAME}/pkg-plist
+PKGMESSAGE= ${.CURDIR}/../${PORTNAME}/pkg-message
+
NO_GAMELIBS= yes
+NO_TOOLS= yes
# OpenArena doc is too messy to bother
NOPORTDOCS= yes
+# Dynamically loaded renderer not yet supported
+WITHOUT_DLRENDERER= yes
-GAMEVERSION= 0.8.5
+GAMEVERSION= 0.8.8
SVNREVISION= 1910
+Q3ENGINEVER= 1.36_SVN${SVNREVISION}+${GAMEVERSION}
Q3TOTALCONV= yes
Q3CLIENT= openarena
Q3SERVER= oa_ded
-Q3TOOLS=
Q3BASE= baseoa
Q3DIR= ${DATADIR}
# No icon included with OpenArena
Q3ICON=
-# Dynamically loaded renderer not yet supported
-WITHOUT_DLRENDERER= yes
-
-.include "../ioquake3/Makefile"
+.include "${MASTERDIR}/Makefile"
diff --git a/games/openarena/Makefile.include b/games/openarena/Makefile.include
index a0a0b848c472..46855f21953b 100644
--- a/games/openarena/Makefile.include
+++ b/games/openarena/Makefile.include
@@ -12,12 +12,10 @@ RUN_DEPENDS+= ${OABIN}:${PORTSDIR}/games/openarena
.include <bsd.port.pre.mk>
# You only need server or client.
-.if exists(${PREFIX}/bin/oa_ded)
+.if exists(${LOCALBASE}/bin/oa_ded)
OABIN= oa_ded
-.elif exists(${PREFIX}/bin/openarena)
+.elif exists(${LOCALBASE}/bin/openarena)
OABIN= openarena
.else
OABIN= openarena-smp
.endif
-
-.include <bsd.port.post.mk>
diff --git a/games/openarena/distinfo b/games/openarena/distinfo
index 1daf5d406a76..3b67c474b862 100644
--- a/games/openarena/distinfo
+++ b/games/openarena/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openarena-engine-source-0.8.x-22.tar.bz2) = d2a9123b3e35f656de795957afcb64917612e91cfc55157410cceaa6a7939a60
-SIZE (openarena-engine-source-0.8.x-22.tar.bz2) = 7422832
+SHA256 (openarena-engine-source-0.8.8.tar.bz2) = 95aa500cb7e42e57fb1f6db7b97a254168f4fa2e3676d6cdc33180b69fde0e77
+SIZE (openarena-engine-source-0.8.8.tar.bz2) = 3777830
diff --git a/games/openarena/files/patch-Makefile b/games/openarena/files/patch-Makefile
index e6844bf57409..fdd102aeaf92 100644
--- a/games/openarena/files/patch-Makefile
+++ b/games/openarena/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2011-11-04 21:03:54.000000000 +0100
-+++ Makefile 2011-11-04 21:09:54.000000000 +0100
+--- Makefile.orig 2011-12-12 23:48:49.000000000 +0100
++++ Makefile 2012-03-07 23:00:53.000000000 +0100
@@ -205,6 +205,8 @@
OPENAL_LIBS=$(shell pkg-config --silence-errors --libs openal)
SDL_CFLAGS=$(shell pkg-config --silence-errors --cflags sdl|sed 's/-Dmain=SDL_main//')
@@ -9,7 +9,7 @@
endif
# Use sdl-config if all else fails
ifeq ($(SDL_CFLAGS),)
-@@ -569,9 +571,15 @@
+@@ -570,9 +572,15 @@
ifeq ($(PLATFORM),freebsd)
@@ -25,7 +25,7 @@
-DUSE_ICON -DMAP_ANONYMOUS=MAP_ANON
CLIENT_CFLAGS = $(SDL_CFLAGS)
SERVER_CFLAGS =
-@@ -594,27 +602,24 @@
+@@ -595,27 +603,24 @@
# optional features/libraries
ifeq ($(USE_OPENAL),1)
diff --git a/games/openarena/files/patch-feature-DEFAULT_LIBDIR b/games/openarena/files/patch-feature-DEFAULT_LIBDIR
index 0e977835024f..f2f06163d8fd 100644
--- a/games/openarena/files/patch-feature-DEFAULT_LIBDIR
+++ b/games/openarena/files/patch-feature-DEFAULT_LIBDIR
@@ -1,5 +1,5 @@
---- code/qcommon/files.c.orig 2011-03-10 02:01:27.599036000 +0100
-+++ code/qcommon/files.c 2011-03-19 22:40:42.000000000 +0100
+--- code/qcommon/files.c.orig 2011-12-24 13:29:32.000000000 +0100
++++ code/qcommon/files.c 2012-03-07 23:00:53.000000000 +0100
@@ -250,6 +250,7 @@
#endif
@@ -8,15 +8,15 @@
static cvar_t *fs_basegame;
static cvar_t *fs_gamedirvar;
static searchpath_t *fs_searchpaths;
-@@ -2956,6 +2957,7 @@
+@@ -2859,6 +2860,7 @@
fs_debug = Cvar_Get( "fs_debug", "0", 0 );
- fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT|CVAR_PROTECTED );
+ fs_basepath = Cvar_Get ("fs_basepath", Sys_DefaultInstallPath(), CVAR_INIT );
fs_basegame = Cvar_Get ("fs_basegame", "", CVAR_INIT );
+ fs_libpath = Cvar_Get ("fs_libpath", Sys_DefaultLibPath(), CVAR_INIT );
homePath = Sys_DefaultHomePath();
if (!homePath || !homePath[0]) {
homePath = fs_basepath->string;
-@@ -2975,6 +2977,11 @@
+@@ -2878,6 +2880,11 @@
if (fs_apppath->string[0])
FS_AddGameDirectory(fs_apppath->string, gameName);
#endif
@@ -28,9 +28,9 @@
// NOTE: same filtering below for mods and basegame
if (fs_homepath->string[0] && Q_stricmp(fs_homepath->string,fs_basepath->string)) {
---- code/qcommon/qcommon.h.orig 2011-03-10 02:01:27.599036000 +0100
-+++ code/qcommon/qcommon.h 2011-03-19 22:40:42.000000000 +0100
-@@ -1104,6 +1104,9 @@
+--- code/qcommon/qcommon.h.orig 2011-12-24 13:29:32.000000000 +0100
++++ code/qcommon/qcommon.h 2012-03-07 23:00:53.000000000 +0100
+@@ -1099,6 +1099,9 @@
char *Sys_DefaultAppPath(void);
#endif
@@ -40,8 +40,8 @@
void Sys_SetDefaultHomePath(const char *path);
char *Sys_DefaultHomePath(void);
const char *Sys_TempPath(void);
---- code/sys/sys_main.c.orig 2011-02-23 17:17:09.009063000 +0100
-+++ code/sys/sys_main.c 2011-03-19 22:40:42.000000000 +0100
+--- code/sys/sys_main.c.orig 2011-12-24 13:29:37.000000000 +0100
++++ code/sys/sys_main.c 2012-03-07 23:00:53.000000000 +0100
@@ -49,6 +49,7 @@
static char binaryPath[ MAX_OSPATH ] = { 0 };
diff --git a/games/openarena/pkg-descr b/games/openarena/pkg-descr
index 70060600293b..9b26f5cd8058 100644
--- a/games/openarena/pkg-descr
+++ b/games/openarena/pkg-descr
@@ -4,4 +4,4 @@ There are many game types supported including Free For All, Capture The Flag,
Domination, Overload, Harvester, and more. There are 17 unique player models to
choose from and 12 weapons.
-WWW: http://openarena.ws/
+WWW: http://openarena.ws/
diff --git a/games/urbanterror-data/Makefile b/games/urbanterror-data/Makefile
index b160925451eb..1cd90057c3ca 100644
--- a/games/urbanterror-data/Makefile
+++ b/games/urbanterror-data/Makefile
@@ -5,36 +5,36 @@
# $FreeBSD$
#
-PORTNAME= urbanterror
+PORTNAME= data
PORTVERSION= 4.1.1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.snt.utwente.nl/pub/games/urbanterror/full_install/linux_or_mac/
-# http://www.urbanterror.info/downloads/software/urt/${DISTNAME}${EXTRACT_SUFX}?download=direct\\\#
-PKGNAMESUFFIX= -data
+MASTER_SITES= ftp://ftp.snt.utwente.nl/pub/games/urbanterror/full_install/linux_or_mac/ \
+ http://www.iourt.com/files/ \
+ http://urbanterror.mtc-team.fr/
+PKGNAMEPREFIX= urbanterror-
DISTNAME= UrbanTerror${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .zip
+EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Standalone realism based mod originally for Quake III Arena
-USE_ZIP= yes
NO_BUILD= yes
NO_PACKAGE= Package will be 1GB; set FORCE_PACKAGE if you really want it
-WRKSRC= ${WRKDIR}/UrbanTerror
-DATADIR= ${Q3DIR}
-
-.include "../quake3-data/Makefile.include"
-
-post-extract:
- @cd ${WRKSRC}/q3ut4 && ${MV} readme${PORTVERSION:S/.//:C/\..*//}.txt ..
+DATADIR= ${PREFIX}/share/quake3
do-install:
${MKDIR} ${DATADIR}/q3ut4
- ${CP} -r ${WRKSRC}/q3ut4/* ${DATADIR}/q3ut4
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTFILES} \
+ ${EXTRACT_AFTER_ARGS} -C ${DATADIR} --strip-components 1 \
+ UrbanTerror/q3ut4
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme${PORTVERSION:S/.//:C/\..*//}.txt \
+ ${MV} ${DATADIR}/q3ut4/readme${PORTVERSION:S/.//:C/\..*//}.txt \
${DOCSDIR}/readme${PORTVERSION:S/.//g}.txt
+.else
+ ${RM} ${DATADIR}/q3ut4/readme${PORTVERSION:S/.//:C/\..*//}.txt
.endif
.include <bsd.port.mk>
diff --git a/games/urbanterror-data/pkg-descr b/games/urbanterror-data/pkg-descr
index 807a9f869444..5c919f23dac8 100644
--- a/games/urbanterror-data/pkg-descr
+++ b/games/urbanterror-data/pkg-descr
@@ -9,4 +9,4 @@ and nice jumps. Urban Terror has 7 game modes, 25 maps and 15 weapons.
This port only contains the data, and can be played with ioUrbanTerror
(games/iourbanterror) or any other Quake 3 Arena compatible engine.
-WWW: http://www.urbanterror.net/
+WWW: http://www.urbanterror.net/