aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-06-30 05:44:47 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-06-30 05:44:47 +0000
commit435c27917a4140dde72303e85a245414d327a40c (patch)
tree38a2e17aee128c8d401a7a9d5b4115f205810f05
parenta63303ceb7bb5967cf8f8eabea72e74f2b712969 (diff)
downloadports-435c27917a4140dde72303e85a245414d327a40c.tar.gz
ports-435c27917a4140dde72303e85a245414d327a40c.zip
textproc/metaf2xml: Upgrade to 1.55
- Upgrade to 1.55 - Move from textproc to science - Introduce conditional run dependency on Apache - Introduce perl install dependency - Improve comment and pkg-descr - Stagify - Pet portlint PR: 180441 Submitted by: Thomas <metaf2xml@users.sourceforge.net> Approved by: maintainer timeout (clsung, 50 weeks) Approved by: swills (mentor)
Notes
Notes: svn path=/head/; revision=359801
-rw-r--r--MOVED1
-rw-r--r--science/Makefile1
-rw-r--r--science/metaf2xml/Makefile40
-rw-r--r--science/metaf2xml/distinfo2
-rw-r--r--science/metaf2xml/files/patch-Makefile8
-rw-r--r--science/metaf2xml/pkg-descr12
-rw-r--r--science/metaf2xml/pkg-plist59
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/metaf2xml/Makefile30
-rw-r--r--textproc/metaf2xml/distinfo2
-rw-r--r--textproc/metaf2xml/pkg-descr6
-rw-r--r--textproc/metaf2xml/pkg-plist28
12 files changed, 123 insertions, 67 deletions
diff --git a/MOVED b/MOVED
index b93d6cd0ebf4..aa0b63c1b305 100644
--- a/MOVED
+++ b/MOVED
@@ -6182,3 +6182,4 @@ www/emacs-w3m-emacs22||2014-06-27|Removed: dependent on editors/emacs22
devel/ode-devel|devel/ode|2014-06-27|Has expired: Outdated by devel/ode
java/eclipse-devel|java/eclipse|2014-06-29|Concentrate maintenance effort on newer java/eclipse
textproc/ruby-hikidoc|textproc/rubygem-hikidoc|2014-06-29|Use textproc/rubygem-hikidoc instead
+textproc/metaf2xml|science/metaf2xml|2014-06-30|Moved to a more appropriate category on maintainer request
diff --git a/science/Makefile b/science/Makefile
index ee46a70827cc..3e6c552892ff 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -93,6 +93,7 @@
SUBDIR += medit
SUBDIR += meep
SUBDIR += mei
+ SUBDIR += metaf2xml
SUBDIR += minc
SUBDIR += minc2
SUBDIR += mol2ps
diff --git a/science/metaf2xml/Makefile b/science/metaf2xml/Makefile
new file mode 100644
index 000000000000..e83d0bebd35a
--- /dev/null
+++ b/science/metaf2xml/Makefile
@@ -0,0 +1,40 @@
+# Created by: Gea-Suan Lin <gslin@gslin.org>
+# $FreeBSD$
+
+PORTNAME= metaf2xml
+PORTVERSION= 1.55
+CATEGORIES= science perl5
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Parse and Decode METAR, TAF, SYNOP and BUOY and Store as XML
+
+OPTIONS_DEFINE= APACHE
+OPTIONS_SUB= yes
+APACHE_DESC= Install Apache config file for metaf2xml (depends on Apache)
+
+MAKE_ARGS= CGI_BIN_DIR=${PREFIX}/www/metaf2xml/cgi-bin \
+ HTDOCS_DIR=${PREFIX}/www/metaf2xml/htdocs \
+ METAF2XML=${PREFIX} \
+ METAF2XML_LIB=${PREFIX}/${SITE_PERL_REL} \
+ METAF2XML_DOC=${DOCSDIR} \
+ METAF2XML_XSL=${DATADIR}
+NO_BUILD= yes
+USES= perl5 tar:tgz
+USE_PERL5= install run
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MAPACHE}
+USE_APACHE_RUN= 22+
+MAKE_ARGS+= CONF_DIR=${PREFIX}/${APACHEETCDIR}/Includes
+.endif
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/www/metaf2xml/cgi-bin \
+ ${STAGEDIR}${PREFIX}/www/metaf2xml/htdocs
+
+do-install:
+ cd ${WRKSRC}; ${MAKE} ${MAKE_ARGS} install-all
+
+.include <bsd.port.mk>
diff --git a/science/metaf2xml/distinfo b/science/metaf2xml/distinfo
new file mode 100644
index 000000000000..4a07e68e00b3
--- /dev/null
+++ b/science/metaf2xml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (metaf2xml-1.55.tgz) = 2b89a7c1a61694e81681228263596b1ca0d27c7fdce5077be0553b9524bfc683
+SIZE (metaf2xml-1.55.tgz) = 338340
diff --git a/science/metaf2xml/files/patch-Makefile b/science/metaf2xml/files/patch-Makefile
new file mode 100644
index 000000000000..d3ad4d543561
--- /dev/null
+++ b/science/metaf2xml/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- ./Makefile.orig 2014-06-01 10:42:17.000000000 +0300
++++ ./Makefile 2014-06-25 19:21:30.625134928 +0300
+@@ -80,4 +80,5 @@
+ CGI_LOG_NAME=${CGI_LOG_NAME} \
+ CURL=${CURL} \
+ CURL_PROXY_OPTS=${CURL_PROXY_OPTS} \
++ BUILD_ROOT=${DESTDIR} \
+ perl ./install.pl $@
diff --git a/science/metaf2xml/pkg-descr b/science/metaf2xml/pkg-descr
new file mode 100644
index 000000000000..15c0f9339eff
--- /dev/null
+++ b/science/metaf2xml/pkg-descr
@@ -0,0 +1,12 @@
+metaf2xml can download, parse and decode aviation routine weather
+reports (METAR, SPECI, SAO), aerodrome forecasts (TAF), synoptic
+observations (SYNOP) and observations from buoys (BUOY). The
+extracted data can be written as XML or passed to a user-defined
+function (all done in Perl).
+
+It also provides XSLT style sheets to convert the XML to plain
+language (text, HTML), or XML with different schemas. A web-based
+(CGI) user interface can be used to download and display up-to-date
+weather data from NOAA, Ogimet, and other sources.
+
+WWW: http://metaf2xml.sourceforge.net
diff --git a/science/metaf2xml/pkg-plist b/science/metaf2xml/pkg-plist
new file mode 100644
index 000000000000..2b8a9fb04f93
--- /dev/null
+++ b/science/metaf2xml/pkg-plist
@@ -0,0 +1,59 @@
+bin/metaf.pl
+bin/metaf2xml.pl
+bin/metafsrc2raw.pl
+%%APACHE%%%%APACHEETCDIR%%/Includes/metaf2xml-1.55-apache.conf
+etc/metaf2xml-1.55-apache.conf
+%%SITE_PERL%%/metaf2xml/parser.pm
+%%SITE_PERL%%/metaf2xml/src2raw.pm
+man/man1/metaf.1.gz
+man/man1/metaf2xml.1.gz
+man/man1/metafsrc2raw.1.gz
+man/man3/metaf2xml::parser.3pm.gz
+man/man3/metaf2xml::src2raw.3pm.gz
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%DATADIR%%/metaf-fullhtml.xsl
+%%DATADIR%%/metaf-html.xsl
+%%DATADIR%%/metaf-lang-de.xml
+%%DATADIR%%/metaf-lang-en.xml
+%%DATADIR%%/metaf-lang-es.xml
+%%DATADIR%%/metaf-lang-pl.xml
+%%DATADIR%%/metaf-lang-pt-br.xml
+%%DATADIR%%/metaf-lang-ru.xml
+%%DATADIR%%/metaf-lang.xml
+%%DATADIR%%/metaf-sum-html.xsl
+%%DATADIR%%/metaf-sum-text.xsl
+%%DATADIR%%/metaf-sum-ui.xsl
+%%DATADIR%%/metaf-sum.xsl
+%%DATADIR%%/metaf-text.xsl
+%%DATADIR%%/metaf-ui.xsl
+%%DATADIR%%/metaf.dtd
+%%DATADIR%%/metaf.xsl
+%%DATADIR%%/stations.xml
+%%WWWDIR%%/cgi-bin/metaf.pl
+%%WWWDIR%%/htdocs/metaf-fullhtml.xsl
+%%WWWDIR%%/htdocs/metaf-html.xsl
+%%WWWDIR%%/htdocs/metaf-lang-de.xml
+%%WWWDIR%%/htdocs/metaf-lang-en.xml
+%%WWWDIR%%/htdocs/metaf-lang-es.xml
+%%WWWDIR%%/htdocs/metaf-lang-pl.xml
+%%WWWDIR%%/htdocs/metaf-lang-pt-br.xml
+%%WWWDIR%%/htdocs/metaf-lang-ru.xml
+%%WWWDIR%%/htdocs/metaf-lang.xml
+%%WWWDIR%%/htdocs/metaf-sum-html.xsl
+%%WWWDIR%%/htdocs/metaf-sum-ui.xsl
+%%WWWDIR%%/htdocs/metaf-sum.xsl
+%%WWWDIR%%/htdocs/metaf-ui.xsl
+%%WWWDIR%%/htdocs/metaf.xsl
+%%WWWDIR%%/htdocs/metaf2xml.css
+%%WWWDIR%%/htdocs/stations.xml
+%%APACHE%%@dirrmtry %%APACHEETCDIR%%/Includes
+%%APACHE%%@dirrmtry %%APACHEETCDIR%%
+@dirrmtry %%SITE_PERL%%/metaf2xml
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry %%DATADIR%%
+@dirrmtry %%WWWDIR%%/cgi-bin
+@dirrmtry %%WWWDIR%%/htdocs
+@dirrmtry %%WWWDIR%%
diff --git a/textproc/Makefile b/textproc/Makefile
index e73a3432f094..dc5afdd5692c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -421,7 +421,6 @@
SUBDIR += mathml-xsd
SUBDIR += mdocml
SUBDIR += meld
- SUBDIR += metaf2xml
SUBDIR += metauml
SUBDIR += mgdiff
SUBDIR += mguesser
diff --git a/textproc/metaf2xml/Makefile b/textproc/metaf2xml/Makefile
deleted file mode 100644
index c1cda78ac6e7..000000000000
--- a/textproc/metaf2xml/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Created by: Gea-Suan Lin <gslin@gslin.org>
-# $FreeBSD$
-
-PORTNAME= metaf2xml
-PORTVERSION= 1.42
-CATEGORIES= textproc
-MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= clsung@FreeBSD.org
-COMMENT= Parses METAR, TAF, and SYNOP messages and stores the components in XML
-
-MAKE_ARGS= CGI_BIN_DIR=${PREFIX}/www/metaf2xml/cgi-bin \
- HTDOCS_DIR=${PREFIX}/www/metaf2xml/htdocs \
- METAF2XML=${PREFIX} \
- METAF2XML_LIB=${PREFIX}/${SITE_PERL_REL} \
- METAF2XML_XSL=${DATADIR}
-NO_BUILD= yes
-USES= perl5
-USE_PERL5= run
-
-NO_STAGE= yes
-pre-install:
- ${MKDIR} ${PREFIX}/www/metaf2xml/cgi-bin \
- ${PREFIX}/www/metaf2xml/htdocs
-
-do-install:
- cd ${WRKSRC}; ${MAKE} ${MAKE_ARGS} install-all
-
-.include <bsd.port.mk>
diff --git a/textproc/metaf2xml/distinfo b/textproc/metaf2xml/distinfo
deleted file mode 100644
index ec21e9a8595f..000000000000
--- a/textproc/metaf2xml/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (metaf2xml-1.42.tgz) = 54e0a43fbb6fe2b3f0ed1d08e1509d2f19f0f9ba1100d36ade6788b1be9e568e
-SIZE (metaf2xml-1.42.tgz) = 260652
diff --git a/textproc/metaf2xml/pkg-descr b/textproc/metaf2xml/pkg-descr
deleted file mode 100644
index 54cb615cfcd3..000000000000
--- a/textproc/metaf2xml/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-metaf2xml parses aviation routine weather reports (METAR, SPECI),
-aerodrome forecasts (TAF), and synoptic observations (SYNOP) and
-stores the components in XML. They can then be converted to plain
-language (text, HTML), or XML with different schemas.
-
-WWW: http://metaf2xml.sourceforge.net/
diff --git a/textproc/metaf2xml/pkg-plist b/textproc/metaf2xml/pkg-plist
deleted file mode 100644
index 8b6524536f60..000000000000
--- a/textproc/metaf2xml/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-%%DATADIR%%/metaf-fullhtml.xsl
-%%DATADIR%%/metaf-html.xsl
-%%DATADIR%%/metaf-lang.xsl
-%%DATADIR%%/metaf-sum-html.xsl
-%%DATADIR%%/metaf-sum-text.xsl
-%%DATADIR%%/metaf-sum-ui.xsl
-%%DATADIR%%/metaf-sum.xsl
-%%DATADIR%%/metaf-text.xsl
-%%DATADIR%%/metaf-ui.xsl
-%%DATADIR%%/metaf.xsl
-%%DATADIR%%/stations.xml
-%%SITE_PERL%%/metaf2xml/XML.pm
-%%SITE_PERL%%/metaf2xml/parser.pm
-bin/metaf2xml.pl
-bin/metafsrc2raw.pl
-www/metaf2xml/cgi-bin/metaf.pl
-www/metaf2xml/htdocs/metaf-fullhtml.xsl
-www/metaf2xml/htdocs/metaf-lang.xsl
-www/metaf2xml/htdocs/metaf-sum-ui.xsl
-www/metaf2xml/htdocs/metaf-sum.xsl
-www/metaf2xml/htdocs/metaf-ui.xsl
-www/metaf2xml/htdocs/metaf.xsl
-www/metaf2xml/htdocs/stations.xml
-@dirrmtry %%DATADIR%%
-@dirrmtry %%SITE_PERL%%/metaf2xml
-@dirrmtry www/metaf2xml/cgi-bin
-@dirrmtry www/metaf2xml/htdocs
-@dirrmtry www/metaf2xml