aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-09-07 14:30:03 +0000
commit570f1b227ce7fdadb7c031679c3aa93fe5f7ee70 (patch)
treec02f89a59a7e138b929074a6ed263c97f8eeabdd
parenteb6b6a7d155e64e16cd7a0a1323db82d2f504dd6 (diff)
downloadports-570f1b227ce7fdadb7c031679c3aa93fe5f7ee70.tar.gz
ports-570f1b227ce7fdadb7c031679c3aa93fe5f7ee70.zip
Replace pecl-fileinfo with php5-fileinfo for php 5.3.x.
Notes
Notes: svn path=/head/; revision=260697
-rw-r--r--Mk/bsd.php.mk7
-rw-r--r--UPDATING9
-rw-r--r--lang/php5/Makefile.ext7
-rw-r--r--lang/php53/Makefile.ext7
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/php5-fileinfo/Makefile14
-rw-r--r--sysutils/php5-fileinfo/files/patch-config.m421
7 files changed, 65 insertions, 1 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 4a23315074fd..b599134c9de4 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -275,7 +275,6 @@ dio_DEPENDS= devel/php${PHP_VER}-dio
dom_DEPENDS= textproc/php${PHP_VER}-dom
domxml_DEPENDS= textproc/php${PHP_VER}-domxml
exif_DEPENDS= graphics/php${PHP_VER}-exif
-fileinfo_DEPENDS= sysutils/pecl-fileinfo
filepro_DEPENDS=databases/php${PHP_VER}-filepro
filter_DEPENDS= security/php${PHP_VER}-filter
fribidi_DEPENDS=converters/pecl-fribidi
@@ -341,10 +340,16 @@ yaz_DEPENDS= net/pecl-yaz
yp_DEPENDS= net/php${PHP_VER}-yp
zlib_DEPENDS= archivers/php${PHP_VER}-zlib
.if ${PHP_VER} == 4
+fileinfo_DEPENDS= sysutils/pecl-fileinfo
hash_DEPENDS= security/pecl-hash
json_DEPENDS= devel/pecl-json
zip_DEPENDS= archivers/pecl-zip
.else
+.if ${PHP_VER} == 52
+fileinfo_DEPENDS= sysutils/pecl-fileinfo
+.else
+fileinfo_DEPENDS= sysutils/php${PHP_VER}-fileinfo
+.endif
hash_DEPENDS= security/php${PHP_VER}-hash
json_DEPENDS= devel/php${PHP_VER}-json
zip_DEPENDS= archivers/php${PHP_VER}-zip
diff --git a/UPDATING b/UPDATING
index 02920a0fb4ae..41bf3d7c1c9e 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20100907
+ AFFECTS: sysutils/pecl-fileinfo
+ AUTHOR: ale@FreeBSD.org
+
+ If you are using php 5.3 (lang/php5) and fileinfo extension, you
+ should switch to sysutils/php5-fileinfo port:
+
+ portmaster -o sysutils/php5-fileinfo sysutils/pecl-fileinfo
+
20100904
AFFECTS: net/netcat
AUTHOR: pgollucci@FreeBSD.org
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index f969b6883ae1..a6c8f54be6bd 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -61,6 +61,13 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
+.if ${PHP_MODNAME} == "fileinfo"
+CONFIGURE_ARGS+=--enable-fileinfo \
+ --with-pcre-dir=${LOCALBASE}
+
+PHP_HEADER_DIRS= libmagic
+.endif
+
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index f969b6883ae1..a6c8f54be6bd 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -61,6 +61,13 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--enable-exif
.endif
+.if ${PHP_MODNAME} == "fileinfo"
+CONFIGURE_ARGS+=--enable-fileinfo \
+ --with-pcre-dir=${LOCALBASE}
+
+PHP_HEADER_DIRS= libmagic
+.endif
+
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 80b4ae9e28b8..96d5af25efdf 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -631,6 +631,7 @@
SUBDIR += phantom
SUBDIR += philesight
SUBDIR += php4-posix
+ SUBDIR += php5-fileinfo
SUBDIR += php5-posix
SUBDIR += php52-posix
SUBDIR += pidof
diff --git a/sysutils/php5-fileinfo/Makefile b/sysutils/php5-fileinfo/Makefile
new file mode 100644
index 000000000000..88a720220b56
--- /dev/null
+++ b/sysutils/php5-fileinfo/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php5-fileinfo
+# Date created: 7 Sep 2010
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= sysutils
+
+MASTERDIR= ${.CURDIR}/../../lang/php5
+
+PKGNAMESUFFIX= -fileinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/php5-fileinfo/files/patch-config.m4 b/sysutils/php5-fileinfo/files/patch-config.m4
new file mode 100644
index 000000000000..1348023ccf64
--- /dev/null
+++ b/sysutils/php5-fileinfo/files/patch-config.m4
@@ -0,0 +1,21 @@
+--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
++++ config.m4 2010-09-07 15:46:50.000000000 +0200
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(fileinfo, for fileinfo support,
+ [ --disable-fileinfo Disable fileinfo support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
++
+ if test "$PHP_FILEINFO" != "no"; then
+
+ libmagic_sources=" \
+@@ -13,6 +16,8 @@
+ libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
+ libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
+
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++
+ PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
+ PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
+