aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-12-15 13:54:30 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-12-15 13:54:30 +0000
commit5b6e5fe1ae5a614a4cc089705ae23115b43d4667 (patch)
tree8d9d75d320ffc47582311dc1b0da5b8d1dc23099
parent796a75c34a9ff57c87c88a712e1688a786f058fe (diff)
downloadports-5b6e5fe1ae5a614a4cc089705ae23115b43d4667.tar.gz
ports-5b6e5fe1ae5a614a4cc089705ae23115b43d4667.zip
- allow staging
- change to new LIB_DEPENDS notation - s/LATEST_LINK/PKGNAMESUFFIX/ - fix MASTERSITE
Notes
Notes: svn path=/head/; revision=336534
-rw-r--r--www/mod_auth_cookie_mysql2/Makefile4
-rw-r--r--www/mod_auth_imap2/Makefile2
-rw-r--r--www/mod_auth_pam2/Makefile17
-rw-r--r--www/mod_auth_pgsql2/Makefile11
-rw-r--r--www/mod_authn_sasl/Makefile21
-rw-r--r--www/mod_bw/Makefile13
-rw-r--r--www/mod_bw/pkg-descr2
-rw-r--r--www/mod_chroot/Makefile9
-rw-r--r--www/mod_jail/Makefile13
9 files changed, 26 insertions, 66 deletions
diff --git a/www/mod_auth_cookie_mysql2/Makefile b/www/mod_auth_cookie_mysql2/Makefile
index 7227e8f47d9c..8fd93dc1a0ae 100644
--- a/www/mod_auth_cookie_mysql2/Makefile
+++ b/www/mod_auth_cookie_mysql2/Makefile
@@ -10,8 +10,7 @@ DISTNAME= ${PORTNAME}_1.0
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
-COMMENT= Allows authentication against a MySQL database via a secure cookie
-
+COMMENT= Allows authentication against MySQL database via secure cookie
USE_MYSQL= yes
USE_APACHE= 22
@@ -23,5 +22,4 @@ AP_INC= ${LOCALBASE}/include/mysql
AP_LIB= ${LOCALBASE}/lib/mysql -lmysqlclient
SRC_FILE= mod_auth_cookie_sql2.c mod_auth_cookie_sql2_mysql.c
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/mod_auth_imap2/Makefile b/www/mod_auth_imap2/Makefile
index 77a5185d0daf..6de6cf3d2ebc 100644
--- a/www/mod_auth_imap2/Makefile
+++ b/www/mod_auth_imap2/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 2.2.0
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://ben.brillat.net/files/projects/mod_auth_imap2/
+PKGNAMESUFFIX= 2
DISTNAME= mod_auth_imap2-${PORTVERSION}
DIST_SUBDIR= apache2
@@ -16,7 +17,6 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}2-${PORTVERSION}
USE_APACHE= 22
-LATEST_LINK= mod_auth_imap2
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
index 7aaacdb41344..fe57e27f96c9 100644
--- a/www/mod_auth_pam2/Makefile
+++ b/www/mod_auth_pam2/Makefile
@@ -7,14 +7,12 @@ PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use PAM modules for user authentication
-
-LATEST_LINK= mod_auth_pam2
-
USE_APACHE= 22+
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -26,15 +24,10 @@ AP_GENPLIST= yes
AP_EXTRAS+= -lpam
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/samples/httpd ${EXAMPLESDIR}/pam-httpd.sample
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/httpd ${STAGEDIR}${EXAMPLESDIR}/pam-httpd.sample
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_auth_pgsql2/Makefile b/www/mod_auth_pgsql2/Makefile
index f4cd76c29f61..e7080c966e56 100644
--- a/www/mod_auth_pgsql2/Makefile
+++ b/www/mod_auth_pgsql2/Makefile
@@ -6,27 +6,22 @@ PORTVERSION= 2.0.3
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.giuseppetanzilli.it/mod_auth_pgsql2/dist/
+PKGNAMESUFFIX= 2
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use PostgreSQL databases for user authentication
-
USE_PGSQL= yes
USE_APACHE= 22
-LATEST_LINK= mod_auth_pgsql2
-
AP_INC?= ${LOCALBASE}/include
AP_LIB?= ${LOCALBASE}/lib -lpq
AP_FAST_BUILD= yes
AP_GENPLIST= yes
PORTDOCS= mod_auth_pgsql.html
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/mod_auth_pgsql.html ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_authn_sasl/Makefile b/www/mod_authn_sasl/Makefile
index 199daa504638..29332c05eca4 100644
--- a/www/mod_authn_sasl/Makefile
+++ b/www/mod_authn_sasl/Makefile
@@ -13,13 +13,12 @@ COMMENT= Allows user authentication based on libsasl2 mechanisms on apache 2.2
LICENSE= AL2
-LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
-
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
OPTIONS_DEFINE= SASLAUTHD
SASLAUTHD_DESC= cyrus-sasl2-saslauthd support
-NO_STAGE= yes
+SASLAUTHD_RUN_DEPENDS= saslauthd:${PORTSDIR}/security/cyrus-sasl2-saslauthd
.include <bsd.port.options.mk>
USE_BZIP2= yes
@@ -31,18 +30,10 @@ AP_LIB= ${LOCALBASE}/lib -lsasl2
PORTDOCS1= AUTHORS LICENSE
PORTDOCS= *
-.if ${PORT_OPTIONS:MSASLAUTHD}
-RUN_DEPENDS+= saslauthd:${PORTSDIR}/security/cyrus-sasl2-saslauthd
-.endif
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}/
- @${FIND} ${WRKSRC}/doc \( -name "*.in" -o -name "*.am" \) -delete
-. for f in ${PORTDOCS1}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-. endfor
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${DOCSDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS1:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR} \
+ "! ( -name *\.in -o -name *\.am )" )
.include <bsd.port.mk>
diff --git a/www/mod_bw/Makefile b/www/mod_bw/Makefile
index ae0c89abcf1c..e157ef2ec944 100644
--- a/www/mod_bw/Makefile
+++ b/www/mod_bw/Makefile
@@ -5,13 +5,14 @@ PORTNAME= mod_bw
PORTVERSION= 0.8
PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= http://www.ivn.cl/apache/files/source/
+MASTER_SITES= http://legacy.ivn.cl/files/source/
EXTRACT_SUFX= .tgz
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= Bandwidth and Connection control per Virtual Host or Directory
+LICENSE= AL2
WRKSRC= ${WRKDIR}/mod_bw
USE_APACHE= 22
@@ -19,14 +20,10 @@ AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= mod_bw.c
-PORTDOCS= LICENSE mod_bw.txt
+PORTDOCS= mod_bw.txt
-NO_STAGE= yes
post-install:
-.ifndef NOPORTDOCS
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && \
- ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_bw/pkg-descr b/www/mod_bw/pkg-descr
index 8c597384a814..671ffd06e95b 100644
--- a/www/mod_bw/pkg-descr
+++ b/www/mod_bw/pkg-descr
@@ -3,4 +3,4 @@ It can:
* Restrict the number of simultaneous connections per vhost/dir
* Limit the bandwidth for files on vhost/dir
-WWW: http://www.ivn.cl/apache/
+WWW: http://ivn.cl/category/apache/
diff --git a/www/mod_chroot/Makefile b/www/mod_chroot/Makefile
index fe3e6d660682..421d0fc2e40d 100644
--- a/www/mod_chroot/Makefile
+++ b/www/mod_chroot/Makefile
@@ -10,17 +10,14 @@ MASTER_SITES= http://core.segfault.pl/~hobbit/mod_chroot/dist/
MAINTAINER= apache@FreeBSD.org
COMMENT= The mod_chroot makes running Apache in a chroot easy
-
USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
PORTDOCS= INSTALL CAVEATS README.Apache20 README
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/www/mod_jail/Makefile b/www/mod_jail/Makefile
index ef0d0e90f640..d416bff0a38d 100644
--- a/www/mod_jail/Makefile
+++ b/www/mod_jail/Makefile
@@ -9,26 +9,15 @@ MASTER_SITES= http://mod-jail.googlecode.com/files/
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module to enable an easy alternative to mod_chroot
+LICENSE= AL2
USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
-NOPORTDOCS= yes
-PORTDOCS= changelog.html documentation.html download.html \
- index.html
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
@${REINPLACE_CMD} -e "s|= apxs|= ${APXS}|" ${WRKSRC}/Makefile
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc && \
- ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
-
.include <bsd.port.post.mk>