aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-05-30 03:09:50 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-05-30 03:09:50 +0000
commit6c825780bf2215583388b67a533f23f91a11a0ae (patch)
tree69e1fda1da31bb5cd12734ab2064c246d3f18ffe
parent4e6a30b9b683cf54f188c97dd436024e753adece (diff)
downloadports-6c825780bf2215583388b67a533f23f91a11a0ae.tar.gz
ports-6c825780bf2215583388b67a533f23f91a11a0ae.zip
New port: net-im/ring-gnome
Ring is a secure and distributed voice, video and chat communication platform that requires no centralized server and leaves the power of privacy in the hands of the user. WWW: https://ring.cx/ PR: 209544 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=416136
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/ring-gnome/Makefile52
-rw-r--r--net-im/ring-gnome/distinfo3
-rw-r--r--net-im/ring-gnome/files/patch-CMakeLists.txt30
-rw-r--r--net-im/ring-gnome/files/pkg-message.in10
-rw-r--r--net-im/ring-gnome/pkg-descr5
-rw-r--r--net-im/ring-gnome/pkg-plist34
7 files changed, 135 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 5e4fefe7f275..865bf275b104 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -150,6 +150,7 @@
SUBDIR += ramblercontacts
SUBDIR += ricochet
SUBDIR += ring-daemon
+ SUBDIR += ring-gnome
SUBDIR += ring-libclient
SUBDIR += rubygem-earthquake
SUBDIR += rubygem-hipchat
diff --git a/net-im/ring-gnome/Makefile b/net-im/ring-gnome/Makefile
new file mode 100644
index 000000000000..fcc49db2faff
--- /dev/null
+++ b/net-im/ring-gnome/Makefile
@@ -0,0 +1,52 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= ring-gnome
+PORTVERSION= 0.160516
+#DISTVERSIONPREFIX= v
+CATEGORIES= net-im net-p2p
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Gnome client of the Ring VoIP SIP phone and IM
+
+LICENSE= GPLv3
+LICENSE_FILES= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libringclient.so:net-im/ring-libclient \
+ libqrencode.so:graphics/libqrencode \
+ libcogl-pango.so:graphics/cogl \
+ libclutter-1.0.so:graphics/clutter \
+ libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
+ libnotify.so:devel/libnotify \
+ libsoup-2.4.so:devel/libsoup \
+ libplc4.so:devel/nspr \
+ libjson-glib-1.0.so:devel/json-glib \
+ libnss3.so:security/nss \
+ libsecret-1.so:security/libsecret \
+ libebook-1.2.so:databases/evolution-data-server
+
+BROKEN_FreeBSD_9= Fails due to compiler issues
+
+USE_GITHUB= yes
+GH_TUPLE+= savoirfairelinux:ring-client-gnome:07107e9
+
+SUB_FILES= pkg-message
+
+USES= cmake compiler:c++14-lang gettext gmake pkgconfig shebangfix sqlite
+USE_GNOME= glib20 gtk20 cairo gdkpixbuf2 libxml2 gtk30
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr xscrnsaver
+USE_GL= gl egl
+USE_QT5= core gui network xml opengl sql sql-sqlite3_run widgets svg \
+ concurrent buildtools_build linguisttools_build qmake_build
+SHEBANG_FILES= ${WRKSRC}/src/ring.cx
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= NLS
+NLS_CMAKE_ON= -DFREEBSD_NLS_ON:BOOL=ON
+OPTIONS_SUB= yes
+
+post-stage:
+ @${GZIP_CMD} ${GZIP} < ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/ring.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/ring.svgz
+ @${RM} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/ring.svg
+
+.include <bsd.port.mk>
diff --git a/net-im/ring-gnome/distinfo b/net-im/ring-gnome/distinfo
new file mode 100644
index 000000000000..9814dfbdb50c
--- /dev/null
+++ b/net-im/ring-gnome/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1463424510
+SHA256 (savoirfairelinux-ring-client-gnome-0.160516-07107e9_GH0.tar.gz) = 14df8601b6520f9040321efb366d33d59a3c139b98acd6b69be0a519e99bdc60
+SIZE (savoirfairelinux-ring-client-gnome-0.160516-07107e9_GH0.tar.gz) = 677210
diff --git a/net-im/ring-gnome/files/patch-CMakeLists.txt b/net-im/ring-gnome/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..335ff217a9a0
--- /dev/null
+++ b/net-im/ring-gnome/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+--- CMakeLists.txt.orig 2016-05-06 14:35:17 UTC
++++ CMakeLists.txt
+@@ -11,7 +11,7 @@ IF (CMAKE_COMPILER_IS_GNUCC)
+ ENDIF()
+ ENDIF()
+
+-ADD_DEFINITIONS("-std=c++1y")
++set(CMAKE_CXX_FLAGS "-std=c++1y")
+
+ # set project name and version
+ PROJECT(ring-client-gnome)
+@@ -306,7 +306,10 @@ GLIB_COMPILE_RESOURCES( GLIB_RESOURCES_R
+ # ADD_SUBDIRECTORY( src/test)
+ # ENDIF()
+
++option(FREEBSD_NLS_ON "NLS option: install translations" OFF)
++
+ # for translations
++IF (FREEBSD_NLS_ON)
+ IF (GETTEXT_FOUND)
+
+ # get all translation files; they're expected to be named using the following convention:
+@@ -331,6 +334,7 @@ IF (GETTEXT_FOUND)
+ ENDFOREACH(PO_FILE)
+
+ ENDIF(GETTEXT_FOUND)
++ENDIF(FREEBSD_NLS_ON)
+
+ # install and compile glib gsettings schema
+ add_schema("cx.ring.RingGnome.gschema.xml" GSCHEMA_RING)
diff --git a/net-im/ring-gnome/files/pkg-message.in b/net-im/ring-gnome/files/pkg-message.in
new file mode 100644
index 000000000000..80a350096a45
--- /dev/null
+++ b/net-im/ring-gnome/files/pkg-message.in
@@ -0,0 +1,10 @@
+======================================================================
+You installed the Ring softphone and IM Gnome client.
+
+Ring is currently in beta, and might not always function as expected.
+
+It will only work when pulseaudio server is running.
+
+For video to work you need to make sure that your webcam is available
+through the V4L interface.
+======================================================================
diff --git a/net-im/ring-gnome/pkg-descr b/net-im/ring-gnome/pkg-descr
new file mode 100644
index 000000000000..357246eb1e7f
--- /dev/null
+++ b/net-im/ring-gnome/pkg-descr
@@ -0,0 +1,5 @@
+Ring is a secure and distributed voice, video and chat communication
+platform that requires no centralized server and leaves the power
+of privacy in the hands of the user.
+
+WWW: https://ring.cx/
diff --git a/net-im/ring-gnome/pkg-plist b/net-im/ring-gnome/pkg-plist
new file mode 100644
index 000000000000..cb56aca21a93
--- /dev/null
+++ b/net-im/ring-gnome/pkg-plist
@@ -0,0 +1,34 @@
+bin/gnome-ring
+bin/ring.cx
+share/appdata/gnome-ring.appdata.xml
+share/applications/gnome-ring.desktop
+share/glib-2.0/schemas/cx.ring.RingGnome.gschema.xml
+share/gnome-ring/gnome-ring.desktop
+share/icons/hicolor/scalable/apps/ring.svgz
+%%NLS%%share/locale/ar/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/da_DK/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/de/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/fa_IR/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/fr_CA/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/he/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/id/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/ru_RU/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/zh/LC_MESSAGES/ring-client-gnome.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ring-client-gnome.mo