aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
commit797bc0968f6c141c034212ff2d71f0d1f5e35194 (patch)
treeae9f52a6cc5a1541ffff20edd302bcbcb336a823
parent5fdaa85b0d76467676b8f9a6cb38497c8fb02688 (diff)
downloadports-797bc0968f6c141c034212ff2d71f0d1f5e35194.tar.gz
ports-797bc0968f6c141c034212ff2d71f0d1f5e35194.zip
Fix ports for building with -current without perl
PR: 38359 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59747
-rw-r--r--devel/decompyle/Makefile9
-rw-r--r--dns/py-adns/Makefile10
-rw-r--r--graphics/graphviz/Makefile7
-rw-r--r--graphics/py-gd/Makefile13
-rw-r--r--graphics/py-paint/Makefile5
-rw-r--r--lang/spl/Makefile21
-rw-r--r--misc/xosd/Makefile3
-rw-r--r--net/py-adns/Makefile10
-rw-r--r--net/py-google/Makefile13
-rw-r--r--textproc/py-rxp/Makefile8
-rw-r--r--www/apache2/Makefile3
-rw-r--r--www/apache20/Makefile3
-rw-r--r--www/apache21/Makefile3
-rw-r--r--www/apache22/Makefile3
14 files changed, 85 insertions, 26 deletions
diff --git a/devel/decompyle/Makefile b/devel/decompyle/Makefile
index 8038a0de865b..207bf6f22840 100644
--- a/devel/decompyle/Makefile
+++ b/devel/decompyle/Makefile
@@ -17,8 +17,15 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,${LOCALBASE}/,,g}
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,/usr/bin/env python2,${PYTHON_CMD},' \
${WRKSRC}/scripts/decompyle
+.else
+ ${SED} -i.orig -e 's,/usr/bin/env python2,${PYTHON_CMD},' \
+ ${WRKSRC}/scripts/decompyle
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index b741415a3123..83e40776422b 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -20,9 +20,17 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
@${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
+.else
+ @${SED} -i.orig -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
+ -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
+ ${WRKSRC}/setup.py
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 923d0e9fe655..05fa9fead54c 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -32,6 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3 -I
ACLOCAL=${LOCALBASE}/bin/aclocal14
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/lib/graphviz
+MAKE_ENV= EXPR_COMPAT=yes
MAN1= acyclic.1 ccomps.1 colorize.1 dot.1 dotty.1 gc.1 gpr.1 \
lefty.1 neato.1 nop.1 prune.1 sccmap.1 tred.1 \
@@ -49,12 +50,6 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
CONFIGURE_ARGS= --with-iconvlibdir=${LOCALBASE}/lib
.endif
-post-patch:
-.if ${OSVERSION} >= 500032
- @${PERL} -pi.orig -e 's|expr |expr -- |' ${WRKSRC}/libtool
-.endif
-
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
index 1fb2887e7c61..cd248ee180ff 100644
--- a/graphics/py-gd/Makefile
+++ b/graphics/py-gd/Makefile
@@ -24,11 +24,22 @@ EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
USE_XPM= yes
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,^(gd.*)$$,\1 -I${LOCALBASE}/include/gd -L${LOCALBASE}/lib,g; s,-lttf,,g; s,/usr/X11R6,${X11BASE},g;' \
${WRKSRC}/Setup
+.else
+ ${SED} -i.orig -e 's,^\(gd.*\)$$,\1 -I${LOCALBASE}/include/gd -L${LOCALBASE}/lib,g' \
+ -e 's,-lttf,,g' -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/Setup
+.endif
.if defined(WITHOUT_X11)
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's,-lX11 -lXpm,,g' ${WRKSRC}/Setup
+.else
+ ${SED} -i "" -e 's,-lX11 -lXpm,,g' ${WRKSRC}/Setup
+.endif
.endif
pre-build:
@@ -40,4 +51,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/gddemo.py ${EXAMPLE_DIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/py-paint/Makefile b/graphics/py-paint/Makefile
index 341a76721755..24e1afc96d67 100644
--- a/graphics/py-paint/Makefile
+++ b/graphics/py-paint/Makefile
@@ -32,8 +32,13 @@ EXAMPLES= test_bar.py test_paint.py testpie.py
.include <bsd.port.pre.mk>
post-patch:
+.if ${OSVERSION} < 500036
${PERL} -pi -e 's@^(.*libraries.*)$$@\1include_dirs=${INC_DIRS},library_dirs=${LIB_DIRS},@g' \
${WRKSRC}/setup.py
+.else
+ ${SED} -i.orig -e 's@^\(.*libraries.*\)$$@\1include_dirs=${INC_DIRS},library_dirs=${LIB_DIRS},@g' \
+ ${WRKSRC}/setup.py
+.endif
.if !defined(NOPORTDOCS)
post-install:
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 0a0d4656caf6..4212b5f2dc4f 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -15,21 +15,30 @@ MAINTAINER= perky@fallin.lv
USE_BISON= yes
USE_GMAKE= yes
+ALL_TARGET= spl2c libspl.a
ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
primes.spl reverse.spl shakesbeer.spl
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
@${PERL} -pi -e 's,= gcc,?= gcc,; s,^CCFLAGS.*,CFLAGS += -Wall,; \
- s,CCFLAGS,CFLAGS,g' \
+ s,CCFLAGS,CFLAGS,g; s,^SPLPATH =.*,SPLPATH =${PREFIX},g; \
+ s, spl/, ${PREFIX}/,g;' \
${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile
+.else
+ @for f in ${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile; do \
+ ${SED} -i "" -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
+ -e 's,CCFLAGS,CFLAGS,g' -e 's,^SPLPATH =.*,SPLPATH =${PREFIX},g' \
+ -e 's, spl/, ${PREFIX}/,g' $$f; \
+ done
+.endif
-do-install:
- ${TAR} -C ${WRKSRC}/spl -cf- . | ${TAR} -C ${PREFIX} -xpf-
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}
- @${PERL} -pi -e 's,^SPLPATH =.*,SPLPATH =${PREFIX},g' \
- ${EXAMPLESDIR}/Makefile
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 3e8aee0ddc73..149c21ebfdcd 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -41,7 +41,4 @@ PLIST_SUB+= WITH_XMMS=""
PLIST_SUB+= WITH_XMMS="@comment "
.endif
-pre-build:
- ${PERL} -pi -e "s@gcc@${CC}@g" ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/net/py-adns/Makefile b/net/py-adns/Makefile
index b741415a3123..83e40776422b 100644
--- a/net/py-adns/Makefile
+++ b/net/py-adns/Makefile
@@ -20,9 +20,17 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
@${PERL} -pi -e 's|^(include_dirs = ).*$$|\1\["${LOCALBASE}/include"\]|g; \
s|^(library_dirs = ).*$$|\1\["${LOCALBASE}/lib"\]|g' \
${WRKSRC}/setup.py
+.else
+ @${SED} -i.orig -e 's|^\(include_dirs = \).*$$|\1\["${LOCALBASE}/include"\]|g' \
+ -e 's|^\(library_dirs = \).*$$|\1\["${LOCALBASE}/lib"\]|g' \
+ ${WRKSRC}/setup.py
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/py-google/Makefile b/net/py-google/Makefile
index 5c2116e04df9..cf9e7a7be960 100644
--- a/net/py-google/Makefile
+++ b/net/py-google/Makefile
@@ -24,15 +24,24 @@ EXTRACT_BEFORE_ARGS= -q -aa
WRKSRC= ${WRKDIR}/pygoogle
EXAMPLESDIR= ${PREFIX}/share/examples/py-google
+.include <bsd.port.pre.mk>
+
post-patch:
# www/py-websvcs has an incompatible version of SOAP.py
@${MV} ${WRKSRC}/SOAP.py ${WRKSRC}/SOAPgoogle.py
+.if ${OSVERSION} < 500036
@cd ${WRKSRC}; for f in *.py; do \
${PERL} -pi -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
done
+ @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.else
+ @cd ${WRKSRC}; for f in *.py; do \
+ ${SED} -i "" -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
+ done
+ @${SED} -i.orig -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.endif
@${MKDIR} ${WRKSRC}/tests
@${MV} ${WRKSRC}/*test*.py ${WRKSRC}/tests
- @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
@@ -41,4 +50,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/py-rxp/Makefile b/textproc/py-rxp/Makefile
index cde6feba8727..16bf922c7eb9 100644
--- a/textproc/py-rxp/Makefile
+++ b/textproc/py-rxp/Makefile
@@ -22,8 +22,14 @@ USE_PYDISTUTILS= yes
EXAMPLESDIR= ${PREFIX}/share/examples/py-rxp
DOCSDIR= ${PREFIX}/share/doc/py-rxp
+.include <bsd.port.pre.mk>
+
post-patch:
+.if ${OSVERSION} < 500036
@${PERL} -pi -e 's/freebsd4/freebsd4","freebsd5/g' ${WRKSRC}/setup.py
+.else
+ @${SED} -i.orig -e 's/freebsd4/freebsd4","freebsd5/g' ${WRKSRC}/setup.py
+.endif
.if !defined(NOPORTDOCS)
post-install:
@@ -32,4 +38,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 93aafec698b2..22f1abad1226 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -28,9 +28,10 @@ WITH_MPM?= prefork # or worker, perchild (neither of them still has a problem on
HTTP_PORT?= 80
GNU_CONFIGURE= yes
+USE_PERL5= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-layout=FreeBSD \
- --with-perl=${PERL} \
+ --with-perl=${PERL5} \
--enable-so \
--with-mpm=${WITH_MPM} \
--with-port=${HTTP_PORT} \
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 93aafec698b2..22f1abad1226 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -28,9 +28,10 @@ WITH_MPM?= prefork # or worker, perchild (neither of them still has a problem on
HTTP_PORT?= 80
GNU_CONFIGURE= yes
+USE_PERL5= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-layout=FreeBSD \
- --with-perl=${PERL} \
+ --with-perl=${PERL5} \
--enable-so \
--with-mpm=${WITH_MPM} \
--with-port=${HTTP_PORT} \
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index 93aafec698b2..22f1abad1226 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -28,9 +28,10 @@ WITH_MPM?= prefork # or worker, perchild (neither of them still has a problem on
HTTP_PORT?= 80
GNU_CONFIGURE= yes
+USE_PERL5= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-layout=FreeBSD \
- --with-perl=${PERL} \
+ --with-perl=${PERL5} \
--enable-so \
--with-mpm=${WITH_MPM} \
--with-port=${HTTP_PORT} \
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 93aafec698b2..22f1abad1226 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -28,9 +28,10 @@ WITH_MPM?= prefork # or worker, perchild (neither of them still has a problem on
HTTP_PORT?= 80
GNU_CONFIGURE= yes
+USE_PERL5= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--enable-layout=FreeBSD \
- --with-perl=${PERL} \
+ --with-perl=${PERL5} \
--enable-so \
--with-mpm=${WITH_MPM} \
--with-port=${HTTP_PORT} \