aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-22 18:39:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-22 18:39:37 +0000
commit87e60f9c74d95149588b3180b5b83f871775e37b (patch)
tree519335fbf67a85f923b2a9013f48df9430170ea0
parent4d0e7ff8b373f0003576cfaf04674977314acf95 (diff)
downloadports-87e60f9c74d95149588b3180b5b83f871775e37b.tar.gz
ports-87e60f9c74d95149588b3180b5b83f871775e37b.zip
Fix build with clang 3.3
Notes
Notes: svn path=/head/; revision=318788
-rw-r--r--audio/penguinsap/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index 60e9d5a49d3b..0af3e41a7825 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -24,9 +24,13 @@ PLIST_FILES= bin/sap
.include <bsd.port.pre.mk>
+_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+
.if ${CXX:T} != "clang++"
+.if ${_CLANG} < 33
CXXFLAGS+= --no-exceptions
.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|linux/soundcard\.h|sys/soundcard\.h|' \