aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-29 17:32:19 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-29 17:32:19 +0000
commita519deff6c18c1ac4ea777ba32a9b7630cb807ae (patch)
tree556eaee68e8c5c9de66d5dd0af211a7d09a50879
parent8ef903640a256ab43495f880f2948117d54f4261 (diff)
downloadports-a519deff6c18c1ac4ea777ba32a9b7630cb807ae.tar.gz
ports-a519deff6c18c1ac4ea777ba32a9b7630cb807ae.zip
Add httping 1.0.4, a ping-like tool for HTTP requests.
PR: ports/85317 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=141360
-rw-r--r--net/Makefile1
-rw-r--r--net/httping/Makefile33
-rw-r--r--net/httping/distinfo2
-rw-r--r--net/httping/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4f9e4db6bb5f..4542db6966d8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -234,6 +234,7 @@
SUBDIR += howl
SUBDIR += htpdate
SUBDIR += http_ping
+ SUBDIR += httping
SUBDIR += hx
SUBDIR += i2p
SUBDIR += icb
diff --git a/net/httping/Makefile b/net/httping/Makefile
new file mode 100644
index 000000000000..f36467ed4e42
--- /dev/null
+++ b/net/httping/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: httping
+# Date created: 26 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httping
+PORTVERSION= 1.0.4
+CATEGORIES= net
+MASTER_SITES= http://www.vanheusden.com/httping/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A ping-like tool for HTTP requests
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\"
+LDFLAGS+= -lssl -lcrypto
+
+SRC= http io str error utils main tcp mssl res
+PLIST_FILES= bin/httping
+
+do-build:
+.for f in ${SRC}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} ${LDFLAGS} ${SRC:C/(.*)/${WRKSRC}\/\1.o/} \
+ -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/httping/distinfo b/net/httping/distinfo
new file mode 100644
index 000000000000..96e73f01c141
--- /dev/null
+++ b/net/httping/distinfo
@@ -0,0 +1,2 @@
+MD5 (httping-1.0.4.tgz) = e685b5cd583ad0442e2f6c8a5bf5ceca
+SIZE (httping-1.0.4.tgz) = 8439
diff --git a/net/httping/pkg-descr b/net/httping/pkg-descr
new file mode 100644
index 000000000000..b65ba2cbb100
--- /dev/null
+++ b/net/httping/pkg-descr
@@ -0,0 +1,8 @@
+Httping is like ping but for http-requests. Give it an url, and it will show
+you how long it takes to connect, send a request and retrieve the reply (only
+the headers).
+
+WWW: http://www.vanheusden.com/httping/
+
+- ehaupt
+ehaupt@critical.ch