aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2016-02-17 23:06:37 +0000
committerDiane Bruce <db@FreeBSD.org>2016-02-17 23:06:37 +0000
commitc9e3e2193d1e1e2f9ffe28f301f6bdcd8bf05467 (patch)
tree31c91c116a0a94491c970feb506c798dbbf460f4
parentff48a07f81d8690f5d8849491cf08eb6cdf44e90 (diff)
downloadports-c9e3e2193d1e1e2f9ffe28f301f6bdcd8bf05467.tar.gz
ports-c9e3e2193d1e1e2f9ffe28f301f6bdcd8bf05467.zip
Open-Source Software Implementation of a DRM (Digital Radio Mondiale) Receiver
under the GNU General Public License (GPL) There was a previous dream port that had been removed. It was audio/dream||2009-01-06|Has expired: Needs DRM enabled in FAAD The Dream development team today releases Dream version 1.12. Dream is a DRM (Digital Radio Mondiale) software receiver and decoder. It is a very complete receiver, featuring compliant decoding of HE AAC v2 audio streams, journaline decoding, a feature rich statistics section providing invaluable information about the streams being received, and automatic update of available stations from the web, among several other features. It also features a limited transmission mode, that uses the FAAC AAC encoder. Dream is multi-platform and has been tested on OSX, Win32 and Linux. Changes since version 1.11: - Fixed problem where users directories being cleared when clearing cache - Fixed timezone problems with EPG - Fixed problem when EPG is 4th service PR: ports/207123 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=409075
-rw-r--r--audio/dream/Makefile59
-rw-r--r--audio/dream/distinfo2
-rw-r--r--audio/dream/files/patch-src__linux__pa_shm_ringbuffer.c20
-rw-r--r--audio/dream/files/patch-src__sound__pa_ringbuffer.c20
-rw-r--r--audio/dream/pkg-descr4
5 files changed, 105 insertions, 0 deletions
diff --git a/audio/dream/Makefile b/audio/dream/Makefile
new file mode 100644
index 000000000000..41f2027215e6
--- /dev/null
+++ b/audio/dream/Makefile
@@ -0,0 +1,59 @@
+# $FreeBSD$
+
+PORTNAME= dream
+PORTVERSION= 2.1.1
+CATEGORIES= audio comms hamradio
+MASTER_SITES= SF/drm/${PORTNAME}/${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-svn808
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Software radio for AM and Digital Radio Mondiale (DRM)
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib\
+ libqwt.so:${PORTSDIR}/x11-toolkits/qwt5\
+ libfftw3.so:${PORTSDIR}/math/fftw3
+
+USE_QT4= qmake_build moc_build uic_build corelib gui network rcc webkit
+QT4_MAKE_ARGS= INSTALL_ROOT=${STAGEDIR}
+USES= gmake pkgconfig
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS_DEFINE= SNDFILE OGG VORBIS FLAC OPUS SPEEX FAAD FAAC
+OPTIONS_RADIO= DEVICE
+OPTIONS_RADIO_DEVICE= PORTAUDIO PULSEAUDIO
+OPTIONS_DEFAULT= PORTAUDIO SNDFILE
+OPTIONS_SUB= yes
+
+PORTAUDIO_LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+SNDFILE_LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
+
+OGG_LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
+VORBIS_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+OPUS_LIB_DEPENDS= libopus.so:${PORTSDIR}/audio/opus
+SPEEX_LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speexdsp
+FAAD_LIB_DEPENDS= libfaad.so:${PORTSDIR}/audio/faad
+FAAC_LIB_DEPENDS= libfaac.so:${PORTSDIR}/audio/faac
+
+MANDIRS= ${PREFIX}/share/man/man1
+PLIST_FILES= %%QT_BINDIR%%/dream share/man/man1/dream.1.gz
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|/opt|/usr|g' -e 's|/usr/local|${PREFIX}|g'\
+ -e 's|target.path = /usr/bin|target.path = ${STAGEDIR}${QT_BINDIR}|g'\
+ -e 's|/usr/share/man/man1|${STAGEDIR}${PREFIX}/share/man/man1|g'\
+ -e 's|INSTALLS += documentation||g'\
+ ${WRKSRC}/dream.pro
+
+do-configure:
+ cd ${WRKSRC} &&\
+ ${SETENV} ${MAKE_ENV} ${QMAKE} dream.pro ${QMAKE_ARGS}
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/linux/dream.1 ${STAGEDIR}${PREFIX}/share/man/man1/
+
+.include <bsd.port.mk>
diff --git a/audio/dream/distinfo b/audio/dream/distinfo
new file mode 100644
index 000000000000..8d6b06449d7d
--- /dev/null
+++ b/audio/dream/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dream-2.1.1-svn808.tar.gz) = 417734a197ed596a08e75363c304be9b4595f2f21581bc64fec47c49f733bb05
+SIZE (dream-2.1.1-svn808.tar.gz) = 898761
diff --git a/audio/dream/files/patch-src__linux__pa_shm_ringbuffer.c b/audio/dream/files/patch-src__linux__pa_shm_ringbuffer.c
new file mode 100644
index 000000000000..c2d2496dbeb6
--- /dev/null
+++ b/audio/dream/files/patch-src__linux__pa_shm_ringbuffer.c
@@ -0,0 +1,20 @@
+--- src/linux/pa_shm_ringbuffer.c.orig 2013-11-11 16:33:40 UTC
++++ src/linux/pa_shm_ringbuffer.c
+@@ -72,12 +72,13 @@
+ ****************/
+
+ #if defined(__APPLE__) || defined(__FreeBSD__)
+-# include <libkern/OSAtomic.h>
++#include <sys/types.h>
++# include <machine/atomic.h>
+ /* Here are the memory barrier functions. Mac OS X and FreeBSD only provide
+ full memory barriers, so the three types of barriers are the same. */
+-# define PaUtil_FullMemoryBarrier() OSMemoryBarrier()
+-# define PaUtil_ReadMemoryBarrier() OSMemoryBarrier()
+-# define PaUtil_WriteMemoryBarrier() OSMemoryBarrier()
++# define PaUtil_FullMemoryBarrier() mb()
++# define PaUtil_ReadMemoryBarrier() rmb()
++# define PaUtil_WriteMemoryBarrier() wmb()
+ #elif defined(__GNUC__)
+ /* GCC understands volatile asm and "memory" to mean it
+ * should not reorder memory read/writes */
diff --git a/audio/dream/files/patch-src__sound__pa_ringbuffer.c b/audio/dream/files/patch-src__sound__pa_ringbuffer.c
new file mode 100644
index 000000000000..00debdd6be24
--- /dev/null
+++ b/audio/dream/files/patch-src__sound__pa_ringbuffer.c
@@ -0,0 +1,20 @@
+--- src/sound/pa_ringbuffer.c.orig 2013-11-11 16:33:41 UTC
++++ src/sound/pa_ringbuffer.c
+@@ -72,12 +72,13 @@
+ ****************/
+
+ #if defined(__APPLE__) || defined(__FreeBSD__)
+-# include <libkern/OSAtomic.h>
++# include <sys/types.h>
++# include <machine/atomic.h>
+ /* Here are the memory barrier functions. Mac OS X and FreeBSD only provide
+ full memory barriers, so the three types of barriers are the same. */
+-# define PaUtil_FullMemoryBarrier() OSMemoryBarrier()
+-# define PaUtil_ReadMemoryBarrier() OSMemoryBarrier()
+-# define PaUtil_WriteMemoryBarrier() OSMemoryBarrier()
++# define PaUtil_FullMemoryBarrier() mb()
++# define PaUtil_ReadMemoryBarrier() rmb()
++# define PaUtil_WriteMemoryBarrier() wmb()
+ #elif defined(__GNUC__)
+ /* GCC understands volatile asm and "memory" to mean it
+ * should not reorder memory read/writes */
diff --git a/audio/dream/pkg-descr b/audio/dream/pkg-descr
new file mode 100644
index 000000000000..38b49650ed8f
--- /dev/null
+++ b/audio/dream/pkg-descr
@@ -0,0 +1,4 @@
+Open-Source Software Implementation of a DRM (Digital Radio Mondiale) Receiver
+under the GNU General Public License (GPL)
+
+WWW: http://drm.sourceforge.net/wiki/index.php/Main_Page