aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-06-17 19:32:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-06-17 19:32:35 +0000
commitcb6f24a11a03d6a1e827869f69be02ef3a8c1d6e (patch)
tree498da1c0ee350965701f1bfeeb99d42a766434cf
parent86d6e1384e30e94aea7a5cd9ae228279073044a3 (diff)
downloadports-cb6f24a11a03d6a1e827869f69be02ef3a8c1d6e.tar.gz
ports-cb6f24a11a03d6a1e827869f69be02ef3a8c1d6e.zip
Update to 1.5.1
Notes
Notes: svn path=/head/; revision=417027
-rw-r--r--security/py-rekall-core/Makefile8
-rw-r--r--security/py-rekall-core/distinfo5
-rw-r--r--security/py-rekall-core/files/patch-setup.py20
3 files changed, 17 insertions, 16 deletions
diff --git a/security/py-rekall-core/Makefile b/security/py-rekall-core/Makefile
index 16537343fa70..3d577b0a5884 100644
--- a/security/py-rekall-core/Makefile
+++ b/security/py-rekall-core/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rekall-core
-DISTVERSION= 1.5.0.post5
+DISTVERSION= 1.5.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,13 +15,13 @@ LICENSE= GPLv2
RUN_DEPENDS= cabextract:archivers/cabextract \
${PYTHON_PKGNAMEPREFIX}PyAFF4>=0.23:security/py-pyaff4 \
${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}acora>=1.9:textproc/py-acora \
+ ${PYTHON_PKGNAMEPREFIX}acora>=2.0:textproc/py-acora \
${PYTHON_PKGNAMEPREFIX}arrow>=0.7.0:devel/py-arrow \
- ${PYTHON_PKGNAMEPREFIX}efilter>=1453815385:devel/py-efilter \
+ ${PYTHON_PKGNAMEPREFIX}efilter>=1.2,1:devel/py-efilter \
${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree \
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}pyelftools>=0.23:devel/py-pyelftools \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2015.7:devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2016.4,1:devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}capstone>=3.0.4:devel/py-capstone \
${PYTHON_PKGNAMEPREFIX}yara>=3.4.0:security/py-yara \
${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.4.4:devel/py-sortedcontainers \
diff --git a/security/py-rekall-core/distinfo b/security/py-rekall-core/distinfo
index 8bc1fc3cdfc2..5876f021e020 100644
--- a/security/py-rekall-core/distinfo
+++ b/security/py-rekall-core/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rekall-core-1.5.0.post5.zip) = 9de7174702eaab563778c63eed189b5d09a3e7294e34c3df6eca5fd0424d78fc
-SIZE (rekall-core-1.5.0.post5.zip) = 1004205
+TIMESTAMP = 1466191431
+SHA256 (rekall-core-1.5.1.zip) = 6d60d294bac406410a96f024642c42effda480e9d76cb4c04016f626c9c4514b
+SIZE (rekall-core-1.5.1.zip) = 1013069
diff --git a/security/py-rekall-core/files/patch-setup.py b/security/py-rekall-core/files/patch-setup.py
index f966e808b1a6..4b1c809c6105 100644
--- a/security/py-rekall-core/files/patch-setup.py
+++ b/security/py-rekall-core/files/patch-setup.py
@@ -1,4 +1,4 @@
---- setup.py.orig 2016-03-28 15:25:48 UTC
+--- setup.py.orig 2016-05-23 16:08:02 UTC
+++ setup.py
@@ -46,23 +46,22 @@ def find_data_files(source):
# approach ensures that any Rekall version will always work as tested - even
@@ -6,34 +6,34 @@
install_requires = [
- "PyAFF4 >= 0.23, < 0.30",
- "PyYAML == 3.11",
-- "acora == 1.9",
-- "argparse == 1.2.1",
+- "acora == 2.0",
+- "argparse == 1.4.0",
- "arrow == 0.7.0",
-- "efilter == 1453815385",
+- "efilter == 1!1.2",
- "intervaltree == 2.1.0",
- "pycrypto == 2.6.1",
- "pyelftools == 0.23",
-- "pytz == 2015.7",
+- "pytz == 2016.4",
- "rekall-capstone == 3.0.4.post2",
- "rekall-yara == 3.4.0.1",
- "sortedcontainers == 1.4.4",
+ "PyAFF4 >= 0.23",
+ "PyYAML >= 3.11",
-+ "acora >= 1.9",
++ "acora >= 2.0",
+ "arrow >= 0.7.0",
-+ "efilter >= 1453815385",
++ "efilter >= 1!1.2",
+ "intervaltree >= 2.1.0",
+ "pycrypto >= 2.6.1",
+ "pyelftools >= 0.23",
-+ "pytz >= 2015.7",
++ "pytz >= 2016.4",
+ "capstone >= 3.0.4",
+ "yara-python >= 3.4.0",
+ "sortedcontainers >= 1.4.4",
# Version 2.5.0 is broken with pyinstaller.
# https://github.com/pyinstaller/pyinstaller/issues/1848
-- "python-dateutil == 2.4.2",
-+ "python-dateutil >= 2.4.2",
+- "python-dateutil == 2.5.3",
++ "python-dateutil >= 2.5.0",
]