aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-13 20:15:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-13 20:15:05 +0000
commitdd196d18d2947c50011eb5ddd3fffac06df7bd5e (patch)
tree247a9ce13a7ed44cc97b5f00a246f6b53972f218
parentfa5be0d638d9544e0158f9373dd387c91e560029 (diff)
downloadports-dd196d18d2947c50011eb5ddd3fffac06df7bd5e.tar.gz
ports-dd196d18d2947c50011eb5ddd3fffac06df7bd5e.zip
Working with disk to URI file mappings
WWW: http://search.cpan.org/dist/HTML-Location PR: ports/116212 Submitted by: Cory R. King <coryking at mozimedia.com>
Notes
Notes: svn path=/head/; revision=199434
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Location/Makefile31
-rw-r--r--www/p5-HTML-Location/distinfo3
-rw-r--r--www/p5-HTML-Location/pkg-descr3
-rw-r--r--www/p5-HTML-Location/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5f601fb25fd6..91fc50c2b610 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -712,6 +712,7 @@
SUBDIR += p5-HTML-FromText
SUBDIR += p5-HTML-LinkExtractor
SUBDIR += p5-HTML-Lint
+ SUBDIR += p5-HTML-Location
SUBDIR += p5-HTML-Mason
SUBDIR += p5-HTML-Pager
SUBDIR += p5-HTML-Parser
diff --git a/www/p5-HTML-Location/Makefile b/www/p5-HTML-Location/Makefile
new file mode 100644
index 000000000000..b61a8cadd755
--- /dev/null
+++ b/www/p5-HTML-Location/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-HTML-Location
+# Date created: 08 September 2007
+# Whom: coryking
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Location
+PORTVERSION= 1.01
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= coryking@mozimedia.com
+COMMENT= Working with disk to URI file mappings (deprecated: see URI::ToDisk)
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Clone>=0.23:${PORTSDIR}/devel/p5-Clone \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-PathTools>=3.25:${PORTSDIR}/devel/p5-PathTools
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Location.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Location/distinfo b/www/p5-HTML-Location/distinfo
new file mode 100644
index 000000000000..b8ec11ae3abe
--- /dev/null
+++ b/www/p5-HTML-Location/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Location-1.01.tar.gz) = d2efa74e784dc5fe7fc9993d6ca3bd5e
+SHA256 (HTML-Location-1.01.tar.gz) = 0b45d041deb24108f3ec793245370e09a7d435304419b29c0da8da6f87cb7260
+SIZE (HTML-Location-1.01.tar.gz) = 25463
diff --git a/www/p5-HTML-Location/pkg-descr b/www/p5-HTML-Location/pkg-descr
new file mode 100644
index 000000000000..b33a29064899
--- /dev/null
+++ b/www/p5-HTML-Location/pkg-descr
@@ -0,0 +1,3 @@
+Working with disk to URI file mappings (deprecated: see URI::ToDisk)
+
+WWW: http://search.cpan.org/dist/HTML-Location
diff --git a/www/p5-HTML-Location/pkg-plist b/www/p5-HTML-Location/pkg-plist
new file mode 100644
index 000000000000..cba964f88782
--- /dev/null
+++ b/www/p5-HTML-Location/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/HTML/Location.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Location/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/Location
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML