aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-10-09 20:12:37 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-10-09 20:12:37 +0000
commite3bc416b63f238155531b61ce616981d47d38c84 (patch)
treedf0c448dbc117562974b24247812b23cf954e681
parentedc55428ddfad36420254c7210f5aa29565f0806 (diff)
downloadports-e3bc416b63f238155531b61ce616981d47d38c84.tar.gz
ports-e3bc416b63f238155531b61ce616981d47d38c84.zip
Use USE_CSTD=gnu89 to build libxml2.
When build with Clang it tries to use C99 math functions we don't have. Also fix a symbol collision with the python bindings that got exposed by a Clang bug. With hat: gnome
Notes
Notes: svn path=/head/; revision=262707
-rw-r--r--textproc/libxml2/Makefile1
-rw-r--r--textproc/libxml2/files/patch-python_libxml.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 08c2c5a96f0a..786a6f1c59db 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -25,6 +25,7 @@ COMMENT?= XML parser library for GNOME
.if !defined(REFERENCE_PORT)
+USE_CSTD= gnu89
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
USE_ICONV= yes
diff --git a/textproc/libxml2/files/patch-python_libxml.c b/textproc/libxml2/files/patch-python_libxml.c
new file mode 100644
index 000000000000..f45ef6f4ad6d
--- /dev/null
+++ b/textproc/libxml2/files/patch-python_libxml.c
@@ -0,0 +1,11 @@
+--- python/libxml.c.orig 2009-09-24 17:31:59.000000000 +0200
++++ python/libxml.c 2010-10-03 09:34:16.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ #if (defined(_MSC_VER) || defined(__MINGW32__)) && !defined(vsnprintf)
+ #define vsnprintf(b,c,f,a) _vsnprintf(b,c,f,a)
+-#elif defined(WITH_TRIO)
++#elif defined(WITH_TRIO) && !defined(vsnprintf)
+ #include "trio.h"
+ #define vsnprintf trio_vsnprintf
+ #endif