aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2004-08-07 07:00:18 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2004-08-07 07:00:18 +0000
commitf0c20c8b696ebffbd2c36315316636c41712351a (patch)
tree29ce213eb602cf9c4d0da6cb8555ba7b7b70b725
parentbbc1787d3dcc16278efe26af444758780e97c118 (diff)
downloadports-f0c20c8b696ebffbd2c36315316636c41712351a.tar.gz
ports-f0c20c8b696ebffbd2c36315316636c41712351a.zip
- Allow to disable IPv6 support [1]
- Add checksum for 2.4a2 PR: 69950 [1] Submitted by: Marcus Grando <marcus@corp.grupos.com.br>
Notes
Notes: svn path=/head/; revision=115551
-rw-r--r--lang/python/Makefile5
-rw-r--r--lang/python/distinfo2
-rw-r--r--lang/python23/Makefile5
-rw-r--r--lang/python23/distinfo2
-rw-r--r--lang/python24/Makefile5
-rw-r--r--lang/python24/distinfo2
6 files changed, 15 insertions, 6 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index ceac8f7cc0fa..080969a76ebd 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -41,7 +41,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -96,7 +97,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
diff --git a/lang/python/distinfo b/lang/python/distinfo
index 75e2fe4a3663..1bd8185ebc57 100644
--- a/lang/python/distinfo
+++ b/lang/python/distinfo
@@ -21,3 +21,5 @@ MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
MD5 (python/Python-2.4a1.tgz) = 7a69d4e7289e5b16ed205fdfddaf0492
SIZE (python/Python-2.4a1.tgz) = 9024737
+MD5 (python/Python-2.4a2.tgz) = 6cface6d1d6d01c16c7ce0cba31fc860
+SIZE (python/Python-2.4a2.tgz) = 8999009
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index ceac8f7cc0fa..080969a76ebd 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -41,7 +41,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -96,7 +97,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
diff --git a/lang/python23/distinfo b/lang/python23/distinfo
index 75e2fe4a3663..1bd8185ebc57 100644
--- a/lang/python23/distinfo
+++ b/lang/python23/distinfo
@@ -21,3 +21,5 @@ MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
MD5 (python/Python-2.4a1.tgz) = 7a69d4e7289e5b16ed205fdfddaf0492
SIZE (python/Python-2.4a1.tgz) = 9024737
+MD5 (python/Python-2.4a2.tgz) = 6cface6d1d6d01c16c7ce0cba31fc860
+SIZE (python/Python-2.4a2.tgz) = 8999009
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index ceac8f7cc0fa..080969a76ebd 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -41,7 +41,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -96,7 +97,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
diff --git a/lang/python24/distinfo b/lang/python24/distinfo
index 75e2fe4a3663..1bd8185ebc57 100644
--- a/lang/python24/distinfo
+++ b/lang/python24/distinfo
@@ -21,3 +21,5 @@ MD5 (python/Python-2.4.a0.20040311.tgz) = 5619b787ce62a1ebac3c973179d36670
SIZE (python/Python-2.4.a0.20040311.tgz) = 8512702
MD5 (python/Python-2.4a1.tgz) = 7a69d4e7289e5b16ed205fdfddaf0492
SIZE (python/Python-2.4a1.tgz) = 9024737
+MD5 (python/Python-2.4a2.tgz) = 6cface6d1d6d01c16c7ce0cba31fc860
+SIZE (python/Python-2.4a2.tgz) = 8999009