aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-20 01:21:50 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-20 01:21:50 +0000
commit20937d1b035146ca6e32d6e1e84a72079c1e6e97 (patch)
tree8e89bbdcb8c1a04b511fc5a5f82166dbf30c1740
parent05ba336eff60d9334f5646c8a75384d2197cbdf2 (diff)
downloadports-20937d1b035146ca6e32d6e1e84a72079c1e6e97.tar.gz
ports-20937d1b035146ca6e32d6e1e84a72079c1e6e97.zip
Add p5-Data-Entropy 0.000, entropy (randomness) management.
PR: ports/100547 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168293
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Data-Entropy/Makefile39
-rw-r--r--security/p5-Data-Entropy/distinfo3
-rw-r--r--security/p5-Data-Entropy/pkg-descr20
-rw-r--r--security/p5-Data-Entropy/pkg-plist14
5 files changed, 77 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e0def2a35aa2..de62e00835a7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -384,6 +384,7 @@
SUBDIR += p5-Crypt-UnixCrypt
SUBDIR += p5-Crypt-X509
SUBDIR += p5-Crypt-xDBM_File
+ SUBDIR += p5-Data-Entropy
SUBDIR += p5-Data-Password
SUBDIR += p5-Digest
SUBDIR += p5-Digest-Adler32
diff --git a/security/p5-Data-Entropy/Makefile b/security/p5-Data-Entropy/Makefile
new file mode 100644
index 000000000000..686da3d9e481
--- /dev/null
+++ b/security/p5-Data-Entropy/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Data-Entropy
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Entropy
+PORTVERSION= 0.000
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Entropy (randomness) management
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt \
+ ${SITE_PERL}/Math/BigRat.pm:${PORTSDIR}/math/p5-Math-BigRat \
+ ${SITE_PERL}/Params/Classify.pm:${PORTSDIR}/devel/p5-Params-Classify
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Entropy::RawSource::RandomOrg.3 \
+ Data::Entropy::RawSource::CryptCounter.3 \
+ Data::Entropy::Algorithms.3 \
+ Data::Entropy::RawSource::RandomnumbersInfo.3 \
+ Data::Entropy::Source.3 Data::Entropy.3 \
+ Data::Entropy::RawSource::Local.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires Perl 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Data-Entropy/distinfo b/security/p5-Data-Entropy/distinfo
new file mode 100644
index 000000000000..62a7189c7093
--- /dev/null
+++ b/security/p5-Data-Entropy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Entropy-0.000.tar.gz) = 99dde7eea7e3b8f4ff36c469015596b9
+SHA256 (Data-Entropy-0.000.tar.gz) = f3c769b259f5319d22579b3cd29348a567a9ef1ac2c2c56d0a9e88977bf6e63a
+SIZE (Data-Entropy-0.000.tar.gz) = 30851
diff --git a/security/p5-Data-Entropy/pkg-descr b/security/p5-Data-Entropy/pkg-descr
new file mode 100644
index 000000000000..3825452302d4
--- /dev/null
+++ b/security/p5-Data-Entropy/pkg-descr
@@ -0,0 +1,20 @@
+This module maintains a concept of a current selection of entropy
+source. Algorithms that require entropy can use the source nominated
+by this module, avoiding the need for entropy source objects to be
+explicitly passed around. This is convenient because usually one
+entropy source will be used for an entire program run and so an
+explicit entropy source parameter would rarely vary. There is also a
+default entropy source, avoiding the need to explicitly configure a
+source at all.
+
+If nothing is done to set a source then it defaults to the use of
+Rijndael (AES) in counter mode (see
+Data::Entropy::RawSource::CryptCounter and Crypt::Rijndael), keyed
+using Perl's built-in rand function. This gives a data stream that
+looks like concentrated entropy, but really only has at most the
+entropy of the rand seed. Within a single run it is cryptographically
+difficult to detect the correlation between parts of the
+pseudo-entropy stream. If more true entropy is required then it is
+necessary to configure a different entropy source.
+
+WWW: http://search.cpan.org/dist/Data-Entropy/
diff --git a/security/p5-Data-Entropy/pkg-plist b/security/p5-Data-Entropy/pkg-plist
new file mode 100644
index 000000000000..c52fea162368
--- /dev/null
+++ b/security/p5-Data-Entropy/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Entropy/.packlist
+%%SITE_PERL%%/Data/Entropy.pm
+%%SITE_PERL%%/Data/Entropy/Algorithms.pm
+%%SITE_PERL%%/Data/Entropy/RawSource/CryptCounter.pm
+%%SITE_PERL%%/Data/Entropy/RawSource/Local.pm
+%%SITE_PERL%%/Data/Entropy/RawSource/RandomOrg.pm
+%%SITE_PERL%%/Data/Entropy/RawSource/RandomnumbersInfo.pm
+%%SITE_PERL%%/Data/Entropy/Source.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Entropy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data/Entropy/RawSource
+@dirrmtry %%SITE_PERL%%/Data/Entropy
+@dirrmtry %%SITE_PERL%%/Data