aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-05-12 11:52:46 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-05-12 11:52:46 +0000
commitedd8e4df1b1960d13dfbd57c4bd7e5382899777e (patch)
treef735bad3ae7e01f089ef272053979da279759212
parent0819bd2142f4fef925c30ad2eb2afbfd963a8162 (diff)
downloadports-edd8e4df1b1960d13dfbd57c4bd7e5382899777e.tar.gz
ports-edd8e4df1b1960d13dfbd57c4bd7e5382899777e.zip
Make this compile.
Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Notes
Notes: svn path=/head/; revision=18813
-rw-r--r--x11-toolkits/gtk--/files/patch-ah11
-rw-r--r--x11-toolkits/gtk--/pkg-plist1
-rw-r--r--x11-toolkits/gtk--2/files/patch-ah11
-rw-r--r--x11-toolkits/gtk--2/pkg-plist1
-rw-r--r--x11-toolkits/gtkmm12/files/patch-ah11
-rw-r--r--x11-toolkits/gtkmm12/pkg-plist1
-rw-r--r--x11-toolkits/gtkmm20/files/patch-ah11
-rw-r--r--x11-toolkits/gtkmm20/pkg-plist1
-rw-r--r--x11-toolkits/gtkmm24/files/patch-ah11
-rw-r--r--x11-toolkits/gtkmm24/pkg-plist1
-rw-r--r--x11-toolkits/gtkmm30/files/patch-ah11
-rw-r--r--x11-toolkits/gtkmm30/pkg-plist1
12 files changed, 72 insertions, 0 deletions
diff --git a/x11-toolkits/gtk--/files/patch-ah b/x11-toolkits/gtk--/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtk--/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtk--/pkg-plist b/x11-toolkits/gtk--/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtk--/pkg-plist
+++ b/x11-toolkits/gtk--/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true
diff --git a/x11-toolkits/gtk--2/files/patch-ah b/x11-toolkits/gtk--2/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtk--2/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtk--2/pkg-plist b/x11-toolkits/gtk--2/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtk--2/pkg-plist
+++ b/x11-toolkits/gtk--2/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true
diff --git a/x11-toolkits/gtkmm12/files/patch-ah b/x11-toolkits/gtkmm12/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtkmm12/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtkmm12/pkg-plist b/x11-toolkits/gtkmm12/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtkmm12/pkg-plist
+++ b/x11-toolkits/gtkmm12/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true
diff --git a/x11-toolkits/gtkmm20/files/patch-ah b/x11-toolkits/gtkmm20/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtkmm20/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtkmm20/pkg-plist b/x11-toolkits/gtkmm20/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtkmm20/pkg-plist
+++ b/x11-toolkits/gtkmm20/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true
diff --git a/x11-toolkits/gtkmm24/files/patch-ah b/x11-toolkits/gtkmm24/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtkmm24/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtkmm24/pkg-plist b/x11-toolkits/gtkmm24/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtkmm24/pkg-plist
+++ b/x11-toolkits/gtkmm24/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true
diff --git a/x11-toolkits/gtkmm30/files/patch-ah b/x11-toolkits/gtkmm30/files/patch-ah
new file mode 100644
index 000000000000..9f278686ff69
--- /dev/null
+++ b/x11-toolkits/gtkmm30/files/patch-ah
@@ -0,0 +1,11 @@
+--- gdk--/gdk--/window.cc.orig Mon May 10 00:08:58 1999
++++ gdk--/gdk--/window.cc Mon May 10 00:24:00 1999
+@@ -57,7 +57,7 @@
+ Gdk_Window::Gdk_Window(const Gdk_WindowAttr &attributes,
+ gint attributes_mask):Gdk_Drawable(0)
+ {
+- create(NULL,attributes,attributes_mask);
++ create((Gdk_Window &)gdk_root_parent,attributes,attributes_mask);
+ }
+
+ Gdk_Window::~Gdk_Window()
diff --git a/x11-toolkits/gtkmm30/pkg-plist b/x11-toolkits/gtkmm30/pkg-plist
index 4fc958e96bab..4d4ac7b0dd6b 100644
--- a/x11-toolkits/gtkmm30/pkg-plist
+++ b/x11-toolkits/gtkmm30/pkg-plist
@@ -208,3 +208,4 @@ share/aclocal/gtk--.m4
@dirrm include/gtk--
@dirrm include/gdk--/extra
@dirrm include/gdk--
+@unexec rmdir %D/share/aclocal 2>/dev/null || true