aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>1999-06-02 06:14:11 +0000
committerMichael Haro <mharo@FreeBSD.org>1999-06-02 06:14:11 +0000
commitf54bf74009179fd2a416223a0347c7890f1927f2 (patch)
treeed0a5bdb1d27f11f8066b16383b9cb236bd2edeb
parent149f65234ee10d8385bda46cd9c650369f816e5e (diff)
downloadports-f54bf74009179fd2a416223a0347c7890f1927f2.tar.gz
ports-f54bf74009179fd2a416223a0347c7890f1927f2.zip
TTCP is a benchmarking tool for determining TCP and UDP performance
between two systems. I could never remember where to get it, others may find it useful to have in the ports collection too.
Notes
Notes: svn path=/head/; revision=19170
-rw-r--r--benchmarks/ttcp/Makefile34
-rw-r--r--benchmarks/ttcp/distinfo3
-rw-r--r--benchmarks/ttcp/pkg-comment1
-rw-r--r--benchmarks/ttcp/pkg-descr14
-rw-r--r--benchmarks/ttcp/pkg-plist3
-rw-r--r--net/ttcp/Makefile34
-rw-r--r--net/ttcp/distinfo3
-rw-r--r--net/ttcp/pkg-comment1
-rw-r--r--net/ttcp/pkg-descr14
-rw-r--r--net/ttcp/pkg-plist3
10 files changed, 110 insertions, 0 deletions
diff --git a/benchmarks/ttcp/Makefile b/benchmarks/ttcp/Makefile
new file mode 100644
index 000000000000..f5adb140179c
--- /dev/null
+++ b/benchmarks/ttcp/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ttcp
+# Version required: 1.12
+# Date created: Tue Jun 1 22:58:13 PDT 1999
+# Whom: mharo@FreeBSD.org
+#
+# $Id$
+#
+
+DISTNAME= ttcp-1.12
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.sgi.com/sgi/src/ttcp/
+DISTFILES= ttcp.c ttcp.1 README
+
+MAINTAINER= mharo@FreeBSD.org
+
+EXTRACT_ONLY= #none
+NO_WRKSUBDIR= yes
+MAN1= ttcp.1
+
+post-extract:
+ ${CP} ${DISTDIR}/ttcp.c ${WRKSRC}/
+ ${CP} ${DISTDIR}/ttcp.1 ${WRKSRC}/
+ ${CP} ${DISTDIR}/README ${WRKSRC}/
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/ttcp ${WRKSRC}/ttcp.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ttcp ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ttcp.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/ttcp
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ttcp/
+
+.include <bsd.port.mk>
diff --git a/benchmarks/ttcp/distinfo b/benchmarks/ttcp/distinfo
new file mode 100644
index 000000000000..980bbb75dedb
--- /dev/null
+++ b/benchmarks/ttcp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ttcp.c) = 3d1b75f6116cc246a4def9788ce58c26
+MD5 (ttcp.1) = 01d3a511a05dc8a0669f30c15ebaae82
+MD5 (README) = 6b1e5ff6247a9f284f3b58eb651b37a9
diff --git a/benchmarks/ttcp/pkg-comment b/benchmarks/ttcp/pkg-comment
new file mode 100644
index 000000000000..d97cd17c584d
--- /dev/null
+++ b/benchmarks/ttcp/pkg-comment
@@ -0,0 +1 @@
+TTCP is a benchmarking tool for determining TCP and UDP performance
diff --git a/benchmarks/ttcp/pkg-descr b/benchmarks/ttcp/pkg-descr
new file mode 100644
index 000000000000..a90ba3f06dd1
--- /dev/null
+++ b/benchmarks/ttcp/pkg-descr
@@ -0,0 +1,14 @@
+TTCP is a benchmarking tool for determining TCP and UDP performance
+between 2 systems.
+
+The program was created at the US Army Ballistics Research Lab (BRL)
+and is in the public domain. Feel free to distribute this program
+but please do leave the credit notices in the source and man page intact.
+
+How to get TCP performance numbers:
+
+ receiver sender
+
+host1% ttcp -r -s host2% ttcp -t -s host1
+
+-n and -l options change the number and size of the buffers.
diff --git a/benchmarks/ttcp/pkg-plist b/benchmarks/ttcp/pkg-plist
new file mode 100644
index 000000000000..5d2266f36ebd
--- /dev/null
+++ b/benchmarks/ttcp/pkg-plist
@@ -0,0 +1,3 @@
+bin/ttcp
+share/doc/ttcp/README
+@dirrm share/doc/ttcp
diff --git a/net/ttcp/Makefile b/net/ttcp/Makefile
new file mode 100644
index 000000000000..f5adb140179c
--- /dev/null
+++ b/net/ttcp/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ttcp
+# Version required: 1.12
+# Date created: Tue Jun 1 22:58:13 PDT 1999
+# Whom: mharo@FreeBSD.org
+#
+# $Id$
+#
+
+DISTNAME= ttcp-1.12
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.sgi.com/sgi/src/ttcp/
+DISTFILES= ttcp.c ttcp.1 README
+
+MAINTAINER= mharo@FreeBSD.org
+
+EXTRACT_ONLY= #none
+NO_WRKSUBDIR= yes
+MAN1= ttcp.1
+
+post-extract:
+ ${CP} ${DISTDIR}/ttcp.c ${WRKSRC}/
+ ${CP} ${DISTDIR}/ttcp.1 ${WRKSRC}/
+ ${CP} ${DISTDIR}/README ${WRKSRC}/
+
+do-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/ttcp ${WRKSRC}/ttcp.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ttcp ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ttcp.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/ttcp
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ttcp/
+
+.include <bsd.port.mk>
diff --git a/net/ttcp/distinfo b/net/ttcp/distinfo
new file mode 100644
index 000000000000..980bbb75dedb
--- /dev/null
+++ b/net/ttcp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ttcp.c) = 3d1b75f6116cc246a4def9788ce58c26
+MD5 (ttcp.1) = 01d3a511a05dc8a0669f30c15ebaae82
+MD5 (README) = 6b1e5ff6247a9f284f3b58eb651b37a9
diff --git a/net/ttcp/pkg-comment b/net/ttcp/pkg-comment
new file mode 100644
index 000000000000..d97cd17c584d
--- /dev/null
+++ b/net/ttcp/pkg-comment
@@ -0,0 +1 @@
+TTCP is a benchmarking tool for determining TCP and UDP performance
diff --git a/net/ttcp/pkg-descr b/net/ttcp/pkg-descr
new file mode 100644
index 000000000000..a90ba3f06dd1
--- /dev/null
+++ b/net/ttcp/pkg-descr
@@ -0,0 +1,14 @@
+TTCP is a benchmarking tool for determining TCP and UDP performance
+between 2 systems.
+
+The program was created at the US Army Ballistics Research Lab (BRL)
+and is in the public domain. Feel free to distribute this program
+but please do leave the credit notices in the source and man page intact.
+
+How to get TCP performance numbers:
+
+ receiver sender
+
+host1% ttcp -r -s host2% ttcp -t -s host1
+
+-n and -l options change the number and size of the buffers.
diff --git a/net/ttcp/pkg-plist b/net/ttcp/pkg-plist
new file mode 100644
index 000000000000..5d2266f36ebd
--- /dev/null
+++ b/net/ttcp/pkg-plist
@@ -0,0 +1,3 @@
+bin/ttcp
+share/doc/ttcp/README
+@dirrm share/doc/ttcp