aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-04-20 20:00:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-04-20 20:00:16 +0000
commit47d1ff02187ea8d825d0af69e7faf4edfddaaaa5 (patch)
treec3a546eb4a39beb11fd73a8d2428ae189005b056
parent2a4bcaef5bbb7de0d60ddf4033d46f2e7fe63188 (diff)
downloadports-47d1ff02187ea8d825d0af69e7faf4edfddaaaa5.tar.gz
ports-47d1ff02187ea8d825d0af69e7faf4edfddaaaa5.zip
Update from 0.8.3 to 0.8.3.1 -- some of my patches were quietly incorporated
and the 0.8.3 is no longer available.
Notes
Notes: svn path=/head/; revision=107749
-rw-r--r--databases/dbf/Makefile2
-rw-r--r--databases/dbf/distinfo4
-rw-r--r--databases/dbf/files/patch-dbf.c14
3 files changed, 10 insertions, 10 deletions
diff --git a/databases/dbf/Makefile b/databases/dbf/Makefile
index 5e488a839e35..9b1af36282ae 100644
--- a/databases/dbf/Makefile
+++ b/databases/dbf/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dbf
-PORTVERSION= 0.8.3
+PORTVERSION= 0.8.3.1
CATEGORIES= databases
MASTER_SITES= http://download.berlios.de/dbf/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/databases/dbf/distinfo b/databases/dbf/distinfo
index faf65c535916..72d8fe5419b9 100644
--- a/databases/dbf/distinfo
+++ b/databases/dbf/distinfo
@@ -1,2 +1,2 @@
-MD5 (dbf-0.8.3.src.tar.gz) = e12b56f007566294e76235c8b0890135
-SIZE (dbf-0.8.3.src.tar.gz) = 26057
+MD5 (dbf-0.8.3.1.src.tar.gz) = d3e4d93ce6c956e52d12c92fba29c376
+SIZE (dbf-0.8.3.1.src.tar.gz) = 26054
diff --git a/databases/dbf/files/patch-dbf.c b/databases/dbf/files/patch-dbf.c
index 2f78adce4eb5..c79a8ed3f854 100644
--- a/databases/dbf/files/patch-dbf.c
+++ b/databases/dbf/files/patch-dbf.c
@@ -4,7 +4,7 @@
int dbfhandle;
FILE *output = NULL;
int header_length, record_length, i;
-- const char *filename, *export_filename;
+- const char *filename = NULL, *export_filename = NULL;
+ const char *filename, *export_filename = NULL;
headerMethod writeHeader = NULL;
lineMethod writeLine = printDBF;
@@ -14,15 +14,15 @@
if (argc < 2) {
fprintf(stderr, "Usage: %s [option][argument] dbf-file, -h for help\n", *argv);
-@@ -342,7 +342,7 @@
+@@ -342,7 +342,4 @@
if (verbosity > 0)
banner();
-- if(0 == strcmp(export_filename, "-"))
-+ if(!export_filename || (0 == strcmp(export_filename, "-")))
- output = stdout;
- else
- output = export_open(export_filename);
+- if(export_filename && 0 == strcmp(export_filename, "-"))
+- output = stdout;
+- else
+- output = export_open(export_filename);
++ output = export_open(export_filename);
@@ -372,12 +372,7 @@
/* At this point we look if the following data set is deleted */
lseek(dbfhandle, rotate2b(db->header_length), SEEK_SET);