aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-04-20 20:30:43 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-04-20 20:30:43 +0000
commita04d79b29e66fdf709836333bfb490b027e83c51 (patch)
tree7387abd8425197dde6c9f037c6f8961ad76c1e4c
parent47d1ff02187ea8d825d0af69e7faf4edfddaaaa5 (diff)
downloadports-a04d79b29e66fdf709836333bfb490b027e83c51.tar.gz
ports-a04d79b29e66fdf709836333bfb490b027e83c51.zip
- Disable the use of mlockall(2) on all version of FreeBSD again (see PR 62930
for a description of the problem). Appears to be a machine-dependant issue as I only see it on one box. - Replace the default path to the rscsi binary in the rscsi client library with the correct location (why did this ever work?). Submitted by: marius (maintainer)
Notes
Notes: svn path=/head/; revision=107750
-rw-r--r--sysutils/cdrtools-devel/Makefile5
-rw-r--r--sysutils/cdrtools-devel/files/patch-conf::configure10
2 files changed, 13 insertions, 2 deletions
diff --git a/sysutils/cdrtools-devel/Makefile b/sysutils/cdrtools-devel/Makefile
index 316d773da7b0..85dfd5b8c55e 100644
--- a/sysutils/cdrtools-devel/Makefile
+++ b/sysutils/cdrtools-devel/Makefile
@@ -8,7 +8,7 @@
PORTNAME?= cdrtools
CDRTLSVERSION= 2.01a27
PORTVERSION?= ${CDRTLSVERSION}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= sysutils audio
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/alpha/ \
ftp://ftp.cs.tu-berlin.de/pub/misc/cdrecord/alpha/
@@ -101,7 +101,8 @@ post-patch:
.endif
.for i in README.rscsi include/deflts.h cdda2wav/cdda2wav.1 \
cdrecord/cdrecord.1 cdrecord/cdrecord.dfl cdrecord/defaults.c \
- readcd/readcd.1 rscsi/rscsi.c rscsi/rscsi.dfl scgcheck/scgcheck.1
+ librscg/scsi-remote.c readcd/readcd.1 rscsi/rscsi.c rscsi/rscsi.dfl \
+ scgcheck/scgcheck.1
@${REINPLACE_CMD} -e 's|\/opt\/schily|${PREFIX}|g; \
s|\/usr\/local|${PREFIX}|g; s|\/etc\/default|${PREFIX}\/etc|g; \
s|\/var\/adm\/messages|\/var\/run\/dmesg.boot|g' ${WRKSRC}/${i}
diff --git a/sysutils/cdrtools-devel/files/patch-conf::configure b/sysutils/cdrtools-devel/files/patch-conf::configure
new file mode 100644
index 000000000000..eda23804083c
--- /dev/null
+++ b/sysutils/cdrtools-devel/files/patch-conf::configure
@@ -0,0 +1,10 @@
+--- conf/configure.orig Fri Sep 19 16:47:37 2003
++++ conf/configure Fri Sep 19 16:49:26 2003
+@@ -5567,6 +5567,7 @@
+ int
+ main()
+ {
++ exit(1);
+ if (mlockall(MCL_CURRENT|MCL_FUTURE) < 0) {
+ if (errno == EINVAL || errno == ENOMEM ||
+ errno == EPERM || errno == EACCES)