aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-09-22 01:59:06 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-09-22 01:59:06 +0000
commite088a4f458f3d17260f32449bd6d1f816c2d8df1 (patch)
tree6e18eff901e2521afb1db2785a9e9f659f1f6e7c
parenta96ff3698210fd43ea1a81e6142d74d260669540 (diff)
downloadports-e088a4f458f3d17260f32449bd6d1f816c2d8df1.tar.gz
ports-e088a4f458f3d17260f32449bd6d1f816c2d8df1.zip
Update all ports using OpenSSL and RSA to work without rsaref since
it is no longer required. Apologies to the various maintainers whom I did not yet hear back from, but the ports freeze is coming up in a few hours and I will be verifying all of these ports on a 4.1 machine myself to catch any problems.
Notes
Notes: svn path=/head/; revision=32957
-rw-r--r--archivers/hpack.non-usa.only/Makefile1
-rw-r--r--ftp/curl/Makefile11
-rw-r--r--ftp/pavuk/Makefile11
-rw-r--r--japanese/w3m-ssl/Makefile2
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/pine4-ssl/Makefile9
-rw-r--r--mail/zmailer/Makefile2
-rw-r--r--net-im/gale/Makefile3
-rw-r--r--net/SSLtelnet/Makefile2
-rw-r--r--net/gale/Makefile3
-rw-r--r--net/pipsecd/Makefile2
-rw-r--r--net/tund/Makefile2
-rw-r--r--russian/apache13-modssl/Makefile2
-rw-r--r--security/bjorb/Makefile2
-rw-r--r--security/cyrus-sasl/Makefile2
-rw-r--r--security/cyrus-sasl2/Makefile2
-rw-r--r--security/keynote/Makefile2
-rw-r--r--security/openssh/Makefile5
-rw-r--r--security/pgp/Makefile63
-rw-r--r--security/racoon/Makefile2
-rw-r--r--security/racoon2/Makefile2
-rw-r--r--security/slush/Makefile2
-rw-r--r--security/sslproxy/Makefile2
-rw-r--r--security/sslwrap/Makefile2
-rw-r--r--security/stunnel/Makefile2
-rw-r--r--security/zebedee/Makefile2
-rw-r--r--www/apache13-modssl/Makefile2
-rw-r--r--www/apache13-ssl/Makefile13
-rw-r--r--www/lynx-ssl/Makefile2
-rw-r--r--www/w3m-ssl/Makefile2
-rw-r--r--www/w3m/Makefile3
33 files changed, 44 insertions, 124 deletions
diff --git a/archivers/hpack.non-usa.only/Makefile b/archivers/hpack.non-usa.only/Makefile
index ca0866dcaccf..26c57f451b74 100644
--- a/archivers/hpack.non-usa.only/Makefile
+++ b/archivers/hpack.non-usa.only/Makefile
@@ -13,7 +13,6 @@ DISTNAME= hpack79src
MAINTAINER= ache@FreeBSD.org
-RESTRICTED= "Using this code inside USA will violate RSA patents"
NO_WRKSUBDIR= yes
MAKEFILE= makefile
ALL_TARGET= freebsd
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 277e77bf4930..473ed01e3337 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -26,21 +26,14 @@ SHLIB_VER= 0
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-.if defined(WITH_SSL)
-USE_OPENSSL= RSA
-.endif
-
.include <bsd.port.pre.mk>
-.if defined(USE_OPENSSL)
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
CONFIGURE_ENV+= CPPFLAGS='-I${OPENSSLINC} -I${OPENSSLINC}/openssl' \
LDFLAGS='-L${OPENSSLLIB}'
.endif
-.if defined(OPENSSL_RSAREF)
-CONFIGURE_ENV+= LIBS="-L${OPENSSLLIB} -lcrypto -lRSAglue -L${LOCALBASE}/lib -lrsaref"
-.endif
-
GNU_CONFIGURE= yes
USE_AUTOMAKE= yes
MAKEFILES= Makefile src/Makefile
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index d7e5e6cedf64..708b555ffb9f 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -30,18 +30,11 @@ USE_XPM= yes
USE_GMAKE= yes
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(OPENSSL_RSAREF)
-CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -lRSAglue -L${LOCALBASE}/lib -lrsaref" \
- OPENSSLLIB=${OPENSSLLIB}
-.endif
-
MAN1= pavuk.1
do-install:
@@ -64,4 +57,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/w3m-ssl/Makefile b/japanese/w3m-ssl/Makefile
index c065707cd195..922080f36f76 100644
--- a/japanese/w3m-ssl/Makefile
+++ b/japanese/w3m-ssl/Makefile
@@ -13,6 +13,6 @@ PKGDIR= ${.CURDIR}/pkg
PLIST= ${MASTERDIR}/pkg/PLIST.ja
JAPANESE= Yes
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include "${MASTERDIR}/Makefile"
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index ad7391e1f30b..acefcf5db0fc 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
CFLAGS+= -I${PREFIX}/include/ncurses
.endif
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.endif
.if defined(WITH_DOCS)
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
diff --git a/mail/pine4-ssl/Makefile b/mail/pine4-ssl/Makefile
index c9692141bcef..ce65eb1debca 100644
--- a/mail/pine4-ssl/Makefile
+++ b/mail/pine4-ssl/Makefile
@@ -33,19 +33,12 @@ FILESDIR= ${.CURDIR}/files
EXTRA_PATCHES= ${FILESDIR}/extrapatch-*
-USE_OPENSSL= RSA
-
-.include <bsd.port.pre.mk>
+USE_OPENSSL= YES
post-extract:
( cd ${WRKSRC} ; tar xfz ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} )
do-build:
-.if defined(OPENSSL_RSAREF)
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf EXTRAAUTHENTICATORS=ssl RSAREF=yes)
-.else
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ./build bsf EXTRAAUTHENTICATORS=ssl)
-.endif
-PRE_MK_INCLUDED= yes
.include "${MASTERDIR}/Makefile"
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index 31aeca3651ab..ce6c73aad666 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= veers@disturbed.net
GNU_CONFIGURE= yes
.if defined(WITH_SSL)
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
CONFIGURE_ARGS= --with-openssl
.else
CONFIGURE_ARGS= --without-openssl
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index 9d5dcf74bb3d..36255112a44a 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -14,9 +14,6 @@ MAINTAINER= peterh@sapros.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
-.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
-LIB_DEPENDS+= rsaref.2:${PORTSDIR}/security/rsaref
-.endif
GNU_CONFIGURE= yes
diff --git a/net/SSLtelnet/Makefile b/net/SSLtelnet/Makefile
index ebee85a0588a..c8669f9387bb 100644
--- a/net/SSLtelnet/Makefile
+++ b/net/SSLtelnet/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
MAINTAINER= issei@jp.FreeBSD.org
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.if !defined(BATCH)
INSTALL_TARGET= install certificate
diff --git a/net/gale/Makefile b/net/gale/Makefile
index 9d5dcf74bb3d..36255112a44a 100644
--- a/net/gale/Makefile
+++ b/net/gale/Makefile
@@ -14,9 +14,6 @@ MAINTAINER= peterh@sapros.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
-.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
-LIB_DEPENDS+= rsaref.2:${PORTSDIR}/security/rsaref
-.endif
GNU_CONFIGURE= yes
diff --git a/net/pipsecd/Makefile b/net/pipsecd/Makefile
index 134298d70af9..4669a63b9127 100644
--- a/net/pipsecd/Makefile
+++ b/net/pipsecd/Makefile
@@ -14,7 +14,7 @@ DISTNAME= pipsec-19991014
MAINTAINER= patrick@mindstep.com
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
ALL_TARGET= pipsecd
diff --git a/net/tund/Makefile b/net/tund/Makefile
index 7e3c72a870dc..cc911bb967a3 100644
--- a/net/tund/Makefile
+++ b/net/tund/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ftp://ftp.chg.ru/pub/networking/freebsd/
MAINTAINER= ks@itp.ac.ru
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
MAN8= tund.8
MANCOMPRESSED= yes
diff --git a/russian/apache13-modssl/Makefile b/russian/apache13-modssl/Makefile
index 29ca62d4f1ae..6ef4d6b31f25 100644
--- a/russian/apache13-modssl/Makefile
+++ b/russian/apache13-modssl/Makefile
@@ -29,7 +29,7 @@ MAINTAINER= dima@Chg.RU
BUILD_DEPENDS= mm-config:${PORTSDIR}/devel/mm \
${LOCALBASE}/lib/libmm.a:${PORTSDIR}/devel/mm
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
diff --git a/security/bjorb/Makefile b/security/bjorb/Makefile
index 8e5fdc13ec00..1e8c1528f74d 100644
--- a/security/bjorb/Makefile
+++ b/security/bjorb/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ftp://ftp.hitachi-ms.co.jp/pub/bjorb/
MAINTAINER= issei@jp.FreeBSD.org
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.if !defined(BATCH)
INSTALL_TARGET= install certificate
diff --git a/security/cyrus-sasl/Makefile b/security/cyrus-sasl/Makefile
index ae2a1b27b0db..ca02d8727d80 100644
--- a/security/cyrus-sasl/Makefile
+++ b/security/cyrus-sasl/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= stb/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail
MAINTAINER= hetzels@westbend.net
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
INSTALLS_SHLIB= yes
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index ae2a1b27b0db..ca02d8727d80 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= stb/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail
MAINTAINER= hetzels@westbend.net
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
INSTALLS_SHLIB= yes
diff --git a/security/keynote/Makefile b/security/keynote/Makefile
index 6ef6cfcbfbba..92c267649532 100644
--- a/security/keynote/Makefile
+++ b/security/keynote/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.cis.upenn.edu/~angelos/Code/
MAINTAINER= kris@FreeBSD.org
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 9be0d009e818..c0aec37774de 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -16,14 +16,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= green@FreeBSD.org
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
-.if defined(OPENSSL_RSAREF)
-CRYPTOLIBS+= -lRSAglue -L${LOCALBASE}/lib -lrsaref
-.endif
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= DESTDIR=${PREFIX} MANDIR=/man/man CRYPTOLIBS="${CRYPTOLIBS}"
.if ${OSVERSION} < 400014
diff --git a/security/pgp/Makefile b/security/pgp/Makefile
index 1f7bc50bcaa8..e2e7b5141299 100644
--- a/security/pgp/Makefile
+++ b/security/pgp/Makefile
@@ -5,76 +5,41 @@
# $FreeBSD$
#
-# Pick an initial default, else it doesn't get set in the INDEX.
+PORTNAME= pgp
+PORTVERSION= 2.6.3i
CATEGORIES= security
-DISTNAME= pgp262s
+MASTER_SITES= ftp://ftp.ifi.uio.no/pub/pgp/2.x/src/ \
+ ftp://ftp.kiarchive.ru/pub/unix/crypto/pgp/
+DISTNAME= pgp263is
MAINTAINER= ache@FreeBSD.org
-# Need to define USA_RESIDENT to YES or NO
-IS_INTERACTIVE= YES
-RESTRICTED= "Crypto"
+WRKSRC= ${WRKDIR}/src
+FILESDIR= ${.CURDIR}/files.non_usa
+PATCHDIR= ${.CURDIR}/patches.non_usa
+
MAKEFILE= makefile
ALL_TARGET= freebsd-${MACHINE_ARCH} OS_CFLAGS="${CFLAGS}"
PGPLIB= ${PREFIX}/lib/pgp
MAN1= pgp.1
do-install:
- cd ${WRKSRC}; install -c -o bin -g bin -m 555 pgp ${PREFIX}/bin
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} -c -o bin -g bin -m 555 pgp ${PREFIX}/bin
cd ${WRKSRC}/../doc; \
- install -c -o bin -g bin -m 444 pgp.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} -c -o bin -g bin -m 444 pgp.1 ${PREFIX}/man/man1
-${MKDIR} ${PGPLIB}
${CHMOD} 555 ${PGPLIB}
cd ${WRKSRC}/..; \
- install -c -o bin -g bin -m 444 pgp.hlp \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 pgp.hlp \
doc/pgpdoc1.txt doc/pgpdoc2.txt ${PGPLIB}; \
[ -f ${PGPLIB}/language.txt ] || \
- install -c -o bin -g bin -m 444 language.txt ${PGPLIB}; \
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 language.txt ${PGPLIB}; \
[ -f ${PGPLIB}/config.txt ] || \
- install -c -o bin -g bin -m 444 config.txt ${PGPLIB}
+ ${INSTALL_DATA} -c -o bin -g bin -m 444 config.txt ${PGPLIB}
-${PREFIX}/bin/pgp > /dev/null 2>&1 # update .idx file
-.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
-pre-fetch:
- @${ECHO_MSG}
- @${ECHO_MSG} You must set variable USA_RESIDENT to YES, if you are USA resident
- @${ECHO_MSG} or to NO, if you aren\'t USA resident to build this package
- @${FALSE}
-.elif defined(USA_RESIDENT)
-.if ${USA_RESIDENT} == YES
-PORTNAME= pgp
-PORTVERSION= 2.6.2
-MASTER_SITES= ftp://utopia.hacktic.nl/pub/crypto/pgp/unix/
-DISTNAME= pgp262s
-
-WRKSRC= ${WRKDIR}/src
-BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
-LIB_DEPENDS+= rsaref.2:${PORTSDIR}/security/rsaref
-USE_ZIP= yes
-FILESDIR= ${.CURDIR}/files.usa
-PATCHDIR= ${.CURDIR}/patches.usa
-
-post-extract:
- cd ${WRKDIR}; $(EXTRACT_CMD) $(EXTRACT_BEFORE_ARGS) -aa $(DISTNAME)i \
- $(EXTRACT_AFTER_ARGS)
- cd ${WRKDIR}; ${RM} -f *.zip
-
-.else
-PORTNAME= pgp
-PORTVERSION= 2.6.3ia
-MASTER_SITES= ftp://ftp.ifi.uio.no/pub/pgp/2.x/src/ \
- ftp://ftp.kiarchive.ru/pub/unix/crypto/pgp/
-DISTNAME= pgp263is
-
-WRKSRC= ${WRKDIR}/src
-FILESDIR= ${.CURDIR}/files.non_usa
-PATCHDIR= ${.CURDIR}/patches.non_usa
-
post-extract:
cd ${WRKDIR}; $(TAR) -xf pgp263ii.tar; \
${RM} -f pgp263ii.tar
-.endif
-.endif
-
.include <bsd.port.mk>
diff --git a/security/racoon/Makefile b/security/racoon/Makefile
index 90ae5588926e..f501a13b3362 100644
--- a/security/racoon/Makefile
+++ b/security/racoon/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= sumikawa@FreeBSD.org
BROKEN= "You must upgrade the OS"
.endif
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/${DISTNAME}/racoon
GNU_CONFIGURE= yes
diff --git a/security/racoon2/Makefile b/security/racoon2/Makefile
index 90ae5588926e..f501a13b3362 100644
--- a/security/racoon2/Makefile
+++ b/security/racoon2/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= sumikawa@FreeBSD.org
BROKEN= "You must upgrade the OS"
.endif
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/${DISTNAME}/racoon
GNU_CONFIGURE= yes
diff --git a/security/slush/Makefile b/security/slush/Makefile
index 9671c98df0b8..d491540026ea 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= shipley@dis.org
GNU_CONFIGURE= yes
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 300000
diff --git a/security/sslproxy/Makefile b/security/sslproxy/Makefile
index 9a088df68229..433640077415 100644
--- a/security/sslproxy/Makefile
+++ b/security/sslproxy/Makefile
@@ -13,7 +13,7 @@ DISTNAME= sslproxy.2000_Jan_29
MAINTAINER= alexlh@funk.org
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sslproxy ${PREFIX}/bin/sslproxy
diff --git a/security/sslwrap/Makefile b/security/sslwrap/Makefile
index cc8c4b09bd6b..fe99fad94b32 100644
--- a/security/sslwrap/Makefile
+++ b/security/sslwrap/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ZGabor@CoDe.HU
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
WRKSRC= ${WRKDIR}/sslwrap205
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 61e0da16f39a..0061ad465abe 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -17,7 +17,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= martti.kuparinen@ericsson.com
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
USE_AUTOCONF= yes
CONFIGURE_ARGS= --localstatedir=/var/run
diff --git a/security/zebedee/Makefile b/security/zebedee/Makefile
index 46ee9b022ee1..fdeedbef6a8d 100644
--- a/security/zebedee/Makefile
+++ b/security/zebedee/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= greg@hewgill.com
BUILD_DEPENDS= ${LOCALBASE}/lib/libbz2.a:${PORTSDIR}/archivers/bzip2
-USE_OPENSSL= NORSA
+USE_OPENSSL= YES
USE_PERL5= yes
MAN1= zebedee.1 ftpgw.tcl.1
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index 90b7eca2e995..084982a873ce 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -42,7 +42,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= rse@engelschall.com
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
diff --git a/www/apache13-ssl/Makefile b/www/apache13-ssl/Makefile
index dad49b24226c..9ddab095c366 100644
--- a/www/apache13-ssl/Makefile
+++ b/www/apache13-ssl/Makefile
@@ -44,7 +44,7 @@ Y2K= http://www.apache-ssl.org/#Y2K
APACHE_VERSION= 1.3.12
APACHE_SSL_VERSION= 1.40
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
@@ -52,15 +52,8 @@ USE_OPENSSL= RSA
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
-.if !defined(OPENSSLINC)
-OPENSSLINC= ${PREFIX}/ssl/include
-.endif
CFLAGS+= -I${OPENSSLINC}/openssl
-.if !defined(OPENSSLLIB)
-OPENSSLLIB= ${PREFIX}/ssl/lib
-.endif
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
@@ -90,11 +83,7 @@ CFLAGS+= -O6 -fomit-frame-pointer
.endif
CONFIGURE_ENV= OPTIM='${OPTIM}'
-.if defined(OPENSSL_RSAREF)
-CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -lRSAglue -L${LOCALBASE}/lib -lrsaref"
-.else
CONFIGURE_ENV+= EXTRA_SSL_LIBS="-L${OPENSSLLIB} -L${LOCALBASE}/lib"
-.endif
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 httpsdctl.8 apxs.8 httpsd.8 logresolve.8 rotatelogs.8
diff --git a/www/lynx-ssl/Makefile b/www/lynx-ssl/Makefile
index 81a3386a0d56..72fd234e7170 100644
--- a/www/lynx-ssl/Makefile
+++ b/www/lynx-ssl/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= www
MASTER_SITES= ftp://lynx.isc.org/current/
DISTNAME= lynx2.8.3rel.1
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include <bsd.port.pre.mk>
diff --git a/www/w3m-ssl/Makefile b/www/w3m-ssl/Makefile
index cac3a737c9a2..4e18014227cb 100644
--- a/www/w3m-ssl/Makefile
+++ b/www/w3m-ssl/Makefile
@@ -11,6 +11,6 @@ MASTERDIR= ${.CURDIR}/../../www/w3m
PKGDIR= ${.CURDIR}/pkg
PLIST= ${MASTERDIR}/pkg/PLIST
-USE_OPENSSL= RSA
+USE_OPENSSL= YES
.include "${MASTERDIR}/Makefile"
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 0dd03eaef50a..e8a425b1a1e1 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -48,9 +48,6 @@ SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
SED_CMD+= -e "s,undef USE_SSL,define USE_SSL,g" \
-e "s,undef USE_SSL_VERIFY, define USE_SSL_VERIFY,g"
-.if defined(OPENSSL_RSAREF)
-EXTRA_SSL_LIBS= -lRSAglue -lrsaref
-.endif
MAKE_FLAGS+= DEFS="${SSL_CFLAGS} -I${LOCALBASE}/include" \
LIBS="${SSL_LIBS} ${EXTRA_SSL_LIBS} -L${LOCALBASE}/lib"
.else