aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-28 16:09:15 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-28 16:09:15 +0000
commit4f33a6ccab59f1ed5e9cb743bf5f4d667dc4c2a9 (patch)
tree155d42006d861150c98272d4cc0d432000fa6477
parente71e1fb70f1a5e776a2aaaf83b7e04b18f1a738e (diff)
downloadports-4f33a6ccab59f1ed5e9cb743bf5f4d667dc4c2a9.tar.gz
ports-4f33a6ccab59f1ed5e9cb743bf5f4d667dc4c2a9.zip
Gnome Basic is an embryonic attempt to provide VB compatible functionality
for the GNOME project, particularly with respect to office (VBA) compatibility.
Notes
Notes: svn path=/head/; revision=29944
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gnomebasic/Makefile31
-rw-r--r--lang/gnomebasic/distinfo1
-rw-r--r--lang/gnomebasic/files/patch-aa36
-rw-r--r--lang/gnomebasic/files/patch-ab11
-rw-r--r--lang/gnomebasic/pkg-comment1
-rw-r--r--lang/gnomebasic/pkg-descr8
-rw-r--r--lang/gnomebasic/pkg-plist27
8 files changed, 116 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 4ef3a13a2429..00826caa333c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -34,6 +34,7 @@
SUBDIR += ghc
SUBDIR += glibstdc++28
SUBDIR += gnat
+ SUBDIR += gnomebasic
SUBDIR += gpc
SUBDIR += guile
SUBDIR += guileobjc
diff --git a/lang/gnomebasic/Makefile b/lang/gnomebasic/Makefile
new file mode 100644
index 000000000000..ff48bc2877e6
--- /dev/null
+++ b/lang/gnomebasic/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnomebasic
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomebasic
+PORTVERSION= 0.0.12
+CATEGORIES= lang gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gb
+DISTNAME= gb-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/lang/gnomebasic/distinfo b/lang/gnomebasic/distinfo
new file mode 100644
index 000000000000..2e482b8577cc
--- /dev/null
+++ b/lang/gnomebasic/distinfo
@@ -0,0 +1 @@
+MD5 (gb-0.0.12.tar.gz) = 4999b445fc20fbb593ba1e27d374ce66
diff --git a/lang/gnomebasic/files/patch-aa b/lang/gnomebasic/files/patch-aa
new file mode 100644
index 000000000000..c4134b1a72f0
--- /dev/null
+++ b/lang/gnomebasic/files/patch-aa
@@ -0,0 +1,36 @@
+--- configure.orig Mon Jun 12 07:07:43 2000
++++ configure Wed Jun 28 10:19:30 2000
+@@ -3180,9 +3180,9 @@
+
+ rm -f conf.glibtest
+
+-GMODULE_CFLAGS=`glib-config --cflags gmodule`
++GMODULE_CFLAGS=`$GLIB_CONFIG --cflags gmodule`
+
+-GMODULE_LIBS=`glib-config --libs gmodule`
++GMODULE_LIBS=`$GLIB_CONFIG --libs gmodule`
+
+
+ for ac_prog in 'bison -y' byacc
+@@ -3433,8 +3433,8 @@
+
+ echo $ac_n "checking for GTK >= 1.2.2""... $ac_c" 1>&6
+ echo "configure:3436: checking for GTK >= 1.2.2" >&5
+-if gtk-config --version > /dev/null 2>&1; then
+- vers=`gtk-config --version | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
++if $GTK_CONFIG --version > /dev/null 2>&1; then
++ vers=`$GTK_CONFIG --version | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test "$vers" -ge 1002002; then
+ echo "$ac_t""found" 1>&6
+ else
+@@ -4044,8 +4044,8 @@
+
+ GB_LIBDIR='-L${libdir}'
+ GB_INCLUDEDIR='-I${includedir}'
+-GB_INCLUDEDIR="$GB_INCLUDEDIR `glib-config --cflags glib`"
+-GB_LIBS="-lgb `glib-config --libs glib`"
++GB_INCLUDEDIR="$GB_INCLUDEDIR `$GLIB_CONFIG --cflags glib`"
++GB_LIBS="-lgb `$GLIB_CONFIG --libs glib`"
+
+
+
diff --git a/lang/gnomebasic/files/patch-ab b/lang/gnomebasic/files/patch-ab
new file mode 100644
index 000000000000..5cd3ea604103
--- /dev/null
+++ b/lang/gnomebasic/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Jun 12 08:09:16 2000
++++ Makefile.in Wed Jun 28 10:28:16 2000
+@@ -124,7 +124,7 @@
+
+ EXTRA_DIST = gbConf.sh.in
+
+-confexecdir = $(libdir)
++confexecdir = $(sysconfdir)
+ confexec_DATA = gbConf.sh
+ CLEANFILES = gbConf.sh
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/lang/gnomebasic/pkg-comment b/lang/gnomebasic/pkg-comment
new file mode 100644
index 000000000000..90d758ab0054
--- /dev/null
+++ b/lang/gnomebasic/pkg-comment
@@ -0,0 +1 @@
+Provide Visual Basic compatible functionality for GNOME, especially VBA
diff --git a/lang/gnomebasic/pkg-descr b/lang/gnomebasic/pkg-descr
new file mode 100644
index 000000000000..cfae12148d8d
--- /dev/null
+++ b/lang/gnomebasic/pkg-descr
@@ -0,0 +1,8 @@
+Gnome Basic is an embryonic attempt to provide VB compatible functionality
+for the GNOME project, particularly with respect to office (VBA)
+compatibility.
+
+It is part of the GNOME desktop environment: a project to create a free,
+user friendly desktop environment.
+
+WWW: http://www.gnome.org/gb/
diff --git a/lang/gnomebasic/pkg-plist b/lang/gnomebasic/pkg-plist
new file mode 100644
index 000000000000..c91c1e0b2ac7
--- /dev/null
+++ b/lang/gnomebasic/pkg-plist
@@ -0,0 +1,27 @@
+etc/gbConf.sh
+include/gb/gb-eval.h
+include/gb/gb-expr.h
+include/gb/gb-lex.h
+include/gb/gb-main.h
+include/gb/gb-mmap-lex.h
+include/gb/gb-object.h
+include/gb/gb-project.h
+include/gb/gb-value.h
+include/gb/gb.h
+include/gb/libgb.h
+include/gbrun/gbrun-eval.h
+include/gbrun/gbrun-object.h
+include/gbrun/gbrun-project.h
+include/gbrun/gbrun.h
+include/gbrun/libgbrun.h
+include/gbrun/objects/gbrun-form.h
+include/gbrun/objects/libgbobj.h
+lib/libgb.a
+lib/libgb.so
+lib/libgb.so.0
+lib/libgbrun.a
+lib/libgbrun.so
+lib/libgbrun.so.0
+@dirrm include/gbrun/objects
+@dirrm include/gbrun
+@dirrm include/gb